Finder qui se relance tout seul...

-anonyme-

Légende
26 Février 2001
66 286
2 670
Un truc bizarre m'arrive.
Ma config est un G4 400 en 10.1.1 (install du x1.1 faite hier sans problème).

Tant que j'y étais, j'ai fait la manip de Resexcellence pour le déplacement du swap sur une autre partition: reformatage de mon 2ème HD, création de la partition (nommée 'SWAP'), commandes nécessaires dans le terminal.

A priori, tout semble s'être passé correctement. Si ce n'est que depuis, les raccourcis sur le bureau ont disparu et que le Finder se relance tout seul dès que je travaille sur autre chose. Ce qui est bizarre, c'est que tout fonctionne en dehors de cela: les applis lancent, connection Internet ok,... Juste ce Finder qui relance tout seul.

A mon avis, deux causes possibles:
- la mise à jour x1.1 (réinstallée après sans + de succès)
- la partition swap: le système ne verrait-il pas le nouvel emplacement de la vm?

Je penche pour la seconde car la commande df -k me renvoie ma partition swap sous le nom 'swap 1'. Connaissant l'importance d'une lettre ou d'un simple chiffre dans ce genre de langage biscornu...

Je ne comprends pas très bien ce qui se passe et je fais appel à vos neurones "appeliens"...
 

TR

Membre confirmé
21 Septembre 2000
109
0
Bon effectivement, il semble y avoir un pb avec ton swap.
Pour vérifier c'est simple : dans un shell fait la commande :
cd /Volumes
ls
Si tu as un "volume" swap ET un volume swap 1
cela signifie que l'OS n'a pas trouvé ta partition swap au moment du démarrage et a donc CRÉÉ un répertoire nommé "swap" sur ta partition principale ds le dossier volume.
Pour vérifier, refait un df. Ta partition swap doit apparaitre AVANT la ligne <volfs>. Si elle est en dessous, c'est que le système la chargé à la fin du processus de boot, et non pas au début, ce qui explique pourquoi il a créé un répertoire nommé swap sur la partition de démarrage.

Je ne connais pas la manip de resexellence, mais pour en avoir essayé plusieur, la seule qui marche est de :
- modifier (ou créer) le fichier /etc/fstab en ajoutant ta partition dedans.
- PUIS de modifier le fichier /etc/rc en mettant le nouveau path de ta swap.
Si tu as bien fait ces 2 manips, vérifie ton fichier fstab, car en toute logique c'est là qu'est le pb. Fait bien gaffe aux espaces : ils ont leur importance. Normalement tu devrais avoir un truc du genre:
/dev/disk0s11 /Volumes/Swap hfs rw 1 2

Malheureusement, je pense que ceci n'a rien à voir avec ton pb de finder. Il m'est arrivé un pb analogue la semaine dernière. Et c'était dû à un problème de disque. Donc le premier truc à faire c'est de rebooter en single-user (pomme-s au démarrage) puis de tapper : fsck -y
Et de recommencer tant qu'il te marque un truc du genre "Filesystem was modified". Pour quitter le mode single user, tappe reboot.
Si le pb persiste (c'était le cas pour moi) le disque est plus gravement endommagé. Donc il faut utiliser un utilitaire plus puissant du type Norton ou techtool, en démarrant bien-sur sur une autre partition. Après une demie-douzaine de passages de Norton, tout est rentré dans l'ordre chez moi. Voilà HTH


P.S.: Il semble que même si ta swap est bien configurée, si ton ordinateur plante, et que tu fais un hard reboot, le système ne trouve pas ta partition swap, et te crée un répertoire swap sur la partition principale. Il suffit de redémarrer normalement pour que ce pb disparaisse. Dc conclusion qd mon ordi plante , je le reboot, puis le reboot
 

-anonyme-

Légende
26 Février 2001
66 286
2 670
Effectivement. Il semble y avoir plusieurs choses: le disque a bel et bein un problème.
fsdisk en mode single user (quelle horreur d'interface....) a trouvé pas mal de problèmes. J'ai voulu redémarrer en OS9 et lui me propose carrément d'initialiser le disque. Bizarre car en x1.1, il le voit quand même...

Pour le swap, j'ai vérifié: il y a bien une partition swap et une partition swap 1 et avec df, la bonne n'est pas au dessus de la lgne donnée. Par contre, vu qu'il finit tjs par planter, je fais souvent un hard reboot. Or, tu dis en PS que du coup il n'essaierait même pas d'utiliser la bonne partition?

Comment savoir ce qu'il en est et surtout comment faire marche arrière pour recommencer la manip correctement?
 

TR

Membre confirmé
21 Septembre 2000
109
0
Le pb de la swap n'est pas grave en soi : au lieu de mettre les fichiers de swap sur la partition que tu lui as dédié, le système la met sur la partition principale comme avant (saus que c'est pas dans le même dossier).

Par contre le pb de disque est plus génant. As-tu bien passé fsck jusqu'à ce qu'il ne signale plus aucune erreur ?

Si oui quand tu as booté sous 0S 9, c'était sous une autre partition ? Ou sur un CD ?

Si tu as un CD de techtool ou Norton, je crois que c'est le moment de l'utiliser.

Sinon, il est possible que le fait de lancer OS X agrave les erreurs de disque. Donc essaye la manip suivante:
- redémarre en single user
- passe fsck jusqu'à ce qu'il n'y ait plus d'erreur
- tappe reboot
- Au démarrage appuie sur alt et démarre imédiatement sur ta partition OS 9...
Si tu n'as pas une machine new world, ou si tu préfères booter sur un cd, remplace la dernière manip' en appuyant sur C au démarrage pour booter sur le CD.

Voilà, en espérant que ça va marcher...
 

-anonyme-

Légende
26 Février 2001
66 286
2 670
Effectivement, pour fsck , je l'ai fait jusqu'à ce qu'il ne me signale plus d'erreurs deux fois de suite.

J'ai démarré OS9 sur une autre partition (en réalité l'autre disque interne) et il a mis un temps abominablement long pour démarrer.

Je vais passer Norton mais de mémoire, il n'est pas compatible X? Dois-je le passer après avoir démarré en 9?

Pour la manip' en reboot, je vais essayer...
 

TR

Membre confirmé
21 Septembre 2000
109
0
Non, effectivement Norton n'est pas compatible OS X. Donc tu dois redémarrer sous OS 9, ou utiliser le cd de Norton.

Attention : Il faut que tu aies la version 6 de norton, les précédentes ne sont pas capables de réparer correctement des disques OS X, et risquent même de créer encore plus de dégats.