Firefox : taupe de l'obsolescence programmée ?

ccciolll

Membre expert
Club MacG
Souvenez-vous, il y a quelques années, nombre d'entre nous (et moi avec) à joyeusement emboîté le pas à Mozilla, et notamment son fer de lance Firefox (dit FF).
Les logiciels libres ! On allait faire trembler Microsoft et autres trusts commerciaux ! Ahah ! La révolution en pantoufles.

Et puis est arrivé FF 4. FF 4 ne tournait plus sur les PowerPC (mac non intel) -même un super G5 surpuissant-, ni non plus avec les mac équipé de tiger (OS pourtant contemporain de certains macs intel). Premier sale coup (notez qu'entre temps FF en est arrivé à sa version 16 voire 17/18/19 (source wikipédia), ça montre depuis combien de temps FF à gommé le PPC et tiger de son histoire (de 3 à 16, ça en fait un beau pourcentage d'exclusion)).
Les utilisateurs PPC ou tiger (moi à la maison, par exemple) n'avaient plus qu'à se rabattre sur TenFourFox pour avoir l'illusion de continuer l'aventure du navigateur libre.

Et là, ce matin, sur mon poste de travail (un intel équipé de leopard), je lis une alerte de FF16 : « votre système d'exploitation ne sera plus géré par FF » (ou un truc du genre, j'ai pas noté). Donc voilà aussi que leopard va passer aux oubliettes de Mozilla.

Du coup, j'en suis à me demander s'il n'y a pas collusion entre Mozilla et les grands industriels. 5mmmmh, une petite théorie du complot pour bien démarrer la journée). Cela est renforcé quand je lis, en cliquant sur « à propos de FireFox », l'évangile suivante « FF est conçu par Mozilla, une communauté mondiale de contributeurs qui travaillent ensemble pour garder internet ouvert, public et accessible à tous. ». À tous, oui, mais seulement si le porte-monnaie (signifié ici par la capacité à utiliser des appareils et logiciels dernier cri) est bien rond.
Alors, je sais bien, je peux participer à Mozilla si ça me convient pas. Et puis on va me dire : si tu réclames à faire tourner internet sur Leopard, pourquoi pas aussi sur MacOS7, sur Amiga500, AmstradCPC464, TO7… Ouais… Enfin Leopard est tout de même un OS contemporain des mac intel et les G4 et G5 sont contemporains d'un internet grand public et de FF.
Bref, moi tout ça me laisse un goût un peu amer. Comme l'impression de m'être fait détourner mes copains par des intérêts supérieurs, voire d'avoir marché dans la combine d'un dealer « viens, goûte, c'est gratuit… »
Du coup, Safari (version 5.0.6 depuis 2003, belle stabilité) redeviendrait une solution d'avenir ? Safari qui, lui, bizarrement, n'a pas besoin de mises à jour frénétiques (passer de 3 à 16 de 2010 à 2012, ça ressemble à de la frénésie, un peu ; et apparemment, le 17 est prévu pour nov 2012, 18 pour janvier 2013, 19 pour février 2013 (un saut de version par mois !!!), à comparer avec un logiciel qui résiste depuis 2003 (c'est presque trop))

Mais safari n'a pas de beaux modules complémentaires. Peste !
 

Romuald

Bof...
Modérateur
Club MacG
14 Septembre 2006
9 132
3 866
Juste une question : c'est pour que ça parte en vrille direct que tu postes ici et pas dans 'réagissez' ? :D
 

subsole

Membre vénérable
Club MacG
16 Octobre 2010
11 157
3 517
Idem, je ne trouve plus de pièces neuves pour ma calèche et plus de stations adaptées pour faire le "plein".

Où va ce monde ?
 

ccciolll

Membre expert
Club MacG
Juste une question : c'est pour que ça parte en vrille direct que tu postes ici et pas dans 'réagissez' ? :D

Non, mauvaise appréciation de ma part (ou plutôt mauvaise connaissance des divers sous-forums existants).

Si un bonhomme vert veut bien la déplacer ça nous évitera une pluie de commentaires approfondis, pertinents et documentés comme celui de subsole
 

ergu

passant qui passe
Club MacG
13 Octobre 2011
2 728
614
28
C'est une taupe ?
Je croyais que c'était un renard - mais c'est vrai qu'on voit pas bien.
'fin une taupe, quand même...
 

ccciolll

Membre expert
Club MacG
Dessinent mal chez Mozilla (déjà, va prononcer un nom pareil…)
 

Yvelan72

Membre confirmé
21 Août 2011
68
1
L'évolution permanente est consubstantielle du Logiciel Libre. Certains désigneront cela en instabilité, d'autres en adaptation et évolution. Le résultat est là : pour la plupart des LL que j'ai connu, y compris les OS Linux et même son noyau, c'est plusieurs mises à jour par an....

Les concepteurs font des choix, et la plupart du temps ces choix sont discutés et transparents. Il est à peu près certain que des discussions ont eu lieu sur les forums ad-hoc sur la compatibilité de FF avec les anciennes plateformes Mac, avec des arguments apportés.

Lorsqu'il y a des choix, il y a forcément des contents et des mécontents. Dans ton cas, il est tout de même difficile de faire prévaloir le point de vue d'une compatibilité jusquà Léopard ...

Après, chacun est libre d'utiliser les versions qu'il veut. Tu es tout à fait libre d'utiliser une ancienne (pas trop quand même) version de FF de la même manière que tu utilises une ancienne version de MacOS. Et dans un cas (FF) comme dans l'autre (MacOS), cela sera supporté un temps puis il y aura des problèmes de compatibilité avec d'autres composants.

C'est comme ça et ça l'a toujours été. De là à y voir un complot, franchement il faut avoir une drôle de façon de voir ...

A+
 

aCLR

Marque déposée
Modérateur
Club MacG
7 Mars 2008
11 246
4 591
Rouen
T'y vas quand même un peu fort là d'un coup !

Et je crois que c'est un panda !
 

Madalvée

Membre un peu pommé
Club MacG
26 Décembre 2009
3 602
693
44
Besançon (25)
Le problème des développeurs c'est qu'ils font partie de ceux qui veulent toujours avoir la plus grosse, il faudrait que certains soient sensibilisés à l'éco-responsabilité et constituent des équipes pour ces machines qui, en effet, savent aussi bien afficher des pages, voire des animations et des vidéos, que les machines modernes.
Mais tant que la dernière poignée de terre rare n'aura pas été utilisée dans la dernière carte mère fabricable, la course à la technologie imposera ses vues.
 

Kallune

Membre actif
8 Décembre 2010
134
6
Là, je suis complètement d'accord avec ça Madalvée. Plutôt qu'un complot, l'obsolescence programmée, c'est plus cette idée qu'il faut jeter des appareils qui fonctionnent ou qu'on pourrait réparer pour avoir toujours le truc neuf.
Il n'y a pas que les développeurs qui veulent avoir la plus grosse !
L'informatique, c'est le pompom, c'est conçu sur le modèle du kleenex.
 

Yvelan72

Membre confirmé
21 Août 2011
68
1
Dans le cas présent, je ne suis pas d'accord avec vous. Il ne s'agit pas de machines mais du choix délibéré d'un utilisateur de fonctionner sur un système d'exploitation trois générations antérieur à l'actuel, et qui voudrait que l'ensemble des développeurs de la terre assume son choix.
Et il y a comme une contradiction de ne pas accepter de ne pas pouvoir utiliser la dernière version de FF alors qu'on fait le choix d'utiliser une ancienne version de son système.

Si nous parlons du LL, je suis désolé mais vous pouvez faire tourner un Linux actuel certes pas très folichon graphiquement mais tout à fait fonctionnel sur des machines avec 500 Mo de RAM. Maintenant, il ne faut pas vouloir à la fois les dernières performances graphiques, faire tourner du HTML5 en veux-tu en voilà, et demander que ça tourne sur les machines ou des systèmes totalement inadaptés. A un moment, il faut savoir ce que l'on veut et éviter d'accuser la terre entière de ses propres choix. Je connais pas mal d'utilisateurs du libre qui tournent sur des noyaux qui datent d'il y a trois ou quatre ans et qui s'en portent très bien.

Perso je ne suis pas scandalisé que l'équipe Mozilla dise : bon, maintenant pour faire tourner telle ou telle techno qui sont demandées partout il faut upgrader son système pour que cela soit possible. Je le répète, personne n'oblige l'utilisateur de mettre à jour d'aujourd'hui tous ses outils surtout du Libre où la dernière version est toujours un peu instable. Quand j'utilisais les suites Linux, j'étais constamment en version V-2 de l'ensemble des outils, y compris les suites Openoffice et Mozilla. En général il y a toujours une version LTS qui permet de tourner jusqu'à quatre ou cinq ans sans avoir besoin de tout mettre à jour.

A+
 

ccciolll

Membre expert
Club MacG
À vrai dire, pour tous mes autres logiciels, j'utilise des vieilleries (CS3, XPress7, MSOffice2004 (!)) sans m'en plaindre. Au contraire, c'est plutôt l'inverse de mon côté. Si je pouvais rester à des versions plus anciennes (stables et qui comportent toutes les fonctions dont j'ai besoin) je le ferai volontiers. Mais n'ayant qu'un seul poste de travail et devant être en mesure d'ouvrir les fichiers fournis, je me suis adapté en prenant des logiciel plus récents que ce dont j'ai vraiment besoin pour faire mon travail.

Je pense que ce qui me fait réagir sur FF c'est qu'il insiste lourdement par divers affichages.
Quand j'étais en FF3.6 sur l'intel en Tiger ou sur le G5, à chaque nouvelle version de FF il me mettait une page d'ouverture me disant que je ne suis pas à jour, avec en plus une invitation à télécharger la nouvelle version (qui, une fois téléchargée au prix de beaucoup de bande passante (donc de pollution) m'annonçait qu'elle ne pouvait pas s'installer…) Comme si un site n'était pas capable de dire « ce mec utilise un PPC / un Tiger, on ne va pas lui proposer un produit inutilisable » !!!
Donc, déjà, la perte de temps et la pollution du téléchargement inutile, et puis cette impression d'avoir un commercial qui te rappelle tous les 2 mois « eh, viens voir ma nouvelle version. Elle est gratuite si tu prends la mise à jour payante de ton OS / Hardware »

Ça déjà, franchement, ça m'a chauffé les oreilles. Je suis donc passé à TenFourFox à la maison (mais je crois que je vais passer à Safari qui est plus coopératif que TFF, bien que datant de 2004, comme quoi on ne peut pas me taxer de ne pas vouloir utiliser des vieux logiciels). Et au travail, j'ai installé Leopard (sur un intel, j'avais encore cette porte de sortie pour rester en FF).

Et là, ce nouveau message, ben ça me donne l'impression de recommencer. Belle page de pub « On va vous larguer car vous ne consommez pas assez ! ». Ben OK, qu'ils le fassent, mais pas la peine de venir me narguer !
Leopard ne se met plus à jour depuis qqes temps, c'est logique, Apple ne le développe plus. Mais ils m'envoient pas pour autant des messages insistants à chaque nouvelle mouture pour me dire que je suis vraiment trop un looser avec ma vieille machine. Ils me foutent la paix.

Voilà un peu le contexte, en fait.
Allez, qu'ils le disent une bonne fois pour toute, comme là pour le FF17, et on en parle plus. OK. Mais ils m'avaient tellement gavé depuis la 3.6 tous les 2 mois (et pour trouver l'info que seule le 3.6 marchait chez moi, il fallait passer 5 minutes sur divers forums), avec leur messages idiots, que je suis un peu à vif sur le sujet.
 
Dernière édition:

Yvelan72

Membre confirmé
21 Août 2011
68
1
Il existe une option bien utile dans les préférences qui permet de ne pas télécharger automatiquement les mises à jour et de ne pas en être averti (Préférences=>Avancées=>Mises à jour=>Ne jamais vérifier les mises à jour).

Je crois qu'il ne faut pas être dans l'interprétation comme ça, hein. Ils font juste leur boulot. Imagines qu'ils ne disent rien et que parce que tu utilises une version ancienne tu te colles des problèmes de sécurité... Tu serais le premier à râler qu'on ne t'avais pas prévenu. Et là à fort juste raison.

Donc, il est de leur devoir de te prévenir de la mise à jour et de ta responsabilité de ne pas vouloir en être averti et d'en assumer les conséquences. Cela n'a rien à voir avec des histoires de consommation ou je ne sais quoi.

A+
 

ccciolll

Membre expert
Club MacG
D'accord avec ça pour le cas où ils mettent un message m'avertissant que je vais bientôt être out. (ici FF16 sous Intel+leopard). Du moment qu'ils n'en mettent pas tous les mois, aussi.

Mais pas du tout d'accord, par contre, quand ils me mettaient une page me demandant de télécharger la nouvelle version pour chaque évolution supérieure à la 3.6 quand j'étais en Intel+Tiger (ou, plus radical, en PPC à la maison). Puisque toute version supérieure à 3.6 était incompatible, il eût été plus juste qu'ils mettent juste une alerte le jour où ils sont passé à la 4 « votre FF ne sera plus jamais mis à jour » et comme ça j'aurais effectivement décoché cette case tout de suite pour être tranquille.

EDIT : soit dit en passant, si j'avais des pb avec internet, je mettrais plutôt en cause mon usage que le logiciel… Donc je ne serai pas « le premier à râler ». Qui s'imagine encore être en sécurité sur internet à part les hackers qui connaissent toutes les parades.
 
Dernière édition: