Fluidité de l'image avec Imovie

Moulinsart

Membre confirmé
17 Décembre 2009
120
0
111
chez moi quand j'y suis
Salut,

Bon, ben après moult essais de montages avec imovie, j'en conclus que le logiciel donne un rendu saccadé dès l'importation à partir du camescope, et ça ne s'arrange pas après montage et partage quelque soit le choix de qualité, hd ou autre.

Le manque de fluidité de l'image est vraiment flagrant, les panoramiques comme les travelling sont pénibles à regarder.

J'ai appelé applecar qui m'ont d'abord répondu que cela pouvait venir de l'imac mais sur les trois que j'ai essayé le problème était identique.

Ensuite mon interlocuteur m'a suggéré d'utiliser le logiciel d'importation de mon camescope sony et de faire le montage ensuite avec imovie, mais le logiciel n'accepte que windows et de plus c'est pas trés pratique et cohérent compte tenu de l'investissement dans l'achat de l'imac.
Alors ma question est, est-ce que je me lance dans l'achat de final cut et cela résoudra-t-il le problème de fluidité rencontré avec imovie ?

p.s. : j'ai essayé l'importation avec deux camescope sony mini dv, un hdv et un sd.
 

whereismymind

Membre d’élite
Club MacG
8 Juillet 2006
3 816
107
43
Paris
Bonjour,

Et ta version de iMovie, c'est laquelle ? Jamais constaté rien de tel ni sur la '08, ni sur la '09.
Peux tu nous dire pas à pas comment tu procèdes pour l'importation ?
 

pulsaracat

Membre confirmé
30 Septembre 2007
299
8
Berre l'etang
www.afcca.org
j'ai constaté cela aussi, mais en fait, chez moi, cela ne se produit que lors de la prévisualisation du film dans iMovie, une fois le film exporté (peu importe le format), tout est normal quand je regarde le film avec VLC ou avec un lecteur de dvd de salon. Je me dis que, peut etre, iMovie "simplifie" le film pour la previsualisation.
 

Duroc

Membre confirmé
26 Juillet 2005
325
13
Haute-savoie
Salut,

j'ai connu des problémes similaires lors de du montage à partir de séquence mp4 (déja compressée), et aussi avec un disque externe pas assez rapide. en tout cas ça ressemble à un probléme de ressource (disque, mémoire ou autre).
 

drs

Oh ouiiiiiiiii !
Club MacG
j'ai un camescope dv que j'utilise avec imovie depuis la version 6.
Aucun problème de fluidité sauf en prévisulalisation plein écran, où là ça saccade un peu par moment (aujourd'hui avec MBP et imovie HD ou 09).
Mais sinon, à l'export pas de soucis.

Mon camescope: un panasonic
 

Moulinsart

Membre confirmé
17 Décembre 2009
120
0
111
chez moi quand j'y suis
Alors il s'agit de imovie 09 connecté en firewire du camescope sony mini dv modèle hc7 hdv à l'imac.
J'ouvre la fenêtre d'importation sur imovie, dans l'onglet caméra il est indiqué : hdv
ensuite je clique sur importer.
dés l'importation finie le rendu est saccadé comme je l'indiquais plus haut et cela avant même tout montage et partage.
J'ai par ailleurs essayé avec une autre camescope sony lui aussi mais sd et le problème est identique. aucune fluidité dans les plans bougés, il n'y a que sur les plans fixes que l'image est bonne.
J'ai un imac intel core i7 avec 8 go de mémoire et 2 T de capacité.
merci pour les réponses.
 

olivkx98

Nouveau membre
12 Août 2010
1
0
40
et t as resolu ton pb?
j ai exactement le meme probleme
video legerement saccadée apres importation dans imovie, meme apres gravure en differentes qualité ou format...??
merci !
 

McHerve

Membre d’élite
Club MacG
1 Décembre 2005
2 748
53
Cagnes-sur-Mer
www.movieconverter-studio.com
une réponse un peu tardive, mais je l'ai constaté moi aussi ;)
imovie, j'en conclus que le logiciel donne un rendu saccadé dès l'importation à partir du camescope
si je me rappelle bien, sur l'extrait (travelling sur montage) je t'avais dit que les trames semblaient "pas régulières"
j'ai constaté ce même soucis avec mon panaTM60:
- les fichiers passés en progressif (=conservation d'une trame sur 2) présentent des heurts lors de la diffusion
- les fichiers en conservant l'entrelacement n'en présentent pas

en regardant chaque trame (dans photoshop) j'ai remarqué qu'elles ne correspondent pas exactement à un déplacement continu, elles sont légèrement décalées certaines fois (ex: je fait rouler une balle devant la cam: déplacement de la balle dans le champ, trame1=1cm, trame2=0.8cm, trame3=1cm,etc)
Donc il y a un manque de continuité dans la capture des images (elles ne semblent enregistrées qu'à intervalle temporel "presque" régulier)

J'ai aussi remarqué que ce soucis apparaissait plus facilement en mode 'haute qualité' (donc au pif complet je dirais que l'électronique est à la ramasse quand elle a trop d'infos à coder à la seconde - avis purement divinatoire :rateau: )


Perso j'ai "résolu la gêne de ces saccades" en conservant l'entrelacement (elles sont toujours là, mais je ne les remarque plus durant la diffusion ;))

en conclusion: essaies avec iMovieHD pour voir si en gardant l'entrelacement ça saccade encore.
Si ça ne saccade plus, investis dans FCE (apte à conserver l'entrelacement).
Tu pourras même utiliser iMovie'08 '09 pour dérusher/démarrer ton montage et le finaliser dans FCE (je n'ai pas vraiment testé cette fonctionnalité, mais il y a un menu de transfert des reushes pré-montés dans iMovie, vers FCE)

à+
 

madmaxmac

Membre émérite
22 Mars 2004
589
21
sans etre un grand specialiste
je dirais quand meme que le hdv n'est pas un format de montage
c un codec mpeg2
c a d que le processeur est obligé de compresser/decompresser les images en temps reel.(et le hdv a une image 5 fois plus grande que du DV par ex)
pas bon pour le montage.
sur FCpro , le hdv doit etre re encoder en apple codec (propre a FCpro)pour pouvoir etre monté.
(enfin je n'ai jamais pratiqué cela(je suis en dv) mais je le suppose)

quand imovie est ouvert le processeur est deja occupé et donc la lecture va devenir saccadé.

maintenant sur un i7 je ne sais pas.
mais si cela le fait avec du DV ...il y a un autre pb.

a verifier si l'import est saccdé sur des lecteurs comme qt ou autre?
en tout cas avec une si belle machine, je mettrais imovie au rebus..et je passerais a FC..(le mieux etant la suite FC Studio).
 

FERY

Membre junior
19 Août 2010
13
0
71
Belgique
Bonjour , j'ai un imac 24" 4 giga de ram etb une carte nividia gforce 130 gt
je monte avec final cut pro7
la visualisation sous FC est bonne mais après compression j'ai des saccades dans les travellings
j'ai remarqué que si je laisse en 50 i/s ca va mais en 24 i/s ce n'est pas bon
les rushs de la camera pana sd700 sont convertis en AIC avec clipwrap qui conserve les 50 i/s
le débit est lui aussi réduit à 10000kbits.
je compresse avec compressor. en h264
si je regarde des clips fait par d'autre je ne remarque pas ces défauts.

que faire pour avoir de la fluidité dans mes montages?

Dany
 

jcfaggia

Membre émérite
2 Juillet 2006
656
24
AJACCIO
En réponse à moulinsart,
Je suis heureux de voir que chaque fois qu'on évoque les problèmes de fluidité, ça déclenche une floppée de réactions propre à de fructueux échanges. un forum, c'est fait pour ça , et si je poste souvent sur ce sujet c'est pour :
-témoigner de mes expériences, ça peut aider du monde.
-demander de l'aide et profiter du savoir des plus calés que moi (et il y en a..)
-En finir avec tous mes errements et essais, mais ça...

Pour être bref ( pour une fois) :
J'ai monté avec iMovie HD des films en SD : résultats corrects sans plus.
Je suis passé à la HD , (Sony HC7/9,) apparition d'effet de peigne, saccades, etc...
Final Cut Express n'a pas résolu les saccades sur panos rapides
Je suis passé sur Final Cut Pro : Plus de saccades, RÉSULTAT IMPECCABLE, qualité du film monté identique à la cassette source.

Un détail : Au montage, le film saccade légèrement sur le navigateur et sur le canevas. Le phénomène disparaît totalement avec export Compressor en H264, après creation image disque HVDVD sur DVD studio pro.
2è détail : Compressor très lent.
Va voir ces fils :
Solution simple pour filmer en HD, du 15 08
FCS et Compressor du 17 05
A+
JCF

---------- Nouveau message ajouté à 21h34 ---------- Le message précédent a été envoyé à 21h23 ----------

Bonjour , j'ai un imac 24" 4 giga de ram etb une carte nividia gforce 130 gt
je monte avec final cut pro7
la visualisation sous FC est bonne mais après compression j'ai des saccades dans les travellings
j'ai remarqué que si je laisse en 50 i/s ca va mais en 24 i/s ce n'est pas bon
les rushs de la camera pana sd700 sont convertis en AIC avec clipwrap qui conserve les 50 i/s
le débit est lui aussi réduit à 10000kbits.
je compresse avec compressor. en h264
si je regarde des clips fait par d'autre je ne remarque pas ces défauts.

que faire pour avoir de la fluidité dans mes montages?

Dany


Ya un truc que je ne comprends pas : pourquoi 50 I/S ?? moi je suis en 25.
Peut être que c'est là que le format non compressé en cassettes a son avantage.
en HD sur cassette et Compressor H264, c'est parfait. Voir post précédent.
Salut
JCF
 

Fab'Fab

Voight-Kampf Tester
Club MacG
5 Décembre 2000
16 042
3 190
Ya un truc que je ne comprends pas : pourquoi 50 I/S ?? moi je suis en 25.
Peut être que c'est là que le format non compressé en cassettes a son avantage.
en HD sur cassette et Compressor H264, c'est parfait. Voir post précédent.
Salut
JCF

50i pour interlaced.
Tu as 50 trames entrelacées pour créer 25 images
 

FERY

Membre junior
19 Août 2010
13
0
71
Belgique
correction...
je précise que 50 i/s s'est bien du 50 progressif mais 50 images par seconde
j'aurais du dire 50 p ..sorry

avec final cut tout est fluide en 50 images mais une fois compresser avec compressor en 24 images par seconde les travelling sont saccadé il n'y à pas de fluidité !
je filme avec la pana sd700 et c'est parreil avec la sony EX1R.
la sony enregistre en 24p
serais t'il possible que compressor perde à la compression des images? ou bien c'est le mac qui ne suit pas ?
 

McHerve

Membre d’élite
Club MacG
1 Décembre 2005
2 748
53
Cagnes-sur-Mer
www.movieconverter-studio.com
est-ce de l'humour?
avec final cut tout est fluide en 50 images mais une fois compresser avec compressor en 24 images par seconde les travelling sont saccadé il n'y à pas de fluidité !
tu pars de 50 images différentes à la seconde,
tu n'en conserves que 24,
et tu t'étonnes de la perte de fluidité ? (j'ai du louper quelque chose :nailbiting: )

à+
 

FERY

Membre junior
19 Août 2010
13
0
71
Belgique
je comprend bien que 50 images sec c'est plus que 24 images sec mais comment expliqué que j'ai vu un rush fait à 100 images sec avec une red puis reconverti en 24 images sec... oups il n'y à pas les saccades, il y à bien sur une différence mais pas aussi flagrante que chez moi de 50 à 24 images sec
si je regarde même un rush natif de ma EX1R en 24p puis compresser avec compressor le clips est moins fluide que l'originale je trouve ça bizarre
 

McHerve

Membre d’élite
Club MacG
1 Décembre 2005
2 748
53
Cagnes-sur-Mer
www.movieconverter-studio.com
juste un détail:
je comprend bien que 50 images sec c'est plus que 24 images sec
50 images c'est du double-PAL
24 c'est du "NTSC FILM"
la conversion (PAL/doublePAL -> NTSC FILM) va te donner 1 saccadde par seconde.
Passes plutôt ton 50 en PAL=25, ces framerate sont compatibles, tu auras une perte de fluidité mais pas de saccade.

un rush fait à 100 images sec avec une red puis reconverti en 24 images sec... oups il n'y à pas les saccade
plus tu as d'images, moins tu saccaderas (quand tu fais n'importe quoi ;)). Comme tu as plus d'images intermédiaires (pour passer de 100 à24), il est possible que le tri (les images conservées dans les 24 résultantes) soit plus heureux…
PS: un 100fps c'est encore un multiple PAL (et toujours pas NTSC ;))
PPS (avis perso): filmer avec une red et en 100fps pour en faire du 24fps, c'est un sacré gâchis :siffle:

si je regarde même un rush natif de ma EX1R en 24p puis compresser avec compressor le clips est moins fluide que l'originale je trouve ça bizarre
en effet c'est bizarre, mais là pas d'idée (tes rushes sont en 24fps, ton projet est bien en 24fps? conservés lors de la compression aussi?)

à+
 

FERY

Membre junior
19 Août 2010
13
0
71
Belgique
Après plusieurs test j'en arrive à la conclusion que chez moi avec le matériel dont je dispose mes montage avec final cut pro en 1920*1080p 50 i/sec compresser en H264 ne s'affiche pas correctement, l'inspecteur quicktime montre que le nombre d'image par sec ne dépasse pas les 25 i/sec sur mon imac
sur un disque dur multimédia connecter à mon plasma il refuse le 50 i/sec 1080*1920
je suis obliger de réduire mon format en 720p
maintenant je compresse mes montages en mp2 720p et 50 i/sec et un débit de 16 mgb, là tout est nickel.