Hackintosh Asus Z490 / Intel i7 10700K / Sapphire RX 5700XT Nitro+

ToUsMiC

Membre confirmé
18 Mai 2012
15
0
46
Hey, oui tu peux faire ça avec une z390 :) Il te faut juste faire un EFI en rapport avec ta CM. Tu peux voir le guide directement. Si t'as des questions, je peux peut-être te répondre.
Salut, merci pour ta proposition.
Cependant en me référant a ma carte mère Asus ROG Héro XI, j'ai appliqué les memes réglages que toi, j'ai utilisé TransMac pour restaurer une image de Catalina ou Mojave sur une USB de 16Go. Une fois que je lance l'installation j'obtiens des erreurs en ligne de commande (parametre -v -x sur Clover). J'avoue etre un peut perdu la.
 

albaaaan

Membre confirmé
24 Janvier 2021
16
6
36
Strasbourg
Salut, merci pour ta proposition.
Cependant en me référant a ma carte mère Asus ROG Héro XI, j'ai appliqué les memes réglages que toi, j'ai utilisé TransMac pour restaurer une image de Catalina ou Mojave sur une USB de 16Go. Une fois que je lance l'installation j'obtiens des erreurs en ligne de commande (parametre -v -x sur Clover). J'avoue etre un peut perdu la.
Salut, je suis désolé mais j'utilise pas Clover comme boot loader mais OpenCore. Je connais pas du tout Clover. Pourquoi tu utilises Clover?
 

ToUsMiC

Membre confirmé
18 Mai 2012
15
0
46
Car avant j'avais déja monté un Hackintosh sur mon ancien z270 et j'avais utilisé Clover.

Ici voici ou cela bloque : Je pense que c'est un soucis au niveau de mes 3 Nvme mais pas sur a 100% ...

hackintosh_error.jpg
 

albaaaan

Membre confirmé
24 Janvier 2021
16
6
36
Strasbourg
Car avant j'avais déja monté un Hackintosh sur mon ancien z270 et j'avais utilisé Clover.

Ici voici ou cela bloque : Je pense que c'est un soucis au niveau de mes 3 Nvme mais pas sur a 100% ...

Voir la pièce jointe 234731
Tu utilises des nvme samsung les EVO je pense? C'est une piste, c'est un problème avec ton nvme, peut-être il faut mettre à jour le nvme, le micro logiciel. Tu peux déjà faire ça. Mon hack est sur un ssd evo 2.5 1to pas sur un nvme.
 

ToUsMiC

Membre confirmé
18 Mai 2012
15
0
46
Je ne comprends pas trop le fonctionnement de OpenCore ....
Deja a la base j'ai réussi a mettre une image OSX via TransMac (via Windows) mais j'avoue etre totalement perdu avec OpenCore
 

edenpulse

Membre expert
Club MacG
10 Août 2010
1 473
332
Qu'est ce que tu ne comprends pas? OpenCore est un bootloader, un programme que ton ordinateur lance au démarrage. Celui ci est installé sur une partition EFI cachée sur un de tes disques.
 

ericse

Membre expert
Club MacG
30 Avril 2019
5 405
934
  • J’aime
Réactions: edenpulse

Sly 49

Membre confirmé
5 Février 2021
19
1
21
Bonjour à tous,

Je me permet de relancer un peu le sujet concernant un petit problème que j'ai sur mon Hackintosh AMD qui tourne sous Windows 10 et Mac OS Big Sur. Je l'utilise pour jouer (sous Windows) et pour travailler (sous MacOS).


J'ai construit le PC récemment, il fonctionne entièrement sur Windows mais presque entièrement sous MacOS avec OpenCore, excepté le son et la mise en veille, pour ce qui est du son, c'est ennuyant mais c'est pas dramatique, pour l'instant j'ai un adaptateur USB-C vers Jack, ça dépanne en attendant de trouver la solution, le plus embêtant reste la mise en veille, qui fonctionnait très bien sur mon précédent Hackintosh (I5-3570, carte mère ASUS Z68) mais pas du tout ici, il ne coupe jamais la ventilation lorsque je met suspendre l'activité, et après il ne se rallume plus à l'écran ni sur le réseau, donc je suis perplexe, si vous avez des idées sur l'origine de mes problèmes, je suis preneur.

Voici ma configuration exact:
Carte mère : MSI B450 Tomahawk Max II => Lien amazon
Processeur: AMD Ryzen 5 5600X
Mémoire : 16Go de RAM (2x8Go) à 3200MHz Corsair Vengeance LPX
Carte graphique : AMD Radeon RX580 8Go PULSE
Stockage: SSD NVME 250Go pour Windows 10 et SSD SATA 120Go pour macOS Big Sur+ 1,5To de HDD pour les données.
Alimentation Corsair 500W
J'utilise OpenCore, qui dans l'ensemble fonctionne bien.

Si vous pouviez m'aider sur mon problème de mise en veille, cela m'aiderai beaucoup.

Je vous remercie d'avance.
 
Dernière édition:

albaaaan

Membre confirmé
24 Janvier 2021
16
6
36
Strasbourg
Bonjour à tous,

Je me permet de relancer un peu le sujet concernant un petit problème que j'ai sur mon Hackintosh AMD qui tourne sous Windows 10 et Mac OS Big Sur. Je l'utilise pour jouer (sous Windows) et pour travailler (sous MacOS).


J'ai construit le PC récemment, il fonctionne entièrement sur Windows mais presque entièrement sous MacOS avec OpenCore, excepté le son et la mise en veille, pour ce qui est du son, c'est ennuyant mais c'est pas dramatique, pour l'instant j'ai un adaptateur USB-C vers Jack, ça dépanne en attendant de trouver la solution, le plus embêtant reste la mise en veille, qui fonctionnait très bien sur mon précédent Hackintosh (I5-3570, carte mère ASUS Z68) mais pas du tout ici, il ne coupe jamais la ventilation lorsque je met suspendre l'activité, et après il ne se rallume plus à l'écran ni sur le réseau, donc je suis perplexe, si vous avez des idées sur l'origine de mes problèmes, je suis preneur.

Voici ma configuration exact:
Carte mère : MSI B450 Tomahawk Max II => Lien amazon
Processeur: AMD Ryzen 5 5600X
Mémoire : 16Go de RAM (2x8Go) à 3200MHz Corsair Vengeance LPX
Carte graphique : AMD Radeon RX580 8Go PULSE
Stockage: SSD NVME 250Go pour Windows 10 et SSD SATA 120Go pour macOS Big Sur+ 1,5To de HDD pour les données.
Alimentation Corsair 500W
J'utilise OpenCore, qui dans l'ensemble fonctionne bien.

Si vous pouviez m'aider sur mon problème de mise en veille, cela m'aiderai beaucoup.

Je vous remercie d'avance.
Hello, pour ton problème lié à la mise en veille : je pense que c'est peut-être en rapport avec tes ports USB de ta CM. T'as fait une cartographie USB perso? Si c'est pas le cas, tu peux déjà voir ça ;) Après c'est un problème connu sur les plateformes AMD. Normalement avec un ajout d'une USBmap ça marche (sur mon ancien hack en 3700X la veille marchait parfaitement).

Pour ton problème de son, sur ta CM MSI tu dois voir comment fonctionne la partie son. Quel codec est utilisé, moi je suis sur une ASUS, MSI je connais pas ;)
 

Sly 49

Membre confirmé
5 Février 2021
19
1
21
Hello, merci beaucoup pour ta réponse rapide, j'avais vu justement que ça avait marché pour toi, donc je me suis dit que tu pourrais m'aider sur le sujet.
Pour ce qui est du mapage USB, je n'est rien fait à ce niveau là, j'ai juste pris un EFI que j'ai trouvé sur internet, correspondant à ma carte mère, et c'est tout. Je t'envoie un lien wetransfert pour mon dossier EFI. Petite question, ou est ce que on règle ça le mapage USB ?
Petite precision (utile ou pas) : tous les ports USB fonctionnent à leur pleine vitesse.

Pour le son, j'ai pourtant installé voodhoo, mais j'ai toujours pas de son (sauf sur la RX580 et par USB-C).

Voici une capture d'écran de l'arborescence des ports USB:
Capture d’écran 2021-11-29 à 19.23.01.png
 
Dernière édition:

albaaaan

Membre confirmé
24 Janvier 2021
16
6
36
Strasbourg
Hello, merci beaucoup pour ta réponse rapide, j'avais vu justement que ça avait marché pour toi, donc je me suis dit que tu pourrais m'aider sur le sujet.
Pour ce qui est du mapage USB, je n'est rien fait à ce niveau là, j'ai juste pris un EFI que j'ai trouvé sur internet, correspondant à ma carte mère, et c'est tout. Je t'envoie un lien wetransfert pour mon dossier EFI. Petite question, ou est ce que on règle ça le mapage USB ?
Petite precision (utile ou pas) : tous les ports USB fonctionnent à leur pleine vitesse.

Pour le son, j'ai pourtant installé voodhoo, mais j'ai toujours pas de son (sauf sur la RX580 et par USB-C).

Voici une capture d'écran de l'arborescence des ports USB:
Voir la pièce jointe 247641
Hey, justement c’est le problème de ta mise en veille. Tu peux pas avoir l’ensemble de tes ports USB fonctionnels si tu veux un EFI propre.

macOS gère que 12 ports USB (ou 15 je sais plus :)) et il faut savoir que un port USB 2.0 = 1 port et un port USB 3.0 = 2 ports pour macOS.

Donc exemple 3 ports USB 3.0 + 2 ports 2.0 ça fait 5 mais en vrai ça fait 8… Donc tu dois choisir selon tes besoins. Quel port de la CM je veux? Quel port du boîtier en façade je veux?

Le mieux vraiment c’est de suivre la rubrique pour la cartographie USB sur le guide de opencore.

Tu peux mapper avec hackintool aussi ça aide pas mal.

Faut comprendre ce que tu fais et pourquoi… Enfin moi à l’époque j’ai attaqué le guide avec cette approche.

Idem pour le son faut voir exactement comment fonctionne ta CM sur la partie audio. Et construire le .kext, moi j’ai une ASUS. MSI je connais pas. Mais le principe reste identique.

Sincèrement potasse le guide :)
 

Sly 49

Membre confirmé
5 Février 2021
19
1
21
Bonjour,

Merci pour ta réponse clair et précise, j'ai regardé du coup sur le guide OpenCore, ainsi que téléchargé hackintool, qui est vachement complet d'ailleurs.
Pour la carto USB, j'ai donc sélectionné les ports qu'il fallait, exporté la Configuration, qui m'as donnée des .Kext, .aml et .dsl, autant j'ai réussi à trouver où mettre les .kext et .aml, mais pas les .dsl, ce qui fait (j'imagine) que même après un redémarrage, tous les ports USB fonctionnent toujours alors que j'en ai désactivé plusieurs.

Pour ce qui est de la partie audio, je n'est pas trouvé de solutions, mais ce n'est pas la priorité pour l'instant, donc ça je verrai plus tard.
 

julietteto

Membre enregistré
16 Janvier 2022
1
0
35
Hello le forum,

Je me présente rapidement et par la même occasion, je présente mon premier Hackintosh...

Je suis graphiste salarié et je travaille dans le domaine du print principalement. Je suis un Apple user depuis toujours, c'est mon outil de travail. Mon premier Mac remonte à l'age de mes 16 ans, 20 ans plus tard j'ai décidé de switch de mon iMac et de mon MBP vers un Hackintosh. Pourquoi?

Je voulais pas mettre 5 000€ dans une nouvelle machine et savoir que je resterai sur du hardware avec aucune possibilité d'update. C'est discutable mais je trouvais l'idée cool de faire autrement pour une fois. Think different comme on dit! :) Je reviendrai chez Apple dans 3/4 ans. J'ai toujours regardé du coin de l'oeil, les montages PC et tout. L'idée de réunir le meilleur des deux mondes me semblait une aventure à faire.

Je sais que le M1 est là et que le Hackintosh c'est terminé d'ici peu. macOS restera supporté encore un moment sur les plateformes INTEL donc il y a le temps avant ça. Du coup mon matériel c'est ça :

Carte mère : ASUS Rog Strix Z490 E Gaming Wifi (socket 1200)​
Processeur : INTEL i7 10700K (comet lake-s)​
Carte graphique : Sapphire RX 5700XT Nitro+ 8Go​
Ventirad : NOCTUA NH-D15 chomax black (non merci le watercooling)​
RAM : Corsair Vengeance LPX 2x16Go 3200 CAS16​
SSD M.2 Sabrent 500Go : pour Windows​
SSD EVO 860 500Go : pour Windows​
SSD EVO 860 1To : pour macOS​
SSD EVO 860 500Go : pour un clone bootable macOS​
Alimentation : Seasonic PX-750W Platinium​
Carte Wifi/BT : Fenvi T919 (pas le choix pour le bluetooth/wifi, elle est reconnue nativement par macOS)​
Ventilation : full NOCTUA chromax black, 2x140mm en façade et 2x140mm sur le haut / 1x120mm à l'arrière​

Des images :

Voir la pièce jointe 210065

J'utilise OpenCore 0.6.5, je trouve le fonctionnement du bootloader vraiment mieux que Clover. La philosophie du truc est vraiment cool. Ça demande pas mal de lectures et de recherches au début histoire de bien bien comprendre les mécaniques du truc. Après, c'est que du plaisir! Ça reste un point de vue perso. J'ai rien contre Clover mais OpenCore injecte tout avant le boot macOS et pour moi c'est la meilleure méthode.

Le BIOS + le boot menu. Je boot pas WIndows depuis OpenCore. Il fait sa vie comme un grand, je le boot depuis le BIOS. J'utilise le côté graphique type bootcamp juste pour le côté propre. J'ai une version de mon EFI en mode DEBUG et une version en mode RELEASE. Le Hackintosh est terminé, je suis donc sur la version RELEASE actuellement.

Voir la pièce jointe 210069
Voir la pièce jointe 210071

Ma cartographie USB, c'est la partie la plus cool je trouve! C'est la partie où il faut prendre son temps. J'ai fait un plan graphique de ma cartographie si jamais ça intéresse du monde. Une capture d'écran de Hackintool + ORegistryExplorer. Ma CM Asus Rog Strix Z490 possède 2 hub USB 2.0 internes donc j'ai quasiment l'ensemble de mes ports USB actifs.

!! Sans cartographie perso, la carte Fenvi T919 fonctionnera pas. Donc pas de wifi/BT. La carte est connectée sur un port PCI + un port interne USB 2.0 de la carte mère. Pour avoir l'ensemble des features Apple c'est un passage obligatoire. !!

Des images, on peut voir que le port interne de la carte Fenvi c'est le contrôleur USB XHC port HS06 qui est un hub. Le port HS13 c'est l'autre hub dont je parlais. Lui il gère mes ports USB liés à mon boîtier. J'ai un boîtier Fractal Design Define R7 Compact. Il y a 5 ports en façade (2 USB 2.0 + 2 USB 3.0 et 1 type-C / Les 2 USB 2.0 sont en réalité un hub).

Voir la pièce jointe 210075
Voir la pièce jointe 210077

Voilà en gros j'ai l'ensemble des features Apple qui fonctionnent. C'est comme mes 2 autres machines Apple, elles communiquent parfaitement entre elles.
AirDrop, Message etc! :) Que du plaisir donc! J'utilise énormément AirDrop entre mon iPhone et mes ordi donc c'était vraiment important pour moi. Petit résumé rapide donc :

Mise en veille + retour en activité via clavier/souris : c'est OK, fonctionnel.
Features Apple : (AirDrop, Message, Partage de co 4G de mon iPhone vers le Hackintosh, iCloud, etc) : c'est OK, fonctionnel. (il faut la carte Fenvi)
NVRAM native : c'est OK, fonctionnel.
Codec audio : c'est OK, fonctionnel. (audio hdmi de la CG mais aussi audio hdmi sur port hdmi de l'iGPU + prise casque/micro etc)
Vidéo : c'est OK, fonctionnel.
Ethernet : c'est OK, fonctionnel. (il faut prévoir un peu de travail sur un fichier .kext)
Wifi/BT : c'est OK, fonctionnel. (avec la carte Fenvi, sur Windows j'utilise le wifi/BT de la carte mère)

Je fais pas toute la liste...

Bref tout fonctionne parfaitement, le 10700K fait grave le boulot. J'utilise la machine quotidiennement sur la suite Adobe. Les températures sont bonnes. C'est fluide stable, super véloce. Je vous laisse des résultats Geekbench, pour moi c'est que des chiffres mais bon les connaisseurs pourront peut-être me dire si c'est bon ou pas. En regardant les comparatifs, mes résultats collent donc c'est bon.

Voir la pièce jointe 210081
Voir la pièce jointe 210083
Voir la pièce jointe 210085

Voilà pour mon retour d'expérience sur mes débuts avec OpenCore. Pour moi, l'aventure est parfaite, je regrette pas mon choix. J'ai appris énormément de choses. J'ai discuté avec des gens vraiment cools sur les forums Hackintosh. Des vrais passionnés.

Je partage mon dossier EFI si jamais des gens sont en demande ou avec le même matériel que moi! ;)
Bonjour,

Je te remercie pour ce poste, qui m'a aidé à comprendre certaines choses lors de la construction de mon hackintosh, notamment le USB map. Tout fonctionne plutôt bien sur ma config, sauf mes 2 ports usb2 du boitier (un fractal aussi, le même) qui ne sont pas détéctés. Par curiosité, et non pas pour que tu me maches le travail ca serait cool si tu pouvais partager avec moi ton dossier EFI ! Merci
Juliette