iBook 12" PowerPC 700mhz G3 qui fait le mort

ness_Du_frat

Membre émérite
6 Février 2007
918
53
38
France
www.lesenfantsdelo.com
je viens de récupérer dans une benne (oui, encore ma benne magique, ça aide d'être pote avec les gars qui gèrent la déchetterie ^^) un vieux G3 avec son chargeur. Je l'ai ramassé par nostalgie, car mon tout premier mac était un iBook 12" (un G4, par contre, mais il avait la même tête). De retour à la maison, je l'allume, tout va bien, batterie morte mais il fallait s'y attendre, je crée un nouveau compte Admin et me dépêche de me débarrasser des comptes existants et de leurs données, pas moyen de me connecter à mes wifi pour cause de clé WPA il ne sait pas ce que c'est, donc câble ethernet, et là, il me propose les mises à jour, je me dis, pourquoi pas, surtout la mise à jour de sécurité de Tiger.

Il redémarre, et au bout de bien 45 minutes à tourner dans le vide pour une pauvre petite mise à jour de 50Mo, je me dis que ça doit coincer, et je force l'arrêt. Je vais pour le redémarrer, rien. Depuis, il fait le mort. J'ai essayé toutes les astuces que j'ai trouvées sur le net, mais rien n'a fonctionné. (Genre ctrl opt shift power pendant 5 secondes, puis power. Ou appuyer à gauche du trackpad à cause du défaut connu de carte mère. Enlever la batterie. Tenter débilement un reset PRAM alors qu'il ne s'allume de toute façon pas. Je peux peut-être forcer un redémarrage en l'ouvrant si je trouve les power pads. Pas sûr qu'il y en ait sur ce modèle.

Des idées ? Il fonctionnait nickel juste avant, j'ai pu configurer mon compte, aller sur internet, j'ai même fait une vérification des permissions du disque, histoire de.

Bon, si je n'arrive pas à le redémarrer, ce ne sera pas le drame du siècle, j'ai de quoi faire avec mes autres ordis (j'ai d'ailleurs encore un iMac à tenter de passer en Hackintosh pour cause de contrôleur SMC foireux), mais je me disais que ça pouvait être fun, ce vieux G3.
C'est pas la bête de course, mais il a quand même une carte airport (ce que mon G4 n'avait pas, j'avais dû la mettre par la suite), 30go de disque dur, un lecteur DVD, une prise firewire... Ca peut toujours dépanner.
 

ness_Du_frat

Membre émérite
6 Février 2007
918
53
38
France
www.lesenfantsdelo.com
Pour info, je l'ai démonté pour voir si par hasard c'était un problème de faux contact avec le bouton d'alimentation. J'ai donc "bypassé" le bouton d'alimentation pour faire le contact direct sur la nappe, mais ça n'a rien changé. Je l'ai aussi laissé hors secteur et sans batterie pendant un moment, et j'ai retenté. Rien.
Dommage.
Ce qui est bête, c'est que je ne comprends pas ce qui a pu se passer. Ça n'a aucun sens et ça m'énerve.
 

Invité

Pommé
Club MacG
19 Février 2005
8 268
469
21000
Dans ton matos, tu n'aurais pas un chargeur compatible ?

Possible qu'il ait rendu l'âme et comme la batterie est morte…
 

ness_Du_frat

Membre émérite
6 Février 2007
918
53
38
France
www.lesenfantsdelo.com
Ben j'ai le chargeur et il fonctionne... La batterie étant morte, il était sur le chargeur tout le temps. J'ai tenté de le laisser un moment débranché du chargeur et d'enlever la batterie, pour qu'il soit complètement vidé, et de réessayer, mais rien. Il est mort de chez mort. Comme si aucun courant ne passait. Alors que la batterie réagit avec le chargeur (j'ai deux batteries, les deux réagissent quand même avec la petite lumière verte quand on appuie dessus). Quand je branche le chargeur, il s'allume en vert, puis devient orange, puis repasse des fois en vert (ça me faisait ça à l'époque du mien quand sa batterie était morte), et le voyant de la batterie dessous est allumé. Donc le courant passe de l'un à l'autre. J'ai laissé pour voir une des deux batteries se décharger complètement (aucun voyant quand on appuie sur le bouton) et je l'ai remise dedans, une fois l'ordinateur branché, quand j'appuyais sur le bouton de la batterie, j'avais le premier voyant vert qui s'allumait.

Ce n'est donc pas un problème de carte d'alimentation. Ce n'est pas non plus un problème avec le bouton de l'alimentation. Du coup, je suis perplexe. Je n'ai jamais vu un truc pareil. Carte-mère, peut-être ?
 

Invité

Pommé
Club MacG
19 Février 2005
8 268
469
21000
Tente :
Enlève la câble d'alim, la batterie, tout ce qui peut s'enlever
Reste appuyée sur le bouton de mise en route pendant 20/30s
Attends 20/30s
Remets la batterie et rebranche

Un changement ?
 

ness_Du_frat

Membre émérite
6 Février 2007
918
53
38
France
www.lesenfantsdelo.com
Rien :( il a l'air mort de chez mort :(
Je ne sais pas ce que j'ai fait, mais je crois que je l'ai vraiment tué en forçant le redémarrage. Je pense que je vais mettre en vente le chargeur histoire de récupérer 10€ (c'est toujours ca), et si quelqu'un veut la carcasse ici histoire de récupérer la carte airport, la RAM, le dur (qui était nickel, c'est un 30go, je peux même fournir mon mot de passe Admin que je venais juste de mettre dessus, mais ce n'est pas compliqué de recréer une session. Tiger est installé dessus, la personne qui l'a jeté avait aussi une version officielle de office 2004, Illustrator 10 et Photoshop 6, entre autres). Le lecteur Dvd fonctionnait aussi, les hauts parleurs aussi, l'écran aussi, bref, il était parfaitement fonctionnel jusqu'à ce redémarrage forcé. C'est peut-être une histoire de condensateur sur la carte-mère, auquel cas poubelle la carte-mère, mais il y a moyen de faire quelque chose avec le reste des pièces. Bref, je l'envoie volontiers à qui le veut contre les frais de port. Le chargeur, j'espérais en ramasser 10€. Donc bon, si jamais, la totalité contre les frais de port + 10€ ^^ en mondial relay, ca doit faire genre 6€ de frais de port, quelque chose comme ça. Bref.
C'est juste frustrant.
Je ne comptais même pas particulièrement en faire quelque chose, c'était juste par nostalgie, car j'avais adoré mon iBook G4. Le contrôleur de batterie sur la carte-mère avait claqué deux mois après la fin de la garantie et le magasin ne m'avait évidemment pas parlé de la garantie contractuelle d'un an supplémentaire, où ils auraient dû me le réparer gratos (ce n'était pas Apple, à l'époque, pas de Apple Store), je l'ai encore traîné plusieurs années en mode portable qui ne s'utilise que sur secteur ^^
 
Dernière édition:

Invité

Pommé
Club MacG
19 Février 2005
8 268
469
21000
Peut être encore re-tester les power-pad puisque tu as fait un reset avec la manip précédente ?
 

ness_Du_frat

Membre émérite
6 Février 2007
918
53
38
France
www.lesenfantsdelo.com
Je n'ai pas vu de power pads dessus. Mais là, honnêtement, je ne redémonte pas tout le dessus pour bidouiller de nouveau la nappe. La manip que tu as suggérée, je l'avais déjà plus ou moins faite, pas aussi longue, mais une dizaine de secondes, ce qui est suffisant pour décharger complètement les condensateurs, donc je doute que cela fasse un gros changement :/
 

Invité

Pommé
Club MacG
19 Février 2005
8 268
469
21000
Perso, j'avais noté sur un de mes ordi, que la condition était d'attendre au moins 20/30s entre chaque manipulation.

Mais c'est de l'empirisme et sur UN ordi.
En revanche, je ne sais plus sur lequel. Je crois que c'était sur l'un de mes 3 iBook, mais sans certitude :D
 

Invité

Pommé
Club MacG
19 Février 2005
8 268
469
21000
Ca voudrait juste dire que c'est le bouton du clavier (ou le câble) qui est foutu… ;)
 

ness_Du_frat

Membre émérite
6 Février 2007
918
53
38
France
www.lesenfantsdelo.com
Non non, ce serait très étonnant, il aurait fonctionné direct quand j'ai testé direct sur la nappe. Assez peu probablement qu'il y ait tout ca en même temps, surtout que je l'avais allumé et éteint plusieurs fois avant de faire la mise à jour de sécurité de Tiger.
C'est con, je n'ai vu nulle part la pile du CMOS de la carte-mère, sinon je l'aurais testée, puis changée si elle était foutue (je pense qu'elle l'était, car la date était au 1er janvier 1970). Mais même ca, ca n'explique pas l'ordinateur qui ne redémarre pas. Au moins, ça aurait forcé le reset.
 

ness_Du_frat

Membre émérite
6 Février 2007
918
53
38
France
www.lesenfantsdelo.com
Peut-être un début de solution ici : https://www.ifixit.com/Answers/View/8439/iBook+won't+power+on+after+attempted+PMU+reset
Je vais tenter. Donc d'abord le laisser tranquille pendant genre deux semaines, (je ne sais pas si ça suffit pour vider complètement le PMU) ce qui me laissera le temps de me procurer un vrai fer à souder qui ne soit pas une daube finie comme celui que j'ai actuellement chez moi puis je tenterai de le redémarrer, on verra bien.
Les symptômes correspondent, et vu le prix de la pièce, ça peut valoir la peine. Faut juste que je voie si c'est la même pièce sur mon G3 à moi.
 

Invité

Pommé
Club MacG
19 Février 2005
8 268
469
21000
Tu pense à enlever la batterie pour faire ça.
Mais combien de temps faut-il ?
 

ness_Du_frat

Membre émérite
6 Février 2007
918
53
38
France
www.lesenfantsdelo.com
Je sais pas, justement... J'ai tenté de le mettre un moment sur le balcon en punition, par ce froid, je me suis dit que ça allait vider les transistors plus vite, j'ai dû le laisser deux heures, puis j'ai testé (sans batterie, sur secteur), rien. Du coup, maintenant, il est dans un coin sans sa batterie, j'ai pas retenté de le mettre dehors. Je vais le laisser en tout cas une semaine. La question que je me pose, c'est est-ce qu'il y a cette pièce sur cette carte-mère là ou pas... Il y a forcément un équivalent, de toute manière. Enfin, je me connais, je vais y passer des heures et ca va jamais marcher ^^ mais bon, au moins j'aurai essayé :)
 

ness_Du_frat

Membre émérite
6 Février 2007
918
53
38
France
www.lesenfantsdelo.com
C'est passionnant, ce truc ! Comment tu as eu ca ?! Je suis sur l'iPad, là, je vais aller sur le mac pour le sauver. Ca me désespère un peu quand je vois le boulot pour sortir la carte-mère, je crois que je vais abandonner là, mais j'ai peut-être trouvé un iBook G4 pas cher, le même très exactement que celui que j'avais, je ne pense pas qu'il ait une carte airport, je dois pouvoir récupérer celle-ci ainsi que le chargeur (celui du gars est un générique tout pourri) et je vais quand même sortir le dur, histoire de. Par contre, sur ton manuel, ils disent de tenter sans le clavier, sans la RAM et sans la carte airport, ça je n'avais pas fait, je vais le tenter quand même, c'est moins chiant que de démonter une carte-mère. Le G4, c'est une enchère, pour l'instant y a personne dessus, on verra ce que ça donne. C'est vraiment par pure nostalgie, parce que j'avoue que j'ai assez d'ordis, mais cet iBook, c'était mon tout premier Mac, c'était quand même quelque chose :)
 

Invité

Pommé
Club MacG
19 Février 2005
8 268
469
21000
J'avais acheté l'ensemble des Services Manuals à un mec sur La Baie il y a une dizaine d'années.
De l'origine à 2006 je crois.

Faut reconnaitre que le démontage (sans rien casser) de ces iBook est une plaie.