• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

10.11 El Capitan iMac 2008 20 pouces - Retour de clean install difficile

Thomas18

Nouveau membre
5 Décembre 2019
3
0
42
Bonjour,

D'abord je suis désolé du coté très "utilitariste" de ce message et de mon inscription sur ce forum, je vous demande de croire que j'ai essayé de me débrouiller par moi-même avant de venir embêter le monde. C'est avec des cernes sous les yeux et des doigts pâteux que je saisis ces "quelques" mots.

Je ne suis pas certain de poster dans la bonne section parce que je ne sais pas exactement d'où vient mon problème, mais comme ce qui motive mon sujet c'est que je n'arrive pas à lancer un diagnostic matériel, je poste ici... Les 2 paragraphes qui suivent sont pour essayer d'être complet mais on pourrait presque ne lire que le dernier paragraphe...

Nous avons depuis 2008 un "mac de salon" qui fait beaucoup de bureautique (travail à la maison), un peu de Netflix et autres (pas de télé dans la maison)... bref il est ancien, il sert beaucoup, mais il s'attelait assez volontairement jusque là aux taches qui lui étaient confiées. J'ai fait monter à la mémoire à 4Go il y a des années et je crois ne pas pouvoir faire plus. Je n'ai changé d'OS qu'au fur et à mesure des blocages sur une applications ou une autre, j'en suis à El Capitan (depuis un bon moment) et visiblement je n'irai pas plus loin. Il y a 9 mois, face à une lenteur devenue pénalisante, j'ai installé un SSD : nouvelle jeunesse pour la machine et assez longue période d'euphorie.

Il y a quelques jours, face à une grande lenteur (que je n'ai pas réussi à relier à une màj), je me suis mis en tête de faire une réinstallation de El Capitan qui a planté. De proche en proche, un mini coup de sang m'a fait opter pour une clean install qui a elle aussi planté. J'ai remis l'ancien disque dur pour faire une clé d'install et ça a fonctionné. Pour brosser un tableau complet, je signale qu'après des 1ers essais "les tripes à l'air" sans problème, lorsque j'ai remonté proprement l'écran le ventilateur CPU s'est affolé, et je n'ai pas réussi à résoudre ça en démontant/remontant. J'ai pensé qu'à force sur les années j'avais dû pincer un câble de sonde, et j'ai installé macs fan control.

Retour à un monde merveilleux et une vitesse de démarrage et lancement des applications très acceptable. Sauf que les vidéos en ligne (youtube, Netflix...) sont hyper saccadées (sauf en petite fenêtre). J'utilise plutôt Firefox, j'ai essayé Safari et même Chrome : c'est pire. J'ai installé silverlight. J'ai quitté toutes les autres applications / plug-ins de fond (ublock, NAS, Macs Fan...), ça ne change rien. Le débit ADSL n'est pas fou (7-8 Mbits/s) mais suffisant et pas pire qu'avant. Sur mon PC, aucun souci de ce genre.

J'ai voulu tester la carte graphique j'ai lu qu'il faut faire un test matériel en maintenant la touche D enfoncée au démarrage, mais ni D ni cmd-D ne fonctionne, je n'ai pas de DVD (d'ailleurs avec la clé d'installation connectée, la touche D fait planter le démarrage). Avez-vous une idée pour réussir à lancer un diagnostic matériel ?

Merci beaucoup, même si vous n'avez pas d'idée, d'avoir parcouru ce post et pour tous les échanges sur ce forum.
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
21 105
3 298
Là-haut
Le AHT (Apple Hardware Test) correspondant à cette machine était sur l'un de ses 2 DVD d'origine. Le coup du D au démarrage ne marche que si on insère le dit DVD ou si on a précédemment installé cet Apple Hardware Test (généralement avec le système d'origine, depuis un des DVD).

Vu le Mac, il s'agissait de Mac OS X Leopard. Généralement, quand les gens réinstallent le système, où upgradent l'OS, ils oublient de réinstaller l'AHT. M'enfin, avec le temps, au fil des upgrades, il devient ingérable par les systèmes plus récents.

Voilà pour la question des outils de diagnostique.
 

Thomas18

Nouveau membre
5 Décembre 2019
3
0
42
Merci de cette réponse. En supposant que je retrouve le DVD, je comprends qu'il y a peu de chances que ça fonctionne vu l'écart de versions d'OS, je chercherai quand même mais c'est dans une chambre d'enfant qui dort. Il n'y a pas de solution alternative ?

Ca me fait penser que je n'ai plus de DVD interne et qu'il me semble bien que j'avais dû faire une manoeuvre genre changer une base de registre en tapant une ligne trouvée sur internet quelque part pour qu'il accepte de lire les DVD sur un lecteur externe, je ne retrouve plus comment j'avais fait... Si quelqu'un sait ça je suis intéressé !
 

Fullcrum

OS Collector
Club MacG
5 Janvier 2016
3 566
708
Dole 39
Salut,

Moi je veux bien te filer une image disque de Snow Leopard avec un tuto pour en faire un volume Bootable, mais je ne vois pas trop en quoi cela va te servir, vu les explications de Moon !
 

Thomas18

Nouveau membre
5 Décembre 2019
3
0
42
Merci de vos réponses, j'ai retrouvé les DVD d'origine, mais je n'ai pas réussi à lancer le diagnostic. Je ne suis même pas trop sûr de la direction dans laquelle je dois chercher, c'est juste la page Netflix qui suggérait de vérifier la carte graphique en cas d'image saccadée sur une fenêtre non réduite, mais ce n'est quand même pas du support de haute volée.
Je n'ai eu aucun souci pour utiliser le lecteur de DVD externe par contre, de toute évidence le fait qu'aucun lecteur interne n'a été démonté lors du clean install me simplifie la vie par rapport à avant.
Ca commence à sentir le sapin (c'est de saison) pour ce bon vieux Mac. J'aimais bien l'idée de le faire durer mais je manque d'idées et même si sur près de 12 ans s'il a été globalement plus fiable que mes PC, la maintenance me prend trop de temps chaque fois qu'il y en a besoin.
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
21 105
3 298
Là-haut
La procédure est inscrite sur le DVD contenant le AHT. Mais il est possible que le raccourcis clavier ne fonctionne pas avec un lecteur externe.

Il faudrait réinstaller le AHT en interne. Ce que je faisais jusqu'à Mavericks sur un MPB 2008, et ça fonctionnait.

Avec El Capitan, d'abord il faut désactiver le S.I.P. car sinon le programme ne pourra pas s'installer.

Ensuite, démarrer la machine et aller sur sa session administrateur. Insérer le DVD contenant le programme des Installations optionnelles. Lancer le programme. Parmi celles-ci, il y a un truc appelé CPU quelque chose (désolé, j'écris cela de mémoire). Cocher la case correspondante et décocher toutes les autres case. Faire l'installation.

Attention, je n'ai jamais effectué cette opération avec succès sur OS X El Capitan.