iMovie : bridé sur certains G5 ???

BBen

Membre confirmé
7 Janvier 2002
468
7
Paris
Bonjour,

Il est bien indiqué sur le site d'Apple qu'iMovie 08' n'est compatible qu'avec un G5 à 1,9 GHz ou supérieur. Je suis possesseur d'un iMac G5 à 1,8 GHz (modèle 2004), je serai donc assez furax si pour 0,1 GHz près je ne pouvait pas utiliser iMovie 08'... :mad:

Je me dis que si l'installateur refuse d'installer iMovie 08' sur ma machine, mais qu'il le fait sur des iMac 0,1 GHz plus rapide, c'est avant tout par mauvaise fois :mouais:
C'est à dire qu'à mon avis, les différences d'architechture entre iMacs à 1,8 et 1,9 GHz ne devraient pas empêcher iMovie 08' de tourner sur les premières machines si elle tourne sur les secondes.

Donc, j'ai extrait le paquet d'iMovie 08' du DVD, et fait le boulot d'installation "à la main" (dépôt de l'application iMovie 08' dans mon dossier "Applications", dépôt des autres fichiers là où il faut).
Et bien, iMovie 08' ne veut pas s'ouvrir... Quand je clique sur l'icone, elle rebondit 1 fois dans le dock puis disparaît... :(
Au passage : le comportement est différent sur PB G4 : quand on essaie de lancer iMovie 08', on a une fenêtre qui apparaît prévenant que cette application nécessite un processeur G5 ou Intel...
Cela me pousse à penser qu'iMovie 08' devrait pouvoir tourner sur TOUS les G5... :mouais:

Qu'en pensez-vous ?

1) Pensez-vous comme moi qu'il n'y aucune raison d'architecture machine qu'iMovie 08' ne tourne pas sur les iMac G5 à 1.8GHz alors qu'il tourne sur les iMac G5 à 1.9 GHz ?
=> sinon, pourquoi ?

Si oui, reste à savoir ce qui ne va pas :

2a) J'ai merdé dans mon installation "manuelle" d'iMovie 08' :
=> savez-vous quelles sont exactement les opérations que réalise l'installateur d'iMovie 08 (fichiers à installer, fichiers à effacer (de l'ancienne application par exemple)...)

2b) Il y a un système de protection "à la noix" : l'application iMovie 08' contrôle quelque chose avant de décider se lancer (ou pas) :
=> elle peut contrôler la présence d'un "Receipts" dans le dossier Bibliothèques (vérification qu'elle a bien été installée à partir de l'installateur). Si c'est ça, est-ce contournable ?
=> elle contrôle le modèle de la machine, et décide de ne pas s'ouvrir si elle trouve un "vieux" Mac G5. Dans ce cas, j'imagine que je suis baisé...
=> autre hypothèse possible ?...

Vous voyez d'autres raisons possibles ? D'autres conseils à donner ? Y-a-t-il parmi les utilisateurs du forum d'autres expériences de ce type avec iMovie 08' sur "vieux" Macs G5 (iMac ou PowerMac G5 à 1.8 GHz)

Je trouverai assez scandaleux que Apple bride l'utilisation de son appli pour des Macs comme le mien. Je comprend qu'ils ne se soient pas fait ch...er à rendre une nouvelle version réécrite d'iMovie compatible G4, mais je ne crois pas justifié de la brider pour l'empêcher de tourner sur des G5 à 1.8 GHz ou à 1.6 GHz, si elle peut tourner sur des G5 à 1.9 GHz... A moins de vouloir nous pousser à changer de machine... :mad:
 

supermoquette

Cas clinique
Club MacG
13 Mai 2002
29 365
3 495
Ouvre le paquet iMovie (l'appli donc) et cherche un fichier texte ou il est question de tester ta fréquence. Ce n'est pas la première fois qu'Apple fait celà. Avec un peu de chance tu trouveras une ligne dans un fichier xml (plist ou autre) le fameux 1,9 que tu changeras en 1,6 ou autre).

Pour savoir comment il s'installe, ouvre le paquet de l'installeur, dedans y a un Archive.pax.gz, copie le sur ton bureau, double-cliques dessus et il se décompressera en maintenant l'arborescence des fichiers à placer exactement.
 

BBen

Membre confirmé
7 Janvier 2002
468
7
Paris
Ouvre le paquet iMovie (l'appli donc) et cherche un fichier texte ou il est question de tester ta fréquence. Ce n'est pas la première fois qu'Apple fait celà. Avec un peu de chance tu trouveras une ligne dans un fichier xml (plist ou autre) le fameux 1,9 que tu changeras en 1,6 ou autre).

Pour savoir comment il s'installe, ouvre le paquet de l'installeur, dedans y a un Archive.pax.gz, copie le sur ton bureau, double-cliques dessus et il se décompressera en maintenant l'arborescence des fichiers à placer exactement.
Hypothèse astucieuse effectivement. Mais je n'ai pas trouvé... :(

Dans le paquet, dans le répertoire racine ("Contents") il y a un fichier "infos.plist" et "version.plist", mais ce n'est pas ceux-la manifestement : je n'ai rien trouvé dedans qui ressemble à un contrôle de version du Mac ou du processeur G5.

Mauvaise pioche... Ou est-ce dans un autre fichier du paquet ? (lequel ?...)
 

da capo

abonné absent
Club MacG
12 Août 2001
17 417
3 675
Tu n'as pas déjà exposé ton affaire dans une autre fil ?

:mouais:

Copie l'installeur de iMovie
Puis, Clic droit -> Afficher le contenu du paquet.

Là dans Ressources, recherche Installation Check.

Je ne t'explique même pas où il doit finir…

:siffle:

A priori, ça peut permettre une installation "forcée" sans pour autant garantir un fonctionnement de l'appli.
 

iRono

Membre junior
7 Février 2006
60
2
Salut à tous,

Ce sujet est passionnant car j'ai une autre énigme pour vous, ecore plus agacante que la premiere, si possible... :

Lors de l'installation de ilife 08 le logiciel d'installation m'indique que iMovie 08 se sera pas installé car le logiciel requiert un processeur intel ou G5....

Soit ! Mais j'ai un MacBook avec un Intel Core2Duo à 2,16 Go et 2Ghz de Ram !!!

C'est trés énervant, non ?

Aidez moi SVP !!

Merci
 

da capo

abonné absent
Club MacG
12 Août 2001
17 417
3 675
Appeler le support Apple pour les installations problématiques :p
 

da capo

abonné absent
Club MacG
12 Août 2001
17 417
3 675

supermoquette

Cas clinique
Club MacG
13 Mai 2002
29 365
3 495
Hypothèse astucieuse effectivement. Mais je n'ai pas trouvé... :(

Dans le paquet, dans le répertoire racine ("Contents") il y a un fichier "infos.plist" et "version.plist", mais ce n'est pas ceux-la manifestement : je n'ai rien trouvé dedans qui ressemble à un contrôle de version du Mac ou du processeur G5.

Mauvaise pioche... Ou est-ce dans un autre fichier du paquet ? (lequel ?...)
En plus du post de starmac (plus pertinent en fait car ça force une installation propre), tu peux chercher d'autres fichiers que ceux là (pas forcément avec .plist comme extension).
 

BBen

Membre confirmé
7 Janvier 2002
468
7
Paris
Copie l'installeur de iMovie
Puis, Clic droit -> Afficher le contenu du paquet.

Là dans Ressources, recherche Installation Check.

Je ne t'explique même pas où il doit finir…

:siffle:

A priori, ça peut permettre une installation "forcée" sans pour autant garantir un fonctionnement de l'appli.

Pb : je ne trouve pas de fichier "Installation Check" dans le dossier "Resources" du paquet...

Il y a bien pourtant un contrôle de la machine sur laquelle l'appli est installée, vu que sur PB G4 j'ai une belle fenêtre qui apparaît et m'informe qu'iMovie 08 nécessite un G5...

Le mystère reste entier... :confused:
 

da capo

abonné absent
Club MacG
12 Août 2001
17 417
3 675
J'ai été un peu "rapide" ;)

Regarde dans le paquet d'installation de l'application désirée :p
 

da capo

abonné absent
Club MacG
12 Août 2001
17 417
3 675
Je comprends bien mais tu as une machine éligible et un soft normal alors… dur de proposer une solution.
 

BBen

Membre confirmé
7 Janvier 2002
468
7
Paris
J'ai été un peu "rapide" ;)

Regarde dans le paquet d'installation de l'application désirée :p
Okay. Donc, j'ai viré le fichier "Installation Check" (script Perl) du contenu du paquet d'installation d'iMovie...

...et ça ne résoud pas le pb : lorsque je clique sur l'icone d'installateur, j'ai une boîte de dialogue qui apparaît :

" Vous tentez une installation qui n’est pas prise en charge. Si vous souhaitez installer une application individuelle, veuillez utiliser le programme d’installation d’iLife et sélectionner Personnaliser."

... avec seulement un bouton "Fermer" comme possibilité. Et quand je clique dessus, bien sûr l'installateur quitte... :(
 

da capo

abonné absent
Club MacG
12 Août 2001
17 417
3 675
C'est lourdingue, je comprends.

Tu peux essayer de faire une image du DVD, puis, dans cette image modifier l'installeur iMovie en enlevant le fichier de test, puis lancer l'installation complète en personnalisant au besoin.

Sinon, je n'ai pas trop d'idées là…
 

BBen

Membre confirmé
7 Janvier 2002
468
7
Paris
C'est lourdingue, je comprends.

Tu peux essayer de faire une image du DVD, puis, dans cette image modifier l'installeur iMovie en enlevant le fichier de test, puis lancer l'installation complète en personnalisant au besoin.

Sinon, je n'ai pas trop d'idées là…
Je ne vois que ça également... Je laisse tomber l'affaire pour ce soir. Je tenterai cette option + tard, et vous tiendrai au courant...

Merci pour l'aide en tout cas ! :up:
 

cosmoscosmos

Membre junior
12 Août 2007
39
3
Bruxelles
Y'a encore pire: j'ai un PowerMac G5 2 X 2.5 GHz.
Hé bien, pas moyen d'importer un film en Haute Def codec AVCHD. Il faut un macintel dit la boite de dialogue. ou sinon le reste marche.
On ne va pas me faire croire que 2 X 2.5GHz ne sont pas suffisants pour exécuter une tâche qu'un simple MacBook Intel de 1.8 Ghz peut faire...
C'est n'importe quoi...
Soit c'est bassement commercial, soit ils n'ont pas pris le temps d'essayer d'optimiser un tant soit peu leur code PPC.
De plus, j'ai la même chose qu'un autre user sur les forums: j'ai du créer un nouveau compte user vierge pour pouvoir lancer IMovie 8 sans plantage immédiat.
:eek: :mad:
 
A

Anonyme

Invité
BBen, moi aussi je possède un iMac G5 1,8Ghz 20 pouces (modèle 2004) et l'installation d'iLife 08 s'est faite sans problème. iMovie a été installé, je l'ai lancé deux ou trois fois, et tout fonctionne. Par contre, c'est vrai que cette nouvelle mouture d'iMovie n'est pas très véloce sur mon "vieux" G5. Elle est plus réactive sur mon Macbook, ya pas à tortiller...
 

DrFatalis

Membre d’élite
Club MacG
11 Avril 2004
1 761
368
perso.wanadoo.fr
Comme aldébaran, j'ai un Imac G5 1,8GHz, installation ilife 08 sans pb (avec 2 Go de RAM, peut être que cela compte) et imovie 08 est utilisable (mzis lent) pour de courts films, de quelques mn... Je préfère imlovie 06...