Importer des descriptions (ou les ajouter massivement) dans Flickr

luc1en

Membre actif
19 Août 2011
791
76
Ici et là, j'aime bien changer
Il existe quand même au moins un logiciel OSX qui intègre bien les fonctions d'exiftool — pour autant que celui-ci ait été installé —, tout en offrant une interface graphique et francisée : l'excellent shareware GraphicConverter. ;)
Je l'avais oublié, ma licence dort dans un coin. Je suppose que les versions récentes ont amélioré le respect des champs IPTC. Je n'étais pas satisfait avec celle que j'ai (V6 ?).
 

ccciolll

Membre expert
Club MacG
Aurais-tu une idée de comment faire pour régler cette histoire d'enregistrement UTF8 ? Je ne crois pas avoir trouvé ça dans Bridge.
 

luc1en

Membre actif
19 Août 2011
791
76
Ici et là, j'aime bien changer

ccciolll

Membre expert
Club MacG
Bonjour,

ça semble être par défaut dans Bridge, voir http://help.adobe.com/en_US/creativesuite/cs/using/WSBCB2D1F5-98B8-45cc-950A-58E8347FD2F8a.html
Je n'ai pas Bridge sous la main, il est resté sur un disque monté en Snow Leopard. Je regarderai si tu ne trouves pas.

De ce que je vois, ils parlent d'UTF 8 dans le cas d'export txt des keywords, je ne suis pas sûr que ça signifie qu'ils soient « implémentés » en UTF8 par Bridge dans les jpg.

Si je t'envoie un de mes JPG, tu as la possibilité de me dire si les keywords sont en UTF8 (ou autre chose) ? Ou alors je peux le faire moi-même ? (comment ?)
 

ccciolll

Membre expert
Club MacG
Alors, d'après un test fait hier, fichier jpg auquel j'ai ajouté des descriptions IPTC via bridge CS4.
Les ï deviennent des ï
C'est pas encore ça.

image testée 2014-05-17_10-50-32
 

ccciolll

Membre expert
Club MacG
Re essayé hier avec le même fichier, et j'ai l'impression que le résultat, bien que toujours faux, soit différent.
un « ï B » aurait donné 堂
et un « Éri » aurait donné 㲩
bizarre bizarre
 

luc1en

Membre actif
19 Août 2011
791
76
Ici et là, j'aime bien changer
Bonjour,

je ne saurais pas voir l'encodage des métadonnées dans l'en-tête d'un jpeg. J'ai déjà essayé de comprendre comment c'était fichu, sans succès.
Tes constats sont en effet étranges. Peut-être en parler sur les forums Adobe, en anglais, si tu sais faire.
 

ccciolll

Membre expert
Club MacG
Alors il semblerait (mais quand je ferai d'autres essais je pourrai confirmer) que la description IPTC se charge en 2 temps.

Dans un premier temps, les caractères spéciaux sont mal interprétées.
Mais si l'on attend que l'image se soit intégralement chargée, sans rien toucher (ne pas affecter d'album, ne pas affecter de droits, ne pas modifier l'ordre), les caractères spéciaux se rechargent, et correctement cette fois-ci.

Ça influence un peu négativement le temps d'intervention car on ne pourrait alors plus profiter du temps d'upload pour finaliser les derniers réglages, mais ça pourrait être une direction intéressante pour profiter pleinement de l'amélioration apportée par l'IPTC inclus aux images.
 
  • J’aime
Réactions: luc1en