• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

10.10 Yosemite Impossible de changer de disque de démarrage

inaden

Membre junior
29 Mars 2008
38
0
Bonjour à tous.
Suite au sujet http://forums.macg.co/threads/impossible-dinstaller-el-capitan.1282098/ que j'ai ouvert, je suis toujours dans ma galère pour changer de système.
Après avoir essayé une multitude chose suite à la discussion précédemment citée, j'en suis arrivé à enlever un disque dur et à installer el capitan depuis un autre ordinateur... et l'autre ordinateur redémarre parfaitement une fois l'instal effectuée.
Quand je remets le disque dur dans l'ordi qui pose problème, si je démarre avec alt pour changer de disque de démarrage, ça redémarre puis, au moment de l'ouverture de session, ça bloque sur l'image du finder sans que celui-ci ne puisse se lancer... et ça tourne, ça tourne.
Si je démarre sur la partition de réinstallation, j'ai un message d'erreur au moment de lancer l'instal comme quoi il faut que j'utilise l'installation téléchargée !
Bref, ma question est la suivante : si je veux utiliser dans les pref système l'option démarrage, j'ai un message d'erreur qui me dit :

Vous ne pouvez pas modifier le disque de démarrage du disque sélectionné
L'outil de validation n'est pas en mesure de définir le disque de démarrage actif

Peut-être que si je pouvais régler cela, je pourrais redémarrer sur le nouveau système. Donc quelqu'un sait-il comment régler ce problème ?

J'ai essayé aussi de démarrer après avoir réinitialisé le contrôleur (https://support.apple.com/fr-fr/HT201295) ainsi que la mémoire NVRAM (https://support.apple.com/fr-fr/HT204063). Pour cette dernière opération, il m'arrive un truc con (pardonnez l'expression) mais comme le mac ne "dong" pas au démarrage, je ne suis pas sûr que le processus ait bien lieu.

Merci d'avance pour vos avis et votre aide.
Denis
 

Yohmi

Membre junior
4 Octobre 2007
43
20
www.wan-way.net
J'ai eu également un souci de ce genre hier, mais le message était légèrement différent. Ce qui posait souci chez moi c'était une partition Recovery HD endommagée, qu'il a fallu supprimer en extrayant le volume de son enveloppe CoreStorage afin de pouvoir s'en occuper indépendamment du volume principal. La réinstallation du système d'exploitation s'est ensuite effectuée sans encombre, en recréant automatiquement une partition Recovery HD saine et en rétablissant l'enveloppe CoreStorage.
Pour « forcer » le changement de disque de démarrage, c'est a priori via la commande "bless".
Voici mon sujet, tu trouveras peut-être des informations utiles pour résoudre ton problème. L'utilisation de la commande "bless" est suggérée par macomaniac à sa troisième intervention.

>> http://forums.macg.co/threads/volume-de-demarrage-accessible-uniquement-via-une-autre-partition.1283102/

Bon courage :)
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
59 274
19 684
Forêt de Fontainebleau
Salut inaden

J'ai lu le fil que tu cites où tu narrais tes déboires antérieurs, et aussi le départ de ce fil-ci. Je conçois que tu sois déconcerté par les dénis d'installation ou de démarrage que tu rencontres, parce qu'il ne semble pas y avoir de « raison » intelligible à cet étrange comportement.

--------------------​

Je comprends que tu as un Mac Pro de 2009 (qui supporte parfaitement a priori les derniers OS) - avec 2 baies pour des disques-Système, que j'appellerai la B1 (baie principale où était loggé initialement ton disque de démarrage supportant «Yosemite 10.10») et la B2 (baie secondaire où était loggé initialement ton disque de stockage avec sa partition vide annexe).

Je crois comprendre aussi que tu as toujours ces 2 disques sous la main, dont le dispositif logique a un tantinet évolué : le disque-Système supportant «Yosemite» qui n'aurait pas été modifié et que j'appellerai D1 ; et le disque de stockage initial que j'appellerai D2, où j'ai l'impression que tu as installé un OS «El Capitan» en l'attachant à un autre Mac, mais sur le Système duquel tu n'arrives pas à démarrer lorsque tu re-logges ce D2 dans n'importe quelle baie de ton Mac Pro.

--------------------​

Afin de me permettre de survoler (avec les « yeux de l'esprit ») le dispositif logique "holistique" de tes 2 disques > est-ce que tu peux, expérimentalement parlant, re-logger ton D1 (OS «Yosemite», bootable en interne) dans sa B1 initiale (baie principale) > et re-logger ton D2 (OS «El Capitan», non bootable en interne) dans sa B2 initiale (baie secondaire) ? - Cela fait, peux-tu démarrer sur le «Yosemite» D1 @B1 > ta session ouverte, aller à : Applications > Utilitaires > lancer le «Terminal» ?

Une fenêtre s'ouvre, qui a l'allure de celle d'un traitement de texte basique, avec une invite de commande à ton nom court d'utilisateur terminé par le symbole du dollar (genre : inaden$) flanquée d'un pointeur déplaçable. Tu peux y saisir des commandes en mode texte, qui retournent des informations logiques ou qui opèrent des modifications d'écritures. Je te propose de passer 2 commandes de type simplement « informatif » (agissant en "lecture seule") :

- a) d'abord tu saisis la commande :
Bloc de code:
diskutil list
et ↩︎ (presse la touche "Entrée" du clavier pour activer la commande) --> cette commande appelle l'utilitaire UNIX diskutil (disk_utility : utilitaire de disque - le même binaire que pilote le logiciel graphique «Utilitaire de Disque») avec le verbe list ("lister") --> en retour, tu vas voir s'afficher le tableau des disques attachés à ton Mac (décrits selon leur table de partition > taille > identifiant de device <appareil logique>) > ainsi que leurs partitions (décrites d'après les paramètres de : format > nom > taille > device).

- b) ensuite du saisis la commande :
Bloc de code:
diskutil cs list
et ↩︎ --> c'est la même commande que ci-dessus, implémentée au milieu de la spécification cs (abrégé de corestorage) --> pour tout format spécial CoreStorage greffé sur une partition-Système de disque (par l'installateur d'«El Capitan», ou l'activation de «FileVault») > tu vas voir s'afficher le tableau en arborescence d'un Groupe de Volumes Logiques comportant les 3 instances ordonnées de : Volume Physique > Famille Logique > Volume Logique.​

=> peux-tu faire des copier-coller de ces 2 tableaux intégraux ici (pas de photos) ? - ça permettra d'avoir une vue exacte et complète du dispositif logique actuel de tes disques.

--------------------​
 

inaden

Membre junior
29 Mars 2008
38
0
D'abord, merci à tous les trois pour votre aide.
Je devrais pouvoir tenter tout ça lundi (peut-être demain, mais c'est pas sûr) et vous tiendrais au courant.
Ce qui me parait le plus dingue, c'est que même en supprimant le disque avec yosemite, le problème persiste !
Je reviens donc vers vous dès que j'ai pu faire les tests.
Encore merci pour vos réponses détaillées.
 

inaden

Membre junior
29 Mars 2008
38
0
bonjour à tous.
En fait, j'ai pu expérimenter.
Donc :
#: TYPE NAME SIZE IDENTIFIER

0: GUID_partition_scheme *1.0 TB disk0

1: EFI EFI 209.7 MB disk0s1

2: Apple_HFS newstock 999.9 GB disk0s2

/dev/disk1

#: TYPE NAME SIZE IDENTIFIER

0: GUID_partition_scheme *1.0 TB disk1

1: EFI EFI 209.7 MB disk1s1

2: Apple_HFS stock2 999.9 GB disk1s2

/dev/disk2 (ÇA C'EST LE DISQUE AVEC YOSEMITE)

#: TYPE NAME SIZE IDENTIFIER

0: GUID_partition_scheme *1.0 TB disk2

1: EFI EFI 209.7 MB disk2s1

2: Apple_HFS ordi 999.3 GB disk2s2

3: Apple_Boot Recovery HD 650.0 MB disk2s3

/dev/disk3 (ÇA C'EST LE DISQUE AVEC EL CAPITAN)

#: TYPE NAME SIZE IDENTIFIER

0: GUID_partition_scheme *1.0 TB disk3

1: EFI EFI 209.7 MB disk3s1

2: Apple_HFS ordinateur 999.3 GB disk3s2

3: Apple_Boot Recovery HD 650.0 MB disk3s3

Par contre :
diskutil cs list
No CoreStorage logical volume groups found

Voilà. sans être spécialiste, j'ai l'impression que la seconde ligne de commande n'est pas réjouissante !
 

inaden

Membre junior
29 Mars 2008
38
0
En fouillant, j'ai trouver cette ligne de commande pour régler le problème... mais comme j'ai l'impression que c'est douteux, je vous la soumet :

cat /dev/random > /dev/disk2
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
59 274
19 684
Forêt de Fontainebleau
Salut inaden

J'aurais besoin d'un éclairage supplémentaire :

Ton Mac Pro a donc en tout 4 baies pour disques durs de 3,5 pouces de 1 To > dans les baies 1 et 2 tu as manifestement des disques de stockage (disk0 > volume newstock et disk1 > volume stock2) > dans les baies 3 et 4 des disques Système (disk2 > volume ordi = «Yosemite» et disk3 > volume ordinateur = «El Capitan»).

Pourquoi réserves-tu les baies 3 & 4 aux disques Système et les 2 premières baies à des disques de stockage ? As-tu essayé de mettre ton actuel disk3 > volume ordinateur = «El Capitan» dans la baie n°1 (à la place de l'actuel disk0 > volume newstock) pour voir si, à cette localisation, le volume ordinateur serait affiché à l'écran obtenu avec "alt" et par suite démarrable ?

--------------------
Par ailleurs : regarde cette page Apple ☞À propos des mises à jour de l’EFI et du programme interne du SMC des ordinateurs Mac à processeur Intel☜ pour vérifier si le Programme Interne de ton Mac Pro et son SMC sont bien à jour (un état "rétro" de ces logiciels pourrait rendre compte de tes problèmes de boot d'un OS comme «El Capitan»).
 

inaden

Membre junior
29 Mars 2008
38
0
Bonjour macomaniac
J'ai vérifié les MAJ SMC et je suis bien pour un modèle MacPro 4.1 sur une version de la rom de démarrage
MP41.0081.B07 par contre, sur la page que tu m'indiques, il n'y pas de version SMC d'indiquée, et je suis sur la version
1.39f5.
Pour les baies, j'avoue que c'est un peu le hasard qui a fait que j'ai installé sur un disque, puis sur l'autre sans véritablement me soucier de la baie sur laquelle étaient insérés les disques. J'essaie de changer les baies et de redémarrer et je te tiens au courant. (Je dois juste aller ce matin au centre antidouleur et je en sais pas si je pourrais te mettre les résultats avant de partir).

Sinon, que penses tu de la solution cat /dev/random > /dev/disk2 ?
En tout cas, merci pour ton aide.
Aller, j'éteins et je change les baies, et je redémarre avec alt pour tenter le démarrage sur el capitan.
 

inaden

Membre junior
29 Mars 2008
38
0
J'y ai cru... mais non, ça démarre sur el capitan (quand j'appuie sur alt au démarrage, c'est même lui qui est par défaut — ce qui change parce que ce n'était pas le cas) mais ensuite, l'image de fond d'écran apparait et le petit disque chromatique tourne, tourne et le finder n'apparait pas ! Bon, je dois y aller, je serais de retour vers 13h30 / 14h.
Encore merci.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
59 274
19 684
Forêt de Fontainebleau
Donc tu vois bien le volume ordinateur affiché à l'écran de choix du disque de démarrage (touche "alt" au départ) > est-ce que tu vois aussi l'autre volume-Système : ordi ? Si tu le ne vois pas > mets tes 2 disques-Système dans les 2 premières baies 1 et 2 (je pense qu'elles sont comptées dans leur rangée à partir de la gauche en direction de la droite).


Indépendamment de cette question d'affichage : quand tu sélectionnes le volume ordinateur > il y a bien selon toute apparence démarrage du Système :

- essaie de décrire les phases à l'écran : tu vois s'afficher la  ? > puis tu vois s'afficher une barre de chargement horizontale ? > elle se charge complètement ? > tu atteins l'écran d'ouverture de session = renseignement du mot-de-passe d'utilisateur ? > il est accepté et la session commencer à s'ouvrir ? > c'est à ce moment-là seulement que les choses se bloquent ?​

=> si ton expérience correspond à ma description : le problème se réduirait à un problème d'ouverture de session graphique (en gros : pas de Finder opérationnel) > est-ce que c'est bien ça ?
 

inaden

Membre junior
29 Mars 2008
38
0
Donc, j'avais mis les deux disques avec système en 1 (el capitan) et 2 (Yosemite).
Quand je sélectionne ordinateur (el capîtan), je vois la pomme, puis la barre de chargement. À un moment donné, la barre de chargement est remplacée par un rectangle tout blanc qui est un peu plus grand, puis elle revient.
Ensuite, je ne passe pas par l'interface d'identification, mais j'ai directement l'image de fond initiale d'el capitan, et ça tourne.
Je suis presque sûr que lorsque j'ai installé el capitan, j'ai demandé à ce que l'allumage passe par l'interface d'identification, parce que je ne l'avais pas fait sur mes premiers essais (qui donnaient la même chose).
Alors, j'ai demandé à Yosemite de passe par l'interface d'identification et j'ai réessayé... pareil, el capitan merdoie en fin d'allumage.
Et quand je démarre sur la partition de réinstallation... j'ai un message d'erreur qui me dit qu'il faut que j'utilise la version d'el capitan téléchargé du l'appel store... ce qui est le cas.

Donc, oui, c'est peut-être un pb d'interface graphique... le ic, c'est que je n'ai pas le problème sur yosemite, et je n'ai pas eu le problème quand j'ai sorti le disque pour l'installer depuis mon portable... tout avait bien redémarré après l'installation !
Comme mes disque de stockage ont plus de 10 ans de boulot dessus, j'ai peur d'erraser les deux disques systèmes vu que je n'arrive jamais à mener une installe depuis un clé !
Et le problème c'est qu'avec yosémite... l'ordi s'éteint parfois alors que je fais des truc dessus !
En tout cas, vraiment merci pour ton attention et ton aide.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
59 274
19 684
Forêt de Fontainebleau
Donc ton Système «El Capitan» (volume ordinateur) se charge complètement > c'est uniquement l'ouverture de ta session graphique qui plante.

Depuis ta session de «Yosemite» (volume ordi) > je te conseille de re-télécharger depuis l'AppStore un installateur d'«El Capitan» (si tu n'en as pas déjà un sous la main) > tu le lances d'un double-clic > tu lui choisis comme "destination" de l'install le volume ordinateur (celui d'«El Capitan»).

Cette action (environ 30') se borne à restaurer les fichiers du Système, sans toucher les comptes d'utilisateur, ni leurs données et préférences, et pas non plus les applications tierces ajoutées > à complétion d'un telle ré-install, régulièrement le Mac re-démarre sur le Système ré-installé > tu vas pouvoir tester si ta session s'ouvre bien ou non...
 

inaden

Membre junior
29 Mars 2008
38
0
J'ai déjà essayé... mais avant de redémarrer, il me dit qu'il y a un problème et qu'il ne peut pas installer.
Pareil si je démarre sur une clé que j'ai fait avec le tuto apple pour faire une clé de boot. Là, il redémarre, mais au second redémarrage, quand il reste une seconde, il ne redémarre pas et quand j'affiche la console, j'ai des erreurs en boucle :
langage Chooser [457:6775]
TSpliceFont Failed creating description for({UnicodeRange="<_NSCFCaracterSetV:0x7FaFb364a810>", name=NotoSansButid;
ça le fait plusieurs fois puis :
Cannot connect to /var/run/systemkeychaincheck.socket : no sych file or directory
Et c'est bien pour ça que je ne sais plus quoi faire !
Je réessairais, mais je reste ouvert à toute solution !
Et merci pour ton soutien
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
59 274
19 684
Forêt de Fontainebleau
Je te propose une autre tentative : essayer de créer un compte d'utilisateur admin auxiliaire dans l'OS «El Capitan», pour voir si tu arrives à ouvrir une session vierge de préférences.

Dans le «Terminal», tu fais un copier-coller de la commande :
Bloc de code:
sudo rm /Volumes/ordinateur/private/var/db/.AppleSetupDone
et ↩︎ --> une demande de password s'affiche (commande sudo) --> tape ton mot-de-passe admin à l'aveugle - aucun caractère ne se montrant à la frappe - et derechef ↩︎

Cette commande supprime un fichier de finalisation de l'install dans «El Capitan» (sans toucher ton compte) --> ce qui fait qu'au re-démarrage sur le volume ordinateur, à la fin > tu devrais te voir re-proposer les panneaux de paramétrage de ton ordinateur et à la fin celui d'un compte admin.

Re-démarre donc avec "alt" > choisis le volume ordinateur > laisse-le le Système charger > à la fin, tu devrais avoir, non l'écran d'ouverture de session, mais les panneaux classiques de choix du pays, langue, AppleID qui interviennent à la fin d'une installation : renseigne tout exactement. Pour terminer, un panneau de configuration d'un compte admin : ne reprends surtout pas les identifiants de ton compte déjà en place > prends : Nom Complet = toto ; Nom de Compte = toto ; mot-de-passe (local) = toto.

=> ce qui est intéressant est de vérifier si tu peux dans la foulée ouvrir une session d'utilisateur toto (vide évidemment) ou s'il y a là encore un blocage graphique.
 

inaden

Membre junior
29 Mars 2008
38
0
J'adore cette astuce.
Je te tiens au courant dès que j'ai pu essayer ça.
Sinon, je reprépare une clé d'instal avec l'astuce qu'il avait ici sur le fait d'ajouter des police dans la clé d'instal. Je l'avais tenté, mais je viens de me rendre compte que j'avais fait l'erreur de mettre le dossier Noto dans le dossier Fonts, et pas les fontes directement.
Que le grand Manitou veille sur toit et les tiens !
 

inaden

Membre junior
29 Mars 2008
38
0
Bien... Et bien maintenant, au démarrage choix des appli (par alt) puis pomme, puis barre de chargement... arrivé presque à la fin, la barre de chargement disparait et le rectangle blanc un peu plus grand la remplace, le petit disque chromatique apparait et tourne... tourne...
Du coup, j'en profite pour relancer la clé avec les polices ajoutées dedans...
Si tu as une idée de ce que le problème veut dire, je suis toute ouie, et je te tiens au courant pour la tentative avec clé.
J'ai pensé aussi essayer de mettre les dites polices dans le dossier Fonts (/System/Library/Fonts) de el capitan pour voir...
Que je n'arrive pas à régler le problème est une chose, mais je crois que ce qui est le plus rageant est de ne pas comprendre d'où il vient !
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
59 274
19 684
Forêt de Fontainebleau
Que je n'arrive pas à régler le problème est une chose, mais je crois que ce qui est le plus rageant est de ne pas comprendre d'où il vient !
Alors on est deux à être logés à la même enseigne


Pour aborder le problème sous un autre angle :

- a) est-ce que tu as un autre Mac ? si oui :

- b) est-ce que tu as de quoi lui attacher le disque supportant ton volume ordinateurEl Capitan») après l'avoir ôté de la baie du Mac Pro (genre : un boîtier SATA <=> USB pour disque 3,5 pouces ; ou un dock du même type ; ou encore un câble SATA <=> USB avec 2 prises : alimentation et transfert de données) ? si oui :

- c) est-ce que tu peux ré-installer le volume ordinateur attaché en externe depuis la session ouverte de l'autre Mac, en lançant un installateur d'«El Capitan» ? si oui :

- d) arrives-tu, à la fin, à ouvrir ta session dans l'OS de ton volume externe ordinateur ? si oui :

- e) en attachant à présent en USB le boîtier recelant le disque 3,5 pouces à ton Mac Pro et en le démarrant la touche "alt" pressée > est-ce que tu arrives à ouvrir ta session dans l'OS du volume ordinateur en externe ?​
 

inaden

Membre junior
29 Mars 2008
38
0
Re salut pour cette nouvelle journée.

a/ oui j'ai un portable qui est sur el capitan
b-c-d/ oui j'ai un boitier pour mettre les disque, c'est d'ailleurs comme ça que j'ai pu installer el capitan sur le disque dur. Lors de l'installation, le portable à bien redemmarrer sur le disque externe
e/ c'est quand je remets le disque dans la baie que je me retrouve avec ce problème au démarrage, mais je n'avais pas essayé de démarrer dessus comme disque externe en le laissant dans le boitier.

Je vais donc essayer cela. J'avais essayer de démarrer sur un disque externe (un vrai) qui a une partition avec el capitan et que est un disque de secours pour démarrer dessus en cas de problème avec un ordinateur... hélas, ça m'avait fait pareil, mais je vais refaire le test.
Penses-tu qu'il faille réinstaller el capitan après la manip que tu m'avais fait faire pour supprimer la finalisation de l'installation ?
Bloc de code:
sudo rm /Volumes/ordinateur/private/var/db/.AppleSetupDone
Je ne sais comment te remercier de ta patience !
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
59 274
19 684
Forêt de Fontainebleau
Tu peux tenter de démarrer en externe sur le disque qui porte le volume ordinateur en l'état - sans ré-installation préalable.

Car le Système est complètement installé > la suppression du fichier .AppleSetupDone changera simplement la donne tout à la fin : au lieu d'afficher l'écran d'ouverture de ta session déjà en place > ce sera des panneaux de paramétrage de l'ordinateur et d'un nouveau compte admin.

=> tu vas bien voir, après complétion de la barre de chargement du Système > si tu obtiens ces panneaux > si tu peux les paramétrer > si tu peux efin ouvrir une session admin auxiliaire toto...