Impossible de se connecter à un autre réseau WIFI que le mien sauf via VPN

dröne

Membre junior
4 Février 2005
29
0
Bonjour,

Sur mon ordi portable (MacBookPro Retina mi-2012, OSX High-Sierra) je n'arrive pas à me connecter à un autre réseau WIFI que celui de chez moi.
Donc chez moi aucun problème, mais dès que je suis ailleurs impossible, sauf si je me connecte à mon VPN… Actuellement pour mon boulot je ne suis pas chez moi et arrive à me connecter car je passe par le VPN. Je ne comprends pas et ne sais pas quoi faire !
Et c'est comme ça depuis quelques temps (je ne sais pas depuis quand, mais quelques années, peut-être à un changement d'OS)

Avez-vous une idée ?
 

ericse

Membre d’élite
Club MacG
30 Avril 2019
2 518
319
Bonjour,
Avec ton VPN désactivé, tu vas dans "Préférences réseau > Avancé > DNS" et tu enlèves toutes les lignes
(Tu peux faire une copie d'écran avant si tu veux les remettre si ça ne change rien, mais normalement il ne faut rien ici)
 

dröne

Membre junior
4 Février 2005
29
0
Merci ericse, je viens d'essayer et ça ne marche malheureusement pas. Bon je n'avais rien à virer en fait, la seule ligne présente est impossible à virer (elle doit correspondre à l'IP de là où je suis).
Du coup je suis revenu sur le Vpn pour pouvoir écrire ce message…
 

ericse

Membre d’élite
Club MacG
30 Avril 2019
2 518
319
Il faudrait que tu essayes les 2 commandes suivantes (sans le VPN) :
Bloc de code:
ping 1.1
ping google.fr
Et que tu copie le résultat ici :)
 

dröne

Membre junior
4 Février 2005
29
0
Cool, merci d'essayer de m'aider.

Alors pour ping 1.1 :
Bloc de code:
PING 1.1 (1.0.0.1): 56 data bytes
64 bytes from 1.0.0.1: icmp_seq=0 ttl=55 time=7.491 ms
64 bytes from 1.0.0.1: icmp_seq=1 ttl=55 time=4.300 ms
64 bytes from 1.0.0.1: icmp_seq=2 ttl=55 time=3.775 ms
64 bytes from 1.0.0.1: icmp_seq=3 ttl=55 time=9.804 ms
64 bytes from 1.0.0.1: icmp_seq=4 ttl=55 time=6.572 ms
64 bytes from 1.0.0.1: icmp_seq=5 ttl=55 time=20.571 ms
64 bytes from 1.0.0.1: icmp_seq=6 ttl=55 time=37.491 ms
64 bytes from 1.0.0.1: icmp_seq=7 ttl=55 time=8.035 ms
64 bytes from 1.0.0.1: icmp_seq=8 ttl=55 time=28.841 ms
64 bytes from 1.0.0.1: icmp_seq=9 ttl=55 time=4.660 ms
64 bytes from 1.0.0.1: icmp_seq=10 ttl=55 time=3.601 ms

Et ça ne s'arrête pas (sauf si je quitte le terminal)

Et pour ping google.fr d'abord ça :
Bloc de code:
ping: cannot resolve google.fr: Unknown host

Comme ça ne fait rien je l'ai refait et j'ai eu ça :
Bloc de code:
 ping google.frping google.fr
usage: ping [-AaDdfnoQqRrv] [-c count] [-G sweepmaxsize]
            [-g sweepminsize] [-h sweepincrsize] [-i wait]
            [-l preload] [-M mask | time] [-m ttl] [-p pattern]
            [-S src_addr] [-s packetsize] [-t timeout][-W waittime]
            [-z tos] host
       ping [-AaDdfLnoQqRrv] [-c count] [-I iface] [-i wait]
            [-l preload] [-M mask | time] [-m ttl] [-p pattern] [-S src_addr]
            [-s packetsize] [-T ttl] [-t timeout] [-W waittime]
            [-z tos] mcast-group
Apple specific options (to be specified before mcast-group or host like all options)
            -b boundif           # bind the socket to the interface
            -k traffic_class     # set traffic class socket option
            -K net_service_type  # set traffic class socket options
            -apple-connect       # call connect(2) in the socket
            -apple-time          # display current time
 

ericse

Membre d’élite
Club MacG
30 Avril 2019
2 518
319
Essayes de mettre les lignes suivantes dans la fenêtre de gauche de "Préférences réseau > Avancé > DNS" (en faisant attention de bien choisir la bonne connexion à gauche juste avant de cliquer sur "Avancé") :
Bloc de code:
1.1.1.1
1.0.0.1
 

dröne

Membre junior
4 Février 2005
29
0
Youhou !! Ça fonctionne, merci ;)
J'écris actuellement sans le Vpn.
Il faudra que je fasse ça à chaque fois ou ça va me garder ces serveurs DNS ?
Et si tu as le temps de m'expliquer vite fait pourquoi j'étais face à ça n'hésite pas !
 

ericse

Membre d’élite
Club MacG
30 Avril 2019
2 518
319
Ca devrait rester.

Les 2 pings montrent que la connectivité IP fonctionne, mais la résolution DNS non.
Normalement le DNS est fournis automatiquement par le réseau local auquel tu te connectes, mais là non, pour une raison inconnue.
En ajoutant les deux lignes tu dis à ton Mac de ne pas utiliser le DNS fournis par le réseau local, mais celui de Cloudflare.
Il y en a d'autres : https://www.techradar.com/news/best-dns-server
Dans ceux-là il y en a un qui filtre les sites dangereux : 9.9.9.9
 

dröne

Membre junior
4 Février 2005
29
0
Parfait, toutes ces infos me permettent de comprendre le soucis et je vais essayer de savoir pourquoi les réseaux auquel je me connecte (tous donc) ne me fournissent pas automatiquement le DNS.
Encore merci !
 

ericse

Membre d’élite
Club MacG
30 Avril 2019
2 518
319
Parfait, toutes ces infos me permettent de comprendre le soucis et je vais essayer de savoir pourquoi les réseaux auquel je me connecte (tous donc) ne me fournissent pas automatiquement le DNS.
Oui, c'est curieux, mais difficile de diagnostiquer ça à distance... Bon courage !