Impossible d'envoyer le moindre mail depuis maj de mon système de 10.6 à 10.7

Alain691

Membre confirmé
8 Mars 2009
32
4
Bonjour à tous,

J'utilise un Mac "antique", à savoir un vieux MacBook en plastique de 2007. Tant que je l'utilisais en sytème 10.6 , Mail fonctionnait bien. Je pouvais recevoir et envoyer des Mails à partir de tous mes comptes actifs (6). Mais depuis que j'ai majé mon système d'un cran (passage au 10.7.5), Mail a été majé en même temps "version
5.3 (1283)". Et cette nouvelle version refuse depuis le début d'envoyer le moindre message avec le serveur SMTP de mon FAI (Free).

Lorsque j'essaie un envoi (depuis n'importe lequel de mes comptes), la roulette tourne plusieurs minutes, et je fini par avoir l'erreur suivante :

Impossible d'envoyer le message depuis le serveur smtp.free.fr
Les connexions au serveur « smtp.free.fr » sur les ports par défaut ont expiré.
Sélectionnez un serveur d’envoi différent dans la liste ci-dessous ou cliquez sur Essayer plus tard pour laisser le message dans votre boîte d’envoi jusqu’à ce qu’il puisse être envoyé.

Et dans la listequi suit, je trouve bien "smtp.free.fr" mais suivi de " (Déconnecté)"

J'ai vérifié le coupe-feu du système, et le port 25 n'est pas bloqué.

Je précise également que suite à une réponse formulée pour un cas similaire, j'ai lu la doc : https://assistance.free.fr/articles/609 et j'ai lu également l'aide en ligne de Mail relative au smtp, mais ça ne m'a pas aidé (je dois avouer aussi que je n'ai pas tout compris)

Je patauge un peu, beaucoup, énormément ... Que pouvez-vous me conseiller ?

Cordialement

Alain
 

Alain691

Membre confirmé
8 Mars 2009
32
4
Bonsoir à tous, et meilleurs voeux pour 2022 !

Bon, ma demande du 26-12 ne semble pas vous inspirer (mais je comprends qu'un problème aussi anachronique ne suscite pas un engouement démesuré, sans compter que les spécialistes de machines et de systèmes aussi anciens ne doivent pas être très nombreux !)
Alors je vais formuler ma demande différemment.
Si j'ai fait cet upgrade de mon système, c'est parce que je ne pouvais plus upgrader Firefox, ni aucun navigateur dont je disposais, et que de + en + de sites s'affichaient mal, voire pas du tout !
Mais j'ai été plutôt déçu du résultat (pas possible d'installer une vr récente de Firefox, plusieurs vieilles applis qui ne sont plus prises en compte, les assenceurs des fenêtres ayant subi une telle cure d'amaigrissement que je n'arrive plus à les attraper, et pour couronner le tout, la nouvelle vr de Mail qui se révelle incappable d'envoyer le moindre message).

Alors ma nouvelle question sera donc la suivante : ai-je une possibilité de revenir en arrière, cad réinstaller le système 10.6.5 ?
Si oui, est-ce que la version de Mail que je retrouverais alors serait capable d'utiliser la BDD du Mail imposé par la vr 10.7.5 ?

Merci d'avance pour vos lumières

Alain
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
54 339
10 362
Nancy___
Alors ma nouvelle question sera donc la suivante : ai-je une possibilité de revenir en arrière, cad réinstaller le système 10.6.5 ?
Oui, en formatant ton disque interne, puis installation de SL à partir de tes DVD, puis passage en 10.6.8 (la dernière version de SL et toutes ses màj de sécurité).


Si oui, est-ce que la version de Mail que je retrouverais alors serait capable d'utiliser la BDD du Mail imposé par la vr 10.7.5 ?
Bonne question. Je ne sais pas. Tu devrais tenter sur un disque externe.

Mais Mail devrait quand même être capable d'envoyer des messages avec le SMTP de FREE sous Lion.
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
23 042
5 710
Là-haut
D'expérience, les problèmes smtp sont souvent à mettre en relation avec le Trousseau d'accès.

Il faut supprimer les anciennes occurrences des comptes mail avant de saisir de nouveau le mot de passe.

D'un autre côté et selon moi, le passage de Snow Leopard à Lion n'est pas vraiment un progrès, plus lourd, pas plus compatible, une interface problématique. Snow Leopard est un système bien plus équilibré pour cette machine.
 
  • J’aime
Réactions: Franz59

Alain691

Membre confirmé
8 Mars 2009
32
4
Bonsoir Sly54 et Moonwalker ,
Merci beaucoup pour les pistes que vous avez eu la gentillesse de m'indiquer.
Alors je viens de supprimer pas mal de choses du Trousseau en relation avec Mail, mais j'ai été surpris de ne trouver qu'un seul élément en relation avec le smtp. Mais après mon nettoyage, l'erreur subsiste : la roulette tourne (beaucoup moins longtemps qu'avant), mais Mail me demande de choisir un autre serveur SMTP. Je n'ai pas encore supprimé les éléments du trousseau en relation avec le serveur POP (qui fonctionne bien). Pensez-vous que je devrais le faire aussi ?
Si j'avais su .... (j'aurais dû vous demander conseil avant d'effectuer cette maj contre-productive)
Bien cordialement
Alain
 

zeltron54

Membre expert
Club MacG
29 Mars 2008
2 497
397
Lorraine
Bonsoir,

Il me semble que le smtp.free.fr devrait avoir le port 587 si configuré en POP et 465 si configuré en IMAP
Sans certitude (de mémoire pour la port POP) actuellement je suis en IMAP port 465.
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
23 042
5 710
Là-haut
Si le port POP de réception fonctionne ne pas y toucher.

Le port d’envoi smtp est le 25 sauf si vous passez en « sécurisé ». De mémoire, parce que je ne suis pas chez Free, il faut changer quelques chose dans votre compte sur le site Free pour être en smtp « sécurisé ».

(c’est d’ailleurs indiqué dans la documentation que vous avez donné en lien)

Vous devriez tenter de passer en « sécurisé » port 465 pour le smtp.

(je dois avouer aussi que je n'ai pas tout compris)
En gros et rapidement.

Tu as deux sortes de configurations pour ton client Mail : POP ou IMAP.

Tu as deux façons de régler cela : sécurisé ou non.

Là, tu es en POP non sécurisé. Le serveur de réception (POP) est sur le port 110. Le serveur d’envoi (smtp) est sur le port 25.

En POP sécurisé ton serveur d’envoi (smtp) est le 465.

Bonsoir,

Il me semble que le smtp.free.fr devrait avoir le port 587 si configuré en POP et 465 si configuré en IMAP
Sans certitude (de mémoire pour la port POP) actuellement je suis en IMAP port 465.
Concernant l’envoi c’est SSL/TLS pour 465 et MD5 pour 587 pour le serveur smtp sécurisé. Qu’on soit en POP ou en IMAP ne change rien. Free indique d’utiliser le 465 (voir doc en lien plus haut).
 

Alain691

Membre confirmé
8 Mars 2009
32
4
Merci encore. Je viens de relire cet article de Free intitulé "Configurer de manière avancée votre logiciel de messagerie". J'ai n'ai pas trouvé qu' il me faudrait aller sur mon compte Free pour changer quelque chose dans les paramètres, mais je n'ai peut-être plus les yeux en face des trous ! Pour les yeux déréglés, il y a pire, car à l'intérieur de Mail, je ne retrouve pas l'endroit où on peut régler le n° du port SMTP ! (si c'est dans les préférences, je donne ma langue au chat)
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
23 042
5 710
Là-haut
Dans les préférences de Mail, sélectionner le compte.

Il y a là des captures d'écran (Mountain Lion) en bas de page.


Concernant l'option "sécurisé" chez Free :
Il faut commencer par valider l'authentification du compte mail sur le site de free en allant sur compte, abonnement, gestion des comptes mails, gestion du smtp authentifié et suivre la procédure.

source : https://forums.commentcamarche.net/...onfigurer-un-compte-mail-free-sur-mac-os-10-8
 
Dernière édition:

Alain691

Membre confirmé
8 Mars 2009
32
4
Bon, j'ai retrouvé l'endroit où l'on peut modifier les paramètres SMTP. Il était déjà précisé (et coché) "utiliser les ports standard 25,465, 587". Et "envoi non sécurisé". J'ai essayé ce qui est indiqué dans la doc Free pour passer en POP sécurisé (donc en forçant le port 465 et en spécifant mon identité et mon mot de passe), mais ça ne fonctionne pas mieux !
Je pense que sécurisé ou pas, le pb est ailleurs ... mais où ?
 

Alain691

Membre confirmé
8 Mars 2009
32
4
Bien. Après avoir bidouillé tous ces paramètres, je n'obtient que des erreurs (que je ne sais pas interpréter). Je ne vais pas y passer la nuit. J'y reviendrai dimanche soir si j'arrive à consacrer du temps là-dessus.
Merci encore à tous pour votre aide.
 

baron

Membre expert
Club MacG
22 Avril 2008
2 037
575
LLN
La lecture de ceci (en anglais) pourrait t'aider…
https://eclecticlight.co/2021/07/02/when-you-cant-send-mail-fixing-smtp-problems/

— En particulier à partir du paragraphe avant cette image :

mailsmtp01.jpg

En bref, ça explique comment assainir (par la méthode bien connue d'élaguer puis repeupler) la liste des serveurs SMTP.
 
Dernière édition par un modérateur:

Alain691

Membre confirmé
8 Mars 2009
32
4
Bonjour à tous !
Victoire ! Après avoir lu attentivement les principaux documents que vous m'avez conseillés, et à force de bidouiller de façon plus ou moins pifométrique, ça a fini par fonctionner !
Je vous donnerai les détails ce soir, mais je vous adresse déjà à tous ma profonde gratitude...
 

Alain691

Membre confirmé
8 Mars 2009
32
4
Bonjour à tous !
Victoire ! Après avoir lu attentivement les principaux documents que vous m'avez conseillés, et à force de bidouiller de façon plus ou moins pifométrique, ça a fini par fonctionner !
Je vous donnerai les détails ce soir, mais je vous adresse déjà à tous ma profonde gratitude...
Alors voilà :
dans l'article de Free https://assistance.free.fr/articles/609 il est bien indiqué "Si une méthode de sécurité vous est proposée, choisissez SSL/TLS port 465 (ou MD5 port 587). " L'accent est donc mis sur le port 465, le 587 semblant plutôt un second choix. Mais à partir du moment ou ma vr de Mail m'averti que la config SMTP sélectionnée n'arrive pas à envoyer, et me propose d'en essayer d'autres, j'ai alors la possibilité de suivre les échanges qui ont lieu en coulisse (dans un langage basé sur une sorte d'anglais technique). Et en lisant ce charabia, j'arrive à comprendre que la 1ere étape (connexion au serveur SMTP) n'est réussie qu'avec le port 587 (j'avais laissé le choix du port sur "Utiliser les ports par défaut 25, 465, 587"). Je me replonge dans une des docs que vous m'avez suggérées (je ne retrouve plus laquelle) et je lis qu'en cas d'utilisation du port 587, il faut choisir le mode d'authentification "Réponse au défi MD5". J'essaie alors cette option, et ça passe !

(je ne saurai probablement jamais ce qu''est le "défi MD5" ni pourquoi sa sélection n'est pas automatique, mais ça fonctionne et c'est le principal)

Alors pour conclure provisoirement, je suis bien conscient que je suis au milieu du gué, car pour l'instant ni mes message entrants ni mes sortants ne sont cryptés en SSL, mais à chaque jour suffit sa peine, et je ne manquerai pas de revenir ici, si lors de cette ultime étape, mon Mail refuse de "tomber en marche".

Merci à tous encore une fois

Alain (soulagé)