Impossible d'installer LibreOffice sur OSX 10.5.8...

MrJDD

Membre confirmé
23 Août 2008
75
2
Bonjour,

J'ai passé une bonne partie de la nuit à interroger Gogole et fouiller partout pour trouver une solution à mon problème : il m'est impossible d'installer LibreOffice. Je n'ai rien trouver non plus sur le forum. Alors je vous le soumets, dans l'espoir que quelqu'un puisse m'aider !

En fait, comme OpenOffice bug un peu trop souvent, et puis que je veux tester son petit concurrent, j'ai téléchargé la dernière version, je l'ai placé dans les Utilitaires, puis j'ai téléchargé l'utilitaire de langues (comme c'est indiqué ici : icihttp://fr.libreoffice.org/telecharger/) ; mais voilà, quand je veux lancer l'application, j'ai ce ***** de message : "L'application Libreoffice a quitté inopinément." Et on me propose d'envoyer un rapport d'erreur...

Rien à faire, malgré des heures de répétition et de recherche, je n'ai pas trouvé comment la lancer. J'ai aussi essayé une version antérieure (même si c'est pas top...), mais c'est pareil. J'ai aussi tenté l'installation sur un autre compte utilisateur, mais c'est pareil.

A chaque fois, pour désinstaller, je recherche "LibreOffice" dans spotlight et je jette puis vide la corbeille ; et, en outre, je vais jeter ce qui apparaît sous ce nom dans les Bibliothèques. Est-ce que j'oublie un endroit à nettoyer ? Est-ce que quelque chose entraîne un conflit ? Est-ce que j'ai raté un chapitre ?

...J'utilise beaucoup Writer et j'en ai besoin aujourd'hui, aussi je vous remercie beaucoup, d'avance, de bien vouloir m'aider (svp, merci de ne pas utiliser un langage trop technique, je ne suis pas non plus un pro :D).


EDIT:
Voici un collé du rapport d'erreur :


Process: soffice [535]
Path: /Applications/LibreOffice.app/Contents/MacOS/soffice
Identifier: org.libreoffice.script
Version: ??? (???)
Code Type: X86 (Native)
Parent Process: launchd [102]

[...]

Dyld Error Message:
unknown required load command 0x80000022
 
Dernière édition:

pascalformac

Membre vénérable
Club MacG
23 Novembre 2003
58 737
1 814
plusieurs trucs bizarres

déjà ca



pourquoi?
c'est un détail


ensuite ca
J'ai aussi tenté l'installation sur un autre compte utilisateur, mais c'est pareil.
sauf si on le veut vraiment
une app ne s'installe pas dans un compte , mais niveau OS

et par ailleurs tu as QUEL MAC?

Rappel
les derniers LO ne sont PAS pour PPC
( normalement il ne devrait même pas s'installer)
---
et tu aimes les typos rikiki. ca fait mal aux yeux
 

MrJDD

Membre confirmé
23 Août 2008
75
2
Merci pour cette réponse. Comme je l'ai dit je suis loin d'être un initié au vocabulaire...

Exact petite erreur, je voulais dire APPLICATIONS et non pas utilitaires.

Ah je ne savais pas que ça s'installait "niveau OS" ; du coup ça élimine encore plus cette éventualité.

J'ai ceci :

2.4 GHz Intel Core 2 Duo
2 Go 667 MHz DDR2 SDRAM
OSX 10.5.8
 

pascalformac

Membre vénérable
Club MacG
23 Novembre 2003
58 737
1 814
ok macintel donc compatible

je conseillerai ca
1 nettoyage
tu vires
l'application

et
le dossier libre office
de
Maison/Bibliotheque/ApplicationSupport/

et
de
Maison/Bibliotheque/Caches/

et les preferences LO
Maison/Bibliotheque/Preferences/
y en a soit aucune car ca s'ouvre pas, soit une ou 2 ( commencent par org.libreoffice)

et ensuite
2 reinstall
soit tu rouvres le dmg que tu as ( l'anglais)
soit tu en prends un neuf
 
Dernière édition:

pascalformac

Membre vénérable
Club MacG
23 Novembre 2003
58 737
1 814
il se trouve qu'il y a des rapports de bugs pile là dessus

je ne sais pas si tu les as vus
exemple
https://bugs.freedesktop.org/show_bug.cgi?id=67688

les aidants pointent une cause
des POLICES ajoutées

voire un souci avec certains 10.5
(affaire de codage du package)

et je conseillerai aussi de verifier des petites choses
comme verifier réparer les autorisations
et verifier réparer le disque
 

MrJDD

Membre confirmé
23 Août 2008
75
2
Ah ! Il est vrai que j'ai (il y a longtemps) ajouté pas mal de polices pour OpenOffice... Il faudrait que je les supprime pour permettre d'installer LibreOffice ?... Mais comment sans les supprimer toutes ? Que c'est compliqué.

Pour les réparations : je l'ai déjà fait avec OnyX.

Je te remercie beaucoup pour le temps que prends pour moi !
 

pascalformac

Membre vénérable
Club MacG
23 Novembre 2003
58 737
1 814
Ah ! Il est vrai que j'ai (il y a longtemps) ajouté pas mal de polices pour OpenOffice... Il faudrait que je les supprime pour permettre d'installer LibreOffice ?... Mais comment sans les supprimer toutes ? Que c'est compliqué.

Pour les réparations : je l'ai déjà fait avec OnyX.

Je te remercie beaucoup pour le temps que prends pour moi !

il ne s'agit pas de les supprimer mais eventuellement dans un premier temps de les désactiver

perso , et je suis loin d'etre le seul, je conseille une très grande prudence avec les ajouts de polices
( beaucoup de merdes, non compatibles ou mal codées)

et t'aurais sans doute intérêt à revenir à un Livre de Polices standard
( voir tous les fils sur redressement nettoyage de livre de police)
 

MrJDD

Membre confirmé
23 Août 2008
75
2
perso , et je suis loin d'etre le seul, je conseille une très grande prudence avec les ajouts de polices ( beaucoup de merdes, non compatibles ou mal codées)
Ah, si j'avais su...


Bon, j'ai d'abord désactivé les polices importées : pareil.
Puis après avoir désinstaller LO, j'ai désactivé toutes les polices du livre : pareil.


:rateau::rateau::rateau::rateau:
 

pascalformac

Membre vénérable
Club MacG
23 Novembre 2003
58 737
1 814
fais le nettoyage à fond
voir les tutos là dessus

( j'ai plus les manips exactes en tête pour cet OS , mais y a plein de tutos ou fils macg et autres)

l'idéal serait d'avoir un livre de polices comme à premiere utilisation
c'est à dire celui de l'OS et rien d'autre
quitte à ensuite faire aussi les usuels pour bétonner
( install de la combo update , reparation des autorisations et verif du disque )
 

pascalformac

Membre vénérable
Club MacG
23 Novembre 2003
58 737
1 814
le livre de polices n'est qu'une des pistes
comme tu as pu le voir sur le rapport de bug
ca ne résoud pas tous les cas

et je dirai
t'aurais peut etre interêt à essayer de résoudre tes soucis avec l'autre suite
( OOO)
dont certains des bugs peuvent d'ailleurs etre liés ...aux polices ajoutées
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
22 750
5 304
Là-haut