Insertion de légendes sur des photos depuis Word

Bloody92

Membre confirmé
16 Avril 2016
17
0
29
Bonjour,

Je rencontre des difficultés à ajouter des légendes sur mes photos (afin de créer une table d'illustration) ...

Voici comment j'ai procédé :
J'ai inséré mes photos (format .tiff) (via InsertionImagesImage à partir d'un fichier ...
Je les ai adaptées à ma page : redimensionnées grâce à la petite flèche dans l'angle de la photographie et centrées via Format de l'imageRéorganiserAlignerAligner au centre).

Alors que les légendes se sont numérotées correctement jusqu'à la cinquième photographie, à présent, la légende stagne à la Figure 5. Toutes les images suivantes ne sont plus numérotées automatiquement, je ne peux qu'ajouter Figure 5.
J'ai fermé mon document puis l'application et réessayé, mais rien ne change.

(Hier, j'ai eu le problème avec la seconde photographie, la légende stagnait à la Figure 2, mais en redémarrant mon Mac ce matin, le problème semblait résolu).


Autre chose : où sont passés les repères statiques qui permettaient d'aligner les images tout en les déplaçants sur la page ?


Je dispose de la version 15.23.2 de Microsoft Word pour Mac sur un MacBook Pro (mi-2012) avec OS X Yosemite (version 10.10.5).


Auriez-vous une idée de ce qu'il se passe ? Ou de ce que je pourrais tenter ?
Je vous remercie par avance :)
 
Dernière édition:

Aliboron

Chercheur de son
Club MacG
1 Janvier 2008
14 335
1 083
Toulouse.cong
faq.office.macintosh.free.fr
Lorsqu'on demande l'insertion d'une légende, Word insère un champ calculé SEQ. On peut le mettre en évidence en allant sélectionner le numéro inséré automatiquement, constater qu'il est grisé et, par un clic droit, demander à "Basculer les codes champs". On voit alors que le numéro attribué à la légende correspond au code {SEQ Figure \* ARABIC }.

Le fonctionnement des codes champs est un peu particulier, la mise à jour n'est pas instantanée. On peut forcer la mise à jour par un clic droit "Mettre à jour les champs", la combinaison "Commande-Option-Majuscule-U" ou en demandant l'impression (le calcul se fait dès l'affichage de la boîte de dialogue, on peut se contenter de l'aperçu) ou l'enregistrement (comme tu as pu le constater). Le fait que le numéro "semble bloqué" n'est pas anormal, le recalcul remet les choses en état...
 
  • J’aime
Réactions: Bloody92

Bloody92

Membre confirmé
16 Avril 2016
17
0
29
Lorsqu'on demande l'insertion d'une légende, Word insère un champ calculé SEQ. On peut le mettre en évidence en allant sélectionner le numéro inséré automatiquement, constater qu'il est grisé et, par un clic droit, demander à "Basculer les codes champs". On voit alors que le numéro attribué à la légende correspond au code {SEQ Figure \* ARABIC }.

Le fonctionnement des codes champs est un peu particulier, la mise à jour n'est pas instantanée. On peut forcer la mise à jour par un clic droit "Mettre à jour les champs", la combinaison "Commande-Option-Majuscule-U" ou en demandant l'impression (le calcul se fait dès l'affichage de la boîte de dialogue, on peut se contenter de l'aperçu) ou l'enregistrement (comme tu as pu le constater). Le fait que le numéro "semble bloqué" n'est pas anormal, le recalcul remet les choses en état...
Encore une fois, merci beaucoup Aliboron ! :coucou:
 

Bloody92

Membre confirmé
16 Avril 2016
17
0
29
Finalement, le clic droit "Mettre à jour les champs" et la combinaison "Commande-Option-Majuscule-U" ne fonctionnant plus, j'ai testé l'aperçu d'impression ... Mes numéros se sont mélangés : Mes "figures" sont à présent dans cet ordre : 1, 3, 2, 4, 7, 6 et 5 ...
 

Aliboron

Chercheur de son
Club MacG
1 Janvier 2008
14 335
1 083
Toulouse.cong
faq.office.macintosh.free.fr
Mes numéros se sont mélangés : Mes "figures" sont à présent dans cet ordre : 1, 3, 2, 4, 7, 6 et 5 ...
Oui, j'ai noté aussi ce genre de cas de figure. Il te reste à déplacer les légendes à la main. Et à penser à faire un aperçu avant impression à chaque ajout de légende dorénavant... Ça m'étonne quand même que le clic droit > "Mettre à jour les champs" ne donne pas de résultat (à moins que tu sois restée avec les champs affichés, en quel cas il te faut revenir par "Basculer les codes de champ" au préalable).
 

Bloody92

Membre confirmé
16 Avril 2016
17
0
29
Plutôt que de les déplacer à la main, je vais recommencer, il n'y en a que 7 à refaire.
Mais est-ce-que la suppression la zone de texte suffit à supprimer la légende ? (Après suppression de la zone de texte, la légende ne figure plus dans la table des illustrations.)

Clic droit → Basculer les codes de champs → Mettre à jour les champs.
Cela fonctionnait jusqu'à l'aperçu d'impression. C'est à ce moment précis que toutes les légendes se sont mélangées.

Me conseillez-vous de supprimer toutes les photographies et de les ajouter au fur et à mesure après l'ajout de la légende ? Parce que j'ai ajouté toutes mes photographies puis j'ai tenté d'ajouter les légendes pour chacune.

In fine, j'aurai une cinquantaine d'illustrations. Il serait peut-être moins chronophage de créer les légendes et la table d'illustration de manière manuelle, en imitant le style initial.