10.15 Catalina Installation/boot impossible avec nouveau SSD suite a crash (erreur EFI et ecran blanc )

Cupra

Membre enregistré
29 Décembre 2021
9
0
31
Bonjour tout le monde,

le MBP (mi-2012 ) de ma compagne a crasher ce week-end , ou plus exactement le SSD.
Symptômes :
- Ecran blanc avec ou sans "?" selon son envie
J'ai ouvert le MBP , enlever puis remis le SSD , le connecteur de la batterie pour vider totalement le mac ( j'appuyais sur power également ).
J'ai fais ces étapes un incalculable nombre de fois , parfois le disque etait vu et on arrivait a booter sur l'OS et a sauvegarder les données importantes sur cle-usb. Après quelques minutes voir secondes de c/c le disque se mettait a crasher et on perdait le mac ..
Néanmoins 99% des documents ont pu être sauvegardé et mis sur un Drive. ( c'est deja ca :siffle: )

Pour information , l utilitaire disque util m'affichait une erreur du type

1640782444587.png

Diskutil me confirmait qu il résolvait le probleme sauf qu au demarrage suivant le probleme ré apparaissait..



J’ai acheté un adaptateur SATA -> USB pour me faciliter le troubleshooting ainsi qu’un nouveau SSD pour repartir sur des bases saines.
L’actuel SSD qui posait des problèmes était un Crucial MX500 500Go ( 4-5 ans )

J’ai acheté un Samsung EVO 700 de 500Go pour le remplacer



- Je procède au formatage du disque à l’aide de l’utilitaire, je choisis APFS et schéma GUID et je procède a l’installation de macOS Catalina.
Cette installation a été incroyablement lente malgré la fibre ( 10h .. )

-A la fin de l’installation et du redémarrage du mac , je me retrouve avec une nouvelle fois un écran blanc et cette fois une pomme suivis d’un panneau sens interdit ( comme s’il ne trouvait pas le disque pour booter )

-Je relance l’utilitaire de disque et en lançant le check je me retrouve une nouvelle fois avec la même erreur EFI

1640783055948.png

1640783077795.png

1640783121296.png

1640783407266.jpeg

1640783586339.jpeg

1640783604792.jpeg

1640783638481.jpeg


1640783623415.jpeg


Et maintenant je ne sais plus quoi faire, je pensais pas galérer autant après etre repartis sur des bases saines avec un nouveau SSD ...
 

maxou56

Membre expert
Club MacG
14 Avril 2020
3 465
710
Lorient
Je relance l’utilitaire de disque
Bonjour,
Attention sur les photos ce n'est pas le Mode Recovery de Catalina, ça semble ancien comme version de macOS, et comme tu es en APFS il faut minimum HighSierra ou + pour que les Volumes APFS soient visibles et utilisables.
D'où le choix du disque de démarrage vide, ou diskutil list qui ne voit pas tout...

Option + Commande + R pour avoir la dernière version compatible.

Je procède au formatage du disque à l’aide de l’utilitaire, je choisis APFS et schéma GUID et je procède a l’installation de macOS Catalina.
Tu avais bien sélectionner la Racine "....Samsung SSD"?
 

baron

Membre expert
Club MacG
22 Avril 2008
2 039
576
LLN
Cette génération de MBP était livrée avec un disque mécanique. Elle est connue pour l'incapacité de sa nappe de connexion du disque à supporter les débits d'un SSD. ; il est donc conseillé de la remplacer par une nappe plus récente, venant d'un bon marchand (MacWay ou iFixit sont souvent plébiscités).

Pour t'assurer qu'il s'agit bien de ça, tu peux retirer ton SSD interne et le brancher en externe avec ton adaptateur SATA-USB. Si tout va bien, c'est que la nappe interne est en cause. Remplace-la et remets le SSD en interne.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
89 100
27 415
Forêt de Fontainebleau
Bonjour,

En complément des indications de maxou -->

- un intitulé de volume de secours : Mac OS X Base System (avec le Mac) initial --> n'est partagé que par les 2 OS : Lion et Mountain Lion. Un de ces 2 OS est l'OS de secours d'usine du Mac.​
- la mention : 7C3457EF-0000-11AA-AA11-00306543ECAC sur une partition dans un tableau de diskutil --> désigne l'UUID qui détermine universellement le type de partition : "Apple_APFS". Cette mention d'UUID n'intervient que lorsque le Système démarré ne reconnaît pas le format apfs - lui étant antérieur. C'est le cas ici avec l'OS de secours d'usine Lion ou Mountain Lion.​

Donc redémarrer par internet avec les 3 touches ⌘⌥R (cmd alt R) pressées --> ce qui devrait charger en RAM un OS de secours prenant en charge l'apfs.
 

Cupra

Membre enregistré
29 Décembre 2021
9
0
31
Merci pour vos messages :)

@baron
Le nouveau SSD ( Samsung EVO 700 ) n'est absolument pas vu par le mac meme en disque externe. Du coup je ne sais pas si c'est une bonne ou mauvaise nouvelle en soit :D
L'ancien SSD ( le Crucial MX500 ) est vu et je peux + ou - booté dessus. Par plus ou moins j'entends qu'aléatoirement ca va crasher , soit durant le boot soit 20-30 minutes après avoir booté

@maxou56 . Bizzarement c'est ce que je pense avoir deja fait , option command r et tout recuperer par internet ( avec demande d'accès au Wi-Fi )
Je vais recommencer le process from scratch , je vais reformater et ne pas choisir APFS , c'est peut-etre ca la solution ...

EDIT : Je viens de voir ton comm @macomaniac et je vais donc reessayer une nouvelle fois ( tjr en APFS )
 

Cupra

Membre enregistré
29 Décembre 2021
9
0
31
Pour info le disque macOS Base System est Catalina et effectivement l interface a changé
J'ai donc procédé au formatage du disk ( en APFS ) et je vais relancer l'installation
1640792594805.png

Diskutil semble fournir de meilleurs infos

1640793417372.png


A voir après que l'installe ait terminé
 

maxou56

Membre expert
Club MacG
14 Avril 2020
3 465
710
Lorient
J'ai donc procédé au formatage du disk ( en APFS )
Tu as bien modifier le présentation pour afficher tous les appareils, puis sectionné la racine du SSD (= disk0), effacer en APFS + GUID?
Car sur la photo ça ne semble pas être le cas "870 EVO 500GB" semble être un Volume (= disk2s1).
Et si tu n'as pas formaté le SSD à la racine, l'erreur EFI risque d'être toujours présente, car la partition EFI n'a pas été effacé, puis recréé.
 
Dernière édition:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
89 100
27 415
Forêt de Fontainebleau
@ Cupra

Je ne sais pas où tu en es actuellement. Au cas où tu n'aurais pas lancé de réinstallation > dans ta session de secours Catalina > passe la commande exacte :
Bloc de code:
diskutil eraseDisk apfs "Macintosh HD" gpt disk0
  • ("Macintosh HD" avec les "") qui réinitialise le disque interne : table GPT > format apfs > volume Macintosh HD

Poste le retour.
 

Cupra

Membre enregistré
29 Décembre 2021
9
0
31
@maxou56 effectivement je viens de m apercevoir que par défaut l'utilitaire n'affiche pas le SSD a sa racine ...

@macomaniac , je viens du coup de lancer ta commande et voici le résultat
 

Fichiers joints

  • PXL_20211229_173920355.jpg
    PXL_20211229_173920355.jpg
    153,9 KB · Affichages: 49

Cupra

Membre enregistré
29 Décembre 2021
9
0
31
Malheureusement une erreur a 98% apparait ( après 12h d'installation ) m'invitant a réessayer ( pas de logs ).
SOS est Ok sur le SSD mais KO sur le Conteneur et "Macintosh SSD" car deja monté

Je reformate le disque à sa racine , en graphique en choisissant APFS et Schéma GUID et c'est repartit pour un tour ...
 

Fichiers joints

  • 1640847816145.png
    1640847816145.png
    552,9 KB · Affichages: 49

Cupra

Membre enregistré
29 Décembre 2021
9
0
31
Je me retrouve avec la meme erreur après avoir relancer une nouvelle fois l'installation du macOS. ( celle affiché dans le post ci-dessus )
J'avais cette fois-ci formaté le SSD avec l utilitaire graphique plutot que DiskUtil...

Voici d'ailleurs le résultat de DiskUtil list , est-ce qu il y a qqes chose qui pourrait expliquer le problème ?
 

Fichiers joints

  • PXL_20211230_192304009.jpg
    PXL_20211230_192304009.jpg
    104,8 KB · Affichages: 37

Cupra

Membre enregistré
29 Décembre 2021
9
0
31
Je precise que la date et l'heure sont correcte ( j'ai vu que ca pouvait etre un problème entrainant l'erreur que je rencontre a la fin de l'install )
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
89 100
27 415
Forêt de Fontainebleau
Reformater via l'Utilitaire de disque ou dans le terminal : c'est bonnet blanc et blanc bonnet. Simple affaire de commodité personnelle. Car l'Utilitaire de disque emploie graphiquement la commande diskutil.

- il semble que ton installation de Catalina plante en chemin sans qu'on en sache la raison. Aurais-tu un autre Mac qui te permettrait de confectionner une clé d'installation démarrable d'un OS compatible avec ton Mac ?​
 

Cupra

Membre enregistré
29 Décembre 2021
9
0
31
Malheureusement pas (vraiment)
J'ai un MBP 2018 et j'ai essayé de faire ca sauf que je n'ai pas le droit de formater les disques ( meme les clé USB ). Disk Utility me lance une erreur comme quoi un process bloque le démontage ou le formatage du disque. J'ai vu que c'était un process McAffee donc je ne peux pas aller beaucoup + loin. C'est un PC pro et je ne suis pas réellement admin de la machine.

Je pourrai éventuellement essayé de créer une VM ( Fusion ) avec un Catalina sur mon MBP puis de formater la cle bootable.

Pour l'instant j'ai essayé de reformater en HFS et de lancer l'install de Lion, a voir si ca passe. J'en ai encore pour 18h ...

Je trouve quand meme cela étrange d'avoir aucune log d'erreur a la fin ou au cours du process d'installation
 

Cupra

Membre enregistré
29 Décembre 2021
9
0
31
Bonjour et bonne année Messieurs :)

Les nouvelles :
J'ai réussis a installer avec succès le macOS sur le nouveau SSD mais uniquement en le branchant en exterieur ( adaptateur SATA -> USB C - > USB A )
L'installation a pris 30min au lieu de 8h et sans erreur.
Par contre en essayant de remettre le disque a l'intérieur , ca ne boot pas et je me retrouve avec un "?"

Donc je pense qu'il y a eu 2 problèmes
Le disque était a la base mal formaté comme vous avez vu @macomaniac et @maxou56 mais qu'en plus il y a une certaine incompatibilité avec le SSD EVO 700 et la nappe SATA du mac comme le pressentait @baron .
Ce qui est bizarre c'est que ca ne posait pas de soucis avec l'ancien SSD MX500; peut-etre le fait que le nouveau soit plus performant entraine des soucis ...

J'ai commandé du coup une nouvelle nappe , car ca sera un peu plus propre si ca fonctionne correctement avec le SSD en interne : https://www.macway.com/nappe-821-20...ook pro 13" 2012 a1278 cable sata&oid=2189239

En tout cas merci les gars :)