Installation de Mac OS X 10.11.6 sur hack Skylake [en cours]

Wootacon

Membre junior
4 Août 2011
59
3
[Mon post est aussi en suivi sur MacBidouille ;), je prend de l'aide sur tous les fronts ;P]

Bonjour,
Je suis en train de me faire un hack sur base skylake avec clover bien entendu et j'avance, mais je galère ;)

Toute aide est la bienvenue et j'aimerai faire de ce post un espèce de guide d'installation de bout en bout, de la création de la clé à l'installation d'OS X avec les pilotes qui vont bien sous OS X El Capitan 10.11.6 en détaillant les options nécessaires aux différentes étapes si possible puisque je trouve que toutes les explications sont répartie partout mais je n'ai rien trouvé qui proposait un suivi de bout en bout avec Clover et qu'il soit récent (surtout pour skylake).

Je pars sur le combo HACK et MacBook en appui de l'autre au cas ou quelque chose foire.

Je compléterai mes explications au fur et à mesure, même les anciennes s'il faut. Je mettrai de l'ordre une fois le hack abouti ou en voie d'aboutissement ;)

Allons-y !!

PROBLEMES ACTUELS DÉTECTÉS :
- Carte Graphique : Le display port ne fonctionne pas, mais le reste oui.
- Côté SON :
> Pas de son en HDMI
> Pas de micro ?? (avec écouteurs avec télécommande apple, sur port casque, comme sur port micro)

LES ÉTAPES SUIVIE POUR LE MOMENT :

I - CREATION DE LA CLÉ D'INSTALLATION
Près-requis :
- 1 Clé de 16 Go (possible que ça loge sur 8, mais je n'ai pas vérifié) formaté avec "Table de partition GUID" dans le format Mac OS étendu (journalisé) (nécessaire pour la partition EFI)
- 1 Mac connecté au Mac App Store


I-1) Télécharger OS X El Capitan 10.11.6 sur son mac
Rien à préciser ici, c'est enfantin ! ;)

I-2) Télécharger et utiliser Flash Drive Maker
J'ai suivi les dires de M. Polyzargone retrouvé sur le web
Flash Drive Maker
Ouvrir l'exécutable, faites glisser-déposer votre clé, entrée
faites glisser-déposer l'installateur OS X El Capitan, entrée
PATIENTER 17 min le temps de la création de la clé.
En gros...

I-3) Monter la participation EFI de la clé et placer le dossier EFI & le config.plist spécial Skylake
D'abord j'ai récupéré un dossier EFI chez Zoneactu

J'ai récupéré les fichiers du tuto de création de clé du site : Tuto Macbidouille
Notament le config.plist skylake.

Ensuite, j'ai monté la partition EFI avec le terminal :
Bloc de code:
diskutil list
mkdir /Volumes/efi
sudo mount -t msdos /dev/diskXsY /Volumes/efi
Où X et Y sont à remplacés par les numéros correspondant à la partition EFI de votre clé

Là on place le dossier EFI à la racine de la partition EFI que l'on vient de monter.
On place le config.plist dans EFI/CLOVER/ en remplaçant celui déjà présent.

J'ai aussi du remplacer le OsxAptioFixDrv-64.efi du dossier EFI/CLOVER/drivers64UEFI par OsxAptioFix2Drv-64.efi sinon problème au boot mettant en cause OsxAptipFixDrv-64 (bizarre le coup du p, mais c'est bien ça)

A partir de là j'ai modifié le config.plist rapidement pour le numéro de série du futur hack.

J'ai conscience que c'est un peu barbare et qu'il faudrait que je me penche réellement sur chaque ligne dans le config.plist histoire de savoir à quoi ça peu correspondre, même si j'ai des idées pour certains éléments.

PS : Le SMBIOS est bon (iMac 17,1 >> cause : Skylake et autres) et prêt pour mon petit trip.

I-4) Placer quelques Kexts (le moins possible)
J'ai récupéré sur le kext AtherosE2200Ethernet.kext pour avoir mon port réseau actif au moment de l'installation.
J'ai récupéré le kext de rehabman USBInjectAll.Kext pour passer la limite des 15 ports par Apple (le fichier config.plist doit être prévu pour aussi ;) )

J'ai placé les 2 dans le dossier EFI/CLOVER/kexts/10.11/
Dans le dossier EFI/CLOVER/kexts/other/ est présent FakeSMC.Kext

Ejecter les volumes (Clé + EFI).

II - INSTALLATION DU HACK
Près-requis :
- Paramétrer le BIOS (je décrirai ça plus tard)
- J'ai débranché 3 de mes 4 barrettes de RAM
- J'ai fais sauter la GTX 960 le temps de l'installation
- Si votre SSD est neuf et vient d'arriver : Penser à formater votre SSD avec l'utilitaire de disque avant/pendant l'installation avec clover afin que ce dernier soit visible et utilisable par clover (oui j'ai bugué sur le coup xD)

Étonnement, installation sans aucun problème, reboot avec l'aide la clé, finalisation de l'installation avec compte iCloud et tout roule ! Yeepee !!

III - POST-INSTALLATION
Là ça se complique un peu.

III-1) Installation de clover sur la partition EFI
Télécharger Clover
Bon là j'ai fais ça à ma sauce, il doit y avoir une étape de trop.

J'ai monté la partition EFI du SSD avec le terminal
Bloc de code:
diskutil list
mkdir /Volumes/efi
sudo mount -t msdos /dev/diskXsY /Volumes/efi
Une fois montée, j'ai formaté cette partition en FAT32 avec le terminal
Bloc de code:
sudo newfs_msdos -v EFI -F 32 /dev/rdiskXsY
Remplacer X/Y par les votres.

Je lance le packet (Clover_v2.3k_r3763) et commence l'installation
Je vérifie l'emplacement, qui est bien la partition de mac OS et je sélectionne les options suivantes :

Dans Bootloader : ne pas mettre à jour les secteurs
Dans Clover EFI : CloverEFI 64-bits SATA
Dans Drivers64UEFI : EmuVariableUefi-64 / OsxAptioFix2Drv-64 / PartitionDxe-64

J'ai choisis les options en fonction des fichiers de ma clé, je mettrai plus tard un screen de mes dossiers EFI pour savoir si tout est utile dedans pour le coup, car Clover m'en a rajouté, mais je ne vois pas l'utilité.
Si l'on peut avoir une liste d'explications claire quelque part, je prend ;)

J'ai replacé mes Kexts Dans les bons dossiers de cette partition EFI.

Redémarrage, passage par le BIOS pour mettre UEFI mac OS X en boot #1
Redémarrage, aucun problème.

Bon déjà là, on à la base.

III-2) Installation de la GTX960 Gigabyte [Résolu, pb DisplayPort/son HDMI en cours]
Pré-requis :
- Remettre en place la CG
- Installer Clover Configurator (ça sera utile, accès EFI simplifié et configuration config.plist aussi)

J'ai fais la dernière MAJ de sécurité de El Capitan du Mac App Store.
J'ai téléchargé les derniers WebDrivers Nvidia.

Problème d'écran noir juste avant l'ouverture de session ?
Suivi de la méthode de Chris27
Commencez par télécharger l'app AGDPfix.app, et laissez la de côté.

Pour que l'app fasse son travail, il faut désactiver le SIP.Explications sur le post #2.
La méthode pour un Hackintosh n'est pas la même que pour les mac.

Donc dans Clover Configurator onglet Rt Variables il faut regarder le champs Csr Active Config

0x0 = SIP Activé (Défaut)
0x3 = SIP Partiellement désactivé (Charger les Kexts non-signés)
0x67 = SIP Complètement désactivé

Logiquement, vous devez être en 0x3.
Vous passez donc en 0x67 > save et reboot
Une fois revenu sur le bureau, lancez l'app que vous avez téléchargé et suivez les consignes (n'oubliez pas de lire, c'est toujours intéressant ;) ).
Quand c'est fait, dans le panneau NVIDIA Driver Manager, cochez NVIDIA Web driver et reboot.
Logiquement, vous devriez arriver au bureau sans encombre avec la carte graphique installée.
Vérification :  > à propos de ce mac, la CG devrait apparaître correctement.
Dans NVIDIA Driver Manager, il est coché OS X Default Graphics Driver, mais tout fonctionne normalement, c'est un bug.

Rouvrir Clover Configurator onglet Rt Variables et dans le champs Csr Active Config, repassez en 0x3, histoire de ne pas laissez le SIP totalement désactivé (ça peut toujours servir pour prévenir de certains malwares ;) )

PS : Chez moi, tout roule, sauf le DisplayPort, je me renseigne dessus pour voir ce que je peux faire, mais au moins ma CG est reconnue pour le moment =)
Pour le HDMI, je ne sais pas si le son fonctionne, on vérifiera ça au prochain titre ;)

Voilà, direction...SON !

III-3) Installation du son [en cours]
À venir.

J'ai du son, ça y est !!

Par contre, mes écouteurs avec télécommande apple ne permettent pas d'utiliser le micro, même branché sur le port micro, il faut que je me penche dessus ;)

III-4) Installation iMessage [à venir...]

III-5) Installation Wifi/Bluetooth [à venir...]
Pré-requis :
- Carte Combo BCM94360CD Hackintosh (que je n'ai pas encore acheté)

Sans doute de futurs problèmes de veille et d'extinction à prévoir...


-------------------------
Je peux faire des screens etc s'il le faut, joindre des fichiers etc...
Je vous remercie pour votre aide.
 
Dernière édition:

Wootacon

Membre junior
4 Août 2011
59
3
Ah j'avais oublié le coup de l'édition avec le délai des 15minutes.

Bref, nouveau petit soucis, le son bug quand le hack sort de veille, je pense qu'il faut que je me penche sérieusement dessus dès que je vais avoir le temps, quitte à suivre une autre voie que celle que j'ai suivi. (je me suis basé sur ce qu'a fait nicolasf pour le son avec son expérience "hackintoshienne"...xD )
 

legallou

Membre junior
2 Octobre 2005
42
4
19
J'ai la même configuration que toi avec la même carte graphique et je n'ai pas de problème de son. J'utilise les haut-parleurs de mon écran. J'ai suivi les tutoriels de Macbidouille. Tu peux récupérer ma config.plist sur mon tutoriel pour voir la différence avec la tienne.
 

Wootacon

Membre junior
4 Août 2011
59
3
Salut !
Ah cool, ben le post n'est plus à jour et j'ai résolu pas mal de problèmes dont le son (c'est un peu plus à jour sur mon post de macbidouille. J'ai utilisé la méthode appleALC.kext, qui a fonctionné direct. À la sortie de veille j'avais des soucis, j'ai utilisé codecCommander.kext que j'avais trouvé je ne sais plus trop où et tout est rentré dans l'ordre.
J'ai branché les écouteurs de l'écran grâce à la sortie audio de la CM et je peux branché mon casque sur le coté de la tour aussi. Juste le port micro qui ne semble pas fonctionner...

Tu as le son en natif avec ton installation ? Tu l'as faite sous clover ? Mac OS Sierra ou El Capitan ?

J'ai fais la mise à jour Sierra depuis et je n'ai pas de soucis.

J'ai mis iMessage en route l'autre jour sans problème.

J'ai commandé une carte wifi/bluetotth et l'adaptateur qui va avec, j'attend de recevoir l'adaptateur pour voir si tout fonctionne, mais il ne devrait pas y avoir de soucis de ce côté là.

En gros, après passage sous Sierra, il me reste à identifier les ports USB de ma tour, vérifier le HDMI (côté son surtout) et le Display Port (image & son), le wifi/bluetooth avec continuité etc... et pour palier à l'absence de micro/caméra, je pense acheter une webcam logitech avec micro intégré. Aucun problème d'instabilité après plus de 3 mois, c'est plutôt cool ! =)
 
Dernière édition:

legallou

Membre junior
2 Octobre 2005
42
4
19
El Capitan (Sierra sur un deuxième SSD)- méthode appleALC.kext standard + HDMIAudio-1.0.dmg pour l'audio sur les haut-parleurs de mon écran connecté en Displayport - pas de wi-fi je suis en Ethernet direct - webcam logitech - iMessage iCloud interdit chez moi. Je veux être indépendant d'Apple pour le jour où le Mac s'arrêtera. Je n'utilise que des solutions communes Apple Windows Linux comme Skype, Dropbox...

Télécharge mon injecteur pour l'USB, son adaptation à ton boîtier devrait être assez facile. La méthode est bien expliquée dans mon tutoriel. C'est celle de Macbidouille.
+
 
  • J’aime
Réactions: Wootacon

Wootacon

Membre junior
4 Août 2011
59
3
Quand je serai rentré chez moi après mes vacances je regarderai pour le HDMIAudio et le Display port ;)
Je viens d'aller sur ton site, et en effet ça n'a pas l'air compliqué pour les ports USB. Il faudra juste que je trouve le temps de m'y mettre un après-midi je pense, le temps d'adapter ton injecteur et de faire le tour du tuto ;)

Merci pour ton aide en tout cas. Mon hack va tourner comme un charme passé ces étapes =) (déjà qu'il tourne sans problème =) )
 

Wootacon

Membre junior
4 Août 2011
59
3
@legallou Merci pour ton tuto d'injection USB, j'ai repris ton fichier.kext, j'ai refais la manip pour mapper tout mes ports USB sur un schéma et leur associer leur petit nom et ça fonctionne sans soucis après =) ports en façade ainsi que les ports à l'arrière, ils sont stables (USB2&USB3) ! =D J'ai sacrifié les 2 ports USB3.1 et un port USB3 juste au-dessus le 3.1 à l'arrière et quelques ports internes que je n'utilise pas.
J'ai du régler un problème de veille/extinction du hack après par contre, mais une fois résolu plus de soucis ;)

Voir le sujet veille/réveil
Pour ma part, je suis passé en BIOS F20 tout à l'heure avant l'injection de ports. Aucun soucis de veille et d'extinction, mais à la suite de l'injection de ports USB (je pensais pas, mais ça rend vraiment servir de s'en occuper ^^) mon hack se rallumait après une extinction et se rallumait aussitôt après être passé en veille.

Pour résoudre le problème suite à quelques tests (Clover v4012) :
- Fixshutdown
- Darkwake (sans paramètre)

Paramètres précédents (au cas ou...) :
- Fixshutdown
- Darkwake=8

"Fixshutdown" est nécessaire pour moi, sans, mon hack redémarre et "darkwake sans paramètre" semble résoudre le problème de sortie de veille. Je vais essayé de le laisser en veille demain en journée pour voir s'il la tient.

Il me reste juste à vérifier le HDMI/DP et le son qui va avec et tout sera bon pour moi =)
 

Wootacon

Membre junior
4 Août 2011
59
3
PETIT POINT SUR L'INSTALLATION (sous Sierra désormais)
s'il y en a qui suivent mon post (je ne peux pas éditer le premier malheureusement, du coup je fais ça rapidement):

À savoir : Je n'utilise plus clover configurator car il me fait sauter l'injection dans la section AUDIO pour le son en sortie de veille. Je passe par un éditeur de texte la plupart du temps ou PListEdit ;)

Pour l'installation du SON :

AppleALC.kext + pour la sortie de veille si problème : CodecCommander.kext, à injecter avec kextBeast (ou tout autre logiciel du même acabit)
et j'ai ajouté ça dans le config.plist pour la sortie de veille :
Bloc de code:
<key>Devices</key>
    <dict>
        <key>Audio</key>
        <dict>
            <key>Inject</key>
            <integer>2</integer>
        </dict>
    </dict>


iMessage / AppStore / iCloud :

Vous trouverez de nombreux tutos (macbidouille et autres, j'ai pioché sur pas mal de site pour ma part histoire de comprendre et de faire ça à ma sauce), le principal étant de générer un numéro qui n'est pas utilisé et non reconnu par Apple pour ne pas être blacklisté d'une certaine façon.
Il faut aussi remplir le champs "BoardSerialNumber" en complétant le "SerialNumber" + 5 chiffres/lettres collées
Attention à ne pas changer de serial number ni de SMBIOS pendant votre configuration, ça peut générer des problèmes et il faudra aller plus loin pour les résoudre il me semble. Préparez le terrain avant une installation en fait ;) ! Pour ma part j'ai gardé un SN et un SMBIOS à chaque réinstalle et le SN était bon, j'ai juste eu à compléter.

Vérifier que l'on a bien cela dans le config.plist pour lire certains contenus protégés (merci à Barijaona) :
Bloc de code:
<key>Patches</key>
            <array>
                <dict>
                    <key>Comment</key>
                    <string>change HECI to IMEI</string>
                    <key>Disabled</key>
                    <false/>
                    <key>Find</key>
                    <data>
                    SEVDSQ==
                    </data>
                    <key>Replace</key>
                    <data>
                    SU1FSQ==
                    </data>
                </dict>
            </array>

Wi-fi/BT :

Là c'est simple, j'ai commandé une carte "BCM943602CS" ainsi qu'une "Apple WLAN Card to PCI-e 1x 16x Desktop PC Wi-Fi Adapter" sur ebay (±32€ au total FDPin).
Il suffit d'assembler, bien serrer les support d'antenne et brancher la carte sur un port PCIe 4x ou 1x (j'avais mis ça sur un 8x et le Wi-Fi ne fonctionnait pas, au contraire du BT) et alimenter grâce au port USB interne de la carte.


Trim pour SSD :

S'il n'est pas actif par défaut, chez moi ça ne l'est pas :
Bloc de code:
<key>KernelAndKextPatches</key>
    <dict>
        <array>
            <dict>
                <key>Comment</key>
                <string>Trim Enabler</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                AEFQUExFIFNTRAA=
                </data>
                <key>Name</key>
                <string>IOAHCIBlockStorage</string>
                <key>Replace</key>
                <data>
                AAAAAAAAAAAAAAA=
                </data>
            </dict>
        </array>
    </dict>


Mise à jour du BIOS en F20 :

Rien de complexe, ça règles pas mal de soucis, il suffit d'aller sur le site de Gigabyte et de Dl la dernière version de BIOS (F20), de mettre ça sur une clé en FAT (FAT32 devrait fonctionner) et de lancer l'installation via q-flash via le BIOS.
/!\ il faut installer le driver "EmuVariableUefi-64.efi" dans le dossier "drivers64UEFI" de clover pour ne pas avoir de problème avec les web drivers Nvidia lors du redémarrage après l'installation du nouveau BIOS.


Injection de ports USB :

Rien de méchant, il suffit de suivre le tutoriel de Legallou et d'adapter les ports et les adresses. Ça prend du temps mais c'est pour votre bien ^^
À la suite de l'injection de ports USB mon hack se rallumait après une extinction et se rallumait aussitôt après être passé en veille.

Pour résoudre le problème suite à quelques tests (Clover v4012) :
- Fixshutdown
- Darkwake (sans paramètre)

Paramètres précédents (au cas ou...) :
- Fixshutdown
- Darkwake=8

"Fixshutdown" est nécessaire pour moi, sans, mon hack redémarre et "darkwake sans paramètre" semble résoudre le problème de sortie de veille. Je vais essayé de le laisser en veille demain en journée pour voir s'il la tient.


Voilà une mise au point rapide, j'espère que ça peut aider. J'essaierai de faire un nouveau sujet beaucoup plus clair sur toute mon installation quand j'aurai vérifié le son et l'image HDMI/DP.
Je vous met mon config.plist à suivre, ça peut aider. ;)

Bloc de code:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>ACPI</key>
    <dict>
        <key>DSDT</key>
        <dict>
            <key>Debug</key>
            <false/>
            <key>DropOEM_DSM</key>
            <false/>
            <key>Fixes</key>
            <dict>
                <key>FixShutdown_0004</key>
                <true/>
            </dict>
            <key>Name</key>
            <string>DSDT.aml</string>
            <key>Patches</key>
            <array>
                <dict>
                    <key>Comment</key>
                    <string>Rename HDAS to HDEF</string>
                    <key>Disabled</key>
                    <false/>
                    <key>Find</key>
                    <data>
                    SERBUw==
                    </data>
                    <key>Replace</key>
                    <data>
                    SERFRg==
                    </data>
                </dict>
                <dict>
                    <key>Comment</key>
                    <string>change HECI to IMEI</string>
                    <key>Disabled</key>
                    <false/>
                    <key>Find</key>
                    <data>
                    SEVDSQ==
                    </data>
                    <key>Replace</key>
                    <data>
                    SU1FSQ==
                    </data>
                </dict>
            </array>
            <key>ReuseFFFF</key>
            <false/>
        </dict>
        <key>SSDT</key>
        <dict>
            <key>DropOem</key>
            <false/>
            <key>Generate</key>
            <false/>
        </dict>
    </dict>
    <key>Boot</key>
    <dict>
        <key>Arguments</key>
        <string>-v</string>
        <key>Debug</key>
        <false/>
        <key>DefaultVolume</key>
        <string>LastBootedVolume</string>
        <key>Legacy</key>
        <string>PBR</string>
        <key>Secure</key>
        <false/>
        <key>Timeout</key>
        <integer>10</integer>
        <key>XMPDetection</key>
        <string>Yes</string>
    </dict>
    <key>CPU</key>
    <dict>
        <key>UseARTFrequency</key>
        <false/>
    </dict>
    <key>Devices</key>
    <dict>
        <key>Audio</key>
        <dict>
            <key>Inject</key>
            <integer>2</integer>
        </dict>
        <key>FakeID</key>
        <dict>
            <key>ATI</key>
            <string>0x0</string>
            <key>IMEI</key>
            <string>0x0</string>
            <key>IntelGFX</key>
            <string>0x0</string>
            <key>LAN</key>
            <string>0x0</string>
            <key>NVidia</key>
            <string>0x0</string>
            <key>SATA</key>
            <string>0x0</string>
            <key>WIFI</key>
            <string>0x0</string>
            <key>XHCI</key>
            <string>0x0</string>
        </dict>
        <key>USB</key>
        <dict>
            <key>AddClockID</key>
            <true/>
            <key>FixOwnership</key>
            <true/>
            <key>Inject</key>
            <true/>
        </dict>
    </dict>
    <key>DisableDrivers</key>
    <array>
        <string>Nothing</string>
    </array>
    <key>GUI</key>
    <dict>
        <key>Language</key>
        <string>fr:0</string>
        <key>Mouse</key>
        <dict>
            <key>DoubleClick</key>
            <integer>500</integer>
            <key>Enabled</key>
            <true/>
            <key>Mirror</key>
            <false/>
            <key>Speed</key>
            <integer>8</integer>
        </dict>
        <key>Scan</key>
        <true/>
        <key>ScreenResolution</key>
        <string>2560x1440</string>
        <key>Theme</key>
        <string>maverickslogin</string>
    </dict>
    <key>Graphics</key>
    <dict>
        <key>Inject</key>
        <dict>
            <key>ATI</key>
            <false/>
            <key>Intel</key>
            <false/>
            <key>NVidia</key>
            <false/>
        </dict>
        <key>NvidiaSingle</key>
        <false/>
        <key>VideoPorts</key>
        <integer>6</integer>
        <key>ig-platform-id</key>
        <string>0x19120000</string>
    </dict>
    <key>KernelAndKextPatches</key>
    <dict>
        <key>AppleRTC</key>
        <true/>
        <key>AsusAICPUPM</key>
        <true/>
        <key>Debug</key>
        <false/>
        <key>KernelCpu</key>
        <false/>
        <key>KernelHaswellE</key>
        <false/>
        <key>KernelLapic</key>
        <false/>
        <key>KernelPm</key>
        <true/>
        <key>KextsToPatch</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>Skylake APIC fix, discovered by Pike R. Alpha</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                wegQD7bw
                </data>
                <key>Name</key>
                <string>AppleAPIC</string>
                <key>Replace</key>
                <data>
                vhcAAACQ
                </data>
            </dict>
            <dict>
                <key>Comment</key>
                <string>SSD Trim Enabler Patch</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                AEFQUExFIFNTRAA=
                </data>
                <key>Name</key>
                <string>IOAHCIBlockStorage</string>
                <key>Replace</key>
                <data>
                AAAAAAAAAAAAAAA=
                </data>
            </dict>
            <dict>
                <key>Comment</key>
                <string>NVIDIA Black Screen fix (Ne pas utiliser sans savoir ce que l'on fait, je ne l'utilise pas) / OS X Sierra 10.12</string>
                <key>Disabled</key>
                <true/>
                <key>Find</key>
                <data>
                hcB0LEmLB0iNdaA=
                </data>
                <key>Name</key>
                <string>AppleGraphicsDevicePolicy</string>
                <key>Replace</key>
                <data>
                hcDrLEmLB0iNdaA=
                </data>
            </dict>
            <dict>
                <key>Comment</key>
                <string>USB port limit 15 to 24 / OS X Sierra 10.12 - GA_Z170MX_G5</string>
                <key>Disabled</key>
                <true/>
                <key>Find</key>
                <data>
                83BD74FFFFFF10
                </data>
                <key>Name</key>
                <string>AppleUSBXHCIPCI</string>
                <key>Replace</key>
                <data>
                83BD74FFFFFF18
                </data>
            </dict>
        </array>
    </dict>
    <key>RtVariables</key>
    <dict>
        <key>BooterConfig</key>
        <string>0x28</string>
        <key>CsrActiveConfig</key>
        <string>0x3</string>
    </dict>
    <key>SMBIOS</key>
    <dict>
        <key>BiosReleaseDate</key>
        <string>12/22/2016</string>
        <key>BiosVendor</key>
        <string>Apple Inc.</string>
        <key>BiosVersion</key>
        <string>xxxxx.xxx.xxxx.xxx.xxxxxxxxxx</string>
        <key>Board-ID</key>
        <string>Mac-xxxxxxxxxxxxxxxx</string>
        <key>BoardManufacturer</key>
        <string>Apple Inc.</string>
        <key>BoardSerialNumber</key>
        <string>XXXXXXXXXXXXYYYYY</string>
        <key>BoardType</key>
        <integer>10</integer>
        <key>ChassisAssetTag</key>
        <string>iMac-Aluminum</string>
        <key>ChassisManufacturer</key>
        <string>Apple Inc.</string>
        <key>ChassisType</key>
        <string>0x13</string>
        <key>Family</key>
        <string>iMac</string>
        <key>LocationInChassis</key>
        <string>Part Component</string>
        <key>Manufacturer</key>
        <string>Apple Inc.</string>
        <key>ProductName</key>
        <string>iMac17,1</string>
        <key>SerialNumber</key>
        <string>XXXXXXXXXXXX</string>
        <key>SmUUID</key>
        <string>xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx</string>
        <key>Trust</key>
        <false/>
        <key>Version</key>
        <string>1.0</string>
    </dict>
    <key>SystemParameters</key>
    <dict>
        <key>InjectKexts</key>
        <string>Yes</string>
        <key>InjectSystemID</key>
        <true/>
        <key>NvidiaWeb</key>
        <true/>
    </dict>
</dict>
</plist>
 
Dernière édition:

Wootacon

Membre junior
4 Août 2011
59
3
Petite mise à jour concernant CloverConfigurator : c'est moi qui faisais l'idiot, tout est rentré dans l'ordre ;)

En ce qui concerne le DP & l'HDMI :

Cas du HDMI :
J'ai l'image, aucun problème, mais le son lui est aux abonnés absents. J'ai essayé avec le kext "HDMIAudio.kext", mais aucun résultat, la sortie n'apparaît pas dans les paramètres de son de Mac OS.

Cas du DP (toujours avec avec le kext "HDMIAudio.kext") :
J'ai l'image (ça fonctionne sous Sierra, cool =) ), mais le son n'est pas au top.
Je m'explique :
J'ai une sortie son qui apparaît dans le menu de Mac OS ("Asus PB278", le nom de l'écran donc), j'ai du son aussi (on y est presque !) mais je ne peux pas le régler --'

Je devrai peut être essayer autre chose je pense, mais au fond, si je n'arrive à rien je retourne en DVI+Port audio jack (mais rien que par défis, j'aimerai bien réussir à avoir le son par DP ^^)
 

Wootacon

Membre junior
4 Août 2011
59
3
Pour bien terminer :

Gradou m'a filé la solution pour le son HDMI (à savoir que le son DP est actif avec HDMIAudio.kext) :
Gradou a dit:
Nickel, ça fonctionne direct après un petit redémarrage.

À savoir : le son en HDMI/DP se règle seulement via le périphérique (écran), les raccourcis clavier (F10/F11/F12) et le réglage via via la barre des menus sont indisponibles dans ces conditions.

Je ne pense plus rien avoir à régler à priori. Tout est super stable. Veille/Extinction y compris.
Juste un petit problème avec iBook à régler (Barijaona a mis ce qu'il faut sur son site).

J'essaierai de faire un nouveau post dans la bonne section pour mon installation complète ;)
 
Dernière édition:

gradou

Membre confirmé
19 Octobre 2013
231
30
Je pense que tu n'as plus besoin d'HDMIAudio.kext y compris pour le DP (à vérifier)
 

Wootacon

Membre junior
4 Août 2011
59
3