Sujet unique Installation de macOS Monterey sur les Mac incompatibles

droyze

Membre actif
21 Juin 2007
321
8
BZH
Une installation par USB, ça peut-être long ... , ça peut prendre entre 30 mn et 1 heure suivant le Mac, le type d'USB, le type de clef, etc... , de plus le temps affiché par Apple est assez souvent n'importe quoi ...
OK toujours bloqué au même endroit, souris bouge plus non plus.

la première installe était beaucoup plus rapide
 

droyze

Membre actif
21 Juin 2007
321
8
BZH
Bon bah idem, j'ai refait une installation et apres 20 minute une fois bien installé, j'arrive sur la pomme bloqué et derrière il y a surement la fenêtre de configuration du premier démarrage car le mac me parle de voice over etc...
 

droyze

Membre actif
21 Juin 2007
321
8
BZH
Bon je sais pas quoi faire du coup.....2eme installation et même problème.

Et j'ai essayé avec VoiceOver de finaliser l'installation mais c'est impossible si je vois pas
 

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
572
201
Nice
blog.nojo.fr
Bon bah idem, j'ai refait une installation et apres 20 minute une fois bien installé, j'arrive sur la pomme bloqué et derrière il y a surement la fenêtre de configuration du premier démarrage car le mac me parle de voice over etc...

Bizarre...

- Ton modèle de Mac est bien reconnu par OCLP ?
IMG_8337.jpeg



- pas d'erreur lors du Build ?

Capture d’écran 2022-01-28 à 12.59.59.png


- tu fais bien une "clean Install" ?

- je te suggère de recommencer en faisant un reset de la NVRAM/PRAM (2 ou 3 reset fois pour être sur), dans certains cas, ça résout des problèmes

- ne pas oublier de booter sur l'EFI de la clef après un reset

- s'il y a encore le problème, essaye avec une autre clef USB pour lever le doute

ça doit fonctionner :)
 

droyze

Membre actif
21 Juin 2007
321
8
BZH
Bizarre...

- Ton modèle de Mac est bien reconnu par OCLP ?
Voir la pièce jointe 253653


- pas d'erreur lors du Build ?

Voir la pièce jointe 253655

- tu fais bien une "clean Install" ?

- je te suggère de recommencer en faisant un reset de la NVRAM/PRAM (2 ou 3 reset fois pour être sur), dans certains cas, ça résout des problèmes

- ne pas oublier de booter sur l'EFI de la clef après un reset

- s'il y a encore le problème, essaye avec une autre clef USB pour lever le doute

ça doit fonctionner :)
Model du Mac ok pendant le Build

Reset de la NVRAM 2-3 fois rien y fait

Je suis bon pour réinstaller Big Sur et refaire tout de A à Z
 

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
572
201
Nice
blog.nojo.fr
Model du Mac ok pendant le Build

Reset de la NVRAM 2-3 fois rien y fait

Je suis bon pour réinstaller Big Sur et refaire tout de A à Z

Si tu as un disque externe USB, essaye de faire l'installation sur ce disque, si ça marche, ça permettra peut-être de comprendre d'où vient le problème.
 

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
572
201
Nice
blog.nojo.fr
Un MacBook Pro late 2013 tournant actuellement sous bigsur

Une autre suggestion est de tout tester sur un disque externe en USB :
  • création de l'installeur sur une clef USB + OCLP
  • booter sur la clef USB
  • faire l'installation sur le disque externe USB
  • booter sur le disque externe USB et tester avec ses applications , etc...
  • si tout est ok: refaire la manip sur le disque interne
 

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
572
201
Nice
blog.nojo.fr
Bah en fait ma clé USB que je parle c'est un SSD externe, mais du coup je vais essayer sur une clé USB

Certains utilisateurs sur le site de référence MacRumors , avec le même Mac que le tien, ont eu le problème que tu décris, voir ce post et les suivants pour la solution :)
 
  • J’adore
Réactions: droyze

droyze

Membre actif
21 Juin 2007
321
8
BZH
Ok j'ai finalisé l'installation et je suis sous MacOS, bon par contre super lent en mode sans echec

J'essaye d'installer et patcher le SSD mais j'ai une erreur

Sans titre 2.png


Et sinon il faut aussi que je fasse le Post installé Root Patch ?

EDIT : Ok ça ne marchait pas, car j'étais en safe mode, j'ai donc appliqué le patch et reboot en normal et la c'est OK

Au top et encore merci pour tous. Chouette communauté
 
Dernière édition:
  • J’aime
Réactions: sergiodadi

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
572
201
Nice
blog.nojo.fr
Et sinon il faut aussi que je fasse le Post installé Root Patch ?

EDIT : Ok ça ne marchait pas, car j'étais en safe mode, j'ai donc appliqué le patch et reboot en normal et la c'est OK

Au top et encore merci pour tous. Chouette communauté

Les patchs post_install sont obligatoires pour certains macs, particulièrement ceux qui ont des CG NVIDIA , pour le tien c'est donc pour supporter les cartes Nvidia Kepler and Intel HD4000 . Attention, pour les macs ayant besoin des patchs post_install, il faut les appliquer de nouveau après chaque mise à jour.
 
  • J’aime
Réactions: droyze

Sev_X

Membre confirmé
30 Octobre 2021
84
10
16
Paris
Bonjour,

Je veux installer macOS Monterey sur un MacBook Pro 17 pouces début 2009 (MacBook Pro 5,2) mais lors de l'installation un message apparaît : "Une erreur est survenue lors du chargement de la mise à jour" et le système ne s'installe donc pas. Est-ce que cela a un rapport avec OCLP ou directement avec macOS Monterey ?
Au fait, j'ai déjà réessayé en recréant la clef USB mais sans plus de succès.
 

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
572
201
Nice
blog.nojo.fr
Bonjour,

Je veux installer macOS Monterey sur un MacBook Pro 17 pouces début 2009 (MacBook Pro 5,2)

Il est supporté par OCLP avec des patchs post_install , pas de problème :)

mais lors de l'installation un message apparaît : "Une erreur est survenue lors du chargement de la mise à jour" et le système ne s'installe donc pas. Est-ce que cela a un rapport avec OCLP ou directement avec macOS Monterey ?

Je ne pense pas que OCLP soit en cause.

Au fait, j'ai déjà réessayé en recréant la clef USB mais sans plus de succès.

Je vois 2 causes possibles:
  • as-tu bien booté d'abord sur l'EFI de la clef ? J'imagine que oui car tu as déjà utilisé OCLP :)
  • As-tu essayé de retélécharger Monterey ? Le message peut signifier que l'installeur est corrompu.
 

Sev_X

Membre confirmé
30 Octobre 2021
84
10
16
Paris
Je ne pense pas que OCLP soit en cause.

D'accord, c'est aussi ce que je me disais, puisqu'il est censé être supporté.

as-tu bien booté d'abord sur l'EFI de la clef ? J'imagine que oui car tu as déjà utilisé OCLP :)

Oui j'ai bien booté sur la clef USB :D

As-tu essayé de retélécharger Monterey ? Le message peut signifier que l'installeur est corrompu.

Oui j'ai retéléchargé l'installateur de Monterey, et j'ai même essayé deux versions différentes : macOS 12.1 et macOS 12.2


Donc je me suis aussi demandé si ce n'était pas la clef USB, mais ce serait bizarre car l'installation s'est très bien passée il y a un peu plus d'une semaine sur mon MacBook Pro 17 pouces fin 2011. Et puis je n'ai pas d'autre clef USB de 16 Go de toutes façons.

Alors ce serait peut-être le disque dur. C'est un SSD mais il n'est pas formaté en APFS car El Capitan, qui est sur cette machine, ne le supportait pas encore. Est-ce que cela pourrait poser problème ? Il me semble qu'il n'y a plus de Mac aujourd'hui encore commercialisé avec des HDD, donc macOS Monterey ne peut peut-être que s'installer sur un SSD au format APFS.

Ou alors je peux tenter Big Sur, mais comme deux versions de Monterey n'ont pas fonctionné, est-ce vraiment pertinent ?
 

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
572
201
Nice
blog.nojo.fr
Alors ce serait peut-être le disque dur. C'est un SSD mais il n'est pas formaté en APFS car El Capitan, qui est sur cette machine, ne le supportait pas encore. Est-ce que cela pourrait poser problème ?

Ah oui, je pense ...

Il me semble qu'il n'y a plus de Mac aujourd'hui encore commercialisé avec des HDD, donc macOS Monterey ne peut peut-être que s'installer sur un SSD au format APFS.

Je pense, sauf erreur de ma part, que tu peux formater en APFS un disque rotatif après avoir booté sur la clef en utilisant l'utilitaire de gestion des disques, pas de problème.

EDIT: j'avais mal lu, tu as un disque SSD, donc essaye de le formater en APFS
 
Dernière édition:

maxou56

Membre expert
Club MacG
14 Avril 2020
3 454
708
Lorient
Il me semble qu'il n'y a plus de Mac aujourd'hui encore commercialisé avec des HDD, donc macOS Monterey ne peut peut-être que s'installer sur un SSD au format APFS.
Bonsoir,
Ça ne date que de quelques mois donc les DD classique seront supportés encore un certain temps ;) (par contre en APFS :()
Disque dur seul c'est avec l'arrêt des iMac 21.5'" HD de 2017, en octobre 2021 et pour les Fusion Drive aout 2020 pour les iMac 27" de 2019 et avril 2021 pour les iMac 21.5" 4K de 2019.
 
Dernière édition:

Sev_X

Membre confirmé
30 Octobre 2021
84
10
16
Paris
Ah oui, je pense ...



Je pense, sauf erreur de ma part, que tu peux formater en APFS un disque rotatif après avoir booté sur la clef en utilisant l'utilitaire de gestion des disques, pas de problème.

EDIT: j'avais mal lu, tu as un disque SSD, donc essaye de le formater en APFS

Ah bonne idée, je vais essayer ça. Merci !
 

Sev_X

Membre confirmé
30 Octobre 2021
84
10
16
Paris
Bonsoir,
Ça ne date que de quelques mois donc les DD classique seront supportés encore un certain temps ;) (par contre en APFS :()
Disque dur seul c'est avec l'arrêt des iMac 21.5'" HD de 2017, en octobre 2021 et pour les Fusion Drive aout 2020 pour les iMac 27" de 2019 et avril 2021 pour les iMac 21.5" 4K de 2019.

Ah d'accord, au temps pour moi.
 

rk44

Membre confirmé
29 Mars 2011
93
1
Bonjour


Sur macmini 6,1 (fin 2012) Monterey Oclp sur ssd ne monte pas a partir d’un disque dur extérieur.
il bloque au demarrage (voir image)

bug monterey.jpeg



par contre il monte si je mets le ssd dans mon Macmini 6,1

En fait je cherche a avoir un backup demarrable

J’ai utilisé scrupuleuseument le protocole de sergiodadi :raz disque, formatage apfs
J’ai racheté un boitié extérieur pour le ssd.

N’y a t il pas un parametre ou patch dans Oclp pour ce cas ?