Sujet unique Installation de macOS Monterey sur les Mac incompatibles

maxou56

Membre expert
Club MacG
14 Avril 2020
3 025
626
Lorient
j'avais bêtement oublié de relancer OCLP après l'installation de Monterey pour effectuer l'option "3. Post-install Volume Patch"
Pourtant avec le Mac mini 2011 et BigSur il fallait déjà faire une « post Install », qui était inutile sur ce MBP fin 2012 avec BigSur, mais nécessaire avec monterey, pour l’iGPU.
Attention il y a des changent par rapport à BigSur, il faudra "Patcher" (remettre des pilotes...) plus de machines.
Il y a moins de machines 100% compatibles (SIP activer, FileVault, aucune modification de macOS) comme avec BigSur.
Donc il y aura peut être une post installation à faire, refaire.


Ivy Bridge iGPU Acceleration (Résolu en 0,1.7 et plus récent)
  • Les iGPU Intel HD4000 ont perdu leur support
Par défaut, ces machines nécessitent des correctifs de volume racine pour gagner en accélération graphique dans Monterey. OpenCore Legacy Patcher prend en charge la prise en charge de la lecture, mais SIP ne peut plus être activé en raison des correctifs root :

  • Macmini6,x
  • MacBookAir5,x
  • MacBookPro9,x
  • MacBookPro10,x
 
Dernière édition:

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
450
171
Nice
blog.nojo.fr
Merci de ta réponse.

Le problème s'est-il finalement résolu sur ton iMac?

Je n'ai pas approfondi car c'est un iMac 27" mi 2011 qui me sert de test, il a encore la CG d'origine et je vais la changer par une carte compatible metal. J'ai un autre iMac 27" mi 2011 avec une carte metal et le problème n'apparait pas :)
 

kaiy75

Membre actif
12 Septembre 2015
129
44
Bonsoir à tous,

Ça fait longtemps que j'ai pas mis dans la main dans le cambouis, puisque mon appareil tourne parfaitement sur Big Sur.

Maintenant que Monterrey est sorti en version finale, j'aimerais mettre à jour. Qu'en est il d'OCLP, peut on mettre à jour son Mac, la version est-elle stable ? Ou n'y a t'il pas encore de version d'OCLP prête pour la version finale de Monterrey ? J'ai un MacBook Pro Retina Early 2013.

Merci d'avance pour vos retours !
 

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
450
171
Nice
blog.nojo.fr
Bonsoir à tous,

Ça fait longtemps que j'ai pas mis dans la main dans le cambouis, puisque mon appareil tourne parfaitement sur Big Sur.

Maintenant que Monterrey est sorti en version finale, j'aimerais mettre à jour. Qu'en est il d'OCLP, peut on mettre à jour son Mac, la version est-elle stable ? Ou n'y a t'il pas encore de version d'OCLP prête pour la version finale de Monterrey ?

Il y a OCLP 0.3.1 qui est sorti quelques heures après la disponibilité de Monterey :)

J'ai un MacBook Pro Retina Early 2013.

Merci d'avance pour vos retours !

En résumé, à mon avis les points les plus importants à voir sont:
  • pas de support par Apple des cartes Nvidia Kepler
  • pas de support par Apple des chips à base de BCM2046 Modules (WIFI + BlueTooth)

Voir ici pour les détails.

Il y a des "Non-Metal GPU Acceleration Patches for Big Sur/Monterey" mais c'est vraiment à tester et il s'agit de "vrais" patchs :(

Pour ton Mac, tout devrait être OK:

IMG_4305.jpeg
 
Dernière édition par un modérateur:
  • J’aime
Réactions: kaiy75

xavax

Membre actif
13 Octobre 2003
840
11
Bonjour tour le monde, quelle est la procédure pour installer macOS 12 sur un imac 27" late 2013 qui est deja patché avec OCLP et macOS11
Mon système est branché sur un SSD branché sur le port USB
C'est faisable ou il faut eviter ? Ca peut se faire comme une mise a jour toute simple ?
Merci pour votre aide
 

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
450
171
Nice
blog.nojo.fr
Bonjour tour le monde, quelle est la procédure pour installer macOS 12 sur un imac 27" late 2013 qui est deja patché avec OCLP et macOS11

La procédure pour une installation complète est la même , il faut utiliser la dernière version de OCLP et c'est bien décrit dans le manuel d'OCLP.

Mon système est branché sur un SSD branché sur le port USB
C'est faisable ou il faut eviter ?

A priori, ton iMac est entièrement supporté:

Capture d’écran 2021-10-26 à 13.55.18.png

Ca peut se faire comme une mise a jour toute simple ?
Merci pour votre aide

Par contre, pour éviter tout problème , je ferais un essai avec un autre disque externe en utilisant OCLP 0.3.1 qui vient de sortir.

Si tout est ok après différents tests, je ferais quand même une installation complète après avoir formaté le disque actuel (en faisant DES sauvegardes comme d'habitude). C'est long mais pour une version majeure d'un OS , c'est en général conseillé :)
 
Dernière édition par un modérateur:

xavax

Membre actif
13 Octobre 2003
840
11
Merci, si j'ai une sauvegarde time machine je peux directement le faire sur le DD existant ? au pire je remets l'ancien system ?
 

kaiy75

Membre actif
12 Septembre 2015
129
44
Il y a OCLP 0.3.1 qui est sorti quelques heures après la disponibilité de Monterey :)



En résumé, à mon avis les points les plus importants à voir sont:
  • pas de support par Apple des cartes Nvidia Kepler
  • pas de support par Apple des chips à base de BCM2046 Modules (WIFI + BlueTooth)

Voir ici pour les détails.

Il y a des "Non-Metal GPU Acceleration Patches for Big Sur/Monterey" mais c'est vraiment à tester et il s'agit de "vrais" patchs :(

Pour ton Mac, tout devrait être OK:

Voir la pièce jointe 243833
Merci pour ton retour @sergiodadi , dès que j'aurai le temps je ferais l'update vers Monterey, car je veux faire une clean Install, je pense que c'est le mieux surtout sur un système patché avec OCLP.
 

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
450
171
Nice
blog.nojo.fr
Merci, si j'ai une sauvegarde time machine je peux directement le faire sur le DD existant ? au pire je remets l'ancien system ?

Comme va aussi le faire @kaiy75 , une "clean install" est vivement conseillée pour passer de Big Sur à Monterey sur un Mac "patché" (quelque soit la méthode de patch) ...

Une "clean install" complète , comme conseille régulièrement @Locke : "Une installation propre inclut le formatage du disque dur interne, donc, par extension cela sous-entend qu'il faudra réinstaller tous tes logiciels un par un et refaire tes réglages. Pour terminer, tu recopieras manuellement tes données personnelles."

En résumé:
  • sauvegarde des données vitales (au moins 2 supports différents)
  • effacement complet du disque (formatage) après le boot sur la clef USB OCLP
  • installation de Monterey avec la procédure OCLP (voir le guide d'OCLP)
  • reinstallation des applications
  • récupération des données utilisateur
 

Fennec72

Membre actif
23 Juin 2010
256
10
49
Il y a OCLP 0.3.1 qui est sorti quelques heures après la disponibilité de Monterey :)
Est-il intéressant de mettre à jour OCLP si Monterey semble bien fonctionner ?

Le contexte:

J’ai installé Monterey sur un MacBook Pro 13" fin-2012 alors que Monterey était encore en beta, puis je l’ai mis à jour vers la 12.0.1 RC2, puis j’ai désinscrits le Mac des betas et je n’ai pas eu de mise à jour proposée au moment de la sortie de la version finale (je suppose que c’est parce que le numéro de build est le même).

Merci d’avance,

Cordialement,

Hervé
 

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
450
171
Nice
blog.nojo.fr
Est-il intéressant de mettre à jour OCLP si Monterey semble bien fonctionner ?

On dit souvent en informatique professionnelle "If it ain't broke, don't fix it" , ce qui signifie "si c'est pas cassé, on ne fait rien" . Si tu n'as pas de problème, en particulier de WIFI ou BlueTooth, ne touche à rien, la nouvelle version d'OCLP n'apportera rien :up:

Le contexte:
J’ai installé Monterey sur un MacBook Pro 13" fin-2012 alors que Monterey était encore en beta, puis je l’ai mis à jour vers la 12.0.1 RC2, puis j’ai désinscrits le Mac des betas et je n’ai pas eu de mise à jour proposée au moment de la sortie de la version finale (je suppose que c’est parce que le numéro de build est le même).

Par contre, je ne sais pas si , à partir d'une version beta installée, la prochaine mise à jour officielle non beta va être proposée ... Peut-être quelqu'un connait la réponse ?
 

maxou56

Membre expert
Club MacG
14 Avril 2020
3 025
626
Lorient
Par contre, je ne sais pas si , à partir d'une version beta installée, la prochaine mise à jour officielle non beta va être proposée ... Peut-être quelqu'un connait la réponse ?
Bonjour,
Avec OCLP ? Mais sinon oui, une fois le mac désinscrit des bêtas, il recevra les MAJ suivantes supérieurs à la version de la bêta installé).

puis je l’ai mis à jour vers la 12.0.1 RC2, puis j’ai désinscrits le Mac des betas et je n’ai pas eu de mise à jour proposée au moment de la sortie de la version finale (je suppose que c’est parce que le numéro de build est le même).
C'est semble t'il la même version que la RC2. "21A559"

Ca peut se faire comme une mise a jour toute simple ?
Ça doit être possible (pas forcement conseillé, je l'ai fait sur un mac mini 2012 entre BigSur et une Beta de Monterey), au moins si macOS n'était pas "Patché" avec BigSur (Post Install), ce qui est le cas sur ton iMac 2013 "entièrement supporté" ou seul l'EFI est patché.
 
Dernière édition:

xavax

Membre actif
13 Octobre 2003
840
11
Merci pour vos réponses. Je testerai qu’à d j’aurais plus de temps en formatant le DD. Et une fois fait je remettrai ma sauvegarde Time Machine.
 

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
450
171
Nice
blog.nojo.fr
Il y a OCLP 0.3.1 qui est sorti quelques heures après la disponibilité de Monterey :)



En résumé, à mon avis les points les plus importants à voir sont:
  • pas de support par Apple des cartes Nvidia Kepler
  • pas de support par Apple des chips à base de BCM2046 Modules (WIFI + BlueTooth)

Il y a aussi l'abandon sous Monterey du chip graphique Intel HD4000 qui se trouve dans certains Macs. Comme pour les points précédents, il existe sous OCLP des (vrais) patchs post-install qui résolvent le problème pour certains Macs . Comme il s'agit de "vrais" patchs, il y a des conséquences : obligation de repatcher après les mises à jour, certaines mises à jour OTA ne fonctionnent plus, etc...

Je pense qu'il vaut mieux attendre la prochaine version officielle d'OCLP qui devrait résoudre pas mal de problème, comme par exemple, dans l'installation de Monterey, Apple a ajouté une nouvelle vérification des "firmwares" :(

Full error: "Your Mac needs a firmware update in order to install to this Volume. Please select a Mac OS Extended (Journaled) volume instead."

This error occurs when macOS determines the firmware to not have full APFS support. To resolve is quite simple, when building OpenCore head to "Patcher Settings" and enable "Moderate SMBIOS Patching" or higher. This will ensure that the firmware reported will show as supporting full APFS capabilities.

Il est possible aussi d'utiliser les versions "beta" dites, nightly d'OCLP à vos risques et péril ;)

Nightly builds can be found here courteous of nightly.link:

 
Dernière édition:

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
450
171
Nice
blog.nojo.fr
Si vous avez un iMac 27 " mi 2011:

J'ai installé Monterey 12.0.1 sur mon iMac 27" mi 2011 qui me sert de test. Comme c'est une version majeure , j'ai préféré faire une "clean install". Cet iMac a:
  • une carte graphique AMD WX4130 pour avoir une CG compatible metal (changement décrit ici)
  • une carte WIFI/BT de type BCM94360CD pour être compatible Monterey

J'avais essayé avec OCLP v 0.3.1 mais je suis tombé sur le bug "Your Mac needs a firmware update in order to install to this Volume. Please select a Mac OS Extended (Journaled) volume instead." J'ai essayé de nouveau avec la version nightly et là, c'était OK.

J'ai donc bien après plusieurs reboots:

Capture d’écran 2021-10-29 à 08.47.04.jpeg


Le WIFI fonctionne:
Capture d’écran 2021-10-29 à 08.52.51.png




Le BT fonctionne:
Capture d’écran 2021-10-29 à 08.51.47.jpeg



La carte WIFI/BT:
IMG_4315.jpeg


Le support:
IMG_4315 2.jpeg



J'attends 1 ou 2 mises à jour de Monterey avant de faire la même chose sur mon iMac principal :)
 
Dernière édition:

DouceProp'

Membre actif
8 Mai 2008
117
3
Bonjour à tous, actuellement sur Mojave, est-ce que je peux me tenter une install de Monterey sur mon iMac de fin 2013 ?
C'est un i7 3,5 GHz, GTX 780M, 32 Go de ram (version 14,3 il me semble) Est-ce qu'on tout fonctionnera ? WiFi, bluetooth...
 

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
450
171
Nice
blog.nojo.fr
Bonjour à tous, actuellement sur Mojave, est-ce que je peux me tenter une install de Monterey sur mon iMac de fin 2013 ?
C'est un i7 3,5 GHz, GTX 780M, 32 Go de ram (version 14,3 il me semble) Est-ce qu'on tout fonctionnera ? WiFi, bluetooth...

La question a été posée ce matin dans MacRumors:

IMG_7916.jpeg


IMG_7917.jpeg


donc , à priori oui, mais avec des patchs "post install" avec les inconvénients associés, pas de SIP, il faut repatcher après chaque mise à jour, pas de mise à jour OTA delta, ...
 

DouceProp'

Membre actif
8 Mai 2008
117
3
Merci pour cette réponse. Donc il faut juste patcher pour récupérer le contrôle de la luminosité sur l'écran. Bien. Une option que j'utilise pas mal... Par contre, qu'est-ce que le SIP ? Perso je porte plutôt des caleçons. Et qu'est-ce qu'une mise à jour OTA Delta ? Encore un variant Indien ?
 

sergiodadi

Membre actif
Club MacG
15 Janvier 2011
450
171
Nice
blog.nojo.fr
Attention, n'installez pas la version beta de Monterey 12.1 sur certains macs (plus de boot dans certains cas :( ), un développeur d'OCLP vient d'annoncer:

"With today's latest Beta, XNU now unconditionally requires all machines to have RDRAND support to boot. Because of this, all pre-Ivy Bridge Macs will no longer boot 12.1.

For the time being, users are advised to stay on 12.0.1 if their machine is Sandy Bridge or older."

Affected Macs:​

  • MacPro5,1 and older
  • MacBook7,1 and older
  • MacBookAir4,x and older
  • MacBookPro8,x and older
  • iMac12,x and older
  • Macmini5,x and older
  • Xserve3,1 and older

Work Arounds​

Currently the only reliable work around is to use 12.0.1
 

DouceProp'

Membre actif
8 Mai 2008
117
3
Attention, n'installez pas la version beta de Monterey 12.1 sur certains macs (plus de boot dans certains cas :( ), un développeur d'OCLP vient d'annoncer:

"With today's latest Beta, XNU now unconditionally requires all machines to have RDRAND support to boot. Because of this, all pre-Ivy Bridge Macs will no longer boot 12.1.

For the time being, users are advised to stay on 12.0.1 if their machine is Sandy Bridge or older."

Affected Macs:​

  • MacPro5,1 and older
  • MacBook7,1 and older
  • MacBookAir4,x and older
  • MacBookPro8,x and older
  • iMac12,x and older
  • Macmini5,x and older
  • Xserve3,1 and older

Work Arounds​

Currently the only reliable work around is to use 12.0.1
Étant sur un iMac 14,3, cette info ne me concerne pas j'imagine...