10.13 High Sierra Installation impossible sur MB Pro, erreur de l’installeur

comeraz

Thierry G.
1 Septembre 2010
20
0
Genève
Bonjour, à ce moment, je n’ai toujours rien de visible dans les mises à jour, j’ai donc téléchargé (2x) l’installeur.

Au lancement il m’indique qu’il doit installer un « utilitaire » puis finit invariablement sur une erreur et me suggère de redémarrer l’application.

La même chose pour les 2 installeurs, même après avoir fait passer sos disk en redémarrant sur la partition de sauvegarde.

Et même en démarrant en mode sans échec pour éviter les diverses extensions.

Bref, IMPOSSIBLE d’installer la mise à jour.

MB Pro ssd de 2015 avec 60 Gb d’espace disque, 16Gb de mémoire.

Zut !

Quelqu’un a-t-il expérimenté la même chose ?
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
34 796
4 045
Bonjour, à ce moment, je n’ai toujours rien de visible dans les mises à jour, j’ai donc téléchargé (2x) l’installeur.
Tu peux détailler, car ce n'est pas clair ? Tu as téléchargé quoi depuis quoi, depuis App Store, autre ?
 

comeraz

Thierry G.
1 Septembre 2010
20
0
Genève
Volontiers. J’ai télécharger l’installer High Sierra (env. 4.6Gb) sur le Mac App Store (puisqu’il n’apparaît pas dans les mises à jour).
J’ai lancé l’application qui m’a demandé de quitter toutes les autres et ma dit qu’il lui fallait quelques Minutes pour installer un utilitaire (je crois).
Ensuite l’installer me dit que le Mac va redémarrer dans 30 secondes et là : « une erreur s’est produite lors de la préparation de l’installation. Essayez d’exécuter à nouveau cette application »

Et je précise que j’ai tenté :
De télécharger à nouveau l’installer,
De réparer le disque depuis la partition de sauvegarde,
De démarrer sans échec puis d’installer le système.
Toujours la même erreur.
Voici ma config. :

J’espère être plus clair, si quelqu’un peut m’aider !
Bye
 

comeraz

Thierry G.
1 Septembre 2010
20
0
Genève
Depuis mon dernier post j’ai
Zappé la PRAM
RE-téléchargé l’installer.
Relancé....
.... toujours la même erreur!
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
74 659
22 703
Forêt de Fontainebleau
Salut comeraz

Tu es confronté à un curieux problème (dont je n'ai pas la clé a priori).

Mais je peux déjà éclairer le point suivant -->

Au lancement il m’indique qu’il doit installer un « utilitaire »
  • Cette opération consiste à créer un dossier intitulé macOS Install Data dans l'espace-racine du volume de destination (le volume démarré ici) > à y copier l'installateur Install macOS High Sierra.app > puis à créer les boot_files (fichiers de démarrage) de l'OS auxiliaire (de type Recovery) recelé dans le paquet de l'installateur.

  • Cette tâche accomplie > le Programme d'installation bénit l'en-tête du volume démarré (pour qu'un chemin y soit inscrit pointant au fichier démarreur = boot.efi de l'OS auxiliaire recelé dans l'installateur) > et inscrit en NVRAM une adresse de démarrage automatique pour l'EFI (Pogramme Interne du Mac) au volume démarré.

Ainsi > le Mac étant re-démarré > l'EFI va au volume > au boot.efi du dossier macOS Install Data > qui lance l'OS auxiliaire d'installation > et l'installation peut commencer.

----------

Donc : à un point donné de cette opération d'ensemble > le Programme d'installation bute sur un obstacle (inconnu).

Comme il est mentionné dans une de tes captures avant le moment critique : « Prêt pour l'installation. Fermeture des applications et préparation au re-démarrage » --> voici mon interprétation : l'installateur Install macOS High Sierra.app (d'environ 4,6 Go) a fini d'être copié dans le dossier macOS Install Data > et c'est dans la phase : [création des boot_files > inscription du chemin de re-démarrage] qu'intervient le blocage.

Si tu inspectes l'espace-racine de ton volume Macintosh HD --> est-ce que tu avises actuellement un dossier intitulé macOS Install Data ?
 

comeraz

Thierry G.
1 Septembre 2010
20
0
Genève
...

Si tu inspectes l'espace-racine de ton volume Macintosh HD --> est-ce que tu avises actuellement un dossier intitulé macOS Install Data ?
Oui j'ai ce dossier qui est présent. Il s'y trouve un fichier .dmg qui, lors d'une autre tentative, semblait poser un problème.
Avec le dernier installeur, je suis retourné voir ce dossier et j'ai pu sans problème monter l'image disque.
Cependant, j'ai vu dans l'installer qu'il y a un historique et que l'erreur mentionnée était "impossible de monter le disque".
Je vais tenter à nouveau et voir ce qu'il se passe. En cas d'échec, je copierai l'historique de l'installer.
Merci de ton aide.

Voici l'historique de l'installer:
Bloc de code:
Sep 29 10:43:20 MacBook-Pro-GatT osinstallersetupd[938]: Failed to load BridgeOSInstall.framework: dlopen(/System/Library/PrivateFrameworks/BridgeOSInstall.framework/BridgeOSInstall, 1): image not found
Sep 29 10:43:20 MacBook-Pro-GatT osinstallersetupd[938]: Current version of BridgeOSInstall.framework doesn't have the latest API, assuming machine does not have bridgeOS
Sep 29 10:43:20 MacBook-Pro-GatT osinstallersetupd[938]: osinstallersetupd registered client
Sep 29 10:43:20 MacBook-Pro-GatT osinstallersetupd[938]: Specifier (<PKPackageSpecifier>:
    {
       URL = "file:///Volumes/InstallESD/Packages/Core.pkg";
       authLevel = 2;
       displayName = macOS;
       identifier = "com.apple.pkg.Core";
       options = 16;
       version = "10.13.0.1.1.1505969314";
    }) missing reference.
Sep 29 10:43:20 MacBook-Pro-GatT osinstallersetupd[938]: Specifier (<PKPackageSpecifier>:
    {
       URL = "file:///Volumes/InstallESD/Packages/EmbeddedOSFirmware.pkg";
       authLevel = 2;
       displayName = macOS;
       identifier = "com.apple.pkg.EmbeddedOSFirmware";
       options = 16;
       version = "10.13.0.1.1.1505969314";
    }) missing reference.
Sep 29 10:45:34 MacBook-Pro-GatT osinstallersetupd[938]: Helper tool loaded
Sep 29 10:45:34 MacBook-Pro-GatT osinstallersetupd[938]: Specifier (<PKPackageSpecifier>:
    {
       URL = "file:///Volumes/InstallESD/Packages/Core.pkg";
       authLevel = 2;
       displayName = macOS;
       identifier = "com.apple.pkg.Core";
       options = 16;
       version = "10.13.0.1.1.1505969314";
    }) missing reference.
Sep 29 10:45:34 MacBook-Pro-GatT osinstallersetupd[938]: Specifier (<PKPackageSpecifier>:
    {
       URL = "file:///Volumes/InstallESD/Packages/EmbeddedOSFirmware.pkg";
       authLevel = 2;
       displayName = macOS;
       identifier = "com.apple.pkg.EmbeddedOSFirmware";
       options = 16;
       version = "10.13.0.1.1.1505969314";
    }) missing reference.
Sep 29 10:45:34 MacBook-Pro-GatT osinstallersetupd[938]: Unable to get fs for (null)
Sep 29 10:45:34 MacBook-Pro-GatT osinstallersetupd[938]: Unable to get fs for (null)
Sep 29 10:45:34 MacBook-Pro-GatT osinstallersetupd[938]: OSISDownloadOperation: totalEstimate=356.000000, significantDownload=1
Sep 29 10:45:34 MacBook-Pro-GatT osinstallersetupd[938]: No native mechanism to verify InstallESD.dmg
Sep 29 10:45:34 MacBook-Pro-GatT osinstallersetupd[938]: Installing timeout for incompatible app list
Sep 29 10:45:34 MacBook-Pro-GatT osinstallersetupd[938]: No native mechanism to verify InstallInfo.plist
Sep 29 10:45:34 MacBook-Pro-GatT osinstallersetupd[938]: Operation queue succeeded
Sep 29 10:45:52 MacBook-Pro-GatT Installer Progress[975]: Progress App loading...
Sep 29 10:45:52 MacBook-Pro-GatT Installer Progress[975]: Progress App is running with no progress set.
Sep 29 10:45:52 MacBook-Pro-GatT Installer Progress[975]: End progress UI called...
Sep 29 10:45:52 MacBook-Pro-GatT Installer Progress[975]: Progress App running...
Sep 29 10:45:54 MacBook-Pro-GatT osishelperd[964]: isModernOS = 0
Sep 29 10:45:54 MacBook-Pro-GatT osishelperd[964]: IASClearInstallProgress: Clearing Registry
Sep 29 10:45:54 MacBook-Pro-GatT osishelperd[964]: IASGetCurrentInstallPhaseList: Unable to get phases
Sep 29 10:45:54 MacBook-Pro-GatT osishelperd[964]: IASSetCurrentInstallPhaseList: phases set to (
     .......

divers lignes sans erreur
     ....... 
Sep 29 10:45:56 MacBook-Pro-GatT osishelperd[964]: Couldn't mount base system dmg! (error code 2)
Sep 29 10:45:56 MacBook-Pro-GatT osishelperd[964]: osishelperd: Failed to mount outer dmg
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
74 659
22 703
Forêt de Fontainebleau
Va à : Applications > Utilitaires > lance le «Terminal» > dans la fenêtre ouverte > saisis la commande simplement informative (en copier-coller) :
Bloc de code:
ls -Ra /"macOS Install Data"
et ↩︎ (presse la touche "Entrée" du clavier pour exécuter la commande)

  • cette commande retourne la liste des objets présents dans le dossier macOS Install Data - y compris ceux qui sont invisibles graphiquement (il y en a une floppée)

Tu n'as qu'à poster le tableau retourné ici en copier-coller > mais attention ! avant de faire ton coller > presse le bouton (4è avant la fin à droite) dans la barre de menus au-dessus du champ de saisie d'un message > menu : </> Code > par ⌘V colle dans la fenêtre Code > presse le bouton Insérer (ce procédé permet un affichage fenêtré qui économise l'espace de page en respectant la mise en forme des tableaux du «Terminal» --> d'où une plus grande lisibilité).

=> ces informations sont cruciales > car elles pemettront de savoir si les boot_files de démarrage du système auxiliaire ont eu le temps d'être créés.
 

comeraz

Thierry G.
1 Septembre 2010
20
0
Genève
Bloc de code:
Last login: Fri Sep 29 10:55:41 on ttys000
MacBook-Pro-GatT:~ gatt$ ls -Ra /"macOS Install Data"
.                    MacOSXInstaller.choiceChanges
..                    OSInstallAttr.plist
.DS_Store                OSX_10_13_IncompatibleAppList.pkg
InstallESD.dmg                index.sproduct
InstallInfo.plist            minstallconfig.xml
Locked Files

/macOS Install Data/Locked Files:
MacBook-Pro-GatT:~ gatt$
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
74 659
22 703
Forêt de Fontainebleau
Le paysage du dossier macOS Install Data est complètement fragmentaire. Pas d'application d'installation complète copiée. Aucune trace d'un dossier invisible .IABootfiles recelant les fichiers de démarrage.

Je t'invite à mettre à la corbeille le dossier macOS Install Data complet et à la vider.

----------

À présent > je pense que j'ai aperçu la raison de l'échec d'installation d'après l'historique d'installation que tu as judicieusement posté -->
Bloc de code:
Failed to load BridgeOSInstall.framework: dlopen(/System/Library/PrivateFrameworks/BridgeOSInstall.framework/BridgeOSInstall, 1): image not found
Current version of BridgeOSInstall.framework doesn't have the latest API, assuming machine does not have bridgeOS
Le Programme d'installation a besoin d'un exécutable qui devrait être présent dans l'OS-hôte at : /System/Library/ PrivateFrameworks/BridgeOSInstall.framework/BridgeOSInstall (il s'agit donc d'un exécutable recelé dans un Framework).

Comme le Programme d'installation de le trouve pas > il plante pour effectuer sa tâche.

Il me semble alors que > pour débloquer ton installation de High Sierra > il faudrait en préalable que tu ré-installes ton OS actuel. Quel est cet OS ?
 
Dernière édition:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
74 659
22 703
Forêt de Fontainebleau
Je suppose que tu n'as pas sauvegardé un installateur quelque part (vu que «Sierra» n'est plus disponible en téléchargement sur l'AppStore ni dans les "Achats" du compte d'utilisateur) ?
 

comeraz

Thierry G.
1 Septembre 2010
20
0
Genève
Pour réinstaller Sierra, je dois démarrer sur la partition de sauvegarde et effectuer une nouvelle installation ? mes données vont rester ? ou je dois faire une clean install et récupérer d'une sauvegarde ?

je crois que je l'ai effacé hier pour m'assurer qu'il y avait assez de place !
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
74 659
22 703
Forêt de Fontainebleau
Oui : démarre par ⌘R en mode Recovery local > lance l'option : "Ré-installer macOS" à destination du volume de ton OS.

(tu n'as pas activé «FileVault» ? - si c'était le cas > il faudrait déverrouiller d'abord le volume de l'OS dans l'«Utilitaire de Disque» afin de le remonter)

=> ce type de ré-installation n'est qu'une restauration du logiciel-système de l'OS. Elle ne touche pas le compte d'utilisateur (avec ses données et réglages) > non plus que les applications tierces ajoutées.

J'espère pour toi que tu n'obtiendras pas un message d'erreur : "Article demandé indisponible. Veuillez réessayer ultérieurement" en te connectant à l'AppStore.
 

comeraz

Thierry G.
1 Septembre 2010
20
0
Genève
Non, je ne l'ai pas, j'ai recherché dans Time Machine, mais il s'agit de Yosemite, Maverick, Lion et Mountain Lion !

OK, merci, de ton aide, j'essaie tout de suite. Je posterai le résultat. Excellente journée (O`te situes-tu, je suis étonné de chatter à cette heure!)
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
74 659
22 703
Forêt de Fontainebleau
Je suis un lève-tôt - très tôt même : je me lève chaque jour à 4 heures du matin, parfois un peu avant.

J'habite en Seine-et-Marne, un village forestier en lisière de Forêt de Fontainebleau.

Tu ne résides pas en France ?
 

comeraz

Thierry G.
1 Septembre 2010
20
0
Genève
Je suis un lève-tôt - très tôt même : je me lève chaque jour à 4 heures du matin, parfois un peu avant.

J'habite en Seine-et-Marne, un village forestier en lisière de Forêt de Fontainebleau.

Tu ne résides pas en France ?
Je vis à Bangkok ! Il est midi et il fait environ 25 degrés aujourd’hui, un peu froid!

DÉCEPTION ! Malgré tes conseils et la réinstallation de Sierra, une nouvelle sauvegarde, j’ai toujours la même erreur lorsque l’installer veut démarrer.
Est-ce que de démarrer depuis une clef USB high Sierra pourrait etre une solution?
HELP
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
74 659
22 703
Forêt de Fontainebleau
Est-ce que de démarrer depuis une clef USB high Sierra pourrait etre une solution?
Cela mérite d'être tenté.

Je te propose d'attacher ta clé à ton Mac > lancer l'«Utilitaire de Disque» > sélectionner le disque de la clé > Effacer > Schéma = GUID > Format = Apple étendu (journalisé) > nom = CLE (majuscules, pas d'accent) --> tu appliques.

Puis tu fais en sorte que ton installateur soit présent dans le répertoire des Applications (intitulé : Install macOS High Sierra.app).

Ces 2 conditions remplies --> tu saisis (en copier-coller dans la fenêtre du «Terminal») la commande (déroule bien le tapis roulant horizontal de la fenêtre) :
Bloc de code:
sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/CLE --applicationpath /Applications/Install\ macOS\ High\ Sierra.app --nointeraction
et ↩︎ --> une demande de password s'affiche (commande sudo) --> tape ton mot-de-passe de session admin à l'aveugle - aucun caractère ne se montrant à la frappe - et à nouveau ↩︎

  • la commande se réfère à l'utilitaire createinstallmedia présent dans le paquet de l'application d'installation et spécialement créé par les ingénieurs de la  pour la création d'une clé d'installation démarrable
  • il va te falloir attendre plusieurs minutes l'achèvement de l'opération

=> il te suffira de re-démarrer en pressant la touche "alt" > de choisir le volume de ta clé qui a été renommé dans l'opération Install macOS High Sierra > et de vérifier si le Programme d'installation parvient à exécuter sa mission.
 
D

Deleted member 1099514

Invité
Salut

Peux-tu démarrer en mode Recovery (cmd+r lors du boot) puis depuis le terminal (Menu/Utilitaires/Terminal passer la commande :
diskutil list
puis faire une copie des résultats; quitter le terminal et dans le menu à 4 choix cliquer sur "obtenir de l'aide" : c'est safari.
Tu peux ainsi publier les résultats entre balises Code de préférence :

Ceci fait, tu retournes sur le terminal et là tu donnes les retours de :
diskutil ap list
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
74 659
22 703
Forêt de Fontainebleau
:coucou: Jean

comeraz
n'a pas de problème pour ouvrir sa session habituelle dans «Sierra» et utiliser le «Terminal» de l'OS, non plus que son «Safari».

Son problème est que, lorsqu'il lance dans l'environnement de «Sierra» démarré l'installateur de High Sierra téléchargé de l'AppStore > le Programme d'installation lui crée bien le dossier macOS Install Data à la racine de son volume démarré > et y injecte tout ce qu'il faut pour que le Mac puisse démarrer dessus > mais qu'au moment où le Mac doit redémarrer sur le système auxiliaire de ce dossier > un message s'affiche comme quoi une erreur s'est produite lors de la préparation de l'installation.