10.9 Mavericks installation propre d'OSX impossible alors que SSD fonctionel

Pierre Courrier

Membre enregistré
29 Avril 2019
4
0
25
Bonjour,
J'aimerais réaliser une installation propre d'un OS (peut importe la version) sur mon MacBook Pro mid-2012. Le mac fonctionnait très bien sur un SSD Sandisk 240Gb jusqu'au jour ou il n'a plus voulu démarrer. J'ai donc testé le SSD et aucun problème de ce coté. j'ai pu récupérer mes données et j'ai même essayé d'installer un autre OS sur un pc (windows 10) et cela a fonctionné. J'ai donc créé une clé usb bootable high sierra, formaté le disque en Mac étendu Journalisée, format GUID, mais problème lors de l'installation, elle s’arrête. J'ai tout essayé : autre clé USB bootable (Mojave, Mavericks...) autre SSD (provenant d'un PC Windows 10 fonctionnel). A chaque fois des problèmes durant l'installation d'OSX avec des messages d'erreurs différents (disque endommagé, erreur est survenue...) alors que mes SSD sont fonctionnels (en tout cas sous Windows). Auriez vous une solution à mon problème ?
Merci d'avance

PS : actuellement j'ai réussi a installer High Sierra sur un disque dur (HDD) provenant d'un PC Windows. il semble que mon mac ne veuille plus entendre parler de SSD...

Pierre
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 805
26 377
Forêt de Fontainebleau
Bonjour Pierre

Ta description fait penser à une défaillance de la nappe SATA (le câble plat type ruban qui relie le disque à la carte-mère et assure l'alimentation et le transfert des données au processeur). Nappe fréquemment défaillante avec le temps dans les MacBook Pro de l'année 2012.

Il faudrait que tu branches ton SSD en USB externe au Mac (boîtier SATA <=> USB pour disque 2,5" ou câble SATA <=> USB) > que tu démarres sur ta clé > et que tu lances l'installation de High Sierra à destination du SSD placé en externe. Si tout se passe bien et si le Mac démarre à la fin sur le volume du SSD externe vs si l'opération plante le SSD en interne => alors il faut changer la nappe.

Problème de débits. Si la nappe s'avère fonctionnelle avec un HDD interne où les débits en lecture / écriture plafonnent à du 100 Mo/s > elle peut très bien ne pas assumer les débits x5 d'un SSD (dans les 500 Mo/s en lecture / écriture). Donc la fonctionnalité d'un HDD connecté en interne à la nappe => n'est pas un argument suffisant : elle peut être hors d'usage pour un SSD.
 

SyMich

Membre actif
13 Février 2018
278
49
55
Ça fait penser à une nappe SATA défectueuse. Le problème ne viendrait pas du SSD, mais de la nappe faisant transiter les données entre le SSD et la carte mère du Mac avec des défauts qui ne se révèlent que lorsque les données transitent à très haut débit (avec un DD standard tout se passe bien).
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 805
26 377
Forêt de Fontainebleau
C'était donc la nappe SATA.

Pour l'achat d'une nouvelle : les 2 choix chez MacWay sont possibles - si tu n'as pas d'embarras pécunier --> prends celle d'iFixit.

Et pour le remplacement > un tuto de chez iFixit justement : ☞Remplacement de la nappe du disque dur du MacBook Pro 13" Unibody mi-2012☜ (clique le lien rouge). Comme tu peux le voir > c'est une opération débonnaire en terme de bricolage.
 
  • J’aime
Réactions: litobar71