Ce forum est en partie financé par l’affichage de publicités. Merci de désactiver votre bloqueur de publicités pour nous permettre de continuer à fournir ce service.

Installer Wget

Discussion dans 'Unix, Linux et open source' créé par @bou @n@ss, 18 Mai 2003.

Modérateurs: bompi, daffyb
  1. @bou @n@ss

    @bou @n@ss Membre confirmé

    Inscrit:
    8 Février 2000
    Messages:
    201
    J'aime reçus:
    0
    Salut,

    J'ai téléchargé Wget mais après l'avoir configuré, j'ai toujours :
    Command not found ;-(

    Qu'est-ce que j'ai loupé ?

    Merci
     
  2. maousse

    maousse Vétéran
    Club MacG

    Inscrit:
    20 Avril 2002
    Messages:
    7 224
    J'aime reçus:
    445
    tu t'y est pris comment pour l'installer ?

    avec un
    "./configure
    make
    make install" ?

    ça t'as mis un message d'erreur pendant ce processus ?
    Tu as bien suivi le readme qui accompagne les sources du programme ?
    Où as-tu trouvé le tarball ?

    Sinon, tu peux l'installer avec fink, c'est très commode et sans échec, assuré, et tu auras accès a des centaines d'autres programmes du même genre [​IMG]
     
  3. @bou @n@ss

    @bou @n@ss Membre confirmé

    Inscrit:
    8 Février 2000
    Messages:
    201
    J'aime reçus:
    0
    <blockquote><font class="small">Post&eacute; &agrave; l'origine par maousse:</font><hr /> tu t'y est pris comment pour l'installer ?

    avec un
    "./configure
    make
    make install" ?

    ça t'as mis un message d'erreur pendant ce processus ?
    Tu as bien suivi le readme qui accompagne les sources du programme ?
    Où as-tu trouvé le tarball ?

    Sinon, tu peux l'installer avec fink, c'est très commode et sans échec, assuré, et tu auras accès a des centaines d'autres programmes du même genre [​IMG]


    [/QUOTE]

    <blockquote><font class="small">Post&eacute; &agrave; l'origine par maousse:</font><hr />

    avec un
    "./configure
    Pas de message d'erreur.
    Je vais relire le readme.

    Le tarball ? késako ?

     
  4. maousse

    maousse Vétéran
    Club MacG

    Inscrit:
    20 Avril 2002
    Messages:
    7 224
    J'aime reçus:
    445
    le tarball, c'est l'archive tar, désolé d'avoir utilisé un anglicisme [​IMG]

    en général, ./configure n'est pas suffisant
    il faut aussi faire "make" et "make install", la procédure est indiquée dans le readme

    sinon, je te le répète, si tu comptes installer de nombreux petits programmes en ligne de commande, etc... fink est de loin la meilleure solution [​IMG]
     
  5. @bou @n@ss

    @bou @n@ss Membre confirmé

    Inscrit:
    8 Février 2000
    Messages:
    201
    J'aime reçus:
    0
    J'ai déjà désinstallé fink 2 fois par manque de place (latex me prenait pas moins de 300Mo) ! Je lui préfère i-Installer mais celui-ci ne propose pas wget.

    Quant à l'installation manuelle de wget, elle me donne ceci :
    <font color="red"> make[1]: Nothing to be done for `all'.
    [aa:~/Desktop/wget-1.8.2] aa% make install
    cd src &amp;&amp; make CC='gcc' CPPFLAGS='' DEFS='-DHAVE_CONFIG_H -DSYSTEM_WGETRC=\"/usr/local/etc/wgetrc\" -DLOCALEDIR=\"/usr/local/share/locale\"' CFLAGS='-O2 -Wall -Wno-implicit' LDFLAGS='' LIBS='-lssl -lcrypto ' prefix='/usr/local' exec_prefix='/usr/local' bindir='/usr/local/bin' infodir='/usr/local/info' mandir='/usr/local/man' manext='1' install.bin
    ../mkinstalldirs /usr/local/bin
    /usr/bin/install -c wget /usr/local/bin/wget
    /usr/bin/install: /usr/local/bin/wget: Permission denied
    make[1]: *** [install.bin] Error 71
    make: *** [install.bin] Error 2
    </font>
     
  6. Bobbus

    Bobbus Membre confirmé

    Inscrit:
    5 Décembre 2001
    Messages:
    146
    J'aime reçus:
    1
    Il y a bien une erreur à l'installation car le 'make install' essaie de copier les binaires dans le dossier approprié '/usr/local/bin', dans lequel seul l'utilisateur root a le droit d'écrire.
    Essaie de faire sudo make install, ça devrait passer, ou alors su puis make install (mais il faut avoir activer le compte root)

    Bob
     
  7. @bou @n@ss

    @bou @n@ss Membre confirmé

    Inscrit:
    8 Février 2000
    Messages:
    201
    J'aime reçus:
    0
    Merci, ça marche mais ./wget ne fonctionne pas et il faut taper /usr/local/bin/wget pour lancer wget !
    Sans faire des alias, il y a bien un fichier à modifier, un PATH ou quelque chose dans le genre, non ?
     
  8. Bobbus

    Bobbus Membre confirmé

    Inscrit:
    5 Décembre 2001
    Messages:
    146
    J'aime reçus:
    1
    Normalement si wget est /usr/local/bin, faire 'wget' (sans ./) doit pouvoir suffire. Sinon il faut redéfinir ta variable d'environnement PATH pour y inclure /usr/local/bin

    Bob
     
  9. @bou @n@ss

    @bou @n@ss Membre confirmé

    Inscrit:
    8 Février 2000
    Messages:
    201
    J'aime reçus:
    0
    <blockquote><font class="small">Post&eacute; &agrave; l'origine par Bobbus:</font><hr /> Normalement si wget est /usr/local/bin, faire 'wget' (sans ./) doit pouvoir suffire. Sinon il faut redéfinir ta variable d'environnement PATH pour y inclure /usr/local/bin


    [/QUOTE]

    Et c'est justement ça qui m'intrigue : wget est bien dans /usr/local/bin, mais ./wget ne marche pas et en plus il n'y a pas d'entrée man pour wget malgré un /usr/local/man/man1/wget.1.

    Une idée ?
     
  10. @bou @n@ss

    @bou @n@ss Membre confirmé

    Inscrit:
    8 Février 2000
    Messages:
    201
    J'aime reçus:
    0
    Quant à mon PATH, il est ainsi :

    <font color="red">
    path = ( \
    ~/bin \
    /usr/local/bin /usr/bin /bin \
    /usr/local/sbin /usr/sbin /sbin \
    )
    </font>
     
  11. Bobbus

    Bobbus Membre confirmé

    Inscrit:
    5 Décembre 2001
    Messages:
    146
    J'aime reçus:
    1
    ./wget ne peut marcher de toutes façons que si tu es dans le répertoire /usr/local/bin

    Pour moi, ça reste un problème tout bête de PATH mal configuré.
     
  12. vnsullivan

    vnsullivan Membre confirmé

    Inscrit:
    28 Février 2003
    Messages:
    183
    J'aime reçus:
    0
    <blockquote><font class="small">Post&eacute; &agrave; l'origine par @bou @n@ss:</font><hr /> Quant à mon PATH, il est ainsi :

    <font color="red">
    path = ( \
    ~/bin \
    /usr/local/bin /usr/bin /bin \
    /usr/local/sbin /usr/sbin /sbin \
    )
    </font>


    [/QUOTE]

    Bizarre. Si ton path contient /usr/local/bin, ça devrait marcher. As-tu réussi à te sortir de toutes ces embrouilles? Si c'est le cas, peux-tu nous dire ce qui n'allait pas? Ça peut toujours être utile pour ceux qui vont venir après toi si tu clos le thread proprement [​IMG]
    Merci de ta réponse.

    vn
     
  13. @bou @n@ss

    @bou @n@ss Membre confirmé

    Inscrit:
    8 Février 2000
    Messages:
    201
    J'aime reçus:
    0
    [​IMG]

    Aucun changement !

    Je (me) tape tjs le /usr/local/bin/ avant la commande ;-(
     
  14. olof

    olof Membre émérite

    Inscrit:
    23 Avril 2002
    Messages:
    770
    J'aime reçus:
    103
    Es-tu vraiment sur de ton path ?

    que donne un

    Code (Text):
    echo $PATH
    ???
     
  15. @bou @n@ss

    @bou @n@ss Membre confirmé

    Inscrit:
    8 Février 2000
    Messages:
    201
    J'aime reçus:
    0
    <blockquote><font class="small">Post&eacute; &agrave; l'origine par olof:</font><hr /> Es-tu vraiment sur de ton path ?

    que donne un

    Code (Text):
    echo $PATH
    ???


    [/QUOTE]

    echo $PATH
    /Users/aa/bin/powerpc-apple-darwin:/Users/aa/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin
     
  16. vnsullivan

    vnsullivan Membre confirmé

    Inscrit:
    28 Février 2003
    Messages:
    183
    J'aime reçus:
    0
    Holàlà!
    Et un challenge! Un!
    C'est vrai que c'est très bizarre ton problème, surtout que l'opération étant tellement basique, l'erreur doit certainement l'être aussi, et ça ne devrait pas être bien compliqué à résoudre...
    Alors est-ce que tu peux commencer par nous donner le message d'erreur précis? Est-ce tout simplement un "command not found"? Tu peux nous faire un copier/coller de ton term?

    vn
     
  17. @bou @n@ss

    @bou @n@ss Membre confirmé

    Inscrit:
    8 Février 2000
    Messages:
    201
    J'aime reçus:
    0

    <blockquote><font class="small">Post&eacute; &agrave; l'origine par vnsullivan:</font><hr /> Holàlà!
    l'opération étant tellement basique, l'erreur doit certainement l'être aussi, et ça ne devrait pas être bien compliqué à résoudre...vn


    [/QUOTE]

    Je faisais du ./wget [​IMG]

    Le wget tout seul marche bien [​IMG]

    Merci, vous m'avez bien aidé?
     
  18. Funnix

    Funnix Membre confirmé

    Inscrit:
    20 Juillet 2013
    Messages:
    127
    J'aime reçus:
    2
    Youpi :) je ne suis pas seul IDEM pour moi, alors je vais faire un joli copier coller qui résume mon pb (qui ressemble méchament au meme que @bou @n@ss)

    Je me sens compris tout d'un coup (sur le forum d'app... c'est très bof la réponse...)

    Primo : imacdejristophe:~ CompteKikoff$ /usr/local/bin/wget
    -bash: /usr/local/bin/wget: Permission denied

    Secondo : voici mon path :
    imacdejristophe:~ CompteKikoff$ echo $PATH
    /opt/local/bin:/opt/local/sbin:/opt/local/bin:/opt/local/sbin:/Users/CompteKikoff:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/opt/X11/bin

    Ma petite histoire : je vous laisse la version américaine, je pense que mon anglais se comprend assez bien (si pb de trad, dites le moi)

    I dowloaded the WGET. I move it in a personal Folder (called myWget) then I start compilation in that personal Folder :

    Step One :
    ./configure --with-ssl=openssl

    Step Two :
    make

    Step Three :
    sudo make install

    I finally have this sump-up in the XTERM window at the end of the compilation :
    configure: Summary of build options:
    Version: 1.15
    Host OS: darwin13.2.0
    Install prefix: /usr/local
    Compiler: gcc
    CFlags: -O2 -Wall
    LDFlags:
    Libs: -lssl -lcrypto -ldl -lz
    SSL: openssl
    Zlib: yes
    Digest: yes
    NTLM: yes
    OPIE: yes
    Debugging: yes

    Then....didn't work !!!!!!!!!!!!
    imacdejristophe:myWGET CompteKikoff$ wget
    -bash: wget: command not found

    :zen::zen::zen::zen::zen:
     
  19. Funnix

    Funnix Membre confirmé

    Inscrit:
    20 Juillet 2013
    Messages:
    127
    J'aime reçus:
    2
    En plus j'essaie de tester la commande su sous Maverick
    mais...je mets le meme mot de passe que celui de l'ouverture de session mais ca marche pas :(

    because ???

    qqn sait ?

    ---------- Nouveau message ajouté à 22h38 ---------- Le message précédent a été envoyé à 22h36 ----------

    imacdejristophe:Users CompteKikoff$ cd /usr/local/
    imacdejristophe:local CompteKikoff$ ls
    bin clamXav etc include info lib man share
    imacdejristophe:local CompteKikoff$
    imacdejristophe:local CompteKikoff$ cd bin/
    -bash: cd: bin/: Permission denied
    imacdejristophe:local CompteKikoff$


    ---------- Nouveau message ajouté à 22h39 ---------- Le message précédent a été envoyé à 22h38 ----------

    imacdejristophe:Users CompteKikoff$ cd /usr/local/
    imacdejristophe:local CompteKikoff$ ls
    bin clamXav etc include info lib man share
    imacdejristophe:local CompteKikoff$
    imacdejristophe:local CompteKikoff$ cd bin/
    -bash: cd: bin/: Permission denied
    imacdejristophe:local CompteKikoff$
     
  20. bompi

    bompi El Moderador
    Modérateur Club MacG

    Inscrit:
    12 Février 2004
    Messages:
    41 816
    J'aime reçus:
    3 121
    Utilise plutôt "sudo" qui permet d'exécuter une commande avec des droits administrateurs.
    Et pour avoir un shell avec les droits d'administration, c'est "sudo -s"

    Il y a de multiples façons d'obtenir wget : compilation autonome, Fink, MacPorts par exemple.
    Le projet Rudix offre des paquets tout faits, très pratiques. Et puis on peut aussi prendre Homebrew.
     
Modérateurs: bompi, daffyb
Chargement...