JOOMLA :Extension qui s'installent pas avec Mamp

fab4_33

Membre junior
19 Décembre 2008
24
0
La Rochelle
Bonjour,

Je viens juste de démarrer dans le monde mac, depuis 8 jours, ça commence à rentrer !!
J'ai installé une solution pour mamp et Joomla 1.5.8 pour développer mes sites web. Tout ce passait très bien, lors de la réinstallation des sites en local et des plugins et autres extensions utilisées. Mais voilà avec certaines extensions, Joomla ne veux pas les installer, il travail un peu puis page blanche, pas de plantage, mis l'extension n'est pas installé, pourtant , en faisant précédent, il y a une erreur "There was an error uploading this file to the server"
Ces extension sont bien compatibles avec Joomla 1.5.8 et fonctionnait correctement sous windows et xampp.

Si vous avez une piste ?

Merci pour votre aide

Dimitri
 

corso

Membre confirmé
14 Avril 2007
219
44
Suisse
Bonjour,

Dans les préférences de MAMP, dans l'onglet PHP, clique sur PHP 4. J'avais les mêmes problèmes pour certains plugins et depuis je n'en ai plus.

Bonne journée.
 

fab4_33

Membre junior
19 Décembre 2008
24
0
La Rochelle
Je vous post la réponse de Microquant posté sur le forum de Joomla.fr , qui permet de faire fonctionner en Php5

Cela doit fonctionner avec php5 ;)

Je te propose d'aller dans MAMP/conf/php5 et d'ouvrir php.ini avec un éditeur de texte genre smultron ou textwrangler et vers la ligne 225 tu modifies les paramètres de cette façon :

PHP:
;;;;;;;;;;;;;;;;;;;
; Resource Limits ;
;;;;;;;;;;;;;;;;;;;

max_execution_time = 60     ; Maximum execution time of each script, in seconds
max_input_time = 90    ; Maximum amount of time each script may spend parsing request data
memory_limit = 32M      ; Maximum amount of memory a script may consume (8MB)

Tu relances Mamp après avoir fait cette modification.