Keynote et Mountain Lion : fond des diapos rouge !

tofpouce69

Membre junior
8 Mai 2009
14
0
Bonsoir à tous,

J'avais créé un cours avec keynote et le thème Éditorial alors que j'étais sous Snow Leopard. Ce cours n'avait aucun problème sous Lion.

Maintenant que j'ai migré sous Mountain Mion, j'ouvre le fichier et les 155 diapos ont un fond rouge :eek: !! Même le pdf que j'avais exporté pour les élèves a maintenant un fond rouge :mad: !!

J'ai essayé de chercher ce qui se passe. Je me suis aperçu qu'en créant un nouveau fichier avec le thème Éditorial, le fond des diapos est normal (couleur sable) à la résolution 1024 x 768, mais qu'au dessus de cette résolution le fond devenait rouge (mon cours est à la résolution 1920 x 1080).

Résolution 1024 x 768 :


Résolution 1280 x 720 :


Est-ce que vous retrouvez le même comportement avec Keynote ? D'où cela peut-il venir ? Aidez moi s'il vous plaît car je n'ai vraiment pas envie de retaper mon cours (avec énormément d'équations, et graphiques) avec PowerPoint ou Impress.
 
M

Membre supprimé 2

Invité
Bonjour,

N'ayant pas Mountain Lion, je n'ai malheureusement ni explication, ni solution élégante à proposer. Je trouve particulièrement curieux le changement de couleur du PDF exporté à partir du diaporama originel…

Ceci dit, en désespoir de cause, as-tu tenté de modifier le fond des diapos dans l'inspecteur (en utilisant une couleur ou une image) ? Le mode opératoire est signalé ici : https://discussions.apple.com/message/6975143#6975143.

Juste dans l'hypothèse où tu n'y aurais pas déjà pensé (parce que là, j'enfonce vraiment une porte ouverte ;)) : si ce changement de couleur en fonction de la résolution n'affecte que le thème Éditorial, tu peux peut-être aussi créer un diaporama à la résolution qui te convient en utilisant un autre thème qui ne serait pas affecté par ce bug, puis copier-coller le contenu de ton ancien diaporama. Évidemment, cela implique 155 opérations individuelles… Mais c'est toujours moins long que de tout ressaisir.
 

tofpouce69

Membre junior
8 Mai 2009
14
0
Bonjour,

chez moi j'ai bien la bonne couleur dans les deux résolutions.
Merci pour l'essai. Maintenant, je sais que le problème vient de chez moi.


Je trouve particulièrement curieux le changement de couleur du PDF exporté à partir du diaporama originel…
Moi aussi. Ce qui est encore plus curieux est que les miniatures à gauche ont la bonne couleur, et que le fond dans l'inspecteur des diapositives est à la bonne couleur !

Ceci dit, en désespoir de cause, as-tu tenté de modifier le fond des diapos dans l'inspecteur (en utilisant une couleur ou une image) ? Le mode opératoire est signalé ici : https://discussions.apple.com/message/6975143#6975143.
Merci car ça marche. J'essaie maintenant de récupérer l'image du fond dans le thème ( /Applications/iWork '09/Keynote.app/Contents/Resources/Themes/Editorial_1920x1080.kth/Contents/Resources ) mais je n'ai pas trouvé. Quelqu'un sait-il où se trouve cette image ? Sinon, j'appliquerais ma propre image, ou un dégradé.
 
M

Membre supprimé 2

Invité
Je n'ai trouvé que ceci en fouinant dans le paquet :

/Applications/iWork '09/Keynote.app/Contents/Resources/Themes/Shared/Editorial_1024x768.jpg
 

quark67

Membre émérite
30 Juin 2002
798
46
Strasbourg
Merci pour l'essai. Maintenant, je sais que le problème vient de chez moi.
As-tu essayé d'ouvrir Keynote à partir d'un autre compte utilisateur ? Ça produit aussi le fond rouge ?

Ce qui m'étonne encore plus, c'est que le pdf affiche le fond rouge, car les informations de couleur contenus dans le fichier pdf sont « figés ». Cela laisse supposer que le problème ne ne cantonne pas à Keynote mais affecte également d'autres logiciels.

Aurais-tu installé un logiciel modifiant le comportement du système, qui ne serait pas parfaitement compatible avec Mountain Lion ?

Cette couleur rouge, ça fait penser à certains logiciels graphiques qui indiquent un niveau de transparence par un fond rouge. Par exemple si tu places dans une diapo Keynote une photo, que tu la sélectionnes, et que tu cliques sur le bouton « Alpha », en bougeant la souris, la zone que tu vas rendre transparente se colore de la même teinte de rouge.
 

tofpouce69

Membre junior
8 Mai 2009
14
0
Merci. J'ai également cherché à l'aide d'EasyFind qui permet de fouiner dans les paquets mais je n'ai pas trouvé d'autres images.

J'ai réglé le problème en appliquant la couleur de fond RVB(247,245,237) qui est la couleur la plus proche, mais sans la texture (mais qui ne se voyait pas au projecteur).

Je trouve néanmoins ce "bug" assez incroyable et c'est toujours stressant de ne pas retrouver sa mise en page.

---------- Nouveau message ajouté à 22h21 ---------- Le message précédent a été envoyé à 22h07 ----------

As-tu essayé d'ouvrir Keynote à partir d'un autre compte utilisateur ? Ça produit aussi le fond rouge ?

Ce qui m'étonne encore plus, c'est que le pdf affiche le fond rouge, car les informations de couleur contenus dans le fichier pdf sont « figés ». Cela laisse supposer que le problème ne ne cantonne pas à Keynote mais affecte également d'autres logiciels.

Aurais-tu installé un logiciel modifiant le comportement du système, qui ne serait pas parfaitement compatible avec Mountain Lion ?

Cette couleur rouge, ça fait penser à certains logiciels graphiques qui indiquent un niveau de transparence par un fond rouge. Par exemple si tu places dans une diapo Keynote une photo, que tu la sélectionnes, et que tu cliques sur le bouton « Alpha », en bougeant la souris, la zone que tu vas rendre transparente se colore de la même teinte de rouge.

Je n'avais pas vu ton message.

N'étant pas un geek, je ne vois pas quel logiciel modifierait le comportement du système. J'aime rester le plus simple possible.

Quand au canal Alpha, le problème est que le fond rouge apparaît à la création d'une nouvelle présentation encore vierge de tout document.

J'essaierai ta suggestion d'ouvrir Keynote à partir d'un autre compte demain matin, car là, je suis cuit de ma journée.

Merci de l'aide de chacun.
 

tofpouce69

Membre junior
8 Mai 2009
14
0
As-tu essayé d'ouvrir Keynote à partir d'un autre compte utilisateur ? Ça produit aussi le fond rouge ?

Ce qui m'étonne encore plus, c'est que le pdf affiche le fond rouge, car les informations de couleur contenus dans le fichier pdf sont « figés ». Cela laisse supposer que le problème ne ne cantonne pas à Keynote mais affecte également d'autres logiciels.

Aurais-tu installé un logiciel modifiant le comportement du système, qui ne serait pas parfaitement compatible avec Mountain Lion ?
Effectivement, à partir d'un autre compte, la présentation Keynote et le fichier pdf n'ont plus le fond rouge mais le fond normal du thème :eek: :confused: :eek:

C'est donc bien un problème propre à mon compte :confused:

Je ne vois vraiment pas de quoi cela peut venir … et j'aimerais savoir / comprendre.

De plus, étant photographe amateur, je manipule beaucoup d'images avec Lightroom, Capture NX, Photoline, … et je n'ai jamais eu d'images rougies.

Si quelqu'un peut encore m'aider à comprendre :zen:
 
Dernière édition:

tofpouce69

Membre junior
8 Mai 2009
14
0
Finalement, j'ai téléphoné à Apple qui m'a résolu le problème (au bout d'une heure quand même avec le technicien "chef").

C'était un problème de Préférence.

En résumé, j'ai du vider les dossier Caches et Saved Application State du dossier Library.

Ensuite, j'ai dupliqué le dossier Preferences, puis vidé ce dossier à part les 2 fichiers Finder.

J'ai redémarré la machine ce qui a régénérré le dossier Preferences, puis copier le dossier Preferences copie dans le dossier Preferences en n'écrasant pas les fichiers de même nom.

Un dernier redémarrage en maintenant Cmd+alt+P+R (j'ignore ce que c'est) puis mon problème était réglé :)

En plus, le démarrage du Macbook Pro est nettement plus rapide. Cela servira peut-être à certains pour redynamiser leur système ;)
 
Dernière édition: