iMac La barre de tache en anglais

bellisa

Membre actif
23 Février 2007
112
0
Bonjour,
J'ai ma barre de taches qui apparait depuis quelques jours en anglais et je n'arrive pas à changer la langue, pouvez vous m'aider ?
merci.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 246
26 206
Forêt de Fontainebleau
Bonjour bellisa

Est-ce que tu veux parler de la barre de menus du Finder tout en haut de l'écran ?

Si c'est le cas > va à : Applications > Utilitaires > lance le «Terminal». Dans la fenêtre qui s'est ouverte > saisis la commande purement informative (en copier-coller direct) :
Bloc de code:
defaults read -g AppleLanguages
et ↩︎ (presse la touche "Entrée" du clavier pour exécuter la commande)

  • cette commande affiche la préférence générale de langue (version abrégée) pour la session d'utilisateur

=> tu n'as qu'à poster ici ce retour tel qu'affiché dans la fenêtre du «Terminal».
 

bellisa

Membre actif
23 Février 2007
112
0
(

"en-FR"

)

Voilà ce qui s'affiche ....mais c'est tes en anglais !!!!!
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 246
26 206
Forêt de Fontainebleau
Le "en" initial est l'abréviation de "english" --> la préférence globale de langue est donc bien sur l'Anglais.

Que tu ne puisses pas opérer de changement de préférence dans le panneau Langue et régions des Préférences Système > me fait penser à un bogue de «Sierra». D'où la question (avant la solution) : ton OS actuel est-il «Sierra» ?
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 246
26 206
Forêt de Fontainebleau
Tu es donc victime d'un bogue de «Sierra» concernant les préférences de langue de session.

Alors voici les commandes à passer dans le «Terminal» (fais un copier-coller chaque fois) -->
Bloc de code:
defaults write -g AppleLanguages '(fr)'
chflags uchg ~/Library/Preferences/.GlobalPreferences.plist

  • la 1ère inscrit la préférence "fr" = french dans le fichier de préférences globales de ta bibliothtèque personnelle de compte
  • la 2è verrouille provisoirement ce fichier pour interdire qu'il soit modifié sournoisement par le bogue de Système

=> cela fait > re-démarre ton Mac pour que la nouvelle préférence entre en vigueur. Ta session ré-ouverte > dis si tu as récupéré le Français comme langue de session (et s'il n'y a pas des menus résiduels en Anglais).
 

bellisa

Membre actif
23 Février 2007
112
0
J'ai fait la manip....le Finder est maintenant en Français, mais Safari toujours en anglais :(:(:(
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 246
26 206
Forêt de Fontainebleau
Alors voici la commande pour régler le compte de «Safari» -->
Bloc de code:
defaults write com.apple.Safari AppleLanguages '(fr)'

Tu quittes «Safari» > tu le relances > et tu dis ce qu'il en est.

Par ailleurs > est-ce que les panneaux des Préférences Système (Menu ) sont en Français ou en Anglais ?
 

bellisa

Membre actif
23 Février 2007
112
0
defaults write com.apple.Safari AppleLanguages '(fr)' ....je le mets dans le Terminal ???

" Préférences Systèmes " sont en anglais
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 246
26 206
Forêt de Fontainebleau
Oui : quand je mets des commandes dans des fenêtres de Code > c'est à passer dans le «Terminal».

Et voici une commande en plus pour les Préférences Système -->
Bloc de code:
defaults write com.apple.systempreferences AppleLanguages '(fr)'

mais pour celle-là > il va te falloir re-démarrer.

Donc tu passes dans le «Terminal» (l'une après l'autre) les 2 commandes données (message #8 & #10) > tu re-démarres > et tu dis ce qu'il en est.
 

bellisa

Membre actif
23 Février 2007
112
0
Merci beaucoup, j'ai tout récupéré en Français :D;)

Mais par contre impossible de remettre une autre langue, je dois avoir un bugg quand même, "Sierra" ou autre ....
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 246
26 206
Forêt de Fontainebleau
N'oublie pas que le fichier des préférences globales est resté verrouillé.

Donc par la commande :
Bloc de code:
chflags nouchg ~/Library/Preferences/.GlobalPreferences.plist

  • tu le déverrouilles > ce qui permet de lui apporter des éditions.

Quelle autre langue est-ce que tu veux ajouter ?
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 246
26 206
Forêt de Fontainebleau
Alors tu passes la commande :
Bloc de code:
defaults write -g AppleLanguages '(fr, en, es)'

  • et tu re-démarres. Espérons que la préférence prioritaire va bien rester sur Français.

Mais je ne sais pas si tu pourras alterner les choix : il est arrivé - non universellement, mais pour certains utilisateurs et uniquement dans une session d'un certain type - qu'il soit impossible d'effectuer des choix de langue de session à la volée dans le panneau Langue et région. C'est un bogue de «Sierra».
 

bellisa

Membre actif
23 Février 2007
112
0
Ca ne marche pas, je ne peux pas rajouter l'anglais ou l'espagnol....pas grave du tout, le principal c'est d'avoir récupéré le français.
Merci, merci. Bonne soirée