macOS Big Sur Le fichier ISO de W10 n'est pas reconnu par Boot Camp

Benckes

Membre junior
Club MacG
30 Décembre 2011
23
4
Bonjour,

J'ai installé la beta publique de Big Sur, assez stable jusqu'ici à part quelques problèmes d'autorisation parfois. Ayant sans doute le dernier MacBook Pro Intel ou pas loin, mon but était d'installer Windows 10 avec Bootcamp.
Problème : après téléchargement du fichier ISO de W10, l'Assistant Bootcamp ne veut pas l'accepter. Il m'indique qu'il n'est pas reconnu, et quand par curiosité je tente de monter le fameux ISO, le message d'erreur est le suivant : aucun système de fichiers montable.
Mon premier test fut de vérifier si cela venait d'une éventuelle corruption du fichier, j'ai donc téléchargé une deuxième image disque de W10. Même principe, même sanction.
J'ai ensuite tenté de créer une clé USB bootable depuis un PC fixe, à partir d'un téléchargement direct via l'outil fourni par Microsoft. Aucun problème de ce côté-là, la clé était fonctionnelle. J'ai donc téléchargé un ISO via le même utilitaire, et tenté tout ça sur le Mac :
  • Bootcamp ne reconnaît pas la clé comme un bon outil d'installation
  • L'ISO était encore une fois impossible à monter

Je suis un peu à court d'idées. Je pourrais tenter de bourriner, démarrer sur la partition de restauration et partitionner le disque comme une brute, pour ensuite booter sur la clé USB d'installation, mais quid alors de Bootcamp, qui n'aura pas fait sa sauce, pour l'amorçage au démarrage ?
Si quelqu'un a une solution pour réparer le problème, je suis preneur.

Je mets en dessous les messages d'erreur, ça facilitera la recherche du fil sur un moteur de recherche :
- Le fichier ISO de Windows 10 n'est pas reconnu
Un problème est survenu lors de la lecture du fichier ISO de Windows 10. Veuillez utiliser un autre fichier ISO.
- Aucun système de fichiers montable

Merci d'avance !

Configuration : MBP TB 2,00 GHz 16Go RAM 2To macOS Big Sur public beta 3
 

Benckes

Membre junior
Club MacG
30 Décembre 2011
23
4
Bon, de ce que j'ai trouvé c'est encore un problème d'autorisations. Je vais tenter de le faire en créant l'utilisateur root puisque je peux monter l'ISO avec le terminal. Décidément !
 

Benckes

Membre junior
Club MacG
30 Décembre 2011
23
4
Ben voilà, problème résolu.
Il suffit de faire toute la procédure, mais avec l'utilisateur root.

Si quelqu'un sait comment désamorcer ces problèmes de permissions, je suis preneur, parce que j'ai également un autre topic sur le sujet, et là l'utilisateur root n'est d'aucun secours.

Merci de votre attention
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
35 831
4 343
Si quelqu'un sait comment désamorcer ces problèmes de permissions, je suis preneur, parce que j'ai également un autre topic sur le sujet, et là l'utilisateur root n'est d'aucun secours.
Il y a de fortes chances que ce soit la protection SIP que l'on peut désactiver via le Terminal. Pour connaître son statut...
Bloc de code:
csrutil status
...s'il affiche enable, il faut passer cette commande...
Bloc de code:
csrutil disable
...pour le réactiver...
Bloc de code:
csrutil enable
...chaque commande doit-être validée avec la touche Entrée.

Sinon, macOS Big Sur est encore en version bêta, pourquoi tenter le diable avec une telle version ? La version finale sortira fin septembre début octobre, ce serait nettement plus raisonnable. Moi, je n'ai même pas installé macOS Catalina, je l'ai testé dans un disque dur USB pour ne pas pourrir ma version en cours.