le spotlight des fenêtres finder ne marche pas

Dark_Fragor

Membre confirmé
6 Avril 2008
60
5
34
Nancy
Bonjour à tous,
J'ai une petite embrouille sur mon iMac 21,5' sous SL 10.6.3.
Mon spotlight dans le finder ne marche pas du tout, tandis que le spotlight en haut à droite (icône en forme de loupe) fonctionne parfaitement.
J'ai fouillé un peu sur le net, en français et anglais. J'ai tenté les astuces décrites sur ce site: http://osxdaily.com/2007/02/15/spot...otlight-menu-with-these-troubleshooting-tips/
sans succès.

qq screenshot pour me faire bien comprendre
http://forums.macg.co/images/attach/jpg.gif
http://forums.macg.co/images/attach/jpg.gif

bien sûr ce bug s'applique quelque soit le dossier ou les options de recherche mais je le répète: UNIQUEMENT dans le finder, pas dans le menu spotlight. Et quand je clic "tout afficher" dans le menu spotlight => retour à 0 résultats dans la fenêtre finder :(

merci de vos réponses.
 

ET80

Membre actif
12 Février 2010
147
1
Amiens
Déjà, sur les deux captures d'écran, ce n'ai pas le même mots clés .... peut être n'y a t'il pas de fichier/dossier "lapin"?
 

Dark_Fragor

Membre confirmé
6 Avril 2008
60
5
34
Nancy
Déjà, sur les deux captures d'écran, ce n'ai pas le même mots clés .... peut être n'y a t'il pas de fichier/dossier "lapin"?

lol, si si l'icone de spotlight trouve des "lapins" dans ma machine, mais pas le finder. J'avais juste envie de changer :D
 

Dark_Fragor

Membre confirmé
6 Avril 2008
60
5
34
Nancy
A l'avenir, fait attention aux dates des sujets que tu consultes... février 2007 c'est 10.4.


Bloc de code:
sudo mdutil -E /

Et tu attends que l'indexation soit finie.

J'ai réalisé la manoeuvre avec onyx mis à jour et pas la commande unix l apremière fois ^^. Je viens de le refaire avec ta commande. Résultat: un peu de progression. Spotlight a fonctionné au début du mot que j'ai tapé, pour au final rester bloquer sur les 3 premières réponses qu'il m'avait trouvé (et qui ne correspondent pas au mot complet, les réponses qu'il me sort correspondent plutôt au début du mot ...). Et quand j'efface mon mot et que je retape un autre mot dans la fenêtre finder, plus de réponse du tout.

J'ai remarqué que la petite roue d'activité tourne indéfiniment en bas à droite. Aucun process ne plante et le disque dur ne tourne pas de manière anormale (vérifié avec istat menu et moniteur d'activité)

:(
ça craint. l'un d'entre vous a t-il une idée ?
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
22 663
5 108
Là-haut
Spotlight n'a pas fini la recherche -> roue crantée. Le problème n'est pas qu'il ne trouve pas mais que quelque chose l'empêche de chercher correctement.

Démarrage en mode sans extension => maintenir la touche majuscule de droite.
Attendre quelques minutes sur la fenêtre de login.
Puis redémarrage normal.

Le Mac va refaire une indexation (contrôler dans le moniteur d'activité => programmes en cours)
Attendre qu'il ait fini.
 

Dark_Fragor

Membre confirmé
6 Avril 2008
60
5
34
Nancy
J'ai fait tout bien ce que tu m'as dit, j'ai attendu bien longtemps sur la fenêtre de login après la désactivation d'extension, j'ai redémarré, le mac a refait l'indexation et ta-daaaaa ! ça marche !!!

Pousserais tu le conseil jusqu'à m'expliquer ce qui s'est passé ? Je comprend pas bien pourquoi une désactivation d'extension répare des choses sur mon ordi...

m'enfin bref, je te remercie Moonwalker.
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
22 663
5 108
Là-haut
Ce n'est pas qu'une désactivation d'extension. Ça, c'est le nom qui lui est resté avec le temps.

Il s'agit d'une procédure d'entretien, de vérification et de réparation, qui efface des caches dont certains très profondément dans le système. C'est pour cela que je préconise d'attendre patiemment que l'OS ait fini de remettre les choses en ordre à chaque étape (perso, j'écoute mon disque dur gratter et ne relance la bête qu'après son silence confirmé).

Plus sur le sujet dans la note technique qu'Apple lui a consacré :
http://support.apple.com/kb/HT1564?viewlocale=fr_FR
 

Dark_Fragor

Membre confirmé
6 Avril 2008
60
5
34
Nancy
Ce n'est pas qu'une désactivation d'extension. Ça, c'est le nom qui lui est resté avec le temps.
ouai je me rappelle que la dernière fois que j'ai utilisé ça, c'était sous OS 9 sur mon iMac G3

(perso, j'écoute mon disque dur gratter et ne relance la bête qu'après son silence confirmé).
c'est ce qui m'a convaincu que je pouvais relancer la machine ;)

Bizarre qu'un gros nettoyage des caches système et utilisateur dans onyx n'ai pas réglé mon problème (ouai j'avais oublié de le dire...)
Encore merci !