Les installateurs ne fonctionnent plus, ni iTunes, ni la MAJ etc.

tfoth

Membre enregistré
23 Août 2007
9
0
39
Ma config : Mac Mini Intel Core Duo, Mac OS X.4.10

Mon souci : En ayant assez de la langue anglaise dans Safari 3 Beta, je décide de le désinstaller avec l'installateur fourni dans le DMG pour repasser à Safari 2.

Et bien entendu, ça plante :D Une erreur est survenue à l'installation blabla. Rien d'affolant néanmoins.

Je réessaie donc de lancer l'installateur, ne fonctionne pas (l'icône disparaît du Dock juste après y être apparue), et en plus j'ai un message d'erreur qui me dit d'éteindre le Mac, en utilisant le bouton.

Ce que je fais.

Redémarrage : Quicksilver ne fonctionne plus (quitte dès qu'il est lancé en fait), ni iTunes, Safari a carrément disparu, son installateur quitte de la même façon, comme tous les autres.

Onyx non plus ne semble pas fonctionner, pas plus qu'Adium, Shiira, Growl, et un paquet d'autres, dont la Mise à Jour.

En revanche, Firefox et les applications X11 n'ont pas de souci, pas plus que iCal, Aide-Mémoire, iPhoto... et l'Utilitaire de Disque, qui m'a permis de faire une inutile réparation des autorisations (il n'y avait rien à réparer)

Même chose en mode sans échec, et sur une autre session.

Bref, j'imagine que le souci se situe pitet dans le framework Cocoa (ou pas ? ) mais je n'ai aucune idée de comment le résoudre.

Si quelqu'un a une idée, je remercie d'avance pour toute suggestion de nature à résoudre mon souci.
 

Toumak

Membre expert
Club MacG
10 Janvier 2006
3 525
328
33
Deep Inside
www.applestuut.com
si le problème est survenu à une mauvaise (dés)installation de safari, le problème vient plus probablement du webkit que de cocoa
 

tfoth

Membre enregistré
23 Août 2007
9
0
39
Logique, en effet :) je n'avais pas pensé que l'installateur pouvait l'utiliser, mais c'est logique en fait ^^

Après, je ne sais toujours pas comment résoudre mon problème, mais ça avance :D