Libre Office quitte à chaque commande d'impression

Checky 10

Membre confirmé
15 Octobre 2012
147
9
Bonjour,

A chaque fois que je lance une commande d'impression avec Libre Office, Libre Office quitte de manière imprévue et j'ai le petit signalement = "LO a quitté de manière imprévue/ Relancer, ou Signaler à Apple etc "

J'ai désinstallé puis réinstallé LO : même chose.

Je viens de vérifier, puis de réparer les permissions avec mon utilitaire de disque. Je viens de vérifier mon disque dur qui "semble être en bon état" = toujours le même souci.

J'aimerais savoir si le souci provient de Libre Office ou bien de mon imprimante (Canon IP 4700 series) ou bien de mon Mac OS X Snow Leopard.

Merci d'avance
 

pascalformac

Légende
Club MacG
23 Novembre 2003
58 699
1 814
la desinstall LO
(sans doute inutile)
comprenait elle TES réglages???

comme toujours

tester dans une autre session
(si possible neuve ou avec LO pas ou très peu utilisé)
 

macrocosme

Membre confirmé
6 Juin 2010
113
2
F-60
Bonjour,

Du Mac, sûrement pas.
Vous avez désinstallé/Réinstallé sans purger le profil. C'est comme si vous n'aviez rien fait.
Il faut purger le profil.
Purge du profil sous Mac
 

pascalformac

Légende
Club MacG
23 Novembre 2003
58 699
1 814
Bonjour,

Du Mac, sûrement pas.
Vous avez désinstallé/Réinstallé sans purger le profil. C'est comme si vous n'aviez rien fait.
c'est une semi desinstall
non
pas forcement
car si ca se trouve LO n'y est pour rien
d'où la manip usuelle de test ( LOet imprimante) sur session autre avant de songer à purger quelque chose
 

Checky 10

Membre confirmé
15 Octobre 2012
147
9
Bonsoir,

Merci pour vos réponses

Je viens de tenter l'impression d'un texte LO sur une autre session "invité" = même souci.

J'ai oublié de le dire tout à l'heure : je suis en dual boot Mac OS X/ Seven avec bootcamp.

J'ai aussitôt vérifié si mon imprimante fonctionnait avec Word sur ma partition Seven : elle fonctionne parfaitement. Donc cela ne vient pas de l'imprimante (normalement reconnue dans ma partition Mac OS X)

Je vais donc voir du côté de la purge de LO qui m'est conseillée. Je donnerai des nouvelles.

A suivre...

---------- Nouveau message ajouté à 19h58 ---------- Le message précédent a été envoyé à 19h50 ----------

Purge de LO effectuée = le souci demeure toujours au lancement de l'impression.

Je vais désinstaller LO et le remplacer par Open Office, on verra bien.

---------- Nouveau message ajouté à 20h52 ---------- Le message précédent a été envoyé à 19h58 ----------

J'ai complètement viré Libre Office.

J'ai installé Open Office : toujours le même problème.

J'y suis depuis le début de cet après-midi et je tourne en rond.

Une remarque : même souci avec Text Edi dès que je lance une impression, je viens d'essayer.

Je ne pense donc pas que cela vienne du logiciel de traitement de texte (que ce soit LO ou OO ou Texte Edit) ni de l'imprimante.

Mais qu'est-ce que ça peut bien être alors ?
 
Dernière édition:

gmaa

Vétéran
Club MacG
8 Janvier 2005
5 842
170
Une réinstall de Mac OS...
Cela n'efface pas les appris ou données. (Pour BootCamp, je ne sais pas mais a priori...)

Si peur trop grande : Clone d'abord.
 

Checky 10

Membre confirmé
15 Octobre 2012
147
9
OH non ! Pitié !

Début Novembre, J'ai réinstallé Snow après un changement de disque dur et j'ai passé une bonne semaine à tout configurer aux petits oignons et il n'y a que ce souci : à la commande d'impression, les logiciels de traitement de texte (Libre Office/ Open Office/ textEdit) quittent de manière imprévue.

J'ai des pistes, cependant : OS X 10.6.7 casse les polices OpenType PostScript, sur MacBidouille.com

OpenType font issues affect PDFs and more in OS X 10.6.7 | MacFixIt - CNET Reviews

Mac OS X 10.6.7 Update Causes Problems With OpenType Fonts | The FontFeed

Mais si ce sont les bonnes pistes je ne vois pas comment procéder. Je suis sur 10.6.8.

Apparemment ce souci (application quittant de manière imprévue sur Mac OS X) semble fréquent sur les forums, je pense qu'il y a une faiblesse inhérente à Mac OS X.

---------- Nouveau message ajouté à 22h37 ---------- Le message précédent a été envoyé à 22h22 ----------

J'ai l'impression que de commencer à mieux situer le souci : Problèmes de polices sous Mac OS X : quelques infos | Problèmes et Solutions Mac | Problèmes et Solutions | Conseils de pro | Atelier Les Yeux Fertiles

Mais ce soir je suis trop crevé , je verrai cela plus tard.

Merci de suivre, je donnerai des nouvelles
 

Checky 10

Membre confirmé
15 Octobre 2012
147
9
Bonjour,

Ce matin j'ai désinstallé/réinstallé l'imprimante = pas de changement.

J'ai réinitialisé le système d'impression = idem

J'ai ensuite lancé l'impression de pages tests = idem

Je relève le message d'erreur suivant :

Error:/Library/Printers/canon/BJprinter/Filters/Command2CanoniJ/bundles/Contents/Mac OS/Command2 CanonIJ failed

Tu me parles de réinstaller Snow Leopard. Mais au début novembre, quand j'ai procédé au changement de disque dur, et alors que je n'avais pas tout configuré sur mes deux partitions, et que je procédais à différents essais (impression, installation de Lightroom), je me souviens avoir eu ce souci d'applications qui, alors, ne montaient pas (comme Lightroom) et qui quittaient inopinément ou qui montaient mais qui n'imprimaient pas (comme Libre Office) et qui quittaient.

Alors cela ne me gênait pas de réinstaller puisque je procédais à des essais. Et tout refonctionnait normalement, juste après la réinstallation.

Mais, maintenant que j'ai tout reconfiguré, je ne vais pas réinstaller SL pour que tout refonctionne juste après et que j'aie à nouveau le même souci un peu plus tard, en devant A NOUVEAU réinstaller.

Ce n'est pas une solution long terme quand même.

Non je veux comprendre ce qui se passe et le solutionner, en l'état, une fois pour toutes.

Je pense qu'il s'agit là d'un conflit de polices.
 
Dernière édition:

pascalformac

Légende
Club MacG
23 Novembre 2003
58 699
1 814
Je viens de tenter l'impression d'un texte LO sur une autre session "invité" = même souci.
donc inutile de purger le profile

. Donc cela ne vient pas de l'imprimante (normalement reconnue dans ma partition Mac OS X)
conclusion trèèèès rapide
Je vais donc voir du côté de la purge de LO qui m'est conseillée. Je donnerai des nouvelles.
pas la peine ,voir plus haut

Purge de LO effectuée = le souci demeure toujours au lancement de l'impression.
qu'est ce je disais,déjà?
:siffle:

J'ai installé Open Office : toujours le même problème.
Une remarque : même souci avec Text Edi dès que je lance une impression, je viens d'essayer.
ca laisse bigrement penser que le couac est coté imprimante
(l'hypothèse plausible que tu as si rapidement exclue)

Je ne pense donc pas que cela vienne du logiciel de traitement de texte (que ce soit LO ou OO ou Texte Edit) ni de l'imprimante.
pas d'accord
ca sent souci imprimante

pilotes mac pas à jour ou mal installés ou fichiers corrompus par exemple

et ca se confirme
Error:/Library/Printers/canon/BJprinter/Filters/Command2CanoniJ/bundles/Contents/Mac OS/Command2 CanonIJ failed
Mais qu'est-ce que ça peut bien être alors ?
l'imprimante coté mac semble de plus en plus la cause
 

Checky 10

Membre confirmé
15 Octobre 2012
147
9
OUF OUF OUF ! GENIAL ! Je viens d'installer Canon Inkjet Printer Drivers et ENFIN ça marche !

C'était donc bien l'imprimante et merci Moonwalker pour le good diagnostique.

Toutes mes excuses à Steve, RIP !

Vraiment sympa...parce que l'idée de devoir réinstaller SL me rendait malade (surtout juste pour ça en plus !)

Bonne journée à tous et encore : 1000 fois merci :up: