LibreOffice 7.0.3.1 : formatage conditionnel des cellules d'une colonne.

ungars

Membre actif
27 Mai 2007
156
5
Bonjour

j'aimerai formater un texte en gras dans une colonne en fonction d'une valeur précise.
Cette valeur est le résultat d'une fonction sur une autre colonne : =SI(ESTERR(TROUVE("ACHAT CB";B2;1));"AUTRE";"ACHAT CB")
Les valeurs "AUTRE" et "ACHAT CB" sont parfaitement restituées.
Je souhait en mettre gras les cellules avec "ACHAT CB".
Reste à mettre en oeuvre le formatage conditionnel. Et là, j'ai fait plein d'essais : rien ne fonctionne...
Dans la boite de dialogue, mon texte "ACHAT CB" est systématiquement remis en minuscules en plus !
Même le site du logiciel ne m'a aidé en rien du tout.
Merci d'avance de votre aide.
 

macrocosme

Membre actif
6 Juin 2010
114
2
F-60
Bonjour

j'aimerai formater un texte en gras dans une colonne en fonction d'une valeur précise.
Cette valeur est le résultat d'une fonction sur une autre colonne : =SI(ESTERR(TROUVE("ACHAT CB";B2;1));"AUTRE";"ACHAT CB")
Les valeurs "AUTRE" et "ACHAT CB" sont parfaitement restituées.
Je souhait en mettre gras les cellules avec "ACHAT CB".
Reste à mettre en oeuvre le formatage conditionnel. Et là, j'ai fait plein d'essais : rien ne fonctionne...
Dans la boite de dialogue, mon texte "ACHAT CB" est systématiquement remis en minuscules en plus !
Même le site du logiciel ne m'a aidé en rien du tout.
Merci d'avance de votre aide.
Bonjour,

Êtes-vous allé poser votre question sur ce forum ? https://forum.openoffice.org/fr/forum/viewforum.php?f=4
 

osnola

Membre actif
14 Novembre 2004
326
29
Bonjour,
il faudrait essayer en tapant "ACHAT CB" dans la valeur à tester : j'ai une version anglaise, si je rentre ACHAT CB, il essaye d'interpréter cela comme un indice de cellule ( "Strings without quotes are interpreted as column/row labels" ), donc commence par tout passer en minuscule, mais si je rentre "ACHAT CB" , il teste bien l'égalité des chaînes.