localhost ou 127.0.0.1

PocketBen

Membre confirmé
8 Janvier 2002
177
0
Visiter le site
suite de mes déboires:

je ne peux pas ouvrir "http;//localhost/index.html" alors que "http://127.0.0.1/index.html" fonctionne... c con, mais je crois bien que c la même chose ?

Puis, aucun des fichiers PHP ou HTML mis dans mon répertoire site ne peut être ouvert par http://127... nom.html mais uniquement ceux qui sont dans Library/Webserver/Documents...

Je ne vois pas non plus pourquoi...

si il y en a qui ont le courage de me répondre !...
 

PocketBen

Membre confirmé
8 Janvier 2002
177
0
Visiter le site
la seconde question n'a pas lieu d'être, c evidemment parce que je dois mettre un ~login entre deux...

c la fatigue je crois,
pardon


PS: c quoi le raccourci MacOS X pour ~ ? (là c une vraie question)
 

Tiberius

Membre confirmé
12 Janvier 2001
448
15
<BLOCKQUOTE><font size="1" face="Verdana, Geneva">quote:</font><HR>Posté à l'origine par PocketBen:
lPS: c quoi le raccourci MacOS X pour ~ ? (là c une vraie question)<HR></BLOCKQUOTE>

Euh, tu dois le connaître, puisque tu as tapé le caractère


Allez, essayes donc ALT-N
 

_gromit_

Membre confirmé
15 Mai 2000
458
5
36
Valence
softomatic.macdk.com
<BLOCKQUOTE><font size="1" face="Verdana, Geneva">quote:</font><HR>Posté à l'origine par PocketBen:
PS: c quoi le raccourci MacOS X pour ~ ? (là c une vraie question)<HR></BLOCKQUOTE>

Bah c'est pas [alt]-[N] puis espace ?

ou tu cherches qqc d'encore plus rapide ?


<BLOCKQUOTE><font size="1" face="Verdana, Geneva">quote:</font><HR>Posté à l'origine par PocketBen:
je ne peux pas ouvrir "http;//localhost/index.html" alors que "http://127.0.0.1/index.html" fonctionne... c con, mais je crois bien que c la même chose ?<HR></BLOCKQUOTE>

ça, j'avais déjà remarqué : le système préfère 127.0.0.1 à localhost, surtout lorsque l'on est pas connecté...
est-ce parce que lorsqu'on met localhost, le navigateur va d'abord chercher sur les DNS ?
 

benR

Membre d’élite
Club MacG
17 Juillet 2000
3 480
11
Paris
www.lasauce.eu
<BLOCKQUOTE><font size="1" face="Verdana, Geneva">quote:</font><HR>Posté à l'origine par _gromit_:

est-ce parce que lorsqu'on met localhost, le navigateur va d'abord chercher sur les DNS ?
<HR></BLOCKQUOTE>

j'ai remarqué ça aussi, et je pense que c'est la raison...
 
A

Anonyme

Invité
Ca dépend pas un peu du navigateur que tu utilises ? j'ai l'impression qu'omniweb transforme tout seul localhost en 127.0.0.1
ca te dit quoi quand ca marche pas?
 

PocketBen

Membre confirmé
8 Janvier 2002
177
0
Visiter le site
Non, Alt-N je savais pas, je l'avais trouvé une fois par hasard et là pour mon post j'ai fait un copier/coller... idiot mais bon...


Sinon, il me met 'impossible d'afficher la pae' quand il ne parvient pas à 'convertir' 127... en localhost...

Bon bah c tout alors tout est normal...que ça marche pas...