l'option ls -C (colonnes) ne fonctionne pas partout...

Rollmops

Membre émérite
17 Juillet 2006
926
27
Bonjour à tous :)

J'aimerais avoir un avis sur le fonctionnement de mon Terminal.

En effet étant sur MacOs X, théoriquement l'option de la commande ls : ls -C (affichage en colonnes) est "par défaut" sur cet Os.

Sur mon Terminal, cela fonctionne à la racine (/) mais pas au niveau du Home
Et cela, même si je tape ls -C

Quelqu'un aurais-t-il une explication et un remède ?

Au niveau du Home : ça ne s'affiche pas en colonnes :

Last login: Sun Jun 3 14:11:25 on ttyp1
Welcome to Darwin!
m237:~ rollmops$ ls -C
02 Aquarella Brazil.wma
Adobe SVG 3.0 Installer Log
Antidote 2000 alias
Applications
Desktop
Documents
Encyclopaedia_Britannica_2007_Ultimate_Reference_Suite_InstallLog.log
Faxes
Hurz
Incomplete
Library
Movies
Music
Opera 7 Preferences.new
Pfurz
Pictures
Public
Shared
Sites
alias
com.apple.Safari.plist
com.apple.Safari.plist.saved
histo 7:07:05.txt
loc.txt
rhf_illustr25.jpg
tmp1.txt
usermarker_search_earth.mrk
m237:~ rollmops$

Au niveau de la racine, les colonnes s'affichent (il faut me croire sur parole mais les cases de saisie de texte du forum refusent (elles aussi) l'affichage en colonnes : imaginez-le : sur mon terminal cette partie là (à la racine) est bien affichée en colonnes)


m237:~ rollmops$ cd /
m237:/ rollmops$ ls -C
ATM?? Deluxe URL Manager Pro 2.6
Adaptec Toast F-4.1.2 Users
Agfa StudioScan Series Utilitaires BJ
Applications VM Storage
Applications (Mac OS 9) Volumes
Brother MFL-Pro Suite Volumes (Mac OS 9)
CD audio appli PAO
CD-Universalis 2.0 appli TXT
Default Folder automount
Default Folder F-3.0.9 ?? bin
Desktop cores
Desktop (Mac OS 9) dev
Desktop DB diable_06.gif
Desktop DF diable_06001.jpg
Desktop Folder diable_06001.pict
Dossier AliStel 2 diable_06002.jpg
Dossier ClarisWorks 5.0 diable_06003.jpg
Dossier HP LaserJet diable_06004.jpg
Dossier Norton AntiVirus dicos
Dossier Syste??me dicos alias
Dossier TopOrganizer etc
Dossier i.Minitel gene??alogie
Dossier techtool pro 3 iserror.log
Ex buro mach
FAXstf 6 mach.sym
Ghost 3.5 mach_kernel
Grand-Me??re disait V 2.2.0 ?? masterclips
Greg's Browser 2.7 mode emploi painter 4
Historiques d???installation polices autres
Informations de dernie??re minute private
Installer Log File sbin
Iomega Extras techtool str vol de10:02:06.rtf
Journal ma??j Office X 10.1.6 testcaract.dmg
LISTE MARIAGES tmp
LOGICIELS SON tmp\ajvssnse.exe
Library tmp\bxzybpeg.exe
Mon buro 30:12:03 tmp\dfdmnsol.exe
NAV??? 7.0 QuickScan tmp\ejujutny.exe
Network tmp\eogixrdt.exe
Pages Web tmp\hhybjtrn.exe
Palm tmp\hlopljhh.exe
Personal Backup X tmp\iggguifr.exe
Polices ATM Deluxe tmp\kmwairqa.exe
Previous Systems.localized tmp\mjdfvknk.exe
Rangement au de??marrage tmp\ormwgbsq.exe
Risperdal_tablets_F.pdf tmp\plhbzuor.exe
STUFFLT 7 tmp\plnkwggf.exe
SurferSerials tmp\pssdsedf.exe
System tmp\qsdryvuh.exe
TCP Infos tmp\qzbtloqg.exe
TheFindByContentFolder tmp\sngjseou.exe
TheVolumeSettingsFolder tmp\uyshcpfw.exe
TopCalculette Pro tmp\ylmrduty.exe
Trash tmp\zpldjrlk.exe
Tri-CATALOG 5.02 usr
Tri-CATALOG Images var
m237:/ rollmops$

Merci d'avance ;)
 

Eul Mulot

Membre émérite
12 Juin 2006
821
73
32
Belfort
Je viens d'essayer, sous la racine, que je fasse ls ou ls -C affichage ligne par ligne ....
Au niveau du home, ls et ls -C se comportent comme il faut par contre.
Dès que j'essaie dans un sous répertoire, ls -C se comporte comme un ls, c'est assez étrange.
 

tatouille

Vétéran
1 Juin 2004
5 174
494
Stanford CA
uname -a et format de votre systeme de fichiers please,
car je n'ai aucun problème opendarwin7 to 10.4.9 ,
un vieux radar correspond à vos dires pour Panther , enfin c'est un réglage user pas réellement un BUG
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 942
3 178
Et puis il faudrait être bien précis. L'affichage en colonne peut très bien marcher sans que vous vous en rendiez compte ...
En effet, si le Terminal utilisé n'est pas très large (la largeur standard par exemple) et que certains fichiers ont des noms trop longs, ls calcule qu'il ne peut utiliser qu'une seule colonne. C'est un simple problème d'arithmétique.

Je précise que chez moi, tout est OK (et j'ai une grande fenêtre de Terminal). [Mac OS X / PPC 10.4.9]
 

Rollmops

Membre émérite
17 Juillet 2006
926
27
Tu as raison Bompi :up: c'est bien un pb de longueur de nom de fichier car j'ai supprimé le fichier à nom très long :

"Encyclopaedia_Britannica_2007_Ultimate_Reference_S uite_InstallLog.log"

et du coup "ls -C" affiche bien en mode "colonnes" !

par contre, ce qui est curieux, c'est que si je replace ce fichier à nom long et que j'agrandis au maximum ma fenêtre de terminal : ça ne marche plus et pourtant le nom n'est pas assez long pour arriver jusqu'au bord droit de la fenêtre du terminal...donc pour le terminal il n'est "plus" trop long...

Donc quand tu écris : " j'ai une grande fenêtre de Terminal" : qu'entends-tu exactement par là ?

Aurais-tu un modèle "spécial" de terminal au format "cinémascope super 90 mm Todd-ao" importé à prix d'or du Japon où il est normalement réservé à une élite de hacker-samouraï de 40° dan ? :D