Mac OS X Server ignore les requêtes du second gateway

QMeuh

Membre junior
7 Août 2007
82
2
Vancouver, BC
kwint.in
Bonsoir,

Par défaut, Mac OS X Server 10.6 semble ignorer les requêtes externes qui passeraient par une passerelle autre que celle définie par défaut dans les paramètres réseau.
Existe-t-il un moyen d'y remédier?

Cordialement,
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 944
3 181
De quelles requêtes parles-tu, au juste (des requêtes, il y en de nombreuses sortes) ?
 

QMeuh

Membre junior
7 Août 2007
82
2
Vancouver, BC
kwint.in
Tout le trafic réseau?
Je redirige certains ports (par exemple 9090) du WAN de la passerelle #2 (10.0.1.254) sur le serveur en question (10.0.1.16). Aucune réponse du serveur sur aucun des ports redirigé, aucune mention de ces requêtes dans les logs.
Par contre, ces même règles sur la passerelle #1 (10.0.1.1) sont bien prises en compte par le serveur, qui répond sans aucun problème.
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 944
3 181
Là, il faudrait que tu sois plus spécifique, parce que je ne vois pas bien comment est configuré tout ça [deux passerelles sur un même réseau, il faut que quelqu'un se charge du routage].
 

QMeuh

Membre junior
7 Août 2007
82
2
Vancouver, BC
kwint.in
La passerelle 10.0.1.1 fait office de serveur DHCP et est attribuée comme passerelle par défaut aux ordinateurs qui se connectent au réseau.
Certains ordinateurs doivent par contre utiliser la connexion du FAI avec lequel j'obtiens une IP externe fixe. Cette deuxième passerelle a l'adresse 10.0.1.254 sur le réseau réseau, son serveur DHCP est désactivé, elle n'interfère donc en rien avec 10.0.1.1.
Il n'y donc pas de routage, juste un parc d'ordinateurs qui utilisent tous la passerelle principale, sauf quelques serveurs qui ont besoin d'une IP fixe.
En l'occurrence j'aimerais savoir s'il est possible pour un de ces serveurs d'utiliser la passerelle principale pour certaines applications, et accepter le trafic du l'autre passerelle pour d'autres (ce qu'il refuse apparemment).
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 944
3 181
Deux choses à vérifier :
- le pare-feu du serveur, pour voir s'il bloque le flux en provenance de ladite passerelle
- si le flux arrive bien (ce qui est loin d'être sûr)
 
A

Anonyme

Invité
Si je comprends bien :

a) Tu as un serveur dhcp qui est en 10.0.1.1
b) ce serveur dhcp fait office de passerelle par défaut
c) tu as une box d'un FAI qui a une adresse interne 10.0.1.254

d) tu as un serveur en 10.0.1.16
e) tu as configuré la box pour rediriger certains ports sur le serveur en 10.0.1.16

ton problème est que le serveur envoie la réponse à la gateway 10.0.1.1

Si c'est cela :
-> peux tu vérifier que le masque de sous réseau est le même dans la configuration dur serveur dhcp et dans la configuration de la box ?
-> peux tu préciser où se situe le serveur dns, si il est unique et si il s'agit d'un dns interne ?
 

QMeuh

Membre junior
7 Août 2007
82
2
Vancouver, BC
kwint.in
Deux choses à vérifier :
- le pare-feu du serveur, pour voir s'il bloque le flux en provenance de ladite passerelle
- si le flux arrive bien (ce qui est loin d'être sûr)

Il n'y a pas de par-feu levé sur ce serveur qui est (on s'en doute) un serveur de test...
Le passerelle est correctement configurée pour transférer le trafic du port 80 vers le serveur 10.0.1.16.

router.tiff


Aucune trace d'erreur dans les logs du routeur. Le serveur web ne fait pas mention d'une tentative d'accès. Les logs du serveur ne relèvent pas un accès via la passerelle ou depuis l'IP externe qui essaie d'accéder au serveur.
Je ne comprends rien :mouais: Je ferai un dessin si ça peut aider à la résolution du problème plus tard...

edit: que voilà > network.png
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 944
3 181
Je ne pense pas que ce soit un problème serveur mais un problème réseau. Tant que tu n'es pas sûr qu'un paquet provenant de la connexion câble arrive sur le serveur, c'est la piste à suivre.

Une fois certain que les paquets arrivent à destination tu pourras t'attaquer à la question de leur traitement par le serveur web.

---------- Post added at 14h17 ---------- Previous post was at 14h11 ----------

J'ajouterais qu'il serait intéressant de connaître les paramétrages réseaux des éléments clefs [adresse et passerelle par défaut].
 
A

Anonyme

Invité
Ca serait bien que tu reprennes ton schéma et que pour chaque équipement tu rajoutes son masque de sous réseau, son dns, sa gateway.

Si tout tes équipements sont en dhcp, je pense que le masque de sous-réseau, la passerelle, et le dns sont les mêmes et sont attribués par le serveur dhcp.

je serais tenté de dire que normalement il faudrait que tu rajoutes une route statique sur ta première passerelle pour dire que le flux internet est a rediriger sur le d-link, mais dans ce cas ton premier accès internet ne te sert a rien.

La si je comprends bien il faut que le mac mini :
- utilise l'airport express pour surfer sur internet
- utilise le d-link pour faire serveur web
- les autres équipements utilisent l'airport express pour surfer sur internet
 

Bigchief

Nouveau membre
19 Octobre 2009
6
0
Désolé mais ça ne peut pas marcher...

Les paquets arrivent avec une adresse externe (il n'y a pas de NAT en entrée) et ton serveur pense qu'il doit répondre aux adresse en dehors de son scope en passant par le 10.0.1.1. Donc la réponse part bien, mais arrive au destinataire depuis une autre ip que celle qu'il a appelé... bref il n'y comprend plus rien...

Il faudrait que tu définisse des routes sur ton serveur pour arriver à quelque chose. Par exemple si tu connais les adresses ip externes qui vont t'appeler il faut définir des routes pour dire que telle adresse est atteignable par le 10.0.1.254.

Si par contre n'importe quelle adresse externe est succeptible de t'appeler tu n'as pas le choix, il faut changer le gateway et faire passer tout le trafic internet par 10.0.1.254.
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 944
3 181
Je suis un peu têtu mais je pense plutôt que aucun paquet n'arrive au serveur [c'est du moins la première chose à vérifier et on peut craindre que ce soit le cas car les logs du serveur Web ne voient rien arriver]. La passerelle 10.0.1.254 semble ne rien faire transiter, quoi.

Si tu actives la translation d'adresse sur celle-ci et qu'elle parvient à envoyer un paquet vers le serveur, alors ce dernier lui répondra et elle renverra à l'envoyeur initial sans plus de souci.