10.13 High Sierra Macbook et nvram

jcezanna54

Membre actif
3 Septembre 2005
342
10
71
Bonjour,
Sur un macbook pro de 2011 avec 16 Go de RAM et le disque initial (500 Go à 5400 tpm)
Je viens de lire le post de Lecreateurlol du 15 Octobre 2020

J'ai le même problème et effectivement ma batterie semble malade et je vais la remplacer.
Par contre j'ai un problème avec la commande nvram.
Je sais que la carte graphique RADEON 6770H est HS puisque sur un boot normal depuis une clé USB avec un high sierra non patché, il y a blocage avec la progression sous la pomme au 2/3 ou 3/4.
j'ai réinstallée High Sierra qui est une version patchée. C'est la version qui rame (sic) sans doute pour cause de batterie

A l'origine je voulais refaire une fresh install de High Sierra.
Et je suis tombé sur le problème de nvram.
après avoir disabeulé le SIP avec
csrutil disable
j'ai essayé de mettre en oeuvre la solution décrite ici :
Bloc de code:
https://forums.macrumors.com/threads/force-2011-macbook-pro-8-2-with-failed-amd-gpu-to-always-use-intel-integrated-gpu-efi-variable-fix.2037591/

Aucun souci avec nvram boot-args="-v" qui est prise en compte.
Par contre
nvram fa4ce28d-b62f-4c99-9cc3-6815686e30f9:gpu-power-prefs=%01%00%00%00
n'a aucun effet, il n'y a que les 2 lignes avec le disble du SIP et le boot-args

Quelqu'un peut il m'aider à comprendre pourquoi la commande nvram du gpu-power... n'est pas prise en compte

Merci
 

jcezanna54

Membre actif
3 Septembre 2005
342
10
71
Bonjour

Alors que j’essayais de faire une fresh install sur un macbook pro de 2011 qui a un problème avec la carte RADEON 6770H,
j'ai essayé de lancé les commandes suivantes après avoir inhibé SIP :
Bloc de code:
nvram fa4ce28d-b62f-4c99-9cc3-6815686e30f9:gpu-power-prefs=%01%00%00%00
nvram boot-args="-v"
La deuxième commande a bien été prise en compte lorsque je lance
nvram -p
mais la première n'a aucun effet.


Si quelqu'un peut me fournir une explication ou une idée de recherche ...
Merci