MacBook Pro MacBook Pro 2017 (14.1), nouveau SSD et déchargement en veille

mmmgl

Membre enregistré
1 Septembre 2021
3
0
24
Hello,

Je sais que le sujet à déjà été abordé mais je n'ai encore trouvé aucune solution, voilà un résumé de la situation.

  • Je possède un Macbook Pro A1708, duquel j'ai changé le SSD avec un Sabrent Rocket Nano 1To et cet adaptateur.
  • Depuis, déchargement pendant la veille, jusqu'a 20-30% de batterie la nuit.
  • J'ai essayé plein de choses:
  1. réglages pmset
  2. Désactivation de Localiser mon mac
  3. Fouillage des logs pmset et assertions
  4. Installation des .kext NVMEFix et SSDPmEnabler qui sont censé corriger les problèmes de veille sur les SSD NVME tiers, rien n'y fait.
  5. Reset NVRAM, PRAM et SMC.

Voilà mes réglages pmset :

System-wide power settings:
Currently in use:
lidwake 1
autopoweroff 1
standbydelayhigh 300
autopoweroffdelay 259200
standbydelaylow 300
standby 1
proximitywake 0
ttyskeepawake 0
hibernatemode 25
gpuswitch 2
powernap 0
hibernatefile /var/vm/sleepimage
highstandbythreshold 50
displaysleep 3
sleep 5
acwake 0
halfdim 1
tcpkeepalive 0
disksleep 3

et mon log de cette nuit :

Time stamp Domain Message Duration Delay
========== ====== ======= ======== =====
UUID: 06C420CD-53CB-46C8-9F8C-D12CB1D25FAD
2021-08-31 22:13:36 +0200 Sleep Entering Sleep state due to 'Clamshell Sleep':TCPKeepAlive=disabled Using Batt (Charge:77%) 45778 secs
2021-08-31 22:13:36 +0200 Assertions PID 197(apsd) Released InteractivePushServiceTask "com.apple.apsd-keepalive-push.apple.com" 00:00:11 id:0x0x1200008375 [System: DeclUser IntPrevDisp kDisp]
2021-08-31 22:13:39 +0200 Wake Requests [*process=powerd request=UserWake deltaSecs=447149 wakeAt=2021-09-06 02:26:08 info="com.apple.alarm.user-visible-Weekly Usage Report,411"]
2021-08-31 22:13:39 +0200 PM Client Acks Delays to Sleep notifications: [com.apple.apsd is slow(3044 ms)]
2021-09-01 10:56:33 +0200 Notification Display is turned on
2021-09-01 10:56:33 +0200 Kernel Client Acks Delays to Sleep notifications: [AppleIntelFramebuffer driver is slow(msg: SetState to 1)(1239 ms)] [RP09 driver is slow(msg: SetState to 1)(1198 ms)] [powerd is slow(3050 ms)] [UPSB driver is slow(msg: SetState to 2)(950 ms)] [AppleHPMIECS driver is slow(msg: WillChangeState to 2)(1095 ms)]
2021-09-01 10:56:33 +0200 Assertions Kernel Idle sleep preventers: IODisplayWrangler
2021-09-01 10:56:33 +0200 Assertions PID 307(mDNSResponder) Created MaintenanceWake "mDNSResponder:maintenance" 00:00:00 id:0x0xd00008382 [System: DeclUser IntPrevDisp kDisp]
2021-09-01 10:56:33 +0200 Assertions PID 307(mDNSResponder) Released MaintenanceWake "mDNSResponder:maintenance" 00:00:00 id:0x0xd00008382 [System: DeclUser IntPrevDisp kDisp]
2021-09-01 10:56:34 +0200 Wake Wake from Standby [CDNVA] : due to EC.LidOpen/UserActivity Assertion Using BATT (Charge:57%) 1708 secs
2021-09-01 10:56:34 +0200 HibernateStats hibmode=25 standbydelaylow=300 standbydelayhigh=300 rd=324 ms
2021-09-01 10:56:34 +0200 WakeTime WakeTime: 4.249 sec
2021-09-01 10:56:34 +0200 Kernel Client Acks Delays to Wake notifications: [UPSB driver is slow(msg: SetState to 2)(535 ms)] [HDEF driver is slow(msg: SetState to 2)(543 ms)] [IGPU driver is slow(msg: SetState to 2)(545 ms)] [AppleIntelFramebuffer driver is slow(msg: SetState to 2)(370 ms)] [AppleHDADriver driver is slow(msg: SetState to 1)(343 ms)] [RP09 driver is slow(msg: SetState to 1)(1202 ms)]
2021-09-01 10:56:34 +0200 Notification Next immediate inactivity window start:'2021-09-01 10:45:00 +0200' end:'2021-09-01 12:15:00 +0200'
2021-09-01 10:56:41 +0200 Assertions PID 233(loginwindow) Created UserIsActive "Loginwindow User Activity" 00:00:00 id:0x0x9000083ae [System: DeclUser IntPrevDisp kDisp]
2021-09-01 10:56:41 +0200 Assertions PID 233(loginwindow) Released UserIsActive "Loginwindow User Activity" 00:00:00 id:0x0x9000083ae [System: DeclUser IntPrevDisp kDisp]
[...]

Total Sleep/Wakes since boot at 2021-08-31 22:11:52 +0200 :2

2021-09-01 12:23:10 +0200 : Showing all currently held IOKit power assertions
Assertion status system-wide:
BackgroundTask 0
ApplePushServiceTask 0
UserIsActive 1
PreventUserIdleDisplaySleep 0
PreventSystemSleep 0
ExternalMedia 0
PreventUserIdleSystemSleep 0
NetworkClientActive 0
Listed by owning process:
pid 222(hidd): [0x0000074500098530] 00:00:00 UserIsActive named: "com.apple.iohideventsystem.queue.tickle serviceID:1000007c3 name:NULL product:Apple Internal Keyb eventType:11"
Timeout will fire in 179 secs Action=TimeoutActionRelease
No kernel assertions.
Idle sleep preventers: IODisplayWrangler

Comme indiqué, veille à 77%, réveil à 57%.

Si quelqu'un a été confronté au problème et trouvé une solution, je suis preneur !
 

mmmgl

Membre enregistré
1 Septembre 2021
3
0
24
Petite update :

J'ai downgrade sous Mojave (question de compatibilité je ne pouvais pas passer à Big Sur), en clean install. Même avec l'OS tout neuf sans rien installer, perte de 25%.

J'ai re-migré mes données, réinstallé les .kext NVMEFix et SSDPmEnabler, et re réglé mon pmset : perte de 8% cette nuit.

C'est pas fou, mais c'est mieux !
 

ericse

Membre expert
Club MacG
30 Avril 2019
5 266
908
Bonjour,
Questions peut être idiote, mais as-tu essayé de remettre le SSD d'origine pour vérifier si c'est juste le nouveau (ou l'adaptateur) qui est en cause ? Et as-tu essayé de faire les changements (de kext et pmset) un par un pour vérifier s'ils sont tous utiles ?