MacBook Pro macbook pro briqué suite à changement de clavier

nommémentnommé

Membre junior
17 Décembre 2017
29
1
40
Bonjour à tous,
j'ai bêtement briqué un macbook pro mid 2012 suite à changement de clavier (QWERTY espagnol vers AZERTY)...
Le pire c'est qu'au début la réparation a fonctionné, que j'ai oublié de brancher le magsafe sur le secteur, et qu'avant de le rebrancher j'ai cru à un problème plus important donc j'ai tout redébranché et rebranché.

Symptômes:
• le macbook démarre le disque puis l'éteint rapidement si branché uniquement sur batterie, ou le laisse tourner ad vitam sans que rien de plus ne se produise si branché sur le magsafe.
• les voyants magsafe et indicateurs de charge de batterie fonctionnent.
• aucun bip n'est entendu lors du démarrage.

Merci d'avance à ceux qui vondront bien m'orienter pour la réparation, à savoir si la carte mère est HS ou bien non. Je connais bien un centre de maintenance Apple, j'aimerais juste savoir si, au cas échéant, la réparation est possible sans les déranger.
 
Dernière édition:

EricM

Membre émérite
28 Juillet 2004
619
23
52
Grimaud Var France
Bonjour,

Bêtement pour commencer. As-tu réinitialisé la SMC qui gère le contrôleur de gestion ?
https://support.apple.com/fr-fr/HT201295

Ou as-tu simplement mal remonté le clavier en débranchant le connecteur de la batterie ?
 

nommémentnommé

Membre junior
17 Décembre 2017
29
1
40
Merci EricM, oui, j'ai essayé (maj/ctrl/option + démarrer pendant 10s), pas de changement das le comportement de la machine
 

EricM

Membre émérite
28 Juillet 2004
619
23
52
Grimaud Var France
Et en démarrant avec les touches Commande + R, immédiatement après avoir appuyé sur le bouton d’alimentation pour démarrer le Mac ?
 

EricM

Membre émérite
28 Juillet 2004
619
23
52
Grimaud Var France
Tu as un autre disque dur où tu pourrais démarrer dessus ?

Il fonctionnait bien avant le changement de clavier ?
 

nommémentnommé

Membre junior
17 Décembre 2017
29
1
40
oui et, même après montage du clavier et du reste (j'ai oublié de dire que je montais aussi un ssd et de la ram),
c'est en voyant le magsafe éteint alors qu'il était débranché, (stupide que je suis)
que j'ai tout vérifié et par la suite ça ne fonctionne plus.
J'ai le ssd, mais il n'y a rien d'installé dessus... Il est en apfs
Sinon, j'ai un usb bootable avec macOS High Sierra
 

EricM

Membre émérite
28 Juillet 2004
619
23
52
Grimaud Var France
Un conseil, reprends tout à zéro. Depuis le départ. Commence par vérifier l'ensemble des câblages et les nappes en démontant ton Macbook. Ton clavier est quand même détecté vu que tu as pu réaliser les commandes au démarrage.
 

nommémentnommé

Membre junior
17 Décembre 2017
29
1
40
Actuellement il est démonté, j'ai vérifié les cablages plusieurs fois, seule chose je tente de booter sans le branchement backlight car j'ai un peu peur de l'abimer tant que je fais des tests. Mais je ne pense pas que ce soit un problème ?
Question : est-ce que le fait que les leds de charge batterie fonctionnent indique que la carte mère fonctionne ? Je n'en suis pas sûr du tout, mais je demande au cas où.
 
Dernière édition:

EricM

Membre émérite
28 Juillet 2004
619
23
52
Grimaud Var France
C'est peut-être ça le problème, le rétro-éclairage. Si tu as débranché le câble il faudrait le remettre pour voir.
 

nommémentnommé

Membre junior
17 Décembre 2017
29
1
40
merci encore, celui-ci pose en fait problème,
j'essaie de l'insérer mais il ne va pas plus loin qu'un demi millimètre dans son logement du coup, il se débranche systématiquement,
le souci, c'est qu'il est très fin et que la méthode qu'on m'a donné au centre Apple pour la nappe clavier (de coller un adhésif pour l'insérer) ne fonctionne que peu avec celui-ci.
 

EricM

Membre émérite
28 Juillet 2004
619
23
52
Grimaud Var France
C'est le câble qui ne s'insère pas dans son logement ou le connecteur qui ne se branche pas ?
 

nommémentnommé

Membre junior
17 Décembre 2017
29
1
40
plutôt le cable qui refuse de s'insérer... c'est une petite nappe minuscule qui va dans un logement avec une minuscule barre qui se rabat pour le bloquer.
 

EricM

Membre émérite
28 Juillet 2004
619
23
52
Grimaud Var France
La nappe tu peux la fixer ? Si oui, bloque le câble dans son logement en l'insérant avec une petite spatule en plastique. Ou alors avec du scotch pur le maintenir.
 

nommémentnommé

Membre junior
17 Décembre 2017
29
1
40
Au fait en termes de branchement backlight, je parle de celui du clavier.
Du coup je ne pense pas que ce soit la cause de l'extinction du HD. Ce serait quand même bizarre de faire dépendre un démarrage carte mère du rétro-éclairage du clavier.
 

nommémentnommé

Membre junior
17 Décembre 2017
29
1
40
Un petit coup de pouce de plus, please ?
J'ai lu quelque part, qu'avant de paniquer 'complet' et de confier la machine à de vrais experts, je devrais essayer de vider la batterie complètement, ce que je fais actuellement, en ayant branché sur magsafe puis démarré puis débranché le magsafe, seule méthode actuelle pour laisser le disque tourner et pomper du courant.
 

EricM

Membre émérite
28 Juillet 2004
619
23
52
Grimaud Var France
Peux-tu brancher ton Macbook sur un écran externe ? Pour voir si c'est un problème d'écran.
 

Ma Dalton

Membre d’élite
4 Avril 2015
1 284
269
64
nappe de rétro-éclairage clavier :
j'essaie de l'insérer mais il ne va pas plus loin qu'un demi millimètre dans son logement du coup, il se débranche systématiquement,
C'est un problème classique quand on remplace le clavier par un pas d'origine (pas Apple).

La nappe de rétro-éclairage est trop épaisse.

Si tu as un pied à coulisse, compare l'épaisseur de la nappe de l'ancien et du nouveau clavier.

S'il y a une grosse différence, utilise un papier abrasif très fin (au pire, une lime à ongle) pour réduire l'épaisseur de la nappe, du côté opposé au contacts dorés, évidemment.
La nappe rentrera sans problème dans le connecteur.

Ne pas avoir branché cette nappe n'explique pas les autres problèmes que tu as : l'ordi peut fonctionner normalement avec la nappe non branchée.
 
Dernière édition:

nommémentnommé

Membre junior
17 Décembre 2017
29
1
40
merci pour vos conseils à tous, surtout celui de Ma', qui me parait très judicieux.
pour les autres problèmes, les principaux en fait, je vais me diriger soit vers une réparation CM, (ça peut être la puce du SMC qui a grillé d'après un technicien Apple que je connais) soit vers un changement de CM, je n'aurais qu'à m'en mordre les doigts d'avoir paniqué et trop vite procédé au redémontage.
 

nommémentnommé

Membre junior
17 Décembre 2017
29
1
40
Finalement après avoir vu un technicien Apple, j'ai appris que la carte mère était oxydée et que ça ne venait donc pas de moi et mes démontages successifs, la personne qui me l'a vendu a juste eu beaucoup de chance qu'il fonctionne jusqu'à la réception, mais je vais essayer de négocier avec celle-ci le paiement 50-50 de la réparation... La CM va être envoyée en Chine pour refaire tout le système d'alimentation.