MacBook Pro MacBook Pro qui ne boot sur aucune partition

BrayanOfficiel

Membre junior
6 Janvier 2020
30
3
Bonjour, Bonsoir;

J'ai en ma possession un MBP début 2013 15" avec un i7-3740QM, 512Gb de SSD ainsi que 16Gb de RAM.
Le problème est qu'il refuse de booter (pas de démarrer) quelque soit le périphérique (SSD vide pour info).
Le RECOVERY-MODE se bloquait vers les 45% puis s'éteignait (ALT+R ou CMD+ALT+MAJ+R) et le SINGLE-USER-MODE fonctionnait, j'ai tout d'abord pensé à un problème de surchauffe dû au fait qu'il s'éteignait durant le boot vers RECOVERY-MODE.
J'ai donc changé le radiateur qui était légèrement déformé, j'ai tenté de booter mais sans succès (par contre il ne s'éteint plus). Le RECOVERY de Windows m'a permis d'accéder aux partitions (que j'ai toutes supprimé afin de réinstaller de 0), maintenant, ni le RECOVERY-MODE, ni le SINGLE-USER-MODE ne fonctionnent, le diagnostic Apple fonctionnait (plus maintenant) mais bootait avec une erreur EFI.

Seulement le REVOVERY par internet fonctionne mais après le téléchargement, il se bloque à 45% lors du boot (ou l'icone qui tourne se bloque lors du téléchargement avec CMD+ALT+MAJ+R vu que le mac est venu d'usine avec 10.8.2).

PS : SIP Activé;
NVRAM/PRAM/SMC reformaté;
J'ai pu voir avant la suppression des partitions sur le SINGLE-USER-MODE que le disque était en lecture seule mais impossible de le remettre en lecture-écriture dû au SIP activé.
Je vis dans un pays sans Apple Store mais avec des "Stores" agrées avec des centres de maintenance tous ouverts en cette période.

Voilà, je m'adresse à vous aujourd'hui car je suis désespéré et je ne sais plus où me tourner.
Merci d'avance ;).
 
Dernière édition:

radioman

Membre émérite
23 Octobre 2007
501
102
Limoges
Wahooooo … ça fait quantité de problèmes/ manipulations pour trouver un début de piste de recherche …

la seule idée qui me vient:
si tu ouvres la machine et déconnecte le disque dur/SSD, lorsque tu démarres est-ce que ça va jusque au dossier avec point d'interrogation qui clignote ?
si oui, ça veut dire que > 1: la machine physiquement démarre et 2 >> qu'elle ne trouve pas d'OS pour lancer une session
ce qui serait un bon début: disque HS
si non, y'a un problème hardware, carte mère …
 
Dernière édition:

BrayanOfficiel

Membre junior
6 Janvier 2020
30
3
Wahooooo … ça fait quantité de problèmes/ manipulations pour trouver un début de piste de recherche …

la seule idée qui me vient:
si tu ouvres la machine et déconnecte le disque dur/SSD, lorsque tu démarres est-ce que ça va jusque au dossier avec point d'interrogation qui clignote ?
si oui, ça veut dire que > 1: la machine physiquement démarre et 2 >> qu'elle ne trouve pas d'OS pour démarrer
ce qui serait un bon début: disque HS
si non, y'a un problème carte mère …
Merci beaucoup pour cette réponse TRES RAPIDE.
Alors effectivement j'ai premièrement pensé à un BIOS corrompu mais lorsque j'ai déconnecté le SSD, le mac affichait un dossier avec un point d'interrogation.

EDIT : J'ai accès à un MacBook Pro 2019 (quasi) en permanence s'il y a besoin de manips avec un autre mac.
 

radioman

Membre émérite
23 Octobre 2007
501
102
Limoges
lorsque j'ai déconnecté le SSD, le mac affichait un dossier avec un point d'interrogation.
bon début: la machine fonctionne.
donc maintenant il faut arriver à mettre un OS sur ce SSD ou sur un autre …

il faudrait acheter un raccord USB/SATA pour connecter ton SSD douteux au MBP 2019 dispo pour voir si tu peux faire une install sur ce disque à partir de cet autre Mac …
 
Dernière édition:

BrayanOfficiel

Membre junior
6 Janvier 2020
30
3
bon début: la machine fonctionne.
donc maintenant il faut arriver à mettre un OS sur ce SSD ou sur un autre …
J'ai un SSD externe occupé par des fichiers importants et un vieux HDD libre.
je peux essayer d'installer dessus Mountain Lion depuis l'autre Mac, mais je présume que ça prendra une éternité étant donné que c'est du USB 2.0.
Merci pour votre réponse, je vais commencer le processus et j'espère que ce sera prêt d'ici demain. ;)
 

radioman

Membre émérite
23 Octobre 2007
501
102
Limoges
Dernière édition:

BrayanOfficiel

Membre junior
6 Janvier 2020
30
3
Arghh là ça va être compliqué, ça veut dire boitier externe M2 …
juste pour faire une bidouille, les tarifs sont pas les mêmes !!!!!

Edit: quoique … je viens de découvrir qu'il existait des doubles dock M2 : https://fr.aliexpress.com/item/1005...84847601-00097-UneMJZVf&device=c&gclsrc=aw.ds
Le petit problème est que la livraison gratuite par AliExpress peut prendre jusqu’à 57 jours (au minimum 40), si je suis pressé je peux prendre la livraison DHL à 140€ mais à ce prix je préfère acheter un nouvel SSD...


C'est cmd R le mode Recovery, pas alt R.

Et démarrer sur un disque externe bootable (touche alt appuyée au démarrage jusqu'à apparition du disque externe) ?
oui CMD+R excuse moi j’ai fait une faute de frappe,
C’est ce que je disais à @radioman , je vais tenter demain d’installer macOS sur un disque externe en espérant que cela fonctionne...

Et si ça ne marche pas, c’est que ça vient très probablement du hardware.

Merci en tout cas de vos réponses.
:)
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
50 302
9 411
Nancy___
Le petit problème est que la livraison gratuite par AliExpress peut prendre jusqu’à 57 jours (au minimum 40), si je suis pressé je peux prendre la livraison DHL à 140€ mais à ce prix je préfère acheter un nouvel SSD...
J'imagine qu'il n'y a pas qu'Ali qui livre ce type de boitier ? OWC pourrait le faire ? MacWay aussi, as tu regardé ?
 

radioman

Membre émérite
23 Octobre 2007
501
102
Limoges
J'imagine qu'il n'y a pas qu'Ali qui livre ce type de boitier ? OWC pourrait le faire ? MacWay aussi, as tu regardé ?
en fait en cherchant bêtement Dock M2 j'ai trouvé ça:


je pensais (à tord) que ça coutait un bras …
 
Dernière édition:
  • J’aime
Réactions: Sly54

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
50 302
9 411
Nancy___

BrayanOfficiel

Membre junior
6 Janvier 2020
30
3
Bonsoir à vous,
désolé de cette réponse tardive,

J'imagine qu'il n'y a pas qu'Ali qui livre ce type de boitier ? OWC pourrait le faire ? MacWay aussi, as tu regardé ?

Je ne pense pas qu'ils aient la possibilité de livrer où je suis, les frontières sont fermés dans mon pays (COVID) , seulement la livraison de documents par DHL est acceptée à passer.

en fait en cherchant bêtement Dock M2 j'ai trouvé ça:


je pensais (à tord) que ça coutait un bras …

J'ai pu en trouver pour l'équivalent de 15€ là où je me trouve;
J'essayerai de m'en procurer un.
EDIT : Les M.2 des MacBooks sont propriétaire Apple donc ce n'est pas le même format qu'un M.2 habituel.

------------------------------------------------
j'ai de nouvelles informations :
  • Le MacBook ne boot pas sur un disque externe avec OS X Mountain Lion dessus...
  • J'ai réussi à installer Windows 10 dessus, pas de problèmes sans drivers mais moitié du hardware qui n'est pas détecté.
    • EDIT : Drivers BootCamp que j'ai sauvegardé sur une clé USB.
  • Après installation des drivers, problèmes d'affichages avec lignes et points verts au passage du curseur, couleurs 8bit et carte graphique NVIDIA diagnostiquée avec des problèmes : "Windows à détecté des erreurs et à arrêté ce périphérique" (pas exactement affiché à l'écran comme ca).
  • Tout fonctionne sans problèmes tant que ce n'est pas en résolution native, c-à-d 2880x1800.
    • EDIT : Il ne boot qu'en safe-mode sur windows maintenant.
Voilà pour les nouveautés, si je ne suis pas pris par le travail, je pourrais passer le Mardi chez un vendeur de composants spécialisé dans la maintenance de Macs.

Merci d'avance pour votre aide.
;)
 

BrayanOfficiel

Membre junior
6 Janvier 2020
30
3
EDIT : Les lignes vertes sont visibles en 2880x1800 avec le core graphique interne au processeur, la carte graphique NVIDIA GEFORCE GT650M dédiée ne fonctionne plus et fait crash windows en plus de tout le pc si elle est activée, j'ai dû donc aller en safe-mode et la désactiver dans le gestionnaire de périphériques, maintenant le Mac boot sur windows sans problèmes et sans safe-mode, mais sans le GPU dédié.
Je pense donc à un GPU mort
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
50 302
9 411
Nancy___
Il y avait un petit utilitaire, https://github.com/steveschow/gfxCardStatus/releases, permettant de désactiver la carte graphique et de ne garder que le chipset graphique Intel activé. Si jamais tu arrives à l'installer (?) tu pourrais tenter de désactiver la CG pour voir si tu peux utiliser ton Mac juste avec le chipset Intel. Ca validerait ton hypothèse.
 

BrayanOfficiel

Membre junior
6 Janvier 2020
30
3
Il y avait un petit utilitaire, https://github.com/steveschow/gfxCardStatus/releases, permettant de désactiver la carte graphique et de ne garder que le chipset graphique Intel activé. Si jamais tu arrives à l'installer (?) tu pourrais tenter de désactiver la CG pour voir si tu peux utiliser ton Mac juste avec le chipset Intel. Ca validerait ton hypothèse.
Je connais ce petit programme mais il est disponible uniquement sur OS X et macOS.
J’ai réussi à désactiver la CG sur Windows manuellement et le Mac fonctionne très bien (sur Windows), mais lorsque je l’active, il crash et reboot.
 
Dernière édition:

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
50 302
9 411
Nancy___
J’ai réussi à désactiver la CG sur Windows manuellement et le Mac fonctionne très bien (sur Windows), mais lorsque je l’active, il crash et reboot.
Et arriverais tu à te préparer un disque externe (Mac OS) de démarrage avec gfxCardStatus activé ? Pour vérifier également sous MacOS que la désactivation de la CG te permet d'utiliser normalement ton Mac ?
 
  • J’aime
Réactions: BrayanOfficiel

BrayanOfficiel

Membre junior
6 Janvier 2020
30
3
Et arriverais tu à te préparer un disque externe (Mac OS) de démarrage avec gfxCardStatus activé ? Pour vérifier également sous MacOS que la désactivation de la CG te permet d'utiliser normalement ton Mac ?
J’essaierai ce soir et je vous tiens au courant,
Merci ;)

721D3345-4FEC-4F9F-ABFC-5FFDBB083511.jpeg
DC5D5610-1D1E-43FE-AB36-4C99B3F6C1F1.jpeg
 

BrayanOfficiel

Membre junior
6 Janvier 2020
30
3
Bonsoir, je confirme que c'était bien un GPU mort,
le mac à réussi à booter en Recovery-Mode (de OS X 10.8).

les commandes dans le single user mode pour désactiver le GPU ne rentraient pas, il a fallu changer la destination de reception de commandes vers :
Bash:
/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin
avec la commande
Bash:
export PATH="/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin"
Impossible de monter le SSD en lecture/écriture car problème I/O mais cela n'a pas grandement impacté la résolution du problème.

Ainsi j'ai entré la commande
Bash:
sudo nvram fa4ce28d-b62f-4c99-9cc3-6815686e30f9:gpu-power-prefs=%01%00%00%00
(sans le sudo car j'étais déjà en root (avec le '#'))

J'ai rebooté avec
Bash:
reboot
et j'ai téléchargé le recovery depuis les serveurs Apple (CMD+ALT+MAJ+R).
J'ai formaté la partition en macOS journalisé et rebooté sur la clé pour enfin installer OS X.

J'attends la fin de l'installation pour supprimer les fichiers .kext et .bundle des drivers NVIDIA.

C'est une manipulation à faire à chaque mise à jour car le NVRAM se réinitialise.

Cela confirmait bien nos doutes sur le GPU mort.

Je vous tiens au courant demain des nouveautés...

Merci à @Sly54 de m'avoir donné l'idée de désactiver le GPU.

EDIT: Après installation, il faut impérativement booter en Single-User-Mode et retaper la commande
Bash:
sudo nvram fa4ce28d-b62f-4c99-9cc3-6815686e30f9:gpu-power-prefs=%01%00%00%00
(encore), puis booter en recovery et supprimer les drivers NVIDIA ou AMD


;)
 

Fichiers joints

  • 699A2626-9F55-4879-B1A7-ECD1C1CB190D.jpeg
    699A2626-9F55-4879-B1A7-ECD1C1CB190D.jpeg
    92,5 KB · Affichages: 10
  • 9EF621B6-71BD-4DAE-94C9-431F111B863B.jpeg
    9EF621B6-71BD-4DAE-94C9-431F111B863B.jpeg
    84,4 KB · Affichages: 10
Dernière édition:
  • J’aime
Réactions: Sly54