Macs Fan Control Maj Sécurité 2017-02

EricM

Membre actif
28 Juillet 2004
698
29
53
Grimaud Var France
Bonjour,

Un souci avec l'application Macs Fan Control qui est installée depuis des mois sur mon Macbook. Depuis la mise à jour de sécurité 2017-002, quand je redémarre, il m'est demandé à l'ouverture de MFC mon mot de passe pour avoir les droits privilégiés, chose que je m'empresse de faire. Réponse de l'Application, contrôle de ventilateurs non disponible. Quand je veux changer un des paramètres de contrôle, je dois rentrer mon mot de passe, mais cela ne donne rien, l'action n'est pas inefficace, le paramètre n'est pas pris en compte, voir les captures d'écran.
Cela ne se produit que lorsque je redémarre et pas en relançant ma session.
Pour ne plus avoir ces alertes et utiliser correctement Macs fan Control, je dois quitter l'application, la relancer et j'ai alors accès aux réglages de l'application.
J'ai supprimé et réinstallé l'application à plusieurs reprises, sans succès. J'ai aussi créer un script Automator pour lancer l'Application à chaque démarrage, pareil. J'ai même démarré sans les extensions, idem. J'ai désactivé SIP.

Merci.

capture-decran-2017-12-10-a-13-49-07-jpg.118307


capture-decran-2017-12-10-a-13-49-19-jpg.118309


04f1c14e-76c1-4530-a2d1-a67173517c93
Capture d’écran 2017-12-13 à 04.21.09.jpg
 

Fichiers joints

  • upload_2017-12-13_4-29-28.png
    upload_2017-12-13_4-29-28.png
    276,3 KB · Affichages: 189

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
38 410
5 511
Il faut aller dans Préférences Système/Utilisateurs et groupes/Ouverture et décocher Macs Fan Control dans la liste de droite pour qu'il soit actif à chaque démarrage. ;)
 

EricM

Membre actif
28 Juillet 2004
698
29
53
Grimaud Var France
Il faut aller dans Préférences Système/Utilisateurs et groupes/Ouverture et décocher Macs Fan Control dans la liste de droite pour qu'il soit actif à chaque démarrage. ;)

C'est pareil , inefficace. J'avais déjà coché décoché, enlevé ou remis l'Application dans Ouverture et toujours la demande de mot de passe. J'ai supprimé l'ensemble des fichiers de MFC. Réinstallé MFC à plusieurs reprises. sans effet.

Les actions dans dans MFC sont sans résultat.

Dernière image. Quand je clique sur "Contrôle" pour changer le mode de gestion des ventilateurs soit Automatique ou Basé sur... la fenêtre de demande de mot de passe s'affiche. Le fait de saisir le mot de passe est sans effet. Les réglages ne s'activent pas, la roue multicolore tourne et s'arrête. Même en remettant le mot de passe, c'est toujours la même chose.

La seule solution c'est de quitter MFC et après les réglages sont effectifs.

En fermant et ouvrant la session le phénomène ne se produit.
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
38 410
5 511
Par défaut, MFC demande bien le mot de passe de l'administrateur pour l'installation et c'est normal.

Dans les préférences de MFC, tu as bien coché ceci...

Capture-000.jpg
 

EricM

Membre actif
28 Juillet 2004
698
29
53
Grimaud Var France
Désolé pour la réponse tardive, je vis à l'autre bout de la planète :)
Oui tout est coché, cela a été le cas au premier lancement et ainsi de suite.
Quand je quitte et relance ma session, MFC se lance normalement sans demande de mot de passe.
Le phénomène se produit quand je redémarre. La séquence de demande de mot passe s'effectue comme indiqué par les captures d'écran. Ce qui est étrange, c'est qu'après avoir indiqué le mot de passe, les actions sur les préférences ne sont pas prises en compte. Le changement de réglages des ventilateurs n'est pas effectif, la demande de mot de passe se fait comme sur la dernière capture.
J'ai même créé un script Automator qui ouvre MFC. Dans ma session, je quitte MFC, je lance le script MFC s'ouvre et là pareil, demande de mot de passe en boucle sans que l'application soit utilisable. Je dois quitter MFC le relancer et là tout est fonctionnel.
En résumé au démarrage MFC me demande toujours le mot de passe mais n'est pas fonctionnel, les réglages ne s'effectuent pas.
En quittant la session avec MFC actif, le peux utiliser correctement MFC.
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
38 410
5 511
A mon avis, tu devrais faire une désinstallation de MFC, puis chercher/effacer toutes les occurrences de MFC en utilisant EasyFind (gratuit) qui est bien plus performant que le Finder et réinstaller MFC.
 

EricM

Membre actif
28 Juillet 2004
698
29
53
Grimaud Var France
Déjà fait ;-)
Cela ne change rien.
Je sèche là.

Merci
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
38 410
5 511
Dans une session Invité c'est le même problème ?
 

EricM

Membre actif
28 Juillet 2004
698
29
53
Grimaud Var France
Bonsoir Jeanjd63

Oui le SIP est activé. J’ai essayé avec ou sans c’est pareil.
 
D

Deleted member 1099514

Invité
Et si tu recherches dans les logs Applications/Utilitaires/Console et là tu tapes Fan dans la zone de recherche, puis tu lances Fan control pour voir ce qu'il te sort.
 

EricM

Membre actif
28 Juillet 2004
698
29
53
Grimaud Var France
Et si tu recherches dans les logs Applications/Utilitaires/Console et là tu tapes Fan dans la zone de recherche, puis tu lances Fan control pour voir ce qu'il te sort.

C’est pas une mauvaise idée. Je le ferai dès mon retour au domicile. Je te tiens au courant. Encore merci de ta patience et je n’oublie pas Lock aussi
 

EricM

Membre actif
28 Juillet 2004
698
29
53
Grimaud Var France
Bonjour Jean.
Voici le Log. Pour faire apparaître le dysfonctionnement, j'ai redémarré mon Macbook, lancé MFC et essayé de changer les réglages. Sans succès. Toujours la demande mot de passe.

Bloc de code:
par défaut    05:48:18.138939 -1000    kernel    [MacsFanControl pid:507 mux-aware] starting, non-mux-aware app count 0, switch-state 0 IG FBs 1 EG FBs 0:0 power-state 6 3D idle HDA idle
par défaut  
05:48:31.290304 -1000    authd    Succeeded authorizing right 'system.privilege.admin' by client '/Applications/Macs Fan Control.app' [507] for authorization created by '/Applications/Macs Fan Control.app' [507] (13,0)
par défaut  
05:48:31.337312 -1000    authd    Succeeded authorizing right 'system.privilege.admin' by client '/usr/libexec/security_authtrampoline' [598] for authorization created by '/Applications/Macs Fan Control.app' [507] (3,0)
par défaut  
05:48:31.382589 -1000    authd    Succeeded authorizing right 'system.privilege.admin' by client '/usr/libexec/security_authtrampoline' [599] for authorization created by '/Applications/Macs Fan Control.app' [507] (3,0)
par défaut  
05:48:35.105821 -1000    MacsFanControl    wasLaunchedAsLoginItem: TRUE
par défaut  
05:48:51.041537 -1000    authd    Succeeded authorizing right 'system.privilege.admin' by client '/Applications/Macs Fan Control.app' [507] for authorization created by '/Applications/Macs Fan Control.app' [507] (13,0)
par défaut  
05:48:51.102500 -1000    authd    Succeeded authorizing right 'system.privilege.admin' by client '/usr/libexec/security_authtrampoline' [669] for authorization created by '/Applications/Macs Fan Control.app' [507] (3,0)
par défaut  
05:48:51.129327 -1000    authd    Succeeded authorizing right 'system.privilege.admin' by client '/usr/libexec/security_authtrampoline' [671] for authorization created by '/Applications/Macs Fan Control.app' [507] (3,0)
par défaut  
05:48:56.917426 -1000    authd    Succeeded authorizing right 'system.privilege.admin' by client '/Applications/Macs Fan Control.app' [507] for authorization created by '/Applications/Macs Fan Control.app' [507] (13,0)
par défaut  
05:48:56.945748 -1000    authd    Succeeded authorizing right 'system.privilege.admin' by client '/usr/libexec/security_authtrampoline' [680] for authorization created by '/Applications/Macs Fan Control.app' [507] (3,0)
par défaut  
05:48:56.972309 -1000    authd    Succeeded authorizing right 'system.privilege.admin' by client '/usr/libexec/security_authtrampoline' [681] for authorization created by '/Applications/Macs Fan Control.app' [507] (3,0)
par défaut  
05:49:07.476903 -1000    authd    Succeeded authorizing right 'system.privilege.admin' by client '/Applications/Macs Fan Control.app' [507] for authorization created by '/Applications/Macs Fan Control.app' [507] (13,0)
par défaut  
05:49:07.509018 -1000    authd    Succeeded authorizing right 'system.privilege.admin' by client '/usr/libexec/security_authtrampoline' [685] for authorization created by '/Applications/Macs Fan Control.app' [507] (3,0)
par défaut  
05:49:07.535195 -1000    authd    Succeeded authorizing right 'system.privilege.admin' by client '/usr/libexec/security_authtrampoline' [686] for authorization created by '/Applications/Macs Fan Control.app' [507] (3,0)
par défaut  
05:49:14.113285 -1000    kernel    [MacsFanControl pid 507 mux-aware] exiting, non-mux-aware app count 0, runtime: 0:00:55.976
par défaut  
05:49:19.337164 -1000    kernel    [MacsFanControl pid:690 mux-aware] starting, non-mux-aware app count 0, switch-state 0 IG FBs 1 EG FBs 0:0 power-state 6 3D idle HDA idle
par défaut    
05:51:49.065980 -1000    kernel    process MacsFanControl[690] caught waking the CPU 45022 times over ~149 seconds, averaging 301 wakes / second and violating a limit of 45000 wakes over 300 seconds.
par défaut    
05:51:49.070515 -1000    symptomsd    Received CPU wakes trigger:
  MacsFanControl[690] () woke the CPU 45022 times over 149.48 seconds (average 301/sec), violating a CPU wakes limit of 45000 over 300 seconds.
par défaut    
05:51:49.076300 -1000    symptomsd      Found DiagUsageStats for RESOURCE_NOTIFY of EXC_CPU_WAKE : NON-FATAL (MacsFanControl) - <DiagnosticCaseUsage: 0x7fbcf2d35430> (entity: DiagnosticCaseUsage; id: 0x66c000cb <x-coredata://3B1838BD-D928-40C2-81AB-17651A7F788D/DiagnosticCaseUsage/p411> ; data: <fault>)
par défaut    
05:51:49.076468 -1000    symptomsd      2 reports for MacsFanControl is still under the limit of 5. Allowing report.
par défaut    
05:51:49.079813 -1000    symptomsd    Updating RESOURCE_NOTIFY report statistics for RESOURCE_NOTIFY : EXC_CPU_WAKE : NON-FATAL : MacsFanControl
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
38 410
5 511
Moi j'ai placé MFC dans Macintosh HD/Applications/Utilitaires et ça fait des années que c'est comme ça.

Sinon, je ne vois pas le problème avec MFC, surtout si tu es sûr d'avoir fait une désinstallation complète, y compris les fichiers annexes. Voilà ce que j'ai chez moi avec EasyFind...

Capture-000.jpg
 

EricM

Membre actif
28 Juillet 2004
698
29
53
Grimaud Var France
Locke,

Je ne vois pas ton fichier de capture EasyFind ;-)