MAMP et htaccess je bute....

pulsaracat

Membre confirmé
30 Septembre 2007
299
8
Berre l'etang
www.afcca.org
voila mon probleme :
lorsque je tape "http://localhost" dans firefox, j'obtiens la liste des reperoires de mon dossier htdocs (pas de page index a la racine), jusque là, tout va bien....mais lorsque je place un fichier .htaccess dans un des repertoires pour le proteger, celui ci n'apparait plus dans la liste, et si j'essaie de l'ouvrir (http://localhost/repertoire) j'ai une magnifique erreur 500 :
"The server encountered an internal error or misconfiguration and was unable to complete your request."
le fichier error-log dit ceci :
Applications/MAMP/htdocs/repertoire/.htaccess: AuthUserFile takes 1-2 arguments
Je dois chercher plutot dans le fichier .htaccess, ou .htpass ou httpd.conf pour trouver l'erreur ?


mon fichier .htaccess ressemble a ça :
AuthUserFile /Applications/MAMP/htdocs/test/.htpass
AuthName "Accès reservé entrez vos identifiants"
AuthType Basic
<LIMIT GET POST>
Require valid-user
</LIMIT>

et mon fichier .htpass :
pulsar:cmoi

le fichier httpd conf est celui d'origine de la derniere version de MAMP, je n'ai rien changé

si quelqu'un a une solution, je suis preneur, merci
 

p4bl0

Membre d’élite
Club MacG
12 Juillet 2004
4 772
425
31
$PWD
p4bl0.net
"le fichier httpd conf est celui d'origine de la derniere version de MAMP, je n'ai rien changé"

C'est là qu'est le problème :D

Par défaut dans MAMP (mais pas dans toutes les versions apparemment), les dossiers sont en AllowOverride None, faut mettre ça à All comme ça les .htaccess sont pris en compte :)