Mavericks + Safari = 100% processeur

SapphirX

Membre junior
11 Juillet 2011
15
0
Bonjour,

Depuis que je suis passé sous Mavericks, je me suis remis à utiliser Safari comme navigateur par défaut.

Malheureusement, depuis quelques jours, je m'aperçois que Safari consomme 100% de mon processeur juste à l'ouverture et pendant toutes mes navigations. (cf : capture d'écran).

J'ai beau vidé mon cache, réinitialiser complètement Safari, désactiver toutes les extensions quelqu'elles soient, enlever tous les plugins-web, rien n'y fait, juste quand par exemple j'ouvre Google la consommation se met à 100%.

Cela est déjà arrivé à quelqu'un ? Une solution ?

Cordialement,

694566Safari100.png
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 944
3 181
Tu n'as pas installé d'extension ?
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 944
3 181
Tu as peut-être un site qui le dérange dans le "Top site".
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 944
3 181
Je sais. Mais je ne sais pas comment travaille Safari et il est toujours possible qu'il fasse dans le "préemptif", même à ton insu.
Disons qu'il ne faut négliger aucune piste puisque celles qui paraissent évidentes n'ont rien donné.

Tu peux aussi essayer de pister les sites vers lequel Safari pourrait chercher à se connecter dès l'ouverture (un pare-feu sortant peut aider en cela ; par exemple LittleSnitch).
 

MadBeatle46

Membre confirmé
Bonjour,

Depuis que je suis passé sous Mavericks, je me suis remis à utiliser Safari comme navigateur par défaut.

Malheureusement, depuis quelques jours, je m'aperçois que Safari consomme 100% de mon processeur juste à l'ouverture et pendant toutes mes navigations. (cf : capture d'écran).

J'ai beau vidé mon cache, réinitialiser complètement Safari, désactiver toutes les extensions quelqu'elles soient, enlever tous les plugins-web, rien n'y fait, juste quand par exemple j'ouvre Google la consommation se met à 100%.

Cela est déjà arrivé à quelqu'un ? Une solution ?

Cordialement,

694566Safari100.png

L'explication ne réside-t-elle pas dans la technologie appnap, utilisée par Mavericks ? En gros, toutes les applis ouvertes dont les fenêtres sont complètement masquées par l'application active (ici safari) sont mises "en veilleuse" et ne demandent presque plus rien en ressources processeur. Du coup, cela donne un max des ressources à l'appli active.

NB : si on veut que certaines applis puissent tourner sans êtres concernées par appnap, il faut sélectionner l'appli, lire les infos et cocher la case "empêcher appnap".
 

SapphirX

Membre junior
11 Juillet 2011
15
0
AppNap ne peut pas être désactivé dans Safari. Puis le processeur consomme 100% de sa capacité quelque soit sa position à l'écran (en arrière plan ou non) et cela continue jusqu'à que je kill le processus à la main.
 

MadBeatle46

Membre confirmé
AppNap ne peut pas être désactivé dans Safari. Puis le processeur consomme 100% de sa capacité quelque soit sa position à l'écran (en arrière plan ou non) et cela continue jusqu'à que je kill le processus à la main.

Ce n'est pas dans safari qu'il faut le désactiver, mais dans les applis qu'on ne veut pas voir mettre en veilleuse.

Ceci dit, c'est vrai que safari, chez moi, il est à 0,8%, donc c'est qu'il y a autre chose chez toi. Sorry.

Pour info, il passe à 0% quand il est en arrière-plan, même si sa fenêtre n'est pas cachée.
 
Dernière édition:

Lean Jinx

Membre junior
20 Octobre 2011
80
0
35
Salut j'avais le même problème, et un coup d'onyx a mystérieusement résolu le problème pour moi. Je vais surveiller si le problème survient à nouveau pour comprendre d'où cela peut venir.
 

SapphirX

Membre junior
11 Juillet 2011
15
0
J'ai trouvé le problème.

Cela vient bien d'un site internet en particulier mais celui-ci se trouve dans ... la liste de lecture. En le supprimant tout est rentré dans l'ordre.