Mavericks + VPN SSL + freebox = HTTP only

liohau

Membre enregistré
9 Juin 2012
3
0
33
Bonjour,

J'ai un soucis assez bizarre lorsque j'essaye de me connecter au VPN (SSL, pas de PPTP ou L2TP pour l'instant) de ma boîte.

Donc en fait, j'ai essayé avec les clients VPN Tunnelblick ou Viscosity (qui de ce que j'ai compris ne sont que des GUI pour openVPN), de me connecter à un VPN SSL, apparemment la phase de connection se déroule sans soucis (vu que j'ai pas vu de message d'erreur :D), mais une fois connecté je n'ai accès qu'aux ressources HTTP.

Ce qui est bizarre, c'est que lorsque je passe sur Windows (via Bootcamp, donc sur le même mac), le VPN me laisse bien accéder à tout. Encore plus bizarre, sur Mavericks, si je n'utilise pas ma freebox comme connection, mais le partage de connection de mon iPhone, j'ai également accès à tout.

J'en conclus qu'openVPN ou mavericks doit mal faire quelque chose aux yeux de ma freebox, mais je n'ai aucune idée de quoi. Tout ce qui est résolution DNS à l'air de fonctionner (un ping sur le domaine local échoue avec des "Request timeout for icmp_seq", mais je vois bien que ping a réussi à transformer le domaine en l'ip correspondante.

Est-ce que quelqu'un à déjà rencontré ce soucis ?

Pour résumer voilà les combinaisons qui fonctionnent:

Mavericks -> Mac Book Pro Perso -> Freebox -> VPN ==> HTTP uniquement
Mavericks -> Mac Book Pro Perso -> partage de connexion iPhone -> VPN ==> OK pour tout
Mountain Lion -> Mac Book Pro du Taff -> partage de connexion iPhone -> VPN ==> OK pour tout également
Windows 8 -> Mac Book Pro Perso -> Freebox -> VPN ==> OK pour tout également

PS : désolé, j'ai hésité à ouvrir mon thread dans la section "Internet et réseau" :)
 
Dernière édition:

Polo35230

Membre expert
Club MacG
4 Janvier 2011
1 687
100
Bonjour,

Je ne crois pas trop à un pb sur la Freebox.
Elle laisse passer le HTTP. Le principe du SSL, c'est que tout est encapsulé dedans. Donc, la box ne sait même pas que c'est du HTTP.
Si elle laisse passer le HTTP, elle doit lisser passer le reste. La preuve, via bootcamp, c'est bon.

Tu dis que http marche, mais tu ne dis pas ce qui marche pas...
Il faudrait faire un test réseau avec le numéro de port d'une appli présente sur le serveur qui pose pb. Supposons qu'en HTTPS (port 443) ça ne marche pas.
telnet AdresseIpLocaleDuServeur 80 (d'après tes tests, ça doit marcher; On doit avoir "connected to...")
telnet AdresseIpLocaleDuServeur 443 (pour voir si on accroche le port 443)

Si ça n'accroche pas, c'est que quelque chose bloque la connexion sur le LAN de l'entreprise: Firewall, passerelle VPN, ou le serveur lui même, si c'est lui qui est serveur VPN.

Mavericks -> Mac Book Pro Perso -> Freebox -> VPN ==> HTTP uniquement
Windows 8 -> Mac Book Pro Perso -> Freebox -> VPN ==> OK pour tout également
C'est ça qui est curieux...
C'est le serveur VPN de l'entreprise qui attribue l'adresse IP au MacBook ou c'est toi qui la configure manuellement?
Quand tu te connecte au serveur VPN de l'entreprise, il y a une phase d'authentification (login/password)?
Que dit l'administrateur réseau de l'entreprise? Il devrait pouvoir te dire s'il te voit arriver ou pas, et là où ça coince.
Après, si le telnet sur le port d'une appli qui ne marche pas renvoie bien "connected to...), il y a peut-être un pb de MTU sur Mavericks (et pas sous windows/bootcamp). On verra alors.
 

liohau

Membre enregistré
9 Juin 2012
3
0
33
Apparemment le DHCP de ma freebox utilisait la même plage d'IP privée que mon entreprise, et ça causait soucis uniquement sur mac (soucis avec OpenVPN?).
 

drs

Oh ouiiiiiiiii !
Club MacG
non pas de souci avec openvpn ici.

Mais un problème d'architecture réseau tout bête. En fait, il faut comprendre à quoi sert le VPN. En gros, et pour faire simple, il est là pour faire croire aux systèmes de ton entreprise que tu es dans les murs, alors que tu n'y es pas.
Pour cela, le VPN va t'attribuer, de manière virtuelle, une adresse connue par les systèmes de l'entreprise (qui ne connaissent pas l'adresse de ta maison).

si on dit que le réseau de ta maison s'appelle LAN_M et celui de l'entreprise LAN_E, activer ton vpn revient à dire à ta machine: "tout ce qui est à destination de LAN_E doit passer par le VPN".

Mais si LAN_M=LAN_E, ta machine ne sait pas quels flux envoyer dans le vpn, car tous les flux correspondent aux réseaux de ta maison. Concernant le HTTP, il est même possible que certains flux qui devaient passer dans le vpn n'y allaient pas en fait.

J'ai eu le souci chez moi, avec un vpn qui me permet d'accéder au réseau maison depuis n'importe où. Mais j'avais un réseau en 192.168.1.0, comme sur la majorité des box. J'ai donc été obligé de le changer, et tout fonctionne impec.