MacBook Air MBA 2011 "votre ordinateur a redémarré en raison d'un problème"

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 736
26 354
Forêt de Fontainebleau
Il faudrait voir > le SSD défaillant clippé dans le Mac correspondant => s'il est stable après démarrage en Single User.

- aucun disque branché en externe au Mac > tu démarres donc alors les 2 touches ⌘S (cmd S) tenues pressées. Obtiens-tu un écran noir sur lequel défilent des lignes de logs de démarrage blanches ? S'immobilisent-elles sur une invite de commande :​
Bloc de code:
root#

  • ou pas ? - si c'est le cas > cette situation dure-t-elle ?

Note : un démarrage en Single User > démarre le Mac sur le volume interne monté en lecture seule > sans aucun service de l'OS initialisé. C'est donc un démarrage minimaliste > dont la fonction est justement de permettre de récupérer un montage de volumes corrompus. Reste à voir si > dans ton cas => ce démarrage minimaliste stabilise la connexion du SSD.

- si ça marchait > il serait possible de cloner via une commande de terminal le contenu du volume démarré => à destination de celui d'un DDE USB. Car la session du Single User est une pure session de terminal de l'utilisateur root. Le clavier est toujours un QWERTY logique - il faut donc adapter les commandes. Aucun volume externe n'étant automatiquement monté (à cause des services non initialisés de l'OS) --> il faut forcer le remontage du volume du DDE => à un point de montage du volume interne via une commande ad hoc.​

Si ton test fonctionnait > tu quittes la session du Single User en passant la commande :
Bloc de code:
reboot

  • (qui fait redémarrer le Mac) --> en pressant aussitôt la touche "alt" pour pouvoir rechoisir ton volume externe et démarrer dessus.
S'il ne fonctionne pas (affichage instable ou déconnexion) => tu forces l'extinction du Mac (pression continue sur le bouton d'alimentation).
 

LiamstorM

Membre actif
10 Janvier 2006
112
1
33
Hello, alors j'ai effectué la commande au démarrage.
J'ai en effet deux écrans noirs avec écritures blanches qui s'enchainent.
Mais extrêmement rapidement.
Le premier est avec un texte "centré"
Le deuxième avec un enchainement de lignes types commandes (centrés à gauche).

Puis ça me remets sur l'écran de démarrage (logo de la pomme + barre de chargement) et au bout de 3 secondes il redémarre.
Je n'ai visiblement pas la main pour taper quoi que ce soit lors des écrans sur fond noir car cela va extrêmement vite.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 736
26 354
Forêt de Fontainebleau
D'accord : échec de stabilisation de la session en Single User. Il faut abandonner cette piste.

- quant à récupérer des fichiers (depuis ta session du volume externe - le SSD clippé en interne) => c'est toujours le même problème : un disque qui se déconnecte à tout bout de champ ne permet pas une tâche de clonage en continu. Il faudrait que tu joues de rapidité > pour accéder très vite dans le volume du SDD aux Utilisateurs > dossier de compte > pour faire un glisser-déposer des fichiers voulus.​
- s'il y avait un problème de permissions d'accès (aux sous-dossiers du dossier de compte) > le volume interne monté > faire un ⌘I (cmd I) sur l'icône du volume affichée sur le Bureau > pour ouvrir une fenêtre d'informations du Finder. Déverrouiller le cadenas. Cocher la case (en bas) : "Ignorer les autorisations de ce volume". Après éjection du volume et son remontage (ou un redémarrage) => il remontera avec l'utilisateur dont la session est ouverte (= toi) pour propriétaire apparent du volume et de tous ses contenus.​
 
  • J’aime
Réactions: LiamstorM

LiamstorM

Membre actif
10 Janvier 2006
112
1
33
Nous avons donc essayé car techniquement si il ne se déconnecte qu'au bout de plusieurs minutes, cela nous donnerait le temps de copier les quelques fichiers (surtout que ce sont des textes, donc copie rapide), même si cela doit être fait en plusieurs fois.

Cependant, quand nous arrivons sur le bureau. Nous ouvrons une fenêtre sur le SSD externe (avec clone) pour préparer le lieu de destination de la copie.
Puis une autre fenêtre avec le SSD interne.
Nous voyons le SSD Interne (Mac HD). Nous cliquons dessus et nous voyons "Users", nous pouvons accéder au dossier, puis au Desktop. Et nous voyons les fichiers et dossiers que nous voulons copier.
Nous les prenons et les déplaçons vers le dossier destinataire sur le SSD externe.
La première fois (j'ai pris un dossier entier qui avait une dizaine de fichiers textes dedans) cela affichait "preparing to copy" puis rien jusqu'à ce que le disque s'éjecte. C'était en copiant vers le clone du SSD externe (partition).

Je viens de le refaire en copiant directement sur le Desktop (donc main volume du SSD externe) et fichiers par fichiers là ça a fonctionné !

Il semble donc très instable et il faut le faire clairement en plusieurs fois mais je pense que nous allons nous en sortir. Nous allons réessayé plusieurs fois jusqu'à demain soir et je vous tiens au courant.

Merci
 

LiamstorM

Membre actif
10 Janvier 2006
112
1
33
Ok, je crois que nous sommes ok et que la plupart des fichiers dont ma femme avait besoin ont été sauvé.

Un GRAND merci pour l'aide reçu au début de thread par les membres qui se sont penchés dessus et encore plus @macomaniac, au delà du fond de tes explications utiles j'ai surtout aimé la forme, très didactique, structurée et claire !

Je rajoute deux petites questions annexes :

1-Si nous voulons faire durer cet ordinateur encore quelques mois (avant d'en racheter un quand nous serons aux Etats-Unis), il ne faut visiblement plus compter sur ce SSD interne défectueux en en racheter/monter un autre, ou alors un petit formatage peu le remettre d’aplomb ?

2-Avec l'installation Mac Os que j'ai effectué sur le SSD externe, est-il possible pour moi de la démarrer sur un PC (j'avoue sortir un peu des clous du topic mais juste un oui/non me suffirait à ensuite effectuer plus de recherches) ?
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
86 736
26 354
Forêt de Fontainebleau
Tu peux effectivement tenter d'effacer le disque entier (dans l'Utilitaire de disque => sélectionner le disque physique = ligne supérieure concernant le SSD > et l'option : "Effacer"). Voir si ça corrige les déconnexions. Douteux mais à tenter.

- tu ne peux pas démarrer un PC sur un disque paramétré "Mac" et recelant une version de macOS.​
 

LiamstorM

Membre actif
10 Janvier 2006
112
1
33
Ok merci !

Tu dois pouvoir en trouver un substituable chez OWC par exemple.
+
Tu peux effectivement tenter d'effacer le disque entier (dans l'Utilitaire de disque => sélectionner le disque physique = ligne supérieure concernant le SSD > et l'option : "Effacer"). Voir si ça corrige les déconnexions. Douteux mais à tenter.

En fait je pense que nous allons fonctionner ainsi si cela semble "cohérent" : nous allons garder le SSD externe comme disque de démarrage car ce n'est l'affaire que de quelques mois avant de changer ce MBA de mi-2012 dont la batterie est aussi en fin de vie.
Comme ça en plus nous gardons ce SSD comme disque de boot si par exemple mon MBA a aussi un problème.
Avec le clone que nous avons fait pendant le thread (#39) 150go devrait lui être suffisant.