MacBook Pro MBP15" mid2014 - Problème lors du passage de Mac OS Yosemite à Mojave

Jauraispasducroquerlapomm

Nouveau membre
2 Février 2020
5
0
42
Problème lors du passage de Mac OS Yosemite à Mojave

La machine : Macbook Pro 15" mid-2014, SSD 512 d’origine, filevaulté avant tous mes tracas, sous Yosemite

Backup TimeMachine en possession (c'est pour me rassurer)

Pourquoi Yosemite à Mojave tout d'un coup ainsi : pour des raisons applicatives professionnelles, mon épouse ne peut pas tourner sous Catalina, en fait on suit les mises à jour en fonction des applicatifs, ici migration Mojave obligatoire)

Mise à jour via l’app officielle; téléchargement application MAJ Mojave via https://itunes.apple.com/fr/app/macos-mojave/id1398502828?ls=1&mt=12
Ensuite lancement de l'application.


Essai 1
Au redémarrage, boucle avec à chaque fois erreur. Un message « Une erreur s’est produite, redémarrer et réessayez de lancer l'installation».
Par contre je n'arriverai plus jamais au Yosemite installé.


Essai 2
Essais multiples pour installer Mojave depuis une clef USB : l’installateur ne voit pas d’autre disque que la misérable clef USB 8GB « Installer Mojave ». Dans l’utilitaire disque, si je m’y rends en premier, il y a bien le SSD de 512 GB d’origine. Il disparaît au bout d’un moment (plus de trace de lui ni dans l’utilitaire ni dans le terminal). A chaque reboot et accès à utilitaire disque, il est là.


Certains essais ont permis de lancer l’installation mais après un momlent message du type : « Une erreur s’est produite, réessayez » ou relancez l’install ou un message de ce type.


Interlude 1
Par dépit, j’ai booté à l’aide d’une clef Ubuntu et hop, j’ai zéroté le SSD.

Le SSD est parfaitement accessible et le reste sous linux durant le zerotage complet (en mode device).

J’écarte du coup la panne du SSD.

Après pas mieux (zéroter le disque n’était sans doute pas la meilleure solution...)


Essai 3
Essai pomme+R pour rebooter depuis internet. L’installation se lance, téléchargement (les fenêtres de dialogue respirent bon les petites boules rouges bien arrondies avec un bel effet de reflet ; ça doit être une vieille version ou Mavericks). J’ai alors un message « il manque une partition de programme interne sur l'ordinateur » et tout s’arrête.


Interlude 2
J’ai installé un Mojave depuis l’autre Macbook de mon épouse sur un SSD externe. Il fonctionne parfaitement sur ce dernier (bootable, utilisable) mais n’est pas détecté sur le 15’’ malade.
J’en déduis qu’il s’agit d’un problème de compatibilité système de fichier ou "bios"...


Essai 4
Là j’essaie d’installer sur une carte SD de 128GB depuis recovery internet et ça fonctionne.

Sauf que dans l’utilitaire disque je ne vois toujours pas ce satané SSD 512GB interne (j’ai un message au démarrage qui me dit pas initialisé puis disparait).


J’ai essayé de clôner la carte SD sur le SSD après un redémarrage recovery Mavericks via l’utilitaire disque. Via l’option « restaurer » en prenant comme source le premier niveau sous la carte SD (partition Mac) et en mettant comme cible le premier niveau sous le SSD (création préalable d’une partition journalisée, GUID). La « restauration » (le clonage) se lance et avant de voir apparaître un délai, j’ai au bout d’une minute une erreur 60 (time out) et le SSD disparaît de l’utilitaire disque. Si je reboote, réapparait … et ainsi de suite.


Essai 5
J’essaie de mettre Catalina sur la SD.

Erreur du même type que l’initiale : erreur programme, quitter le programme et redémarrez.

Après redémarrage, je suis bien dans Mavericks et je ne vois aucun autre disque que la carte SD...








Je ne suis pas un habitué de l’écosystème Apple. Des lectures de ce forum ces dernières heures, j’ai l’impression que mon problème pourrait venir de paramètres incorrects cachés quelque-part ailleurs que sur le SSD et d’une mise à jour de l’EFI impossible ?
Je suppose que la mise à jour de l’EFI passera par une réinstall sur le SSD (pas possible d'ailleurs) puis mise à jour.


Comment arriver à réinstaller sur le SSD n’importe quoi, y compris Maverick ?

Help !
 

Jauraispasducroquerlapomm

Nouveau membre
2 Février 2020
5
0
42
J'ai essayé "⌘+R" aka dernier OS installé (qui d'ailleurs avec le SSD vierge donne le même que "⌘ + option + R") et "⌘ + option + R" aka OS le plus moderne qui me ramènent curieusement au même Mavericks. Je devrai pouvoir passer au-dessus. Surtout que l'update officiel Mojave aurait du flasher l'EFI même si pas abouti (enfin je suppose qu'il commence par là, ajouter les supports manquants comme apfs ...)

Là, je tente une copie de la SD qui fonctionne sur le SSD (via Linux).

J'essaierai après ta solution Maj + Option + ⌘ + R qui devrait aussi me ramener à Mavericks mais qui verra peut-être le SSD.

J'en viens quand-même à me demander si le SSD n'a pas un soucis car j'ai des erreurs avec l'internet recovery et Mavericks (qui à priori ne nécessite pas de reflash EFI) et que c'est passéé sur la carte SD.

J'écarte l'idée d'une nappe foireuse vu qu'à priori dans ce modèle c'est un slot.

Pour info, j'ai aussi réalisé un reset NVRAM et SMC.



Je teste et je reviens ... mais j'ai déjà une autre question : si c'est le SSD, avec un MBP qui n'a jamais passé le stade du MacOS 10.10, un SSD alternatif, c'est mort ?


Merci !
 

Jauraispasducroquerlapomm

Nouveau membre
2 Février 2020
5
0
42
En lisant plus attentivement ton lien, je peux expliquer pourquoi quelles que soient les touches pressées, j'aie Mavericks :

  • Si macOS Sierra 10.12.4 ou version ultérieure n’a jamais été installé sur ce Mac, la combinaison de touches Option + Commande + R installe la version de macOS fournie avec votre Mac ou la version la plus proche encore disponible. La combinaison Maj + Option + Commande + R n’est pas disponible.
  • Si vous avez effacé l’intégralité de votre disque au lieu de vous limiter au volume de démarrage sur ce disque, il est possible que la fonctionnalité de récupération de macOS ne propose que la version de macOS fournie avec votre Mac ou la version la plus proche encore disponible. Vous pouvez ensuite effectuer une mise à niveau vers une version ultérieure.
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
46 189
8 043
Nancy___
Je teste et je reviens ... mais j'ai déjà une autre question : si c'est le SSD, avec un MBP qui n'a jamais passé le stade du MacOS 10.10, un SSD alternatif, c'est mort ?
Pas sûr de comprendre ce que tu entends pas "un SSD alternatif" ?

Si tu veux parler d'un SSD externe, pas de problème.
Si tu parles de changer le SSD interne, regarde les tutos de démontage sur iFixit. Puis regarde chez OWC pour voir s'ils vendent un SSD de remplacement.
 

Jauraispasducroquerlapomm

Nouveau membre
2 Février 2020
5
0
42
C'est exactement ce que j'entendais pas "alternatif" : pas un produit APPLE.
La solution externe est bloquante (sans EFI updaté à priori, point de succès pour des versions MacOS récentes)

OWC propose deux modèles AURA X2 et N.
Le X2 demande que le MBP de destination ait fait tourner MacOS 10.13 ou supérieur préalablement à son installation.
Le N la v10.10 de MacOS avec le dernier firmware (du SSD). Eventuellement une piste ici !


Ma compréhension de cet écosystème en est à ses balbutiements mais au moins les réinstall/formatages/téléchargements me laisse du temps à côté.
 

Jauraispasducroquerlapomm

Nouveau membre
2 Février 2020
5
0
42
Le clônage sous Linux de la carte SD qui faisait office de disque externe a été salvateur.
Après avoir modifié le disque de démarrage pour le SSD, celui-ci a bien pris le relai.
J'ai pu ensuite faire la mise à jour de Mavericks vers High Sierra.

Je boote maintenant sur de l'apfs et j'en déduis que l'update EFI s'est fait.
[High Sierra me permet de me prémunir en cas de nouvelle surprise en me garantissant l'usage d'un SSD de remplacement. Ouf.]

Je vais maintenant remettre un backup TM en route puis je testerai une mise à jour vers Mojave.

Je ne m'explique pas vraiment pourquoi le SSD disparaissait (par fainéantise je n'avais zéroté qu'une partie du SSD, peut-être une piste).

Par contre mon SSD n'est exploité que sur 128GB (il me faudra redimensionner le volume apfs) et j'ai un doute sur l'alignement 4k (vu que la SD utilisait des bs de 512bytes).