MBPMid2010_GPUFix : Enfin un correctif pour corriger le kernel panic des MacBook Pro 2010 !

julian-poidevin

Nouveau membre
7 Mai 2017
6
2
29
MBPMid2010_GPUFix est un utilitaire que permet de corriger le problème d'affichage d'un écran noir de manière intermittente ou à la perte de video (kernel panic) du MacBook Pro (15 pouces, mid-2010).
L'algorithme est basé sur une solution proposée par l'utilisateur fabioroberto sur les forums MacRumors.

L'utilitaire est basé sur le Framework Qt et seulement disponible sur OSX.

Quel est ce bug de GPU ?
Les MacBook Pro de Mi-2010 (MacBook6,2) souffre de problème de GPU. C'est un problème connu d'Apple. Typiquement, un kernel panic se déclenche de manière aléatoire pendant l'utilisation de l'ordinateur.

Quelle est la soluton ?
Un correctif logiciel a été trouvé par l'utilisateur fabioroberto sur ce sujet.
Mon logiciel permet de réaliser le correctif d'une manière automatique.

Screenshot
OEjuk8Y.jpg


N'hésitez pas à "Star" mon GitHub si ce correctif a fonctionné pour vous ! :)

Téléchargements rapide

Dernière release
La dernière version de l'application peur être trouvée ici

ENJOY !
 

Nevcam

Membre confirmé
12 Novembre 2016
154
8
33
Bonjour merci beaucoup pour votre patch !

Il a fonctionné dans un 1er temps sur mon MacBook Pro mi-2010 puis tout d'un coup c'est revenu comme avant avec des redémarrages fréquents... Je n'ai pas fait de MàJ ni rien, simplement tout d'un coup le patch a cessé de fonctionner. J'ai tenté de le réinstaller mais maintenant l'installation échoue...

Savez-vous ce qu'il se passe ?

Merci :)
 

Nevcam

Membre confirmé
12 Novembre 2016
154
8
33
Bonjour @Nevcam, merci d'appliquer la procédure suivante :
  • Appliquer le patch (même si il échoue)
  • Redémarrer la machine
  • Ré-appliquer de nouveau le patch : ça devrait fonctionner.

Bonjour,

J'ai bien suivi votre procédure mais au redémarrage lorsque je tente de nouveau d'installer le patch ça ne fonctionne toujours pas... ?
 

Nevcam

Membre confirmé
12 Novembre 2016
154
8
33
Oui, pas de problème, et voilà :

Bloc de code:
| Checking compatibility
MBPModelVersion : MacBookPro6,2 ➔ Compatibility : OK ✓
| Checking SIP Status
No SIP for this OS
| Searching for AppleGraphicsPowerManagement.kext
AppleGraphicsPowerManagement.kext found

********** Starting MBP GPU Fix **********
Copying Info.plist file
Patching Info.plist
- FindChild - key|MacBookPro6,2
- NextSibling - dict
- FindChild - key|LogControl
- ModifyIntValue - integer|1
- FindSibling - key|Vendor10deDevice0a29
- FindSibling - key|BoostPState
- FindSibling - key|BoostTime
- FindSibling - key|Heuristic
- FindSibling - key|IdleInterval
- ModifyIntValue - integer|10
- RemoveSiblingLabel - P3HistoryLength Not found
- FindSibling - key|SensorSampleRate
- ModifyIntValue - integer|10
- FindSibling - key|Threshold_High
- FindSibling - key|Threshold_High_v
- FindSibling - key|Threshold_Low
- FindSibling - key|Threshold_Low_v
Info.plist successfully patched
| Loading Kernel Extension
Removing existing kext in tmp : ✓
Copying actuel kext into tmp : ✓
Copying patched Info.plist into kext : ✓
Changing permission of kext : ✓ /tmp/AppleGraphicsPowerManagement.kext/Contents/_CodeSignature/CodeResources
/tmp/AppleGraphicsPowerManagement.kext/Contents/_CodeSignature
/tmp/AppleGraphicsPowerManagement.kext/Contents/Info.plist
/tmp/AppleGraphicsPowerManagement.kext/Contents/MacOS/AppleGraphicsPowerManagement
/tmp/AppleGraphicsPowerManagement.kext/Contents/MacOS
/tmp/AppleGraphicsPowerManagement.kext/Contents/version.plist
/tmp/AppleGraphicsPowerManagement.kext/Contents
/tmp/AppleGraphicsPowerManagement.kext

Removing existing kext : ✓
Copying patched kext into Extension : ✓
Loading modified kext : ✗ : Requesting load of /tmp/AppleGraphicsPowerManagement.kext.
/tmp/AppleGraphicsPowerManagement.kext failed to load - (libkern/kext) not loadable (reason unspecified); check the system/kernel logs for errors or try kextutil(8).

********************* MBP GPU Fix FAILED *********************

Merci à vous :)
 
Dernière édition par un modérateur:

Nevcam

Membre confirmé
12 Novembre 2016
154
8
33
Bonjour,

Je voulais rajouter une petite précision. Je viens de faire une "Automation" via Onyx et également une "réparation" du système via la procédure fsck -fy. Et cette fois j'ai pu de nouveau installer votre patch mais par contre le problème persiste toujours, les crashs sont toujours là contrairement à la 1ère installation où ils étaient bien bloqués.

Voilà, je suis un peu perdu.

Merci d'avance de votre réponse.