10.12 Sierra MDP reconnu sur ML mais plus sur Sierra

Celtia

Membre confirmé
11 Mars 2014
354
9
Bonjour à tous. Jusqu'à présent j'utilisais ML sur ma partition principale avec nom d'administrateur "X" et MPD "Y". Récemment sur ma deuxième partition, j'ai installé Sierra (10.12.6), et là patatra, "X" et "Y" ne sont plus reconnus lorsque je veux déverrouiller le cadenas dans Economie d'énergie par exemple. Pourtant j'avais démarrer sur le DD Sierra avec "X" et "Y" sans aucun problème (il m'aurait donc repris automatiquement ces données que j'utilisais sur ML ???!!! :bookworm:). Quelle serait la solution, hormis créer un nouveau MDP alors que je voudrais conserver mon ancien (donc valable pour les 2 OS) ?
 

Yuls

Membre d’élite
1 Juin 2003
1 034
165
41
Lyon
Bonjour,
Quel est le modèle de Macbook Pro ? (Menu Pomme / A propos de ce Mac)
++
 

Invité

Pommé
Club MacG
19 Février 2005
7 985
436
21000
Tu peux toujours aller dans "préférences système/utilisateurs et groupes" sélectionner ton compte et "modifier le mot de passe"
A tous les champs tu mets ton MdP. Donc l'ancien (si il passe) et qui sera aussi le nouveau…
 

Celtia

Membre confirmé
11 Mars 2014
354
9
Merci pour le conseil :merci:
D'autre part (toujours sur Sierra) je n'arrive pas à mettre les dossiers des 2 partitions (avec icone DD) comme c'était le cas sur ML. Peut-être faut-il TOUJOURS passer par Aller (shift-com-C) pour les afficher ? Mais comment les placer sur le finder (pas encore trouvé la manip) ??
 

Invité

Pommé
Club MacG
19 Février 2005
7 985
436
21000
Merci pour le conseil :merci:
D'autre part (toujours sur Sierra) je n'arrive pas à mettre les dossiers des 2 partitions (avec icone DD) comme c'était le cas sur ML. Peut-être faut-il TOUJOURS passer par Aller (shift-com-C) pour les afficher ? Mais comment les placer sur le finder (pas encore trouvé la manip) ??
Tu as coché "afficher les disques durs" dans les préférences du Finder ?
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
33 089
3 701
D'autre part (toujours sur Sierra) je n'arrive pas à mettre les dossiers des 2 partitions (avec icone DD) comme c'était le cas sur ML.
Ca n'a pas changé comme le mentionne la réponse #6. ;)
 

Celtia

Membre confirmé
11 Mars 2014
354
9
Vu, merci. Disons qu'avant le DD s'affichait automatiquement à la première installation (va falloir que je "think different" ;))
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
33 089
3 701
Disons qu'avant le DD s'affichait automatiquement à la première installation
Négatif et ce quelle que soit la version de macOS, il faut toujours passer par les préférences du Finder pour afficher tous les disques durs qui sont toujours masqués après une première installation. ;)
 

Celtia

Membre confirmé
11 Mars 2014
354
9
Erratum : effectivement, je pensais plutôt aux mises à jour OS qui reprenaient les prefs précédentes :shy:
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
33 089
3 701

Celtia

Membre confirmé
11 Mars 2014
354
9
Après moult essais et selon piste invité, l'affaire commence à être ubuesque : Modifier le MDP dans Utilisateurs n'est effectif que si le cadenas est déverrouillé (Pour modifier, cliquer sur le cadenas) !!!!!!!!!!!!! Et donc j'essaie vainement de déverrouiller mais ça se trémousse à qui mieux mieux :mad::mad:. Ce que je ne comprends pas c'est qu'au démarrage nom admin+MPD sont corrects et après ça déraille ?????!!!!!!!!! J'ai vérifié, le clavier est bien Français. Un réglage qui m'échappe ?...
 
D

Deleted member 1099514

Invité
Salut

Tu veux dire que tu as un utilisateur administrateur qui fonctionne bien lors du démarrage, mais qui ensuite ne te donne pas de privilèges?

Que te renvoient dans le terminal :
diskutil listusers / | grep '^50'
et
id
 

Celtia

Membre confirmé
11 Mars 2014
354
9
Résultat (j'avoue que c'est la première fois que j'ouvre Terminal :bookworm:), "X" étant le nom admin :

Last login: Sun Jul 30 04:57:22 on ttys000
iMac:~ X$ Last login: Sun Jul 30 04:03:10 on ttys000
wtmp begins Tue Jul 12 05:46
iMac:~ X$ iMac:~ X$ diskutil listusers / | grep '^50'ID
-bash: iMac:~: command not found
iMac:~ X$ iMac:~ X$
-bash: iMac:~: command not found
iMac:~ X$
iMac:~ X$
iMac:~ X$
iMac:~ X$

En essayant une deuxième fois, ça donne ça (si ça peut aider à la compréhension ?) — en fin de code j'ai validé par un enter (sais pas s'il faire ça ?!) :

Last login: Sun Jul 30 05:10:06 on ttys000
iMac:~ X$ diskutil listusers / | grep '^50'ID
iMac:~ X$
 
Dernière édition par un modérateur:
D

Deleted member 1099514

Invité
Ce sont 2 commandes différentes.
D'abord :
diskutil listusers / | grep '^50'
puis tu valides par la touche "Entrée"
et ensuite :
id
 

Celtia

Membre confirmé
11 Mars 2014
354
9
Last login: Sun Jul 30 05:32:09 on ttys000
iMac:~ X$ diskutil listusers / | grep '^50'
501 X X
iMac:~ X$ id
uid=501(X) gid=20(staff) groups=20(staff),12(everyone),61(localaccounts),402(com.apple.sharepoint.group.1),100(_lpoperator)
iMac:~ X$

Punaise, va falloir que je me mettes sérieusement au Terminal :siffle:
 
D

Deleted member 1099514

Invité
Et si tu fais un :
sudo ls
Ton mot de passe te sera demandé et tu le tapes "en aveugle" (il ne s'affiche pas).
Ça dit quoi?
 

Celtia

Membre confirmé
11 Mars 2014
354
9
Last login: Sun Jul 30 06:14:19 on console
iMac:~ $ sudo ls
Password:
X is not in the sudoers file. This incident will be reported.
iMac:~ X$

J'ai bien tapé à l'aveugle exactement le MPD...
 
D

Deleted member 1099514

Invité
Donc il y a un problème sur ton utilisateur qui ne semble pas faire partie du groupe admin.
La solution est un peu barbare, mais ça va fonctionner.
Commence par donner les retours de :
diskutil list
En indiquant le nom de ta partition Sierra qui pose problème.
 

Celtia

Membre confirmé
11 Mars 2014
354
9
Last login: Sun Jul 30 06:32:21 on ttys000
iMac:~ X$ diskutil listX-S
diskutil: did not recognize verb "listX-S"; type "diskutil" for a list
iMac:~ X$