• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

Mes icônes Classic sont disparus !

Pascal-007

Membre junior
15 Mars 2001
98
3
Québec, QC
Depuis que j'ai redémarré en Mac OS 9 pour faire une sauvegarde de mon Palm, je constate que tous mes icônes Classic sont disparus sous Mac OS X (10.0.4) : je ne voit que des icônes génériques. Pire : je ne peux pas reconstruire mon bureau pour tenter de corriger le problème, le bouton "reconstruire le bureau" étant grisé en permanence dans le panneau "Classic" des "Préférences système", ce qui n'était pas le cas avant...

Pourquoi cela m'arrive-t-il ? Qu'ai-je fait ? Est-ce une punition divine ? Comment puis-je me racheter ?
 

Gwenhiver

Membre d’élite
Club MacG
8 Décembre 2000
3 351
2
Visiter le site
Je suppose que redémarrer sous Mac OS 9 et reconstruire le bureau au cours de ce redémarrage (sur toutes tes partitions, n'hésite pas) devrait résoudre ton problème.
 

Tiberius

Membre confirmé
12 Janvier 2001
448
15
Esasye de supprimer les trois fichiers LSApplications, LSClaimedTypes et LSSchemes du dossier Preferences de ton utilisateur... (DisqueOSX/Users/nom_utilisateur/Library/Preferences)
 

Pascal-007

Membre junior
15 Mars 2001
98
3
Québec, QC
Merci de la suggestion. J'ai tenté l'expérience, sans succès.

Même après un redémarrage complet de ma machine (et non une simple fermeture de session), le problème persiste.

(J'utilise Mac OS X 10.0.4 sans modification, tel que fourni par Apple...)
 

Pascal-007

Membre junior
15 Mars 2001
98
3
Québec, QC
J'ai résolu le problème d'une façon agressive : j'ai réinstallé Mac OS X après avoir effacé la partition qui le contenait.

Ce qui m'a permi de découvrir que le problème était au sein de Mac OS X et non sur les autres partitions de mon ordinateur (et donc Classic). Il faut savoir, en effet, que le disque principal de mon ordi est divisé en trois :

1- « Mac OS X » (8 Go) : seulement Mac OS X, tel qu'installé par Apple, sans plus.
2- « Mac Classique » (1 Go) : le Mac OS 9.1 qui me sert pour Classic, sans plus.
3- « Courvoisier » (28 Go) : Mac OS 9.1 "autonome", mes applications et mes dossiers personnels.

Après réinstallation de Mac OS X, sans modifier les versions de OS 9 qui se trouvent sur les autres partitions, ni même reconstruire les bureaux, les icônes des applications Classic sont revenues.

Il s'agissait donc bel et bien d'un bogue de Mac OS X. Quel fichier aurait-il fallu que je jette ? Le mystère persiste... Mais au moins il y a là un début de piste !