• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

mettre un fichier son sur un site

Nyatout

Nouveau membre
8 Avril 2005
12
0
Bonjour tout le monde,

Comment faire pour qu'une musique se diffuse dès qu'on arrive à la page d'accuiel de mon site ? On voit souvent ce genre de présentation avec un son. Je utilise GoLive 5 sur Mac. Quelqu'un peut m'aider, S.V.P ?
 

PA5CAL

Vétéran
Club MacG
21 Juillet 2005
9 228
596
Île-de-France
Bonsoir

Il faut créer ton fichier sonore (.wav ou .mid), le mettre sur ton site, et inclure les lignes suivantes dans le code source de ta page d'accueil :
Bloc de code:
<embed src="mamusique.wav" autostart="TRUE" hidden="TRUE" loop="TRUE">
<noembed>
<bgsound src="mamusique.wav" loop="-1">
</noembed>
(Il faut y remplacer "mamusique.wav" par le nom de ton fichier)

L'utilisation des deux tags <embed ...> et <bgsound ...> est rendue nécessaire par le fait que les navigateurs ne reconnaissent généralement pas l'un ou l'autre. Cette manière de faire règle donc le problème dans la majorité des cas.
 
  • J’aime
Réactions: yakalelo

Nyatout

Nouveau membre
8 Avril 2005
12
0
Merci Pa5cal. J'ai déjà un fichier .wav. Je mets mon fichier dans la page en le glissant, j'insère ton code en remplaçant par mon nom du fichier. Cela ne marche pas ni en local ni en ligne. Je ne mets pas ton code au bon endroit ? C'est pas entre <p> et </p> ?
 
A

Anonyme

Invité
Salut !
Peux tu mettre le code (ou un morceau) de ton site stp pour voir si ça vient du code ;)
a+
 

PA5CAL

Vétéran
Club MacG
21 Juillet 2005
9 228
596
Île-de-France
Nyatout a dit:
Je mets mon fichier dans la page en le glissant, (...)
??? je ne comprends pas bien, mais ça ne doit pas être ça.


Le fchier .wav doit se trouver à l'endroit spécifié dans les paramètres "scr". Si tu n'indiques pas le chemin du fichier .wav, ce fichier doit se trouver dans le même dossier que la page HTML.

Par exemple, si ta page est "http://monsite.free.fr/index.htm" et que tu places ton fichier "mamusique.wav" dans le dossier "http://monsite.free.fr/musique/", tu devras spécifier src="musique /mamusique.wav".

Le bout de code HTML que j'ai donné peut être inséré dans l'entête (<header>...</header>) ou le corps (<body>...</body>) du document, ça doit marcher.
 

PA5CAL

Vétéran
Club MacG
21 Juillet 2005
9 228
596
Île-de-France
richarddeux a dit:
Pourquoi ne pas utiliser dewplayer.swf ( http://www.spip-contrib.net/Player-Flash-Mp3-leger)?

C'est du Flash et il n'y a rien à écrire: facile. :siffle:

C'est ce que j'utilise sur mon site.

Enfin, ce que j'en dis...;)
C'est vrai, ça semble être une possibilité intéressante (merci, je vais me la garder sous le coude). Toutefois, ça suppose d'avoir Flash installé sur l'ordinateur de l'internaute, ce qui n'est pas garanti à 100%.
 

richard-deux

Membre d’élite
Club MacG
10 Mars 2004
2 608
367
Reims
A mon avis, tout le monde à Flash.
De plus en plus de sites ont une animation flash et nécessite ce logiciel. ;)
 

Nyatout

Nouveau membre
8 Avril 2005
12
0
Merci tout le monde,

J'ai inséré le code de Pa5cal entre <head> et </head>, en mettant le fichier son (qui s'appelle air.wav) au même niveau que la page html. Cela marche en local "Explorer" ! Mais pas en safari (en local) ni en ligne. Je vous mets une copie de la source.

<html>

<head>
<meta http-equiv="content-type" content="text/html;charset=ISO-8859-1">
<meta name="generator" content="Adobe GoLive 5">
<title>test son</title>
<embed src="air.wav" autostart="TRUE" hidden="TRUE" loop="TRUE">
<noembed>
<bgsound src="aire.wav" loop="-1">
</noembed>
</head>

<body bgcolor="#a9a9a9">
<p>Test son </p>
<p></p>
</body>

</html>
 

PA5CAL

Vétéran
Club MacG
21 Juillet 2005
9 228
596
Île-de-France
Il y a une faute de frappe dans le nom du fichier à <bgsound src="aire.wav" loop="-1">

... à moins qu'il faille un "e" à "air" dans <embed src="air.wav" ...
 

Nyatout

Nouveau membre
8 Avril 2005
12
0
Merci Pa5cal,

Je n'avais pas remarqué la faute. Et je l'ai corrigée. Cela marche pour tous les navigateur en local (Explorer, Safari, Netscape) maintenant mais cela ne marche toujours pas en ligne.


<html>

<head>
<meta http-equiv="content-type" content="text/html;charset=ISO-8859-1">
<meta name="generator" content="Adobe GoLive 5">
<title>test son</title>
<embed src="air.wav" autostart="TRUE" hidden="TRUE" loop="TRUE">
<noembed>
<bgsound src="air.wav" loop="-1">
</noembed>
</head>

<body bgcolor="maroon">
<h1><font face="Arial,Helvetica,Geneva,Swiss,SunSans-Regular">Test son</font></h1>
<p></p>
</body>

</html>
 

PA5CAL

Vétéran
Club MacG
21 Juillet 2005
9 228
596
Île-de-France
Bonjour

Si ça marche en local, ça devrait aussi marcher en ligne, il n'y a pas de raison.

En ligne, vérifie que le fichier "air.wav" est bien dans le même dossier que le fichier HTML.

Il est aussi possible que le démarrage de la musique tarde, puisque le fichier .wav doit être chargé depuis le site. S'il est volumineux et que le débit de la ligne ou du serveur est faible, ça peut prendre du temps avant d'entendre quelque chose.

Si tu le veux, indique-moi l'URL de ta page pour que je regarde (et entende) ce que ça donne vu de chez moi.
 

Nyatout

Nouveau membre
8 Avril 2005
12
0
Tu as raison. Non seulement que c'est un peu lent mais aussi il fait comme le disque rayé !!! Mon "air.wav" n'est pas tout à fait ça? Le fichier est trop lourd ?

http://www.chez.com/moneycopy/

C'est un site que j'utilise pour tester des choses.
 

PA5CAL

Vétéran
Club MacG
21 Juillet 2005
9 228
596
Île-de-France
Il y a un soucis avec le fichier "air.wav".

Quand je l'écoute, même pris séparément, il n'y a pas de son.

En l'ouvrant dans Audacity, on a la confirmation qu'il est vide (6 secondes de silence).
 

Nyatout

Nouveau membre
8 Avril 2005
12
0
J'ai remplacé par un fichier .mp3. Et ça marche ! Mais il fait le boucle toutes les 20 secondes, est-ce normal ? Y a-t-il des moyens pour faire écouter le morceau entier qui dur 3 mn 53 ?
 

PA5CAL

Vétéran
Club MacG
21 Juillet 2005
9 228
596
Île-de-France
Ça dépend.

Regarde le fichier qui est chez toi (en local). S'il est incomplet, alors il faut le re-fabriquer correctement. Par contre s'il est correct (avec ses 3 mn 53), ça signifie que le fichier du site web a été endommagé lors de son transfert (problème FTP) et qu'il faut seulement le re-transférer.
 

Nyatout

Nouveau membre
8 Avril 2005
12
0
Le fichier est correct en local. Effectivement, il avait du mal à uploader mes fichiers son. Depuis le premier test. Comme tu dis, il est peut-être endommagé pendant le FTP. J'essaie de le re-uploader, maintenant il veut pas, "Opning BINARY mode data connection for /www/ivo.mp3".
 

Pochtroi

Membre confirmé
Ca c'en est une idée qu'elle est bonne, de foutre une musique sur son site ! J'essaierais bien mais j'ai remarqué que quand je tombe sur un site avec de la musique et que mon iTunes fonctionne en même temps, j'ai tendance à apprécier un petit bouton "off" pour choisir si je veux du son ou pas.
Vous savez comment on peut s'y prendre?

P.S.: Je suis débutant tout ce qu'il y a de plus débutant, donc molo sur le destroy... ;)