10.15 Catalina Migration 500Go> 1To et Bootcamp

AladdinVonSane

Membre actif
5 Août 2013
152
0
Bonjour à tous,

Ça me surprend que la question n'ai pas été traitée mais je ne trouve vraiment pas de réponse, peut être mes mots clefs n'étaient pas les bons...

Je suis actuellement sur HDD 500go (MBP mi-2012) et souhaite passer sur SSD 1To.

Mon HDD actuel est partitionnné ainsi : 350go Mac OsX (normalement Catalina s'installe au moment où j'écris ces lignes) et 150Go sur Windows (environ j'ai une partition recovery normalement).

Pour effectuer le transfert HDD500Go à SSD 1To je pensais faire ça :

1- clone de ma partition OsX via CCC ;
2- clone de windows via WinClone
3- démontage HDD remontage SSD
4- démarrage du MBP je clone ma sauvegarde OsX sur mon nouveau SSD
5- j’agrandis via l'utilitaire de disque la partition OsX pour prendre l'intégralité du SSD (puisque je clone une partition de 350Go elle n'occupera pas automatiquement les 1To libres du nouveau SSD si ?)
6- je réinstalle ma sauvegarde windows via bootcamp en octroyant cette fois 400Go environ

Est-ce que j'ai bon ? est-ce que j'ai dit des conneries ? J'ai peur de faire une bêtise lors de l'opération et vos lumières seraient les bienvenues :oops:
 

ericse

Membre expert
Club MacG
30 Avril 2019
5 425
937
Bonjour,
Je trouve juste dommage de ne pas acheter un boîtier usb3 vide en même temps que le ssd : ça ne coûte pas cher, ça permet de mettre le ssd et de cloner directement dessus, et de tester que ça boote avant même d’ouvrir le Mac. Ensuite on y mets l’ancien disque au lieu de ne rien en faire.
Pour le reste ça semble ok mais je n’ai jamais testé comme ça exactement [emoji56]
 

AladdinVonSane

Membre actif
5 Août 2013
152
0
Ah oui bien vu ! Il faudra juste que je vois comment bidouiller ma partition Windows pour la cloner sur un espace plus important (je crois que j'ai vu 2/3 tutos) mais super conseil pour la partition OsX je vais faire ça comme ça :up:

Ok je viens de voir que j'avais quasi poser la même question il y a deux ans... *Facepalm*

On me conseillait sinon d'utiliser Stellar Drive Clonent qui copie tt, puis d'utiliser Camptune X pour modifier la taille des partitions
 

AladdinVonSane

Membre actif
5 Août 2013
152
0
Salut à tous, :coucou:

SSD enfin acheté, j'ai tenté la "double" migration osX+windows et je suis passé à "ça" de réussir !

Stella Drive Clonent qui semble top ne fonctionnant pas sous Catalina, j'ai fait les opérations suivantes :

  1. Branchement en externe du SSD (effectivement @ericse c'était un bon conseil!)
  2. Copie via CCC5 de ma partition osX sur les 1To du SSD préalablement formaté en APFS (le fait de passer d'un HDD de 375Go à 1To n'a posé aucun soucis, c'est bootable, tout est ok)
  3. Création d'une sauvegarde winclone
  4. Ajout d'une partition sur le SSD (format exFat ou Fat) via l'utilitaire de disque (500Go/500Go ou 600/400 je ne me souviens plus...)
  5. Tentative de migration de la partition windows sur le SSD, et c'est là qu'intervient le soucis :
Je passe par winclone en cliquant sur "restore image", je choisi la sauvegarde créée à l'étape 3, en destination la partition créée à l'étape 4, tout semble bien se dérouler jusqu'à la fin où j'ai le message suivant :​

"The windows partition could not be mounted read/write to create the boot folder at the root of the windows partition. Mount the windows partition read/write, delete hiberfil.sys, and then try setting legacy bootable manually."
Et là j'avoue être complètement perdu, je n'ai aucune idée de comment je peux monter la partition windows, supprimer le fichier en question (je ne sais pas ce que c'est), et enfin, créer manuellement le "legacy bootable" ... Quelqu'un a-t'il déjà eu ce soucis ou comprends comment le résoudre ?

Merci pour vos lumières ! :)



-----------------

EDIT : je pense avoir compris le problème : quand windows se met en veille prolongé, cela créer un fichier "hiberfil.sys"
J'ai finalement compris que depuis ma partition OsX je dois accéder à la partition windows (qui est montée par de soucis), puis trouver ce fichier qui est dans la fichiers cachés (je ne comprends pas pourquoi je ne réussis pas à les afficher), le supprimer, puis recréer ma sauvegarde windows mais en passant par "Tools" pour sélectionner "Make legacy bootable"
 
Dernière édition:

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
39 601
6 026
1- clone de ma partition OsX via CCC ;
2- clone de windows via WinClone
3- démontage HDD remontage SSD
4- démarrage du MBP je clone ma sauvegarde OsX sur mon nouveau SSD
Jusque là pas de souci, mais pour la suite il fallait faire...
5) lancement d'Utilitaire de disque
6) réserver une taille de 400 Go pour Windows en sélectionnant impérativement le format FAT32 (MS-DOS) sans toucher à Table de partition GUID
7) lancer Winclone et faire le rétroclonage du fichier de sauvegarde .winclone

Winclone se charge lors de la recopie de faire la conversion à la volée dans le format NTFS, donc je me répète avec Winclone, il faut impérativement faire le formatage de la partition en FAT32 (MS-DOS). Information importante, par la suite, pour agrandir/rétrécir les partitions macOS/Windows il faudra impérativement utiliser le seul logiciel fonctionnant sous macOS qui est Camptune.

A tout hasard, une grosse lecture... https://forums.macg.co/threads/inst...ier-usb-3-0-sans-assistant-boot-camp.1330007/ ...en utilisant un disque dur USB 3.0 dédié.
 

AladdinVonSane

Membre actif
5 Août 2013
152
0
Merci pour ta réponse, j'ai deux questions :

6) réserver une taille de 400 Go pour Windows en sélectionnant impérativement le format FAT32 (MS-DOS) sans toucher à Table de partition GUID
7) lancer Winclone et faire le rétroclonage du fichier de sauvegarde .winclone

Est-ce que je fais les opérations depuis le SSD ou depuis le HDD duquel je suis parti ? (finalement avant de tout démonter/remonter je le fais en externe) A te lire j'ai l'impression que je peux depuis le SSD directement mais je préfère m'en assurer.

Et, question con, mais comment je fais pour ne pas toucher à la Table de partition GUID ? Jusqu'à présent j'ajoutais simplement une partition depuis l'utilitaire, en cliquant sur "partitionner", puis "+"

Je vais jeter un coup d'oeil à la discussion que tu as posté, merci !
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
39 601
6 026
Est-ce que je fais les opérations depuis le SSD ou depuis le HDD duquel je suis parti ? (finalement avant de tout démonter/remonter je le fais en externe) A te lire j'ai l'impression que je peux depuis le SSD directement mais je préfère m'en assurer.
Tu pouvais très bien installer ton SSD de 1 To en interne, démarrer sur le 500 Go installé dans un boîtier USB et faire le rétroclonage avec Carbon Copy Cloner. En démarrant depuis ton nouveau SSD de 1 To, tu avais confirmation que tout s'était bien passé, de là tu installais Winclone et tu passais à la suite depuis...
5) lancement d'Utilitaire de disque
6) réserver une taille de 400 Go pour Windows en sélectionnant impérativement le format FAT32 (MS-DOS) sans toucher à Table de partition GUID
7) lancer Winclone et faire le rétroclonage du fichier de sauvegarde .winclone
...pour moi c'était le plus rapide.
Et, question con, mais comment je fais pour ne pas toucher à la Table de partition GUID ? Jusqu'à présent j'ajoutais simplement une partition depuis l'utilitaire, en cliquant sur "partitionner", puis "+"
En fait, comme beaucoup d'utilisateurs font pas mal de bêtises, j'insiste sur le fait qu'il ne faut jamais faire un formatage en MBR et en choisissant le format NTFS ! Pour le coup, c'est mission impossible et il faut recommencer tout depuis le début. :( Si lors de la réservation pour Windows via Utilitaire de disque, on voit bien que la partition de base est en Mac OS étendu (journalisé) ou APFS dans une Table de partition GUID, alors tout va bien et on lance Winclone.
 

AladdinVonSane

Membre actif
5 Août 2013
152
0
Dacc, merci pour tes réponses, et effectivement ça aurait sans doute été plus rapide en mettant direct le SSD...

Bon sinon je crois que j'ai fait une bêtise, mon clone winclone ne fonctionnait pas sans que je comprenne pourquoi, ma partition Bootcamp se démontait sans cesse.

Du coup je me suis dit que c'était peut être lié à la suppression du fichier hiberfil.sys, et je me suis souvenu que winclone me disait de me mettre manuellement en legacy, j'ai donc tenté via winclone, ça ne fonctionnait toujours pas.

Et là je crois que j'ai craqué : j'ai du coup mis manuellement en UEFI, puis j'ai tenté de booter sur ma partition windows et là j'ai cet écran :

103599097_701281040710374_6876570468506989001_n.jpg



Je suis retourné sur ma partition OsX, j'ai remis manuellement en legacy, mais rien n'y fait je continue d'avoir cet écran quand je veux booter sur windows...

(au moment où j'écris ces lignes je suis de retour sur ma partition OsX qui a mis très très longtemps à se démarrer sans que je comprenne pq mais avec une belle frayeur !)
 
Dernière édition par un modérateur:

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
39 601
6 026
je me suis souvenu que winclone me disait de me mettre manuellement en legacy, j'ai donc tenté via winclone, ça ne fonctionnait toujours pas.

Et là je crois que j'ai craqué : j'ai du coup mis manuellement en UEFI,
Allons bon, à quel moment ? Je n'ai jamais rencontré cette option lors de la restauration avec Winclone, mais alors jamais. Pourquoi et pour quelle raison d'ailleurs ? Et tu as fait comment ce bidouillage, avec le Terminal ?

De plus ton écran bleu de la mort de Windows indique bien un grave dysfonctionnement et c'est irréparable. Un Mac, ce n'est pas un PC, il ne possède pas de BIOS, et non la petite partition EFI Boot n'a aucun rapport, cela stocke des informations de démarrage et c'est tout. Ce n'est, ni de près, ni de loin l'équivalent du BIOS d'un vrai PC.

Ceci pour dire qu'en cas de problème grave que l'on ne peut pas démarrer sur un support quelconque comme un DVD, une clé USB ou la mini partition de récupération de Windows pour tenter de faire des réparations. Et à la base tu es vraiment sur que ta version de Windows était fonctionnelle avant d'utiliser Winclone, quelle version d'ailleurs la 7, la 10 ?
 

AladdinVonSane

Membre actif
5 Août 2013
152
0
Allons bon, à quel moment ? Je n'ai jamais rencontré cette option lors de la restauration avec Winclone, mais alors jamais. Pourquoi et pour quelle raison d'ailleurs ? Et tu as fait comment ce bidouillage, avec le Terminal ?

J'ai fait ça parce que winclone me conseillait de supprimer le fichier hiberfil.sys puis de forcer en legacy, du coup j'ai booté sur ma partition windows, désactivé l'hibernation, et de retour sur ma partition OsX j'ai voulu faire mon clône. J'ai eu un message d'erreur, je me suis dit que ça pouvait être lié à ça (au fait de ne pas avoir forcé le legacy).

Du coup depuis l'onglet "Tools" de winclone j'ai cliqué sur "Make Legacy Bootable" en sélectionnant ma partition bootcamp.

J'ai reessayé de faire mon clone, nouvel échec j'ai donc retenté en cliquant avant sur "Make EFI Bootable", toujours impossible de cloner et c'est là en voulant rebooter sur ma partition windows que j'ai eu l'écran bleu :(

Pour fini je suis retourné sur winclone recliqué sur "Make Legacy Bootable", mais rien n'y fait et effectivement après avoir fait qqs recherches j'ai compris que ça n'avait sans doute rien à voir :-/

Je ne comprends pas à quel moment j'ai supprimé le mauvais fichier :(

Bon ça fait :muted: mais ce n'est pas dramatique, je devais avoir une sauvegarde de jeux ou deux, je vais racheter une licence windows et faire une clean install

Et à la base tu es vraiment sur que ta version de Windows était fonctionnelle avant d'utiliser Winclone, quelle version d'ailleurs la 7, la 10 ?

Ma version fonctionnait avant que j'aille désactiver l'hibernation, j'étais sur Windows10 :)