Imprimantes mon imprimante imprime des carrés à la place du texte

jean83fun

Membre confirmé
26 Avril 2016
58
2
51
bonjour à tous,
mon iMac M1 big sur 11.6 tout neuf me pose un problème d'impression
Imprimante PageWide 377 dw.
Pilotes chargés depuis le site HP, adapté au MacOS (d'après HP)

Autant à l'écran, j'ai des documents pdf propres, et textes OpenOffice qui s'affichent bien, autant la feuille qui sort de l'imprimante est pleine d'anomalies : des petits rectangles blancs (bordure noire) à la place de tous les caractères pour les pdf et pour nombre de caractères pour le OpenOffice (mais Page aussi).

Par exemple, le caractère 1/2 qui se transforme automatiquement en un seul caractère -> rectangle. La lettre µ --> rectangle pour certaines polices.

Je suis passé par le site HP, car ça le faisait déjà en AirPrint, sans installation de pilotes. Je me suis dit qu'il fallait les pilotes idoines. Ben que dalle.
Livre des Polices : tout est à jour, validé, et à l'écran, tout est nickel.

Et par contre, aucun souci pour imprimer les mêmes documents depuis mon MacBook Pro qui est Catalina (si je ne me trompe pas, mais pas Big Sur, c'est sûr) : tout sort parfaitement bien.

Là, j'ai un refus d'obstacle de la part de l'imprimante.

Alors il me reste à appeler l'Assistance HP, dès que j'aurai le temps :)
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
22 746
5 295
Là-haut
Si cela fonctionne avec Catalina et pas avec Big Sur le problème vient soit de Big Sur lui-même soit de la configuration sur Big Sur.

As-tu essayé après avoir réinitialiser le système d’impression ?

Sinon :
 

jean83fun

Membre confirmé
26 Avril 2016
58
2
51
Si cela fonctionne avec Catalina et pas avec Big Sur le problème vient soit de Big Sur lui-même soit de la configuration sur Big Sur.

As-tu essayé après avoir réinitialiser le système d’impression ?

Sinon :
Merci de ta réponse.
Alors en fait, mon MacBook Pro, sur lequel ça fonctionne nickel est sous Mojave 10.14.6
l'iMac est bien sous Big Sur. Merci pour ton lien, mais je suis passé 3 fois par lui déjà et rien.
Je vais, comme tu le suggères, réinitialiser tout le truc.
 

jean83fun

Membre confirmé
26 Avril 2016
58
2
51
J'ai bien tout réinitialiser les imprimantes, redémarré l'ordinateur, il n'y avait plus rien dans la liste.
J'ai laissé l'iMac trouver l'imprimante et l'installer à sa guise. Puis j'ai pratiqué les essais suivants, sous 4 polices.

à l'écran, sous Open Office :
sous OpenOffice.png


à l'écran, sous Pages :
sous Pages.png


Résultat de l'impression. Voyez comme le caractère µ est bien imprimé avec la police Helvetica Neue :
resultat impression.png
 

gwen

iModo
Modérateur
Club MacG
25 Octobre 2001
14 605
2 234
50
Caen et de temps en temps Limoges
www.shito.com
Est-ce des polices poscript, true-type ou open-type ?
Ces erreurs etaient un cauchemar des imprimantes laser n’ayant pas le bon poscript. Mais c’était il y a 20 ans. Je n’ai jamais revus ça depuis.
 

jean83fun

Membre confirmé
26 Avril 2016
58
2
51
C’est un massacre. o_O

Lorsque tu génères un PDF via le système d’impression, par exemple sur Pages, ça donne quoi à la sortie ?
document Pages :
On note que Pages ne remplace pas le "1/2" par un caractère de fraction unique
Capture d’écran 2021-09-30 à 07.20.16.png



document pdf généré via Pages
Capture d’écran 2021-09-30 à 07.20.30.png


résultat imprimé du pdf :
Numériser 1.jpeg
 

jean83fun

Membre confirmé
26 Avril 2016
58
2
51
Est-ce des polices poscript, true-type ou open-type ?
Ces erreurs etaient un cauchemar des imprimantes laser n’ayant pas le bon poscript. Mais c’était il y a 20 ans. Je n’ai jamais revus ça depuis.
ben euh.... je ne sais pas répondre. Où dois-je regarder ?

trouvé dans Livre Des Polices
Arial et Times : OpenType TrueType
Helvetica , Herculanum : TrueType
 

gwen

iModo
Modérateur
Club MacG
25 Octobre 2001
14 605
2 234
50
Caen et de temps en temps Limoges
www.shito.com
ben euh.... je ne sais pas répondre. Où dois-je regarder ?

trouvé dans Livre Des Polices
Arial et Times : OpenType TrueType
Helvetica , Herculanum : TrueType
Le soucis ne vient donc pas de là.
 

daffyb

-Duck Warrior-
Modérateur
Club MacG
18 Octobre 2001
14 017
1 759
Angoulême
Est ce que le problème persiste lorsque l'imprimante est connectée en USB directement au Mac (et que tu imprimes via cette connexion) ?
Qu'as tu sur ton réseau ? TimeCapsule, Nas.... ?
 

jean83fun

Membre confirmé
26 Avril 2016
58
2
51
Est ce que le problème persiste lorsque l'imprimante est connectée en USB directement au Mac (et que tu imprimes via cette connexion) ?
Qu'as tu sur ton réseau ? TimeCapsule, Nas.... ?
Oui, le problème lorsque branchée en USB, étant entendu que : j'ai ré-initialisé le système d'impression, désactivé le WiFi de l'ordinateur, et branché l'imprimante en USB.
En quelques secondes, elle fut reconnue et est apparue dans les gestionnaire d'imprimantes (si on peut dire) et le problème persiste.
Sur mon réseau, je n'ai pas de Capsule, de NAS, encore que je ne sache pas ce que c'est. J'ai... euh.... rien... ou alors comme tout le monde, des objets connectés (télé, décodeur), mais rien de nouveau quoi.
 

Dominique G.

Membre enregistré
27 Octobre 2021
1
0
47
Bonjour,
J'ai exactement les mêmes problèmes avec une HP Pagewide 477dw et un MacBook Pro sous BigSur 116.
Après une très grande qualité d'essais, les meilleurs résultats sont d'imprimer en PDF depuis Word/Excel/.... d'ouvrir ce PDF avec Acrobatreader et d'imprimer depuis. Cela de fonctionne pas à tous les coups, mais statistiquement, c'est comme ça que j'ai les meilleurs résultats. Quand ça ne marche pas, parfois ça marche en imprimant le PDF depuis Aperçu, ou en imprimant de PS depuis Word/Excel/... et imprimant ce PS depuis Aperçu....
Je n'ai pas ce soucis avec mon vieil iMac sous Yosemite et un PC sous windows10.
Je n'ai pas souvenir de la date d'apparition du pb, mais il me semble que c'est suite à une mise à jour de MacOS.
 

Germinoo

Membre enregistré
28 Octobre 2021
1
0
29
Bonjour,
J’ai le même problème sur une HP pagewide pro 477dw.
j’ai bloqué pendant longtemps les mises à jour car j’avais des cartouches compatibles. Hors hier j’ai remis à jours l’imprimante et depuis impossible de sortir des documents textes sans ces carrés. Je viens de passer la maj Monterey, aucune différence. J’ai l’impression qu’il s’agît d’une version d’un pilote HP vu le problème et le fait que tout le monde soit touché sur des impressions HP
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
22 746
5 295
Là-haut
Non j'en possède une, pas soucis.

Par contre c'est peut-être spécifique avec ce modèle précis.
À mon avis, c’est un problème d’interprétation postscript.

Par ailleurs, la liste des versions de macOS compatibles avec ce modèle s’arrête à 10.14.