Mon Mac Pro 2010, après la mise en place de Big Sure avec Opencore ne boot que sur la clé USB

philo64

Membre enregistré
23 Avril 2009
8
0
Bonjour, j'ai mis à jour mon mac pro 2011 avec opencore, mais je n'arrive qu'a booter sur la clé USB qui m'a servi pour la procédure. J'ai bien essayé avec MountEFI, mais je n'y suis pas arrivé. Est ce que quelqu'un.e peut m'aider merci. Sinon, tout marche bien avec Big Sure. Mon mac me propose la mise à jour vers Monterey, mais j’hésite, qu'en pensez vous? Merci

Ma clé contient 2 volumes : EFI disk9s2 apparemment vide dans le finder et "Install mocOS Big Sur" disk9s3
L'os est installé sur un SSD "Sans titre" avec deux volumes : Instantané système APFS • APFS macOS 11.6.1 disk7s5s1 et Volume de données APFS • APFS disk7s1
 

Fichiers joints

  • Capture d’écran 2021-11-26 à 16.38.37.png
    Capture d’écran 2021-11-26 à 16.38.37.png
    119,4 KB · Affichages: 26

maxou56

Membre expert
Club MacG
14 Avril 2020
3 206
664
Lorient
mais je n'arrive qu'a booter sur la clé USB
Bonjour,
Pourtant la capture semble faite sur macOS et donc depuis le SSD.
Ce qui est confirmé.
Sinon, tout marche bien avec Big Sure. Mon mac me propose la mise à jour vers Monterey, mais j’hésite, qu'en pensez vous? Merci
Donc cela signifie que tu boot bien depuis le SSD, mais en utilisant l'EFI modifié par Opencore qui est sur la Clé USB.

Open Core legacy Patcher?
Si oui il faut aussi modifier l'EFI du SSD. Comme tu l'as fait sur la clé.

Mon mac me propose la mise à jour vers Monterey, mais j’hésite, qu'en pensez vous?
La CG est compatible Metal (tu était sous Mojave), si oui macOS n'est pas Patcher avec OCLP et BigSur. Il le sera avec Monterey (il faudra faire pour le GUI "Patch Système Volume" ou pour la TUI "Post installation Volume Patch") Mais comme macOS est modifier pas de SIP, pas de MAJ OTA...


Edit: si c'est bien un MBP 2011, alors MacOS est déjà Patché (pour le GPU), donc pas de changement avec Monterey.
 

Shadownet

Membre actif
13 Juillet 2018
145
30
47
Tu dois monter la partition EFI de ton disque dur interne et mettre OC dessus (et bless cet EFI)
 

philo64

Membre enregistré
23 Avril 2009
8
0

maxou56

Membre expert
Club MacG
14 Avril 2020
3 206
664
Lorient
Si j'enlève la clé, le mac ne démarre pas écran avec un cercle barré
C'est normale. Car tu n'as sans doute pas re-fait l'étape 1+2 en TUI ou "build and install open core" en GUI sur le SSD, comme tu l'a fait pour la clé USB.
Pour démarrer avec BigSur il faut que l'EFI soit modifier pour faire croire à macOS que le Mac est compatible. Donc si tu n'as pas respecté les différentes étapes pour OCLP, BigSur n'est pas compatible avec ton MAC, d'où le Cercle barré.

Donc Mac Pro 2009, 2010 ou 2012?

Et c'est Open Core Legacy Patcher ou Open Core?
 

philo64

Membre enregistré
23 Avril 2009
8
0
C'est normale. Cat tu n'as sans doute pas re-fait l'étape 1+2 en TUI ou "quid and install open core" en GUI sur le SSD, comme tu l'a fait pour la clé USB.
Pour démarrer avec BigSur il faut que l'EFI soit modifier pour faire croire à macOS que le Mac est compatible. Donc si tu n'as pas respecté les différentes étapes pour OCLP, BigSur n'est pas compatible avec ton MAC, d'où le Cercle barré.

Donc Mac Pro 2009, 2010 ou 2012?

Et c'est Open Core Legacy Patcher ou Open Core?
Mac pro mi2010, j'ai changé le processeur et la carte graphique. Je ne me rappelle plus quel OpenCore j'ai utilisé. Je suis un peu perdu pour ce genre de manip.
 

Fichiers joints

  • Capture d’écran 2021-11-26 à 17.13.06.png
    Capture d’écran 2021-11-26 à 17.13.06.png
    91,7 KB · Affichages: 22

maxou56

Membre expert
Club MacG
14 Avril 2020
3 206
664
Lorient
Je ne me rappelle plus quel OpenCore j'ai utilisé.
Si c'est Open core Legacy Patcher tu vas sur l'icône de l'app sur macOS BigSur.
Capture d’écran 2021-11-26 à 17.17.15.png

Puis tu l'ouvres, tu choisis soit "build and install open core" pour la version Graphique GUI ou TUI via le terminal, étape 1 et 2 en choisissant le SSD (au lieu de la clé comme tu l'as fait précédemment).
Puis tu retires la clé, et tu redémarre, éventuellement en maintenant Alt/option pour choisir l'EFI

Mais d'après la capture du message #1 (Clover) ça semble plutôt être Open Core (méthode Hackintosh) là je laisse d'autres membres répondre.
 
Dernière édition:

philo64

Membre enregistré
23 Avril 2009
8
0
Je ne trouve pas l'app seulement ce que vous voyez sur la capture d'ecran /:
 

Fichiers joints

  • Capture d’écran 2021-11-26 à 17.24.06.png
    Capture d’écran 2021-11-26 à 17.24.06.png
    191,4 KB · Affichages: 20

philo64

Membre enregistré
23 Avril 2009
8
0
Bon, en fin de compte j'ai installé OCLP, patché et installé sur le disque où il y a Big Sure, redémarré. Et ça marche. Merci les ami.e.s :)