Neige sur écran iMac 15'

myckmack

Membre d’élite
Club MacG
6 Octobre 2001
2 748
17
Je viens d'installer un iMac G4 15' presque neuf (il vient du refurb d'Apple). Tout allait pour le mieux jusqu'à ce que ma fille lance Harry Potter à l'école des sorciers : l'écran s'est couvert de neige (comme quand un écran de télé est parasité par certaines ondes magnétiques). Quand je redémarre, tout redevient normal. Ça le fait aussi avec Tony Hawk's Pro Skater 4 (fourni avec l'iMac). Et ça m'est même arrivé en écoutant de la musique sur iTunes !.
J'ai appelé Apple. Après avoir effectué pas mal de manipulations (redémarrage avec Pomme-Alt-P-R puis Pomme-Alt-F-O (je crois) puis des reset-je ne sais plus quoi) et avoir redémarré, rebelotte : toujours le même problème. Et on me conseille de réinstaller le système !
Avant d'en arriver à cette extrémité, je lance TechTool Pro (action en cours) et je vous demande votre aide : est-ce déjà arrivé à quelqu'un ? Que dois-je faire ?

PS : réinstaller le système, je veux bien (j'ai des sauvegardes) mais l'iMac était fourni avec Jaguar (en DVD) et une mise à jour pour Panther (en CD !) : ça prend trois à quatre fois plus de temps que d'installer directement Panther...
 

myckmack

Membre d’élite
Club MacG
6 Octobre 2001
2 748
17
En fait, cette espèce de neige vient quand il y a changement de résolution (les jeux le pratiquent souvent) . Cet iMac a une carte nVidia GEForce4 MX; peut-être y a-t-il un problème avec son firmware ?
 

myckmack

Membre d’élite
Club MacG
6 Octobre 2001
2 748
17
myckmack a dit:
En fait, cette espèce de neige vient quand il y a changement de résolution

...
Même chose quand je change le nombre de couleur ! Pourvu que ce ne soit qu'un problème logiciel...
 

myckmack

Membre d’élite
Club MacG
6 Octobre 2001
2 748
17
Suite de mon monologue (
).

Après avoir contacté Apple (trois quarts d'heure au téléphone !), il s'avère que le problème apparaît aussi après un retour de veille. Un technicien doit m'appeler la semaine prochaine pour prendre rendez-vous et venir faire une intervention sur site. Ce qui est énervant, c'est que c'est un problème déjà répertorié par Apple (sur des iMac 15'' USB 2) et qu'ils vendent encore des machines ayant ce problème
.
 

vincmyl

Vétéran
Club MacG
24 Septembre 2003
5 665
37
39
Strasbourg
Tu as tout tenter, reset de la PRAM etc...mise a jour du firmwire de la carte etc....
 

myckmack

Membre d’élite
Club MacG
6 Octobre 2001
2 748
17
vincmyl a dit:
Tu as tout tenter, reset de la PRAM
Si c'est Pomme-alt-P-R, oui (je l'indique dans mon premier message
).

etc...mise a jour du firmwire de la carte...
Je n'ai pas effectué de mise à jour du firmware de la carte mère, ni de la carte graphique nVidia GEForce4 MX car je ne sais pas où les trouver s'il y en a
.

J'ai eu l'impression hier que les problèmes ne surviennent pas quand la machine est froide (c'est à dire qu'elle vient de démarrer) ! Je vais refaire un test tout à l'heure.
 

myckmack

Membre d’élite
Club MacG
6 Octobre 2001
2 748
17
Suite du presque monologue : après avoir écouté (au téléphone) la description de mes problèmes, un technicien Apple pense que ça vient de la carte vidéo. Il faut la changer !
 

vincmyl

Vétéran
Club MacG
24 Septembre 2003
5 665
37
39
Strasbourg
Aie!!!!!
 

myckmack

Membre d’élite
Club MacG
6 Octobre 2001
2 748
17
vincmyl a dit:
Pas tant que ça : un technicien doit venir procéder au changement à mon domicile
. J'attends son appel téléphonique pour décider du rendez-vous. J'espère juste que ça réglera effectivement le problème
.
 

myckmack

Membre d’élite
Club MacG
6 Octobre 2001
2 748
17
myckmack a dit:
Pas tant que ça : un technicien doit venir procéder au changement à mon domicile
. J'attends son appel téléphonique pour décider du rendez-vous. J'espère juste que ça réglera effectivement le problème
.
Ça y est, c'est fait. Enfin
. Pour le moment, tout baigne
. En fait, c'est la carte mère qui a été remplacée car elle contient le processeur graphique et sa mémoire.