MacBook Pro Nouveau SSD et le MacBook ne boot plus...

PierreOh

Nouveau membre
27 Novembre 2013
4
0
Bonjour,

J'ai changé le disque dur de mon MacBook Pro mid 2012 par un SSD 250go de chez SAMSUNG. J'ai fais une clean install de Sierra par l'installateur sur le SSD sans problème. Lorsque j'utilise le SSD en USB avec un adaptateur sata, tout fonctionne parfaitement. Cependant, dès que je remplace le disque dur interne par le SSD, mon ordinateur ne boot plus : il y a un chargement et j'obtiens une page grise avec une sorte de "panneau interdit".

Mon SSD fonctionne parfaitement (en USB) et le câble sata (interne) n'est pas le problème puisque le disque dur fonctionne lorsqu'il est branché dessus.

J'ai tenté sans succès plusieurs solutions : Clean install (encore), RESET, etc... :(

Avez vous une idée du problème ? Merci d'avance !!
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
83 076
25 015
Forêt de Fontainebleau
Bonjour PierreOh



Mon SSD fonctionne parfaitement (en USB) et le câble sata (interne) n'est pas le problème puisque le disque dur fonctionne lorsqu'il est branché dessus.
Avez vous une idée du problème ?

Il n'y a nul besoin d'être diplômé en informatique pour avoir une idée du problème - il suffit d'être un lecteur de Conan Doyle.

Rappelle-toi la maxime de Sherlock Holmes : "quand on a éliminé l'impossible, alors la conjecture restante, quand bien même aurait-elle l'air improbable, doit être la vérité".

Application : la combinaison Mac x SSD fonctionne en externe (USB) > pas en interne (nappe SATA). La nappe SATA doit donc être défaillante - même si elle fonctionne avec un HDD.

Un élément peut-il être à la fois utilisable et inutilisable ? Le principe logique d'exclusion de la contradiction, pris en bloc, tendrait à faire rejeter ce type d'assertion. Sauf que le principe d'exclusion de la contradiction dit en détail que : on ne peut pas attribuer à un sujet une qualité et son inverse dans le même temps sous le même rapport.

Le « rapport » est-il le même dans ton cas de figure ? - non : la nappe SATA est utilisable en connexion avec un HDD et elle est inutilisable en connexion avec un SSD. Or un SSD (2,5") est un disque exigeant des débits de tranmission de données x5 par rapport à un HDD. Un câble SATA peut très bien supporter un débit x1 de transmission de données et ne pas supporter un débit x5 de transmissions de données.

Un fil électrique peut supporter du 10A et pas du 40A. Une corde peut supporter un sac de ciment de 50 kg et pas une palette de 500 kg [etc.].

=> tu vois ce qui te reste à faire ?
 

melaure

Chasseur de Bobos
Club MacG
24 Octobre 2001
24 845
1 734
50
Le Grand Lyon
Rappelle-toi la maxime de Sherlock Holmes : "quand on a éliminé l'impossible, alors la conjecture restante, quand bien même aurait-elle l'air improbable, doit être la vérité".
-> Apple bloque ton SSD en interne, pour te vendre une nouvelle machine ...

Ben quoi, c'est pas improbable ? :D :D :D

ok je sors ...
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
83 076
25 015
Forêt de Fontainebleau
Ben quoi, c'est pas improbable ?

Improbable mais pas impossible. Donc théoriquement possible. Il suffirait d'une mise-à-jour de l'EFI bloquant l'exécution d'un boot_loader dans tout volume d'un disque interne de type SSD "tierce-partie".

Possibilité contredite il est vrai par la mise à disposition d'une extension du noyau gérant le TRIM sur des SSD de tierce-partie admis installés en interne.

Ou alors il faudrait un monstrueux machiavélisme pour autoriser une fonction TRIM inexécutable par interdiction d'un démarrage sur un SSD tiers interne. Machiavélisme improbable mais pas impossible...
 
  • J’aime
Réactions: melaure

Yuls

Membre d’élite
1 Juin 2003
1 038
165
42
Lyon
J'ai changé le disque dur de mon MacBook Pro mid 2012 par un SSD 250go de chez SAMSUNG. J'ai fais une clean install de Sierra par l'installateur sur le SSD sans problème. Lorsque j'utilise le SSD en USB avec un adaptateur sata, tout fonctionne parfaitement. Cependant, dès que je remplace le disque dur interne par le SSD, mon ordinateur ne boot plus : il y a un chargement et j'obtiens une page grise avec une sorte de "panneau interdit".

Je me demande si c'est la nappe interne de ton MBP 2012 qui pose problème, vu le test que tu as fait.
Un changement de la dite nappe est à prévoir.
 

ness_Du_frat

Membre émérite
6 Février 2007
991
57
38
France
www.lesenfantsdelo.com
J'ai vu le même cas passer sur un forum américain l'an dernier quand je cherchais à résoudre un problème similaire sur un iMac (mais dans mon cas ça n'avait rien à voir), c'était la nappe qu'il avait fallu changer pour une nappe de meilleure qualité. Donc je renchéris sur ce qui a déjà été dit.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
83 076
25 015
Forêt de Fontainebleau
:coucou: ness

Toi > je sens que tu as envie de troquer la plume pour le tournevis-
361608_original.png
 

ness_Du_frat

Membre émérite
6 Février 2007
991
57
38
France
www.lesenfantsdelo.com
Ben là pas trop, t'as vu ce qui m'arrive dans l'autre fil ? Mais du coup j'ai vu son problème et comme j'avais vu le cas exact l'an dernier je me suis dit que j'allais aussi confirmer pour appuyer le truc car l'autre personne avait changé la nappe et son problème avait été résolu de cette manière (et il n'était pas tout seul). J'espère que ça va résoudre cette histoire de SSD, c'est énervant quand ça ne marche pas sans logique !
 

melaure

Chasseur de Bobos
Club MacG
24 Octobre 2001
24 845
1 734
50
Le Grand Lyon
Non mais là tu n'as pas de questions à te poser, car ça m'est déjà arrivé aussi sur un 2009, fonctionnement nickel avec DD, KO avec SSD. La nappe n'est pas défectueuse, mais pas d'assez bonne qualité pour supporter le débit d'un SSD, donc il faut la changer. Sur un forum US, j'avais lu qu'Apple avait probablement fait des économies de quelques centimes sur des nappes low-cost ...
 

ness_Du_frat

Membre émérite
6 Février 2007
991
57
38
France
www.lesenfantsdelo.com
Oui, c'est exactement ça. Désolée, je suis en stress sur mon truc donc je n'étais pas rentrée dans les détails, mais c'était une question de qualité de la nappe, pas du fait qu'elle soit défectueuse ou pas. La nappe pouvait gérer le HD, mais pas le SSD.
@macomaniac, même rubrique.
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
37 271
4 925

melaure

Chasseur de Bobos
Club MacG
24 Octobre 2001
24 845
1 734
50
Le Grand Lyon
Tiens-nous au courant et bon démontage !